Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit Apache 2.4 und Virtual-Hosts

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    [Webserver] Problem mit Apache 2.4 und Virtual-Hosts

    Hallo miteinander,
    hab hier ein kleines Problem mit der Smartvisu (oder dem Apache Server?). Nach dem zusätzlichen Aufsetzten einer Owncloud auf unseren Ubuntu 14.04 LTS Server, wollte ich den Zugriff über Domains in Verbindung mit den Virtual-Hosts realisieren. Das klappte auch ganz gut, bis darauf das mir jetzt keine Icons mehr in der Smartvisu angezeigt werden.

    firefox.jpg

    Aufruf der SmartVISU über in IP Adresse zeigt allerdings eine korrekte Darstellung der Seite inkl. aller Icons. Beim Versuch die Icons über ihre URL direkt aufzurufen bekomme ich immer einen 404 Fehler (Not Found). Anbei hier noch das Config-File des Apache V-Host:

    Code:
    <VirtualHost *:80>
            ServerName smartvisu.zz
            ServerAlias smartvisu.zz *.smartvisu.zz
            DocumentRoot "/var/www/html/smartVISU/"
            ErrorLog /var/log/apache2/smartvisu.zz-error_log
            TransferLog /var/log/apache2/smartvisu.zz-access_log
            <Directory "/var/www/html/smartVISU/">
                    Options Indexes FollowSymLinks MultiViews Includes ExecCGI
                    AllowOverride All
                    Require all granted
            </Directory>
    </VirtualHost>
    Suche schon seit 2 Tagen nach einer Lösung, vielleicht kann mir jemand helfen oder einen Tipp geben

    Grüße
    Andreas

    #2
    Hallo Andreas,

    bei Apache ist in einem Config File (ich habe auch schon gehabt, aber vergessen) ein Alias für das icon Verzeichnis gesetzt. Damit landen alle Referenzen auf PNG's dort und nicht in smartvisu (und damit nicht auffindbar). Dieser Alias muß gelöscht werden und schon klappts.

    Michel

    PS: z.B. http://forums.interworx.com/threads/...-for-PCI-scans)
    Zuletzt geändert von Orion; 22.09.2015, 13:16.

    Kommentar


      #3
      Hallo Michel,

      du hast mich auf den richtigen Lösungsweg gebracht. Das Config File "httpd.conf" gibt es bei Ubuntu 14 / Apache 2 nicht mehr, aber das File apache2.conf. Dort kann man sehen auf welche Config Files noch abgearbeitet werden. Bei mir versteckte sich der angesprochene Alias in /etc/apache2/mods-available/alias.conf, nach dem auskommentieren und
      Code:
      a2enmod
      läuft es nun perfekt.

      Danke dir

      Grüße
      Andreas

      Kommentar

      Lädt...
      X