Ankündigung

Einklappen
Keine Ankündigung bisher.

- √ - Kein ssh Zugriff

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    - √ - Kein ssh Zugriff

    Moin zusammen,

    ich versuche Zugriff aufs Wiregate mittels ssh zu bekommen. Leider kommt als Antwort immer:
    Read from socket failed: Connection reset by peer

    Im SSH-/Telnet-Login Reiter des Webmins (root Zugang) steht:
    Failed to lookup IP address for wiregatexxx.local to test telnet or SSH server.


    Der SSH Server selber läuft, wurde auch schon Testweise ausgeschaltet und neu gestartet.

    Im auth.log kommt u.a. folgendes hoch:
    Sep 29 19:30:09 wiregatexxx sshd[11276]: Server listening on :: port 22.
    Sep 29 19:30:09 wiregatexxx sshd[11276]: Server listening on 0.0.0.0 port 22.
    Sep 29 19:30:21 wiregatexxx sshd[11306]: error: Could not load host key: /etc/ssh/ssh_host_rsa_key
    Sep 29 19:30:21 wiregatexxx sshd[11306]: error: Could not load host key: /etc/ssh/ssh_host_dsa_key
    Sep 29 19:30:21 wiregatexxx sshd[11306]: Disabling protocol version 1. Could not load host key
    Sep 29 19:39:08 wiregatexxx sshd[17599]: error: Could not load host key: /etc/ssh/ssh_host_rsa_key
    Sep 29 19:39:08 wiregatexxx sshd[17599]: error: Could not load host key: /etc/ssh/ssh_host_dsa_key
    Sep 29 19:39:08 wiregatexxx sshd[17599]: Disabling protocol version 1. Could not load host key

    Für Protocol Version 2 analoge Meldungen...

    Über die Kommandozeile des Webmins kommen die selben Fehlermeldungen (connection reset by peer). Eingabe der IP Adresse des Wiregates bringt auch keine Verbindung.
    Muss ich zwingend dsa und/oder rsa keys erstellen?

    Hat jemand Ideen für mich?

    Danke,
    Grüße

    #2
    Hast du den root-zugang im Webmin aktiviert?
    Gruss Patrik alias swiss

    Kommentar


      #3
      Zitat von swiss Beitrag anzeigen
      Hast du den root-zugang im Webmin aktiviert?
      Jup. Bin über den root Zugang angemeldet, um mir die Optionen im SSh Server anzugucken.

      Kommentar


        #4
        Der ssh Zugriff funktioniert "out of the box". Da musst du keine Schlüssel erstellen. Allerdings meldet z.B. putty bei der ersten Anmeldung, dass der Schlüssel heruntergeladen und gespeichert werden will...
        Gruss Patrik alias swiss

        Kommentar


          #5
          Nachklapp:
          Mittels Portscan bekomme ich Port 22 vom Wiregate als offen gemeldet. Daran liegt es also auch nicht...
          Mit Putty kommt selbe Meldung wie ohne (connection reset by peer).

          Macht es Sinn den OpenSSH Server neu zu installieren?
          Wiregate Neustart hat nix gebracht...

          Kommentar


            #6
            Moin,

            bekomme immer noch keinen Zugriff aufs Wiregate mittels ssh. FTP Zugriff funktioniert allerdings ohne Probleme!?

            Wahrscheinlich liegt der Fehler irgendwo zwischen den Ohren, ich finde den aber nicht.

            Ich habe:
            1. Root Zugang im Webmin aktiviert
            2. Firewall auf dem PC deaktiviert
            3. Putty runtergeladen (und gestartet)
            4. IP Adresse des Wiregates eingegeben (Port 22) und ...

            Fehler: Software caused connection abort (immerhin habe ich mittlerweile einen anderen Fehler..)
            Muss ich in dein Einstellungen von Putty noch was anpassen?

            Grüße,
            Moe

            EDIT:
            Selber Fehler auf anderem Rechner (auch WinXP)
            Mit meinem Mac bekomme ich im Terminal die Fehlermeldung: Connection refused by peer
            Portscan meldet Port22 des Wiregates offen...
            WinSCP funktioniert (logisch) auch nicht

            Kommentar


              #7
              probiers mal mit ssh -vvv, dann bekommst Du mehr Infos
              Gruss
              Uwe

              Kommentar


                #8
                Kommt das hier:

                debug1: Reading configuration data /etc/ssh_config
                debug2: ssh_connect: needpriv 0
                debug1: Connecting to xxx.xxx.x.Xx [xxx.xxx.x.xx] port 22.
                debug1: Connection established.
                debug1: identity file /Users/Myname/.ssh/identity type -1
                debug1: identity file /Users/Myname/.ssh/id_rsa type -1
                debug1: identity file /Users/Myname/.ssh/id_dsa type -1
                debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
                debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
                debug1: Enabling compatibility mode for protocol 2.0
                debug1: Local version string SSH-2.0-OpenSSH_5.2
                debug2: fd 3 setting O_NONBLOCK
                debug1: SSH2_MSG_KEXINIT sent
                Read from socket failed: Connection reset by peer

                Wenn ich mich (via Browser) als root anmelde und dann in der Kommandozeile versuche mich via ssh anzumelden kommt Folgendes:
                debug1: Reading configuration data /etc/ssh/ssh_config
                debug1: Applying options for * debug2: ssh_connect: needpriv 0
                debug1: Connecting to xxx.xxx.x.xx [xxx.xxx.x.xx] port 22.
                debug1: Connection established. debug1: permanently_set_uid: 0/0
                debug1: identity file /root/.ssh/identity type -1
                debug3: Not a RSA1 key file /root/.ssh/id_rsa.
                debug2: key_type_from_name: unknown key type '-----BEGIN'
                debug3: key_read: missing keytype
                debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug3: key_read: missing whitespace debug3: key_read: missing whitespace
                debug2: key_type_from_name: unknown key type '-----END'
                debug3: key_read: missing keytype
                debug1: identity file /root/.ssh/id_rsa type 1
                debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
                debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
                debug1: identity file /root/.ssh/id_dsa type -1
                debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
                debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
                debug1: Enabling compatibility mode for protocol 2.0
                debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5
                debug2: fd 3 setting O_NONBLOCK
                debug1: SSH2_MSG_KEXINIT sent
                Read from socket failed: Connection reset by peer

                Jetzt sind meine Kenntnisse leider am Ende


                Grüße,
                Moe

                EDIT: Hat der OpenSSH Server eine Logdatei?

                Kommentar


                  #9
                  Hier die Daten des Servers:

                  > /usr/sbin/sshd -ddd
                  debug2: load_server_config: filename /etc/ssh/sshd_config
                  debug2: load_server_config: done config len = 788
                  debug2: parse_server_config: config /etc/ssh/sshd_config len 788
                  debug3: /etc/ssh/sshd_config:8 setting Protocol 1,2
                  debug3: /etc/ssh/sshd_config:10 setting HostKey /etc/ssh/ssh_host_rsa_key
                  debug3: /etc/ssh/sshd_config:11 setting HostKey /etc/ssh/ssh_host_dsa_key
                  debug3: /etc/ssh/sshd_config:13 setting UsePrivilegeSeparation yes
                  debug3: /etc/ssh/sshd_config:16 setting KeyRegenerationInterval 3600
                  debug3: /etc/ssh/sshd_config:17 setting ServerKeyBits 768
                  debug3: /etc/ssh/sshd_config:20 setting SyslogFacility AUTH
                  debug3: /etc/ssh/sshd_config:21 setting LogLevel INFO
                  debug3: /etc/ssh/sshd_config:24 setting LoginGraceTime 120
                  debug3: /etc/ssh/sshd_config:25 setting PermitRootLogin yes
                  debug3: /etc/ssh/sshd_config:26 setting StrictModes yes
                  debug3: /etc/ssh/sshd_config:28 setting RSAAuthentication yes
                  debug3: /etc/ssh/sshd_config:29 setting PubkeyAuthentication yes
                  debug3: /etc/ssh/sshd_config:30 setting AuthorizedKeysFile %h/.ssh/authorized_keys
                  debug3: /etc/ssh/sshd_config:33 setting IgnoreRhosts yes
                  debug3: /etc/ssh/sshd_config:35 setting RhostsRSAAuthentication no
                  debug3: /etc/ssh/sshd_config:37 setting HostbasedAuthentication no
                  debug3: /etc/ssh/sshd_config:42 setting PermitEmptyPasswords no
                  debug3: /etc/ssh/sshd_config:46 setting ChallengeResponseAuthentication no
                  debug3: /etc/ssh/sshd_config:61 setting X11Forwarding no
                  debug3: /etc/ssh/sshd_config:62 setting X11DisplayOffset 10
                  debug3: /etc/ssh/sshd_config:63 setting PrintMotd no
                  debug3: /etc/ssh/sshd_config:64 setting PrintLastLog yes
                  debug3: /etc/ssh/sshd_config:65 setting TCPKeepAlive yes
                  debug3: /etc/ssh/sshd_config:72 setting AcceptEnv LANG LC_*
                  debug3: /etc/ssh/sshd_config:74 setting Subsystem sftp /usr/lib/openssh/sftp-server
                  debug3: /etc/ssh/sshd_config:76 setting UsePAM yes
                  debug3: /etc/ssh/sshd_config:77 setting UseDNS no
                  debug3: /etc/ssh/sshd_config:78 setting GatewayPorts yes
                  debug3: /etc/ssh/sshd_config:79 setting AllowTcpForwarding yes
                  debug3: /etc/ssh/sshd_config:80 setting KeepAlive yes
                  debug3: /etc/ssh/sshd_config:81 setting IgnoreUserKnownHosts no
                  debug3: /etc/ssh/sshd_config:82 setting PasswordAuthentication yes
                  debug1: sshd version OpenSSH_5.1p1 Debian-5 Could not load host key: /etc/ssh/ssh_host_rsa_key Could not load host key: /etc/ssh/ssh_host_dsa_key Disabling protocol version 1. Could not load host key
                  debug1: rexec_argv[0]='/usr/sbin/sshd'
                  debug1: rexec_argv[1]='-ddd'
                  debug2: fd 3 setting O_NONBLOCK
                  debug1: Bind to port 22 on ::. Bind to port 22 on :: failed: Address already in use.
                  debug2: fd 3 setting O_NONBLOCK
                  debug1: Bind to port 22 on 0.0.0.0. Bind to port 22 on 0.0.0.0 failed: Address already in use. Cannot bind any address.

                  Liegt der Fehler an den letzten Zeilen (Cannot bind to address)??

                  Grüße,
                  Moe

                  EDIT:
                  Mit Netstat -plntu kommt folgende Zeile (nach Start des Servers!, vorher ist Port 22 nicht belegt):
                  Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
                  tcp 0 0 192.168.1.30:22 0.0.0.0:* LISTEN 31468/sshd

                  Somit sollte der Server doch laufen??

                  Kommentar


                    #10
                    Hmmm...

                    2 Fragen...

                    - Handelt es sich um ein Original Wiregate von ElabNet?
                    - Hast du daran irgend etwas als Root herum gebastelt?

                    Denn wie gesagt funktioniert ssh auf dem Wiregate out-of-the-box. Also werden auch die Schlüsselpaare beim ersten Start richtig erstellt usw... Wenn ich dein Log richtig lese findet der ssh Server schon die Schlüssel nicht...
                    Gruss Patrik alias swiss

                    Kommentar


                      #11
                      Moin,

                      jup, original erstanden.
                      Als root "rumgebastelt" habe ich folgendes:

                      ProFTPd Server gestartet (weil ja der ssh Zugriff nicht ging)
                      Und dann heute einige Einstellungen des sshd Servers geändert (leeres Passwort etc.) bzw. in der Kommandozeile die oben geposteten Aufrufe laufen lassen.
                      Das wars. Nichts gelöscht, umgeschrieben oder sonstwie verändert...

                      Das mit den Schlüsseln hat mich auch schon gewundert. Allerdings hat ein längeres Trennen vom Stromnetz (geschätzt 15Min) auch nichts gebracht...

                      Grüße,
                      Moe

                      EDIT:
                      Folgende Möglichkeiten: 1. Schlüssel erstellen (mittels ssh -keygen etc.); 2. openssh neu "installieren" (mittels dpkg?)

                      EDIT 2:
                      Kann ich das Wiregate nochmal neu "intialisieren", um so den "Schlüsselerstellvorgang" nochmal anzustoßen? Habe nix auf dem Wiregate was sicherungswürdig wäre...

                      EDIT 3:
                      OpenVPN Keys scheinen erstellt worden zu sein (im Verzeichnis etc/openvpn/keys finden sich auf jeden fall verschiedene key Dateien)

                      Kommentar


                        #12
                        An den Configs würde ich vorerst nicht schrauben. Ich gehe davon aus, dass da auch spezielle Einstellungen drin sind die gebraucht werden, damit ElabNet im Supportfall über das WartungsVPN und ssh zugreiffen kann.

                        Aber das generieren von neuen ssh Schlüssel wäre sicher ein Versuch wert. Erst mal ohne irgend welche Paktet drüber zu bügeln (wegen den oben genannten Sonderlocken)
                        Gruss Patrik alias swiss

                        Kommentar


                          #13
                          mach doch bitte mal ein "ls -al /etc/ssh". Ich vermute Dir fehlen die Host Keys (kann man mit "dpkg-reconfigure openssh-server" neu erzeugen) ...
                          Gruss
                          Uwe

                          Kommentar


                            #14
                            Die Schlüssel warens. Komisch, dass die bei der Inbetriebnahme nicht erzeugt worden sind. Wie dem auch sei, läuft!

                            Grüße!

                            PS: Falls das mal jemand braucht, ich habs mit folgenden Befehlen gemacht:

                            ssh-keygen -f /etc/ssh/ssh_host_key -N '' -t rsa1
                            ssh-keygen -f /etc/ssh/ssh_host_rsa_key -N '' -t rsa
                            ssh-keygen -f /etc/ssh/ssh_host_dsa_key -N '' -t dsa

                            Kommentar

                            Lädt...
                            X