Ankündigung
Einklappen
Keine Ankündigung bisher.
Raspberry Image Eibd, linknx mit CometVisu
Einklappen
X
-
hallo sorry bin vollkommen neu mit Linux und raspberry versuche mich da rein zu fuchsen zwecks Visualisierung habe eine raspberry 3 aber bekomme den nicht zum laufen mit den Image von michixx ... er bootet nicht .. was läuft da falsch?
-
Hallo,
Du musst bei EIBD_PORT_IPT, die IP der IP-Schnittstelle eintragen und nicht die IP vom Raspberry.
Also in deinem Fall "EIBD_PORT_IPT = 192.168.2.51"
Ich habe das im ersten Thread jetzt noch mal eindeutiger formuliert.
Gruß
Michi
Einen Kommentar schreiben:
-
Hallo zusammen. Bin noch ziemlich am Anfang und komme im Moment nicht weiter, da keine Verbindung zwischen KNX und Raspberry zustande kommte.
Es hängt vermutlich an der default/EIBD Datei. Ist die unten stehende EIBD Konfiguration so richtig (siehe auch Bild im Anhang)? Oder sind die Adressen falsch?
Was hat es eigentlich mit der EIBD PORT IP = 224.0.23.12 auf sich? Diese war schon standardmäßig vergeben, allerdings weiß ich nicht wo diese herkommt.
IP Raspberry: 192.168.2.50
IP KNX IP Adapter: 192.168.2.51
Meine EIBD Konfig:
EIBD_BACKEND_ADDR = 1.1.253
EIBD_BACKEND = ipt
EIBD_PORT_IP = 224.0.23.12
EIBD_PORT_IPT = 192.168.2.50
EIBD_T = y
EIBD_R =
EIBD_I = y
EIBD_C = y
Angehängte Dateien
Einen Kommentar schreiben:
-
Hi @llZitat von OliWit82 Beitrag anzeigenVielleicht hilft dir das hier:
Ich hab mir die Tage ebenfalls Michis Image auf nem Raspi installiert.
Per Groupswrite kann ich schonmal s Licht ein uns ausschalten ;-)
Ich möchte nun ebenfalls auf die aktuelle Comet Version updaten.
Wenn ich mich an die Vorgehensweise aus dem Link halte und die Datei mit wget herunterladen möchte kommt immer:
https://github.com/CometVisu/CometVi..._0.9.0.tar.bz2
Auflösen des Hostnamen »github.com (github.com)«... 192.30.252.128
Verbindungsaufbau zu github.com (github.com)|192.30.252.128|:443... fehlgeschlagen: Verbindungsaufbau abgelehnt.
Der Link sollte ja eigentlich passen; in den Browser eingefügt geht der...
Weiss jemand Rat?
beste Grüße
Michael
Einen Kommentar schreiben:
-
Hallo,
Ich bin noch sehr neu in der Materie Cometvisu auf dem Raspberry, daher weiß ich nicht ob meine Frage gerechtfertigt ist....
Hab ich eine Möglichkeit das Image auf die neueste Version der Cometvisu zu Updaten? Die Version 0.9 wurde ja vor einigen Tagen released.
Gruß Stefan
Einen Kommentar schreiben:
-
Ich habe das Problem zum Teil selbst gelöst und es lag eher daran das ich zu viel gelesen hatte
In einem anderen Post hatte jemand nach den knxd Argumenten für eine IP-Schnittstelle gefragt und folgende empfohlen bekommen:
--daemon=/var/log/knxd.log -D -T -R -S -i -u IPT:<ip-des-knx-Interface>
Danach hat der Fragende bestätigt das es mit diesen Parametern geht was ich dann als gesicherte Erkenntnis notiert hatte.
Natürlich habe ich mir auch angesehen was die einzelnen Parameter zu sagen haben und das hat für mich auch erst mal gepasst.
mit genau diesen Argumenten bekomme ich aber immer den besagten Fehler:
E00000016: OpenLocalSocket /tmp/eib: bind: Address already in use
initialisation of the knxd unix protocol failed: Address already in use
Jetzt habe ich aber gerade festgestellt das es wohl doch nicht die perfekten Argumente für mich sind.
Denn folgende Argumente gehen jetzt bei mir zu mind. wenn ich knxd von Hand aufrufe:
--daemon=/var/log/eibd.log -D -T -S -i ipt:192.168.2.142 (-u weglassen)
Und ein Basistest mit knxtool groupswrite war erfolgreich
Leider geht es über die bei der Installation angelegten start-scripte immer noch nicht,
wenn ich die neuen Parameter unter /etc/init.d/knxd wie folgt eintrage:
DAEMON=/usr/bin/knxd
DAEMON_ARGS="--daemon=/var/log/eibd.log -D -T -S -i ipt:192.168.2.142"
dann liefer ein /etc/init.d/knxd start immer noch einen open Socket error
pi@raspberrypi ~ $ /etc/init.d/knxd start
E00000016: OpenLocalSocket /tmp/eib: bind: Address already in use
initialisation of the knxd unix protocol failed: Address already in use
Update: Nachdem ich das Ganze noch einmal von vorne mit dem neuesten Jessie Image gemacht habe gingen dann auch die startscripte.Zuletzt geändert von misc2000; 21.11.2015, 15:48.
Einen Kommentar schreiben:
-
Zitat von misc2000 Beitrag anzeigenhat jemand einen Link zu einem Image für einen Raspberry PI auf dem eibd oder knxd 100% geht?

Einen Kommentar schreiben:
-
Mein IP-Interface sollte eigentlich nicht das Problem sein. Zum Zeitpunkt des Test war weder ETS (Auf einer Windows VM da aus war) noch eine OpenHAB-Installation auf einem Mac unter OSX (Mac war an aber OpenHAD auf jeden Fall nicht) am laufen und wenn ich diese starte können diese ohne Probleme über die ABB IP-Schnittstelle (IPS/S 2.1) auf den Bus zugreifen.
Zuerst dachte ja das irgend etwas auf meinem Raspberry PI den Port belegt den KNXD benutzen will (Image was dem Netz und historie daher unbekannt) daher habe ich ja gestern den Raspberry PI komplett neu aufgesetzt und nur noch KND installiert und bekomme aber wieder genau den gleichen Fehler. Kann jemand sagen welcher Port auf dem Raspberry PI und welche auf dem ABB IP-Interface genutzt werden soll vieleicht passt da ja noch was nicht da ich im Moment in der Konfig keinen Port angebe, bzw. hat sonst jemand schon mal dieses Problem gehabt?
Bzw. hat jemand einen Link zu einem Image für einen Raspberry PI auf dem eibd oder knxd 100% geht?
Oder kann man bei knxd den Loglevel erhöhen um besser zu sehen wo genau das Probem ist?
Zuletzt geändert von misc2000; 11.11.2015, 09:45.
Einen Kommentar schreiben:
-
Habe leider kein IP-Interface bin daher da ein wenig blank. Kann es sein, dass schon ein anderer Dienst gegen dein IP-Interface connected ist? Wenn du einen Router hasst, dann können glaube ich mehrere Verbindungen aufgebaut werden. Dazu ist aber eine spezielle config in der ETS nötig. Hasst du das gemacht?
Einen Kommentar schreiben:
-
knxd startet nicht - HILFE erforderlich Eigentlich will ich Homebridge testen und benötige dafür ja ein funktionierendes eibd oder knxd.
Ich habe jetzt schon 2 Installationen von knxd gemacht und bekomme es einfach nicht ans laufen.
Nachdem ich es zuerst auf meiner vorhandenen Raspberry Pi 2 Installation versucht hatte habe ich es heute noch einem von Scratch gemacht und leider genau den gleichen Fehler bekommen:
pi@raspberrypi ~ $ /etc/init.d/knxd start
E00000016: OpenLocalSocket /tmp/eib: bind: Address already in use
initialisation of the knxd unix protocol failed: Address already in use
Installiert habe ich heute wie folgt:
aktuelles wheezy image auf eine SSD geladen "2015-05-05-raspbian-wheezy.img“ und dann nach der Anleitung aus dem Post# #304 (von bigblue1735) aus diesem Beitrag alles ohne Fehler durchgeführt.
Bis dann der USB Teil kommt welchen ich weg gelassen habe da ich eine ABB IP-Schnittstelle (IPS/S 2.1) mit der IP 192.168.2.142 habe.
Für diese habe ich dann DAEMON_ARGS="--daemon=/var/log/knxd.log -D -T -R -S -i -u IPT:192.168.2.142"
in die Datei /etc/init.d/knxd aufgenommen
Wenn ich dann wie folgt von Hand starten will bekomme ich immer den Fehler von oben
pi@raspberrypi ~ $ /etc/init.d/knxd start
Zuerst dachte ich knxd würde schon warum auch immer laufen aber ps zeigt mir nur das :-(
pi@raspberrypi ~ $ ps -ef | grep knxd
pi 22541 2277 0 21:58 pts/0 00:00:00 grep --color=auto knxd
Ich verstehe einfach nicht wo das Problem ist und frage mich ob es ggf. mit dem aktuellen Stand des Image zu tun hat und sich hier vieleicht was nicht verträgt. Da ja zuerst das Grundimage komplett auf den neuesten Stand gebracht wird bevor die Installation beginnt.
Ich bin für jede Hilfe dankbar und bin auch bereit noch mal neu zu installieren wenn mir jemand eine funktionierenden Weg kurz beschreiben kann.
Zuletzt geändert von misc2000; 10.11.2015, 22:40.
Einen Kommentar schreiben:
-
Nachdem ich nun Alles nochmal neu aufgesetzt habe, funktioniert es auch mit dem knxd.
Einen Kommentar schreiben:
-
Wenn ich deine Argumente kopiere bekomme ich die Meldung, dass -e früher stehen muss. Probier mal die Reihenfolge so umzustellen, dass --eibaddr=1.1.128 gleich nach dem daemon Argument steht. Stell auch sicher, dass der User Schreibrechte für /var/log/knxd.log hat und dass du überall Bindestrich und nicht etwa Gedankenstriche verwendest. Im Zweifelsfall nochmals alles eintippen und nicht irgend woher kopieren.Zitat von macaholic Beitrag anzeigenIch setze einen GIRA IP Router ein und habe die entsprechende IP-Adresse dort eingetragen.Code:[COLOR=#AFAD24][FONT=Monaco][SIZE=10px][SIZE=14px][FONT=arial][COLOR=#000000]DAEMON_ARGS[/COLOR][COLOR=#34bd26]=[/COLOR]"--daemon=/var/log/knxd.log -D -T -R -S -i -u --eibaddr=1.1.128 ipt:192.168.xxx.xxx"[/FONT][/SIZE][/SIZE][/FONT][/COLOR]
Wenn ich nun knxd starte, bekomme ich die Fehlermeldung "not a valid url".
Einen Kommentar schreiben:
-
hmmm, dann ist er auf keinen Fall gestartet worden. Sorry jetzt bin ich leider aus. Ich habe in dem knxd Thread noch mal eine Anfrage bezüglich eines anderen Problems gestellt. Vielleicht bekomme ich da eine Antwort und kann dir dann weiterhelfen. Leider ist ohne Logs da jetzt nicht mehr viel zu machen. Aber wo die liegen weiß ich auch nicht.
Einen Kommentar schreiben:
-
Ich bekomme einCode:[FONT=Monaco][SIZE=10px][SIZE=14px] 2727 pts/0 S+ 0:00 grep knxd[/SIZE][/SIZE][/FONT]
Einen Kommentar schreiben:


Einen Kommentar schreiben: