Ankündigung

Einklappen
Keine Ankündigung bisher.

Intergrierter Internet Explorer im QuadClient veraltet?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Q-Client Intergrierter Internet Explorer im QuadClient veraltet?

    Hallo,

    im QuadClient Menü lässt sich über die "Navigationstaste-URL" in der Menüleiste am unteren Bildschirmrand der integrierte "Vollbild-Browser" aufrufen.

    Dies führt aber nicht zum auf dem PC installierten Browser, sondern laut Wie ist meine IP Adresse: IP anzeigen - WieIstMeineIP.NET zum (veralteteten) Internet Explorer 7.0.

    Unter anderem ist damit die Darstellung von Google-Calendar nicht optimal.

    Lässt sich der integrierte "Vollbild-Browser" ersetzen? Beispielsweise durch einen "Upgrade" des Browsers im QuadClient oder ein Verlinken zum Standard-Browser des PCs?

    Vielen Dank schon für eure Unterstützung!

    Grüße
    Carl

    P.S. Ansonsten kam mir als Workaround bisher nur die Verwendung von QCExe in den Sinn: Butten (im "Tabellen-Menü") auf QCExe-PlugIn, dort Öffnen einer .url-Datei, dann öfnet sich die URL im Standard-Browser. Ist aber nicht so elegant wie direkt über einen Button im QC-Menü.

    #2
    Hallo,

    hast DU zufällig dafür eine Lösung gefunden ?

    Gruß Dennis

    Kommentar


      #3
      Leider immer noch keine gute Lösung. Hatte gestern QuadClient 4.4.0 installiert, die Website "www.meine-browser-version.de" zeigt an, dass Internet Explorer 7 benutzt würde.* Google meldet u.a. bei Maps und Calender, dass der Browser nicht unterstützt würde, teilweise wg. "Kompatibilitätsansicht".

      Weiß jemand:
      a) wie man an die "Internetoptionen" des integrierten Browser kommt, um die Kompaitbilitätsansicht anzupassen?
      b) ob es möglich ist, einen anderen Standardbrowser bzw. den Standardbrowser des Hosts (d.h. des Windows-Rechners, auf dem der QuadClient läuft) einzubinden?

      Grüße
      Carl

      *wenn man auf die Website geht, die lt. Google eine Lösung anbieten soll (http://www.update.microsoft.com/wind...&&thankspage=5), kommt dort, dass nur ab Internet Explorer 5 nutzbar... Also ist der integrierte Browser <5?!
      Zuletzt geändert von carlmahr; 12.06.2016, 16:43.

      Kommentar


        #4
        Hab auch das selbe Problem mit der ADAC Staukarte und Google Staukarte.

        Gibt es da noch keine Lösung ?

        Kommentar


          #5
          Hurra die Lösung ist da!

          Ursache: Der integrierte Browser kommt aus dem .NET-Framework. Das ist zwar grundsätzlich aktuell, aber im QuadClient läuft er in einer "Kompatibilitätsansicht" und erscheint Websites fälschlicherweise als - veralteter - IE7.

          Lösung: Den Kompatibilitätsmodus ausschalten! Leichter gesagt als getan, aber eine gute Fee - die ungenannt bleiben möchte - flüsterte folgende "Zauberformel" zu: Zwei Einträge "hs_client_net.exe" müssen in der Registry gemacht werden. Ggf. sind dazu auch die Schlüssel und Werte neu anzulegen. Der integrierte Browser läuft dann als normaler - und aktueller - Internet Explorer.

          Voilà: Google Maps läuft nun anstandslos wieder. Getestet unter Experte/QuadClient 4.7, der heute frisch aufgespielt wurde. Danke nochmals an die gute Fee, die von der Zauberquelle der Weisheit des QC sprach...

          Eintrag1.png Eintrag2.png
          Angehängte Dateien

          Kommentar


            #6
            Geht bei 4.7 auf Windows 10

            Gibts auch ein Trick, Eintrag für 4.4/4.5 ? Resp. Windows 7
            Zuletzt geändert von Axel; 04.10.2018, 12:34.

            Kommentar


              #7
              Hab es. Geht auch unter Windows 7
              Da ich unterschiedliche Benutzer habe, muss das ganze in HKLM rein.

              Der Wow6432 Eintrag ist nötig, wenn es ein 64Bit System ist. Ansonsten kann man sich den auch sparen.

              Kommentar


                #8
                Hallo Zusammen!

                Der Beitrag hier ist zwar schon ein bisschen älter aber ich dachte damit die Lösung meines Problems gefunden zu haben.... leider nein!

                Ich nutze einen HS 4.11. Ich würde gerne im QC meine Grafana Diagramme per URL Aufruf anzeigen. Ich bekomme immer diese Fehlermeldung:

                If you're seeing this Grafana has failed to load its application files

                1. This could be caused by your reverse proxy settings.

                2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath. If not using a reverse proxy make sure to set serve_from_sub_path to true.

                3. If you have a local dev build make sure you build frontend using: yarn start, yarn start:hot, or yarn build

                4. Sometimes restarting grafana-server can help

                5. Check if you are using a non-supported browser. For more information, refer to the list of supported browsers.


                Kann mir jemand sagen woran das liegen könnte?

                Alex

                Kommentar


                  #9
                  Die Fehlermeldung liefert ja schonmal 5 Lösungsvorschläge mit - hast du die alle erfolglos versucht?

                  Kommentar


                    #10
                    Ich denke Punkt 1 und 2 hängen irgendwie zusammen, muss aber gestehen das ich keine Ahnung habe was zu tun ist. In der grafana.ini habe ich einiges umgestellt wie beispielsweise "nicht-authorisierter Zugriff" oder "erlaubtes embedding". Zu root_url settings habe ich nichts gefunden.

                    Punkt 3 muss ich checken.

                    Punkt 4 habe ich erfolglos probiert.

                    Punkt 5 ist ähnlich zum Treat-Thema. Wenn ich die url http://www.wie-ist-meine-ip.net einbinde zeigt diese mir Mozilla5.0 an!?

                    Kommentar


                      #11
                      Welche Grafana-Version?
                      Im Quad-Client auf IE gestellt oder nicht?
                      Welche .net-Version?

                      Ich kann sagen, dass es geht. HS 4.11.1, kein IE, Win11 ARM, Grafana 7.5.5
                      Greenshot 2021-11-25 11.26.30.png Greenshot 2021-11-25 11.27.14.png

                      Kommentar


                        #12
                        Vielen Dank Sven! Ich hätte es fast schon aufgegeben. Habe vor dem Beitrag in diesem Forum schon viel Zeit verheizt.

                        Es funktioniert jetzt! Es lag jetzt letztendlich an der IE Einstellung die bei mir zum Schluss aktiv war. Bin mir aber sicher das ich das schonmal ohne IE aktiv getestet hatte. Das sagt mir das es sehr wahrscheinlich Multicausal war. Möglicherweise waren es zusätzlich die Änderungen in der grafana.ini die das Problem jetzt behoben haben.

                        Das nächste mal wende ich mich früher ans Forum!!!

                        Vielen Dank an alle die sich einen Kopf um mein Problem gemacht haben!!!

                        Kommentar

                        Lädt...
                        X