Ankündigung

Einklappen
Keine Ankündigung bisher.

Update HS4 Experte 4.5.0 auf 4.8.1 - Probleme

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    HS/FS Update HS4 Experte 4.5.0 auf 4.8.1 - Probleme

    Hallo zusammen.
    Ich bin mir nicht mehr ganz sicher, welcher Teufel mich am Pfingstmontag geritten hat, dass ich den stabil laufenden Experten 4.5.0 (4.5.0.160913R) auf den Experten 4.8.1 aktualisiert habe - wahrscheinlich hatte mich der Lehrgang bei Gira dazu inspiriert ... mit all der Zertifikatesicherheit und der Benutzerverwaltung. Egal.
    Also Firmware wie in der Readme.txt hochgeladen, Experten installiert, das mit den Zertifikaten durchexerziert ... startet alles wunderbar, HS läuft.

    Probleme:
    Leider geht im Prinzip nicht mehr viel im Haus nach dem Update.
    Sämtliches DALI-Licht, Lüfter, Heizung, Messwerte via Szenen oder Visu per HS4 - alles weg!
    Was sich noch per Visu schalten lässt, sind (manche) 1bit-Sachen wie (manche - nicht alle!) Steckdosen und die Deckenlautsprecher.
    Diese Rückmeldungen werden auf der Visu korrekt angezeigt - alle anderen nicht.
    Alle Gewerke lassen sich natürlich nach wie vor per Schalter oder ETS direkt ansteuern.
    Es funktionieren sämtliche Szenen, die Dimmwerte senden, nicht mehr.
    Es funktionieren keine Logiken mehr.
    Die Übergabe der 1-Wire Messwerte vom Timberwolfserver funktioniert auch nicht mehr. Das lief bis zum Update alles völlig problemlos seit Jahren.

    Beispiel Küche Szene Kochen:
    Vor dem Update: dimmt Deckenlicht an, dimmt Kochstellenlicht an, dimmt Spülenlicht an, Abzugslüfter auf 35%, Deckenlautsprecher an.
    Nach dem Update: -, -, -, -, Deckenlautsprecher an

    Ich bekam vom hiesigen Gira-Vertriebsmann den Tipp, die Firmware nochmals komplett einzuspielen (also die ganze Updateprozedur nochmals zu machen)
    Jetzt geht zusätzlich die Szene Badezimmerlicht wieder (DALI-Licht mit Dimmwerten, Lüfter mit Dimmwerten) - allerdings schaltet der Lüfter aus Mangel an Luftqualitätswerten nicht mehr ab. ALLE anderen DALI-Lichtszenen gehen nach wie vor nicht.

    Der KNX IP-Router (Gira 216700 I15, Applikation V4), über den der HS4 läuft, funktioniert (der G1 funktioniert zumindest problemlos, Messwerte kommen aber auch hier nicht an).
    Hat irgend jemand einen oder oder mehrere Tipp(s), was man noch testen kann?
    Als letzter Ausweg: Wie bekomme ich die 4.5er Firmware wieder auf die Kiste? Gibt es dabei etwas zu beachten?

    Gruß
    Stephan

    #2
    Kurzer Nachtrag: Das digitale Schlüsselbrett, das mit einer digitalen IO-Schnittstelle per Timberwolfserver (TWS) an das KNX-System angebunden ist, funktioniert auch noch. Die Anwesenheitswerte (1bit) werden zur Visu korrekt gemeldet und angezeigt. Die "Alles Aus" Schalthandlung wird ebenfalls korrekt ausgelöst, wenn der letzte Schlüssel herausgenommen wird - also funktioniert ein Teil der HS4-Logiken doch noch!

    Kommentar


      #3
      Remanentspeicher vor dem Update gesichert und nach dem erneuten Übertragen des Projekts zurück auf den HS geladen?

      Kommentar


        #4
        Ja, Remanentspeicher wurde rückgesichert. Evtl. habe ich da aber etwas falsch gemacht?

        Reihenfolge:
        2.1. Notieren der installierten Firmware-Version (Debug-Seite System/Version) 4.5.0.160913R
        2.2. Sicherung des Remanentspeichers über den Experten (Remanentspeicher sichern) OK
        2.3. Archivieren des aktuellen Projektes mit dem Experten OK
        2.4. Installation des neuen Experten und Import des archivierten Projekts OK
        2.5. Installation der neuen Firmware OK
        2.6. Vollständiges Übertragen des aktuellen Projektes (Option "Bilder+Daten+Ansagen",
        Remanentspeicher NICHT löschen) mit dem neuen Experten. OK
        2.7. Prüfen der Remanentdaten auf dem HS/FS. ?

        Wie führe ich denn Punkt 2.7 aus?

        An welcher Stelle (Punkt 2.x?) genau soll der Remanentspeicher wieder eingespielt werden?
        Ich habe den Remanentspeicher NACH dem Hochladen der Firmware und NACH dem Hochladen des Projektes rückgesichert und dann das Projekt NOCHMALS eingespielt. Muss der Remanetspeicher evtl. VOR dem Hochladen der Firmware rückgesichert werden?

        Gruß
        Stephan
        Zuletzt geändert von 773H; 12.06.2019, 06:06.

        Kommentar


          #5
          Sieht so aus, als ob ein Downgrade wirklich das allerletzte Mittel der Wahl ist.

          https://knx-user-forum.de/forum/%C3%...-4-5-downgrade

          Leider wurde seitens des Girareferenten mit keinem Wort erwähnt, dass das Update auf den Experten 4.8 evtl. nicht völlig ohne Reibungsverluste vonstatten geht und ein Downgrade seitens Gira gar nicht vorgesehen ist.

          Bin also völlig offen für Hinweise, die mir meine Szenen wieder zum Laufen bringen

          Kommentar


            #6
            Hi
            Da bei dem Upgrade von 4.5 nach => 4.7 eine neue Version der Python Scripting Language kommt, müssen einige Logikbausteine angepasst werden.
            Alle von Gira gelieferten Bausteine sind angepasst. Du musst aber beim Upgrade aufpassen, dass du nicht die alten Bausteine aus deinem Projekt mit importierst. Der Experte fragt dich dazu beim Import des alten Projektes. Du musst die neuen benutzen und evtl. deine Logiken anpassen. Das sollte allerdings keine große Aktion sein.
            Schwieriger wird es mit Bausteinen hier aus dem Download Bereich. Du musst dazu checken ob diese Bausteine auch für die neue Version vorhanden sind und fkt. Und du musst diese natürlich einbauen.
            Wenn das alles geschafft ist, sollte wieder alles fkt. Ich glaube nicht dass alte Szenen in der neuen FW nicht mehr laufen. Es sei denn du hast da irgendwelche eigenen Logiken drin.
            Auch beim Quadclient musst du die neuen Funktionsvorlagen benutzen (Die kommen automatisch mit dem neuen Experten), darfst nur nicht die alten danach wieder drüber bügeln.
            Ich musste ganz wenig an den "original" Gira Sachen anpassen (hat Gira ja schon für mich gemacht). Aber die "freien" Logikbausteine, mussten fast alle angepasst werden.

            Den Remanent Speicher musst du nicht zurückladen, der wird beim Upgrade automatisch "übernommen". Die Sicherung ist nur für den Fall der Fälle :-)

            Kommentar


              #7
              OK. Vielen Dank für die Infos. Das sehe ich mir baldmöglichst an.

              Allerdings erklärt die Logikthematik nicht, warum keinerlei Rückmeldungen und Temperaturwerte (sowohl KNX als auch 1W Werte) am HS ankommen.

              Kommentar


                #8
                Das mit den Bausteinen habe ich geprüft - schaut gut aus.
                Ich kram das mal wieder hoch, weil immer noch nicht viel* geht ...

                *Dimmwerte von Szenen, Temperaturen, Rückmeldungen, Schalten und Dimmen per Visu und App, etc.
                Hat diesbezüglich noch jemand Tipps?

                Gruß
                Stephan

                Kommentar


                  #9
                  Hat noch jemand irgendwelche Ideen zu dem Thema?

                  Kommentar


                    #10
                    Hast Du denn HS auf einen IP Router gehangen? Der I15 ist ja recht neu (Februar meine ich)

                    Kommentar


                      #11
                      Ja, habe ich. Das ist die einzige Schnittstelle zu KNX.
                      Meinst du, das kann das Problem sein?

                      Gruss
                      Stephan

                      Kommentar


                        #12
                        Ja, das vermute ich

                        Kommentar


                          #13
                          OK. Danke für den Tipp. Ich check das mal mit einer USB-Schnittstelle heute Abend.

                          Gruß
                          Stephan

                          Kommentar

                          Lädt...
                          X