Ankündigung

Einklappen
Keine Ankündigung bisher.

Sonoff S20 mit tasmota knx Firmware

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Sonoff S20 mit tasmota knx Firmware

    Hallo zusammen,

    leider bin ich durch die Suche nicht wirklich fündig geworden.
    Ich steh grad auf dem Schlauch...

    Ich habe eine Sonoff S20 Wifi-Steckdose und habe diese mit der Tasmota-Firmware am Laufen.
    Nun habe ich gelesen, dass es diese auch mit knx-Anbindung gibt.
    Nach der Installation habe ich versucht den knx zu konfigurieren:

    Unbenannt.JPG

    Die GAs sind klar, die Physical Address würde wohl einer freien Adresse entsprechen, die nicht durch knx-Geräte in Verwendung ist.

    Aber wie kommuniziert Sonoff mit meinem KNX-Bus?

    Ich habe ein Weinzierl 730 (IP-Interface) und einen Raspi mit knxd im System.

    Habe ich bei Tasmota noch andere Möglichkeiten der Konfiguration die ich übersehen habe?
    Kann mir jemand auf die Sprünge helfen?

    Danke.

    #2
    Tasmota arbeitet im Routing. Musst also den KNXd als Router konfigurieren....
    Gruß Stephan

    Kommentar


      #3
      Ok, und woher weiß tasmota von der Existenz des knxd?
      Muss man das noch irgendwo bekannt geben?

      Kommentar


        #4
        Es geht davon aus, dass es einen KNX-IP Router gibt ... schickt einfach Multicast und hofft, dass es irgendein Gerät interessiert

        https://smarthome-zimbelmann.de

        Kommentar


          #5
          I created some projects with Arduino IDE myself. I looked very in-depth last months to the KNX library for Arduino (which is used by Tasmota for the SonOff).

          This device will output multicast packets on your network.. Note that your WiFi has to support this (some have rare or broken IGMP or snooping functionality).

          The KNX multicast address is: 224.0.23.12. In your Gira/Wienzerl/MDT or whatever vendor IP router, first DISABLE filtering (just to test). Open your ETS and start the Bus/Group Monitor.

          Then if it works.. create a Dummy device in ETS and apply filtering for your KNX/IP router again.

          Kommentar


            #6
            You do not need KNXd or another application. Just an KNX/IP router like Gira 2167 00

            Kommentar


              #7
              Versteh ich das richtig: der Router (egal ob KNX-Router als Hardware oder knxd als Software und als Router konfiguriert) nutzt die Multicast-IP 224.0.23.12.
              Tasmota kommuniziert ebenfalls mit dieser.
              Da diese IP fix ist, kann man diese bei Tasmota auch nicht einstellen.

              Kommentar


                #8
                Zitat von Roeller Beitrag anzeigen
                You do not need KNXd or another application. Just an KNX/IP router like Gira 2167 00
                ...but I don't have a router. A knxd is running here...

                Kommentar


                  #9
                  netfriend Genau so.. Tasmota kommuniziert im Routing Multicast. Deswegen kannst auch nichts einstellen...
                  Gruß Stephan

                  Kommentar


                    #10
                    Zitat von netfriend Beitrag anzeigen

                    ...but I don't have a router. A knxd is running here...
                    Activate the routing function, and everything will be fine.
                    Zuletzt geändert von vento66; 05.10.2019, 00:09.
                    Mfg Micha
                    Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                    Kommentar


                      #11
                      Laufen die bei dir sauber?

                      Ich hab mir auch mal welche besorgt und die FW läuft ... alles soweit eingestellt ... Infos aus dem Bus bekommt Sie aber nicht mit, schalte ich dagegen am Gerät sendet Sie den Status in den Bus ...

                      Kommentar


                        #12
                        Zitat von derPaul Beitrag anzeigen
                        Infos aus dem Bus bekommt Sie aber nicht mit, schalte ich dagegen am Gerät sendet Sie den Status in den Bus .

                        könnte an Deinem WLAN liegen ... https://www.computerwoche.de/a/fritz...ltag,3218003,5

                        https://smarthome-zimbelmann.de

                        Kommentar


                          #13
                          Danke, nein, ich hab mein gesamtes Netzwerk auf Ubiquiti Hardware aufgebaut.
                          Ich hab aber entsprechend da schon alles eingestellt für Multicast etc.

                          Also ich hab auch gerade rausgefunden das es ansich läuft.
                          Ich hab in der ETS mal die Multicast Schnittstelle genommen und darüber übern Bus Monitor gesendet und siehe da die Steckdose schaltet.

                          Ehm doofe Frage, aber sollte das der knxd nicht sowieso mitlauschen? Muss ich den noch irgendwie als Dummy oder so in meine Linie mit aufnehmen?


                          Oder hab ich mein knxd noch nur falsch dafür gestartet?
                          Zuletzt geändert von derPaul; 10.10.2019, 19:32.

                          Kommentar


                            #14
                            Zitat von derPaul Beitrag anzeigen
                            Laufen die bei dir sauber?

                            Ich hab mir auch mal welche besorgt und die FW läuft ... alles soweit eingestellt ... Infos aus dem Bus bekommt Sie aber nicht mit, schalte ich dagegen am Gerät sendet Sie den Status in den Bus ...
                            Wenn Du mich damit meinst, ja das hat soweit funktioniert.
                            Ich habe den knxd noch mit dem Parameter -R für Router gestartet, und schon habe ich den Status der Steckdose in der ETS gesehen. Über die ETS konnte ich dann auch die Steckdose schalten.

                            In meinem (FritzBox-) Netzwerk musste ich nichts ändern.

                            Kommentar


                              #15
                              Komisch,
                              das ist mein Startbefehl :

                              knxd -e 1.1.240 -E 1.1.241:8 -DTRS -c -i -b ipt:192.168.10.4

                              Die 192.168.10.4 ist meine Gira IP Schnnittstelle.
                              Schalten bekommt er aber nnur mit wenn ich in der ETS explizit die Multicast Schnittstelle die knxd dann bereit stellt auswähle ... normale Bus Traffic bekommt er nicht mit ...

                              Kommentar

                              Lädt...
                              X