Ankündigung

Einklappen
Keine Ankündigung bisher.

Hilfe wegen sporadischer Telegrammverluste gesucht.

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Hilfe wegen sporadischer Telegrammverluste gesucht.

    Hallo KNX-Forum!

    Ich betreue bei unseren Firmengebäuden die KNX Installationen und habe auch die entsprechenden Grundkenntnisse(mehr aber auch nicht). Es gibt mittlerweile 3 autarke Gebäude mit je um die 200 Teilnehmer.

    Ich melde mich nun hier in der Hoffnung jemanden zu finden, der uns, bzw. dem ausführenden Installateur, bei der Fehlersuche helfen kann. Wir haben nämlich in unserem neusten Bauabschnitt(Bj 2019) immer wieder sporadisch Probleme mit Telegrammverlusten. So möchte ich das mal nennen. Diese machen sich so bemerkbar, dass z.B. ein BM ein EIN-telegramm sendet, das Licht in diesem Bereich wird aber nicht eingeschaltet. Der BM denkt aber, dass es EIN ist und wenn das ein stark frequentierter Flur ist, dann kommt den ganzen Tag kein erneuter EIN Befehl und das Licht bleibt aus. Im Gruppenmonitor sieht man dann auch, dass der EIN-Befehl mit der entsprechenden GA kam, aber der Aktor hat nicht darauf reagiert. Es gibt auch Fälle, wo von 2 adressierten Aktoren nur einer schaltet und den Status zurück meldet. Leider hatte ich das bisher nur mit dem Gruppenmonitor betrachtet und dokumentiert. Ich habe hier aber schon gelesen, dass man z.B. Wiederholung von Telegrammen nur im Busmonitor sehen kann. Diesen werde ich nun in Zukunft dafür verwenden.

    Das Unternehmen, welches die Installation der Anlage durchgeführt hat, ist nun schon über ein Jahr dran und nicht in der Lage die Ursache dafür zu finden. Es war auch schon mal ein vom Hersteller beauftragter Techniker da. Dieser hat aber nur durch filtern der GA in den LK die Buslast verringert, welche aber schon vorher nicht so hoch war(vorher: 2500/h, jetzt:1000/h). Ich war mir damals schon sicher, dass die Buslast nicht die Ursache dafür sein kann, da z.B. auch Befehle wie die Außenbeleuchtung EIN um 5:30 wenn das Gebäude leer ist in dem Gruppenmonitor gefehlt haben.

    Es gibt also 2 Fehlermodi:
    1. Das Telegramm wird gesendet und ist auf dem Gruppenmonitor zu sehen, aber nicht alle Aktoren reagieren darauf(Licht bleibt aus und Aktor sendet keine Statusänderung)
    2. Das Telegramm fehlt gänzlich im Gruppenmonitor(entweder wurde es gar nicht gesendet, oder es wurde vom IP-Interface nicht empfangen)

    Zur Häufigkeit der Fehler. Es kann sein, dass mir mal 1-2 Wochen gar kein Fehler gemeldet wird(was aber nicht heißt, dass es keine gab). Es kann aber auch mal in einer Woche fast täglich was sein. Daher ist der Leidensdruck zum Glück auch nicht so hoch. Die Ursache dafür sollte aber irgendwann einmal gefunden werden.

    Irgendwie habe ich den Eindruck, dass es ein Hardware Problem sein könnte und ein Teilnehmen oder eine schlechte Verbindung die Signalqualität auf dem Bus dämpft und es aus diesem Grund zu den Telegrammverlusten kommt. Oder ist das total abwegig?

    Meine Frage ist nun, ob es hier im Rhein-Main-Gebiet Firmen gibt, die sich auf die Fehlersuche in KNX-Anlagen spezialisiert haben und die sich ggf. auch die Signalqualität auf dem Bus ansehen können? Ich würde den Kontakt dann an den Installateur weiterleiten.

    Gerne nehme ich auch Ratschläge an um die Ursache für das Problem weiter eingrenzen zu können. Auf dem Busmonitor konnte ich in der letzten Stunde sehen, dass bei 1000 Telegrammen bei 3 Stück eine Wiederholung notwendig war. Was vermutlich ja auch mal sein darf? Leider hängt das IP-Interface nicht auf der Hauptlinie weshalb ich durch die LK mit Filter nicht mehr alles mitbekomme…

    #2
    Solche sporadischen Fehler sind immer schwierig. Schlechte, korrodierte oder wackelnde Verbindung kann ich mir vorstellen, würde dann aber eher in Richtung zusammenhängender Bereiche gehen.
    Als Erstmaßnahme würde ich die BWMs in den stark frequentierten Bereichen auf zyklisch senden ändern - kein Beheben des Fehlers aber eine Linderung der Probleme.
    Sind bei den Problemen dann immer LKs mit betroffen oder fehlen die Signale dann nur innerhalb einer Linie.
    Betreffen die Signale nur eine Linie oder betrifft das mehrere Linien?

    Kannst du einen dauerhaften Busmitschnitt erzeugen, möglichst Linienübergreifend?

    Viel Erfolg
    Florian

    Kommentar


      #3
      Hallo Florian,

      danke für deine schnelle Antwort!

      Zitat von Beleuchtfix Beitrag anzeigen
      Sind bei den Problemen dann immer LKs mit betroffen oder fehlen die Signale dann nur innerhalb einer Linie.
      Betreffen die Signale nur eine Linie oder betrifft das mehrere Linien?
      Es sind eigentlich alle Linien betroffen. Innerhalb der Hauplinie und Linien übergreifend:
      - BM auf 2.1 schaltet Aktor auf 2.0(Hauptlinie) nicht
      - BM auf 2.3 schaltet Aktor auf 2.0(Hauptlinie) nicht
      - Telegramme der Zeitschaltuhr auf 2.0 kommen nicht bei der Wetterstation auf 2.0 an
      - Fassadenbefehle der Wetterstation kommen nicht bei allen Jalousieaktoren an(alle auf 2.0)

      Es ist aber immer die Hauptlinie beteiligt. Was aber auch einfach daran liegt, dass alle Aktoren auf der 2.0 liegen. Das wurde so gemacht, weil sonst die Anzahl der Teilnehmer in den einzelnen Linien >64 geworden wäre.

      Zitat von Beleuchtfix Beitrag anzeigen
      Kannst du einen dauerhaften Busmitschnitt erzeugen, möglichst Linienübergreifend?
      Das könnte ich machen wenn ich weiß wie das genau geht Muss ich mich dafür einfach nur an eine USB-Schnittstelle auf der 2.0 hängen? Laufen denn alle Telegramme immer über die Hauptline? Das wurde mir mal so gesagt...

      Danke André

      Kommentar


        #4
        Zitat von bambam Beitrag anzeigen
        Laufen denn alle Telegramme immer über die Hauptline?
        Also alle Telegramme der Linie 2.0 in jedem Fall :-) und eigentlich auch alle, die außerhalb der eigenen Linie bearbeitet werden sollen. Gefilterte Telegramme kommen natürlich nicht an. Ich würde jetzt einmal die Busspannung der Hauptlinie messen und von da aus suchen.
        Gruß
        Florian

        Kommentar


          #5
          Zitat von Beleuchtfix Beitrag anzeigen
          Also alle Telegramme der Linie 2.0 in jedem Fall :-) und eigentlich auch alle, die außerhalb der eigenen Linie bearbeitet werden sollen. Gefilterte Telegramme kommen natürlich nicht an. Ich würde jetzt einmal die Busspannung der Hauptlinie messen und von da aus suchen.
          Gruß
          Florian
          So hätte ich das jetzt auch erwartet. Ich schau mir die Hauptlinie dann mal genauer an.

          Mich würde aber schon mal interessieren, ob es Geräte zur Analyse der Signalqualität auf dem KNX-Bus gibt(ähnlich wie ein Oszilloskop oder Spektrumanalysator). Oder braucht man eine Analyse der Signale auf dem Bus nicht, weil es in 99,9% der Fälle nicht daran liegt?

          Kommentar


            #6
            Zitat von bambam Beitrag anzeigen
            Mich würde aber schon mal interessieren, ob es Geräte zur Analyse der Signalqualität auf dem KNX-Bus gibt
            Dazu weiß ich nichts, aber eigentlich ist der Bus so robust, dass so typische Probleme wie fehlender Abschlusswiderstand, falsches Pärchen gewählt sich so schnell nicht auswirken. Vorstellen kann ich mir auch ein Problem bei der Wetterstation, die als Außengerät mit auf der Hautlinie hängt, etwas, was ich so nicht machen würde. Ich hatte neulich bei einem Kunden, dass ein noch nicht angeschlossener Außen-BWM (also Kabel war schon draußen, die ganze Außenlinie zum Stehen gebracht hat, Feuchtigkeit und Frost. Nach 3 Tagen war dann der Spuk vorbei. Zum Glück war die Außenlinie getrennt.

            Gruß
            Florian

            Kommentar


              #7
              Das

              Zitat von bambam Beitrag anzeigen
              2.0(Hauptlinie)
              und das

              Zitat von bambam Beitrag anzeigen
              bei der Wetterstation auf 2.0
              ist schonmal keine gesunde Kombination.


              Zitat von bambam Beitrag anzeigen
              Mich würde aber schon mal interessieren, ob es Geräte zur Analyse der Signalqualität auf dem KNX-Bus gibt
              Spannungsversorgungen mit Diagnose können schonmal helfen und bieten teilweise interessante Diagnoseobjekte.

              Die Begrenzung auf 64 Geräte je Liniensegment halte ich für ein geringeres Problem, gerade wenn die Geräte so zum Großteil aus 2010 und jünger stammen.

              Telegrammverlust innerhalb der gleichen Linie ist ganz schlecht und da alle anderen Verluste irgendwie auch immer diese Linie betreffen würde ich auch die Spannungsversorgung und Klemmstellen der HL mal prüfen. Bei wilder physikalischer Topologie auch drauf achten das da keiner nen Ring gebastelt hat.
              ----------------------------------------------------------------------------------
              "Der Hauptgrund für Stress ist der tägliche Kontakt mit Idioten."
              Albert Einstein

              Kommentar


                #8
                Hallo,

                ich habe nun das Notebook an der Hauptlinie 2.0 hängen und den Bussmonitor am laufen. Da sieht es überwiegend so aus, dass alle Nebeneingänge der BM ihr Telegramm wiederholen müssen weil kein ACK kommt weil bei keinem Teilnehmer das Lesen Flag gesetzt ist. Sehe ich das richtig? Das ist zwar sicherlich unschön und sorgt für viel unnötige Buslast, aber ich sehe darin noch nicht den Grund dafür, dass z.B. nachts Telegramme der Zeitschaltuhr nicht kommen. Nachts ist auf dem Bus nix los.

                Und noch eine Frage, warum sehe ich nicht alle Telegramme auf dem Busmonitor? Die Wetterstation sendet ja z.B. dauernd Werte, welche ich aber nur im Gruppenminitor und nicht auf dem Busmonitor sehe. Auch die Telegramme der Zeitschaltuhren sehe ich nicht auf dem Busmonitor.

                Wie schon zu Beginn geschrieben, fall hier jemand aus der Region Mainz/Frankfurt kommt, kann er sich gerne melden um hier vor Ort zu analysieren....
                You do not have permission to view this gallery.
                This gallery has 3 photos.
                Zuletzt geändert von bambam; 03.03.2021, 11:23.

                Kommentar


                  #9
                  Zitat von bambam Beitrag anzeigen
                  Nebeneingänge der BM ihr Telegramm wiederholen müssen weil kein ACK kommt weil bei keinem Teilnehmer das Lesen Flag gesetzt ist.
                  Ein ACK hat nichts mit einem L-Flag zu tun.

                  Ein ACK hat nur damit was zu tun ob es im Gesamtsystem oder auf der Linie ein weiteres Gerät mit Verbindung zu der gesendeten GA gibt ja/nein.

                  Zitat von bambam Beitrag anzeigen
                  Die Wetterstation sendet ja z.B. dauernd Werte
                  Also Standard Telegramme sind in beiden Monitoren zu sehen. Ein ACK-Telegramm selbst bzw. weitere Systemtelegramme sind nur in einen der beiden Monitore sichtbar. Bringe ich aber auch immer durcheinander.

                  Wenn Du da gerade mit dem Monitor auf der HL 2.0 bist, dann frage ich mich allerdings warum die Telegramme zur 1/7/240 überhaupt auf der Linie zirkulieren wenn die GA nur mit Geräten der Linie 2.3.x verbunden ist.

                  Mir dünkt da sind gar keine Filter auf den LK aktiv bzw. teilweise falsche oder nur bei einigen LK. Da kann dann sowas bei rauskommen das einige Telegramme nicht auf andere Linien gelangen und andere unnötiger Weise schon.

                  Daher immer wenn man einige linienübergreifende GA-Verlinkungen gemacht hat, dann auch im Anschluss die betroffenen LK neu programmieren, damit die Filtertabellen da drinnen auf aktuellem Stand sind. Und bei vielen Linien dann auch immer schön die Filter aktivieren.
                  ----------------------------------------------------------------------------------
                  "Der Hauptgrund für Stress ist der tägliche Kontakt mit Idioten."
                  Albert Einstein

                  Kommentar


                    #10
                    Zitat von gbglace Beitrag anzeigen
                    Ein ACK hat nur damit was zu tun ob es im Gesamtsystem oder auf der Linie ein weiteres Gerät mit Verbindung zu der gesendeten GA gibt ja/nein.
                    Und warum werden dann die ganzen Telegramme der BM wiederholt? Grüne und gelbe Zeilen sollten doch normalerweise System nicht vorhanden sein, oder?

                    Zitat von gbglace Beitrag anzeigen
                    Wenn Du da gerade mit dem Monitor auf der HL 2.0 bist, dann frage ich mich allerdings warum die Telegramme zur 1/7/240 überhaupt auf der Linie zirkulieren wenn die GA nur mit Geräten der Linie 2.3.x verbunden ist.

                    Mir dünkt da sind gar keine Filter auf den LK aktiv bzw. teilweise falsche oder nur bei einigen LK. Da kann dann sowas bei rauskommen das einige Telegramme nicht auf andere Linien gelangen und andere unnötiger Weise schon.
                    Das stimmt allerdings. Vermutlich hast du Recht, ODER die USB-Schnittstelle hängt gar nicht auf der 2.0 wie mir gesagt wurde und wie es in der Topologie ist. Das würde auch erklären warum keine Telegramme der Wetterstation usw. zu sehen sind. Ich programmiere mal alle LK neu und checke die USB-Schnittstelle...

                    Kommentar


                      #11
                      Es ist auch seltsam, dass im ersten Bild sowohl die Telegramme von 2.1.x als auch von 2.3.114 mit Routingzähler 6 ankommen. Im letzten sieht man die von 2.0.x mit 5 und die von 2.3.x mit 4.
                      Also ist wahrscheinlich die USB-Schnittstelle auf 2.1 und das Gerät 2.3.114 ist fälschlicherweise an die 2.1 angeschlossen.
                      Die Filtertabellen passen dann natürlich nicht.
                      Zuletzt geändert von Klaus Gütter; 03.03.2021, 12:58.

                      Kommentar


                        #12
                        Zitat von Klaus Gütter Beitrag anzeigen
                        Es ist auch seltsam, dass im ersten Bild sowohl die Telegramme von 2.1.x als auch von 2.3.114 mit Routingzähler 6 ankommen. Im letzten sieht man die von 2.0.x mit 5 und die von 2.3.x mit 4.
                        Also ist wahrscheinlich die USB-Schnittstelle auf 2.1 und das Gerät 2.3.114 ist fälschlicherweise an die 2.1 angeschlossen.
                        Die Filtertabellen passen dann natürlich nicht.
                        Danke! So wird es wohl sein. Daher findet die 2.3.114 keinen Abnehmer für seine Telegramme!

                        Edit: also die USB-Schnittstelle war schon mal auf der 2.1. Nun gibt es noch mindestens 3 BM, die auf der 2.1 hängen und da aber nicht hingehören.
                        Zuletzt geändert von bambam; 03.03.2021, 13:42.

                        Kommentar


                          #13
                          Ich habe jetzt mal wirklich die Telegramme auf der Hauptline 2.0 aufgenommen. Ich glaube hier kann man sehen, dass es hier sporadisch Probleme gibt. Oder wie ist zu erklären, dass z.B. die Uhrzeit 5/0/102 von der Wetterstation manchmal ein LL_ACK hat und manchmal nicht? Grün heisst, dass nicht alle adressierten Geräte ein ACK gesendet haben und gelbe Zeile bedeutet, dass gar kein LL_ACK kam?

                          Wenn man sich unten die grüne 1/1/214 betrachet, dann sendet die 2.2.13 den geänderten Status, die Zeile ist aber trotzdem grün. D.h. der Homeserver hat dann sein LL_ACK nicht gesendet? Oder könnte es auch sein, dass das LL_ACK von der 2.2.13 nicht bei der 2.2.130 ankam?

                          Busmonitor_03.03.2021_1.1.214.jpg GA_1.1.214.jpg Busmonitor_03.03.2021_2.0.jpg
                          Angehängte Dateien

                          Kommentar


                            #14
                            Wenn du mit der Schnittstelle auf der 2.0 sitzt, siehst du die Acks der Linienkoppler, da auf der 2.0 je keine Geräte sind, die mit der GA verbunden sind.
                            Beachte, dass das LinkLayer-Acks sind, also lokal die Übertragung auf dem Liniensegment absichern - es gibt bei KNX-Gruppenkommunikation keine Ende-zu-Ende-Sicherung.

                            Kommentar


                              #15
                              Noch was: welche USB-Schnittstelle benutzt du? Ältere USB-Schnittstellen (die noch auf einer BCU basierten), verlieren im Busmon-Betrieb auch mal Telegramme zwischen Bus und PC.

                              Kommentar

                              Lädt...
                              X