Ankündigung

Einklappen
Keine Ankündigung bisher.

Samba Mount mit Openmediavault

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Samba Mount mit Openmediavault

    Moin!

    Seit gestern habe ich meinen Qnap NAS gegen einen Server mit Openmediavault ersetzt. Um z.B. die Mülltermine auf dem Server zu haben und nicht per ssh auf den Edomi Rechner zu müssen, habe ich ein Verzeichnis per Samba auf den Edomi Rechner gemounted. Das geht nun leider nicht mehr...

    Ob über fstab oder über manuellem mount Befehl, bekomme ich den Fehler
    Code:
    mount error(13): Permission denied
    Die Befehle bzw. Zeilen sind:
    Code:
    mount.cifs -vvv -o user=user,password=Geheim,domain=WORKGROUP //192.168.2.179/Public /mnt/Public
    respektive in der /etc/fstab
    Code:
    //192.168.2.179/Public /mnt/Public cifs credentials=/root/.sharecredent 0 0
    Wenn ich die gleichen Befehle auf anderen Debian Maschinen ausführe, kann ich das Verzeichnis mounten (also copy&paste, also kein typo drin).
    Weiterhin kann ich von CentOS auch mit smbclient auf den Share drauf...
    Solangsam weiß ich nicht weiter.
    Dmesg | tail liefert:
    Code:
    [root@localhost ~]# dmesg | tail
    CIFS VFS: cifs_mount failed w/return code = -13
    Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    CIFS VFS: Send error in SessSetup = -13
    CIFS VFS: cifs_mount failed w/return code = -13
    Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    CIFS VFS: Send error in SessSetup = -13
    CIFS VFS: cifs_mount failed w/return code = -13
    Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    CIFS VFS: Send error in SessSetup = -13
    CIFS VFS: cifs_mount failed w/return code = -13
    Ok, man hat ja nicht nur ein Protokoll. Zack, nfs eingebunden. Hier liegt das Problem, dass der Ordner zwar die Rechte 777 an der Quelle hat, aber vom user mit der id 1000 erstellt wurde, den es bei Edomi nicht gibt. Der Ordner wird eingebunden, und als root habe ich keinen Zugriff darauf... Permission denied. Das verstehe ich nun am allerwenigsten.

    Habt ihr Tipps, wie eins der beiden Probleme gelöst werden könnte?

    Grüße
    Christian

    #2
    Das erste Problem hat sich nach Blick in dern Server log, den ich bisher ignoriert habe, gelöst. Und zwar gibt es im Changelog von Samba diese Aussage:
    Code:
     =============================
                       Release Notes for Samba 4.5.0
                               September 7, 2016
                       =============================
    
    
    This is the first stable release of the Samba 4.5 release series.
    
    
    UPGRADING
    =========
    
    NTLMv1 authentication disabled by default
    -----------------------------------------
    
    In order to improve security we have changed
    the default value for the "ntlm auth" option from
    "yes" to "no". This may have impact on very old
    clients which doesn't support NTLMv2 yet.
    
    The primary user of NTLMv1 is MSCHAPv2 for VPNs and 802.1x.
    
    By default, Samba will only allow NTLMv2 via NTLMSSP now,
    as we have the following default "lanman auth = no",
    "ntlm auth = no" and "raw NTLMv2 auth = no".
    Und genau dieser "very old" client ist Edomi (genau wie mein Qnap). Wieder aktiviert und der Punkte geht!

    Kommentar

    Lädt...
    X