Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS19001723: Sensor-Redundanz (Watchdog).

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    LBS19001723: Sensor-Redundanz (Watchdog).

    Der Baustein leitet im E1 direkt an A1 weiter. Sollte E1 ausfallen (länger als E3 Sekunden keine Aktualisierung erhalten) wird der Ersatzwert von E2
    an A1 gesendet und ein Alarm aktiviert.

    Download unter:
    https://service.knx-user-forum.de/?c...ad&id=19001723


    sG
    Joe

    #2
    Würde das nicht auch mit EDOMI-Mitteln funktionieren? So in dieser Art:

    E1: Primärer Sensor
    E2: Redundanter Sensor

    2020-01-15 14_12_05-EDOMI · Administration.png

    Würde nur bei einem Sensorwert von genau 0 nicht funktionieren, aber da könnte man noch einen Binärauslöser dazwischen schalten.
    Gruß
    Stefan

    Kommentar


      #3
      Servus,

      danke für die Anregung.
      Ja, schon und nein. Diese Logik verhindert zB nicht das nochmalige Aktualisieren einer GA, wenn ich als Eingangs und Ausgangs GA dieselbe GA nehme. In manchen Fällen ist das praktisch.
      zusätzlich macht es nicht die Sensor Anpassung. Wie gesagt, meine KNX Sensoren sind ca 10 cm am Puffer versetzt zu den 1w sensoren. Ich muss also zu jedem Ersatzwert einen Zusatz Wert addieren, damit die Berechnung beim Ausfall ungefähr stimmt.
      Klar kann ich auch dafür einen additionsLBS hinzufügen.
      Gesamt habe ich dass jedoch 160 Mal im Einsatz, für alle 160 Sensoren, die ich doppelt in Verwendung habe. Diese schreiben mir mit einem String Bauteil auch gleich eine passende Fehlermeldung in die Visu. Aus diesen Gründen ist für mich dieser LBS eine angenehme Erleichterung.
      Aber natürlich bin ich für weitere Anregungen sehr offen!

      Sg Joe

      Kommentar


        #4
        Sollte so auch gehen. Sind dann halt mehr Bausteine.

        Kommentar


          #5
          Hallo givemeone

          Vielen Dank für den LBS, soetwas habe ich gerade gesucht. Allerdings hat der Baustein jede Menge Errors ins Log geworfen, wenn er mit nicht-numerischen Werten gefüttert wurde. Du findest einen Patch im Anhang. Ich habe den Formatter drüber gejagt, die Doku angepasst und die non-numeric-Errors gefixt.

          Lass mich wissen, ob das so ok ist für Dich oder ob Du weitere Details wissen möchtest.

          PS: Die Doku zu E4 fehlt gänzlich. Was ist Deine konkrete Idee dafür?
          Angehängte Dateien
          Kind regards,
          Yves

          Kommentar


            #6
            Hallo starwarsfan, Servus Yves,

            Danke dafür!

            Leider bekomme ich den Patch nicht applied,
            Code:
            git apply 19001723_reformated_and_fixed_errors_if_non-numeric_values_given.patch
            error: patch failed: 19001723_lbs.php:1
            error: 19001723_lbs.php: patch does not apply
            kannst Du mir die Datei ganz schicken?
            Ich hab ihn mir angesehen und werde das dann sehr gerne übernehmen!

            E4 nutze ich in meinem Fall zur Anpassung an eventuell unterschiedliche Messwerte. Meine Ersatz-Temperatursensoren (1-Wire) im Puffer sind beispielsweise ein paar cm unterhalb der normalen Sensoren(PT1000) und haben ein Delta von ca. 0.5°. Das passe ich hier an. Wenn der Baustein umschaltet und E2 anstatt E1 sendet, wird der Wert E2 um diesen Wert angepasst. Würdest Du das eher extern erhhen, um keinen Konlikt mit Texten zu bekommen? Oder sollte man E4 im init leer lassen und bei der Berechnung einfach auf is_numeric prüfen?

            sG Joe

            Kommentar


              #7
              Hi Joe

              Zitat von givemeone Beitrag anzeigen
              Leider bekomme ich den Patch nicht applied,
              Code:
              git apply 19001723_reformated_and_fixed_errors_if_non-numeric_values_given.patch
              error: patch failed: 19001723_lbs.php:1
              error: 19001723_lbs.php: patch does not apply
              Hm, seltsam...


              Zitat von givemeone Beitrag anzeigen
              kannst Du mir die Datei ganz schicken?
              Klar, ist hier im Anhang.


              Zitat von givemeone Beitrag anzeigen
              Ich hab ihn mir angesehen und werde das dann sehr gerne übernehmen!
              Cool, freut mich!


              Zitat von givemeone Beitrag anzeigen
              E4 nutze ich in meinem Fall zur Anpassung an eventuell unterschiedliche Messwerte. Meine Ersatz-Temperatursensoren (1-Wire) im Puffer sind beispielsweise ein paar cm unterhalb der normalen Sensoren(PT1000) und haben ein Delta von ca. 0.5°. Das passe ich hier an. Wenn der Baustein umschaltet und E2 anstatt E1 sendet, wird der Wert E2 um diesen Wert angepasst. Würdest Du das eher extern erhhen, um keinen Konlikt mit Texten zu bekommen? Oder sollte man E4 im init leer lassen und bei der Berechnung einfach auf is_numeric prüfen?
              Das kann schon so bleiben. Jetzt sollte es ja auch sauber funktionieren resp. einfach gar nichts machen, wenn keine numerischen Werte übergeben werden. Aber das habe ich jetzt nicht explizit getestet. Sollte sauber in der Doku beschrieben werden und dann kann jeder selber entscheiden, ob's für ihn brauchbar ist oder nicht.
              Angehängte Dateien
              Kind regards,
              Yves

              Kommentar

              Lädt...
              X