Ankündigung

Einklappen
Keine Ankündigung bisher.

ZSU schaltet nicht

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    ZSU schaltet nicht

    Hallo,

    ich habe das Problem, dass meine ZSUs nicht den KO-Wert zu den gegebenen Schaltzeiten wechseln.

    Zum Beispiel habe ich folgende ZSU angelegt:
    ZSU.png

    Das KO 4/0/7 ist auf 1 per Init-Wert (überprüft mit LiveWert) und das interne KO "Status ZSU Nacht 1" ist remanent (DPT1) und hat keinen Wert.
    Wenn ich die Erläuterungen richtig verstanden habe, dann sollte mein KO "Status ZSU Nacht 1" [1605] um 21:00 Uhr den Wert 1 erhalten und in der Woche um 06:45 Uhr bzw. am Wochenende um 08:00 Uhr wieder auf 0 wechseln, bis es wieder 21:00 Uhr ist usw.

    Aber das funktioniert bei mir nicht, die Uhrzeit stimmt in EDOMI, aber die ZSU führt keine Schaltvorgänge aus und im Fehlerlog wird auch kein Fehler eingetragen.

    Mache ich was falsch oder habe ich das Prinzip nicht verstanden?

    #2
    Du hast das Prinzip korrekt verstanden Sollte eigentlich funktionieren - das Problem wird wahrscheinlich an anderer Stelle zu finden sein (Logik?).

    Als ersten Schritt kannst Du mal das MonitorLog aktivieren (falls nicht schon geschehen) und die Ereignisse beobachten. Falls Du die ZSU auch in der Visu anzeigst, sollte der Status ja auf "Ein" stehen - nur mal so als Kontrolle...

    Aktiviert hast Du das Projekt ja bestimmt nach dem Erstellen der ZSU bzw. der Schaltzeiten?
    EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

    Kommentar


      #3
      Danke für die Antwort, eine Visu habe ich nicht, aber im Syslog taucht eine Fehlermeldung beim Starten auf:
      2016-04-13 00:40:21 893405 MAIN 3268 DB edomiLive.timerData: Incorrect file format 'timerData' ERROR
      2016-04-13 00:40:21 908261 MAIN 3268 Check: 91 Datenbanken überprüft (1 Fehler) ERROR
      Die hat vermutlich was damit zu tun, oder?
      Edit: Die Fehlermeldung bleibt auch da, wenn ich alle ZSUs lösche.
      Zuletzt geändert von panzaeron; 12.04.2016, 23:52.

      Kommentar


        #4
        Die hat in der Tat etwas damit zu tun

        Scheint so, als ob die ZSU-Datenbank "kaputt" ist - vermutlich wurde Dein Server mal "hart" abgeschaltet oder rebooted.

        Versuche mal die Datenbank zu löschen:
        Einfach das Projekt erneut aktivieren und dabei die Option "Zeitschaltuhren" auswählen (siehe Screenshot).
        Bildschirmfoto 2016-04-13 um 00.01.49.png

        Wenn das auch nicht helfen sollte, muss die Datei manuell gelöscht werden - im Ordner /var/lib/mysql einfach alle entsprechenden Dateien löschen:

        Code:
        rm -rf /var/lib/mysql/edomiLive/timerData.*
        Zuletzt geändert von gaert; 13.04.2016, 00:05.
        EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

        Kommentar


          #5
          Zitat von gaert Beitrag anzeigen
          Versuche mal die Datenbank zu löschen:
          Einfach das Projekt erneut aktivieren und dabei die Option "Zeitschaltuhren" auswählen.
          Genau das war die Lösung, jetzt funktionieren die ZSU wieder.
          Danke für deine Hilfe ☺

          Kommentar


            #6
            So ganz funktionieren meine ZSU noch nicht bzw. genauer die ZSU schon, aber nicht das remanente Speichern der Zustände.

            Wenn ich in EDOMI das Live-Projekt neu aktiviere, um Änderungen zu übernehmen sind alle remanent gespeicherten Werte weg.
            Ich habe mir eine Test ZSU eingerichtet, die ein internes KO schaltet, welches auch sonst nicht verwendet wird.

            Die ZSU setzt auch die 1 wie eingestellt, aber beim Aktivieren des Live-Projekts ist der Wert wieder weg.
            Da es aber beim Aktivieren extra einen Punkt zum Löschen der KOs gibt, sollte der Zustand vermutlich nicht verloren gehen,
            aber warum werden die Werte bei mir nicht gespeichert?

            Wäre für Tipps dankbar, von dem Projekt habe ich schon alle Inhalte gelöscht...

            Gruß Axel



            Kommentar


              #7
              Die ZSU setzt das KO wie jede andere Funktion auch (also z.B. eine Logik/Visu/...). Daher wird die ZSU nicht schuldig im Sinne der Anklage sein

              Ich kann nicht ausschließen, dass in Sachen remanente KOs irgendwo ein Fehler steckt - aber ich konnte bislang noch keine Probleme feststellen. Daher wäre mehr Information nützlich, z.B. ein Test (ohne ZSU) mit einem beliebigen remanenten KO.

              Noch ein Hinweis: Sobald an der KO-Konfiguration etwas verändert wurde (z.B. Datentyp), wird der remanente Wert dieses KOs beim Aktivieren natürlich gelöscht!
              EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

              Kommentar


                #8
                ​[QUOTE=gaert;n938940]Die ZSU setzt das KO wie jede andere Funktion auch (also z.B. eine Logik/Visu/...). Daher wird die ZSU nicht schuldig im Sinne der Anklage sein
                Das glaube ich auch und die ZSU schaltet auch wie erwartet.
                Zitat von gaert Beitrag anzeigen
                Ich kann nicht ausschließen, dass in Sachen remanente KOs irgendwo ein Fehler steckt - aber ich konnte bislang noch keine Probleme feststellen. Daher wäre mehr Information nützlich, z.B. ein Test (ohne ZSU) mit einem beliebigen remanenten KO.

                Noch ein Hinweis: Sobald an der KO-Konfiguration etwas verändert wurde (z.B. Datentyp), wird der remanente Wert dieses KOs beim Aktivieren natürlich gelöscht!
                Ich habe eine kleine Testlogik erstellt:

                Test remanent.png

                Mit zwei KOs, einmal ein KNX-Objekt (GA 0/0/50) als Zulieferer und ein internes KO Test, welcher als remanent gekennzeichnet ist.

                Wenn ich jetzt über den KNX-Bus eine 1 sende, dann wechselt auch das interne KO "Test" auf 1 und sollte, wenn ich es richtig verstehe, diese 1 auch behalten wenn ich nichts weiter ändere, sondern nur das Projekt erneut aktiviere (Kommunikationsobjekte löschen ist natürlich nicht ausgewählt) muss anschließend das KO "Test" immer noch auf 1 sein.
                Wie man hier sieht (LiveWerte sind aktiviert) ist es das nicht, sondern beide sind leer, wobei das bei dem KNX-Objekt "Test DPT1" so sein soll:
                Test remanent nach Projektaktivierung.png

                Jetzt habe ich ein Problem mit meiner Datenbank gehabt wie oben festgestellt, sehr wahrscheinlich durch ein hartes Abschalten der VM, also vermute ich mal werden nur bei mir die internen KOs nicht remanent gespeichert, aber was könnte ich dagegen tun?

                Hättest du noch einen Tipp? Beim Aktivieren des Projekts habe ich schon die Option "Live-Projekt komplett löschen" aktiviert gehabt, ohne eine Besserung.

                Kommentar


                  #9
                  Verstehe ich nicht so ganz... Wird die KNX-GA denn beim Start abgefragt oder ähnliches? Denn dann wird das KO natürlich sofort auf diesen Wert gesetzt. Im 2. Bild sehe ich keine Livewerte?

                  DB-Probleme sind immer doof Am Besten in der Verwaltung "Liveprojekt löschen" und dann neu aktivieren.
                  EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

                  Kommentar


                    #10
                    Zitat von gaert Beitrag anzeigen
                    Verstehe ich nicht so ganz... Wird die KNX-GA denn beim Start abgefragt oder ähnliches? Denn dann wird das KO natürlich sofort auf diesen Wert gesetzt.
                    Nein kein Initialwert oder InitScan, sondern ist so wie im folgenden Screenshot zu sehen konfiguriert: GA Test DPT1.png



                    Zitat von gaert Beitrag anzeigen
                    Im 2. Bild sehe ich keine Livewerte?

                    DB-Probleme sind immer doof Am Besten in der Verwaltung "Liveprojekt löschen" und dann neu aktivieren.
                    Ja, weil leider keine Live-Werte da sind , was aber bei KO "Test" nach meinem Verständnis der Fall sein sollte, wie der folgende Screenshot nach der Projekt-Aktivierung zeigt: KO Test.png



                    Habe ich noch irgendwelche Optionen, wenn "Live Projekt löschen" keine Besserung bringt?

                    Kommentar


                      #11
                      Irgendwie scheint da einiges im Argen zu sein... Also DB-mäßig!

                      Was sagt denn das SystemLog dazu - beim Start wird die DB ja untersucht?

                      Wenn die DB "kaputt" ist, macht es keinen Sinn hier weiter zu analysieren - denn das sind Umstände mit denen die Funktionen natürlich nicht rechnen. Nur als "Beweis": Ich habe seit Monaten ein remanentes KO (Stromzähler) dabei, dass per KNX+Logik aktualisiert wird. Hat schon hunderte "Aktivierungen" überlebt

                      Noch ein Tipp: Interne KOs sollten grundsätzlich vom Typ "Variant" sein, also nicht DPTx... Vielleicht liegt's auch daran - habe ich noch nie getestet.
                      EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

                      Kommentar


                        #12
                        Zitat von gaert Beitrag anzeigen
                        Noch ein Tipp: Interne KOs sollten grundsätzlich vom Typ "Variant" sein, also nicht DPTx... Vielleicht liegt's auch daran - habe ich noch nie getestet.
                        Der Tipp hat geholfen, ich habe jetzt meine internen KOs auf Variant umgestellt und siehe da, nach einem Neustart ist auch der KO-Wert noch vorhanden

                        Danke für die Unterstützung

                        Kommentar


                          #13
                          Liegt vermutlich daran, dass DPT1 nicht "leer" sein kann, sondern nur 0 oder 1...
                          EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

                          Kommentar

                          Lädt...
                          X