Ankündigung

Einklappen
Keine Ankündigung bisher.

Konfiguration knxd bei Weinzierl IP Router

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Konfiguration knxd bei Weinzierl IP Router

    Hallo,

    ich versuche gerade meinen IP Router Weinzierl 752 secure zur Zusammenarbeit mit dem knxd zu verleiten. Leider bin ich bislang gescheitert.
    Schaltbefehle über die visu werden nicht angenommen, Fehlermeldungen in der mail-Datei:
    Aug 10 18:35:36 SmartHomeNG knxd[2395]: Layer2 '/etc/knxd.ini' not supported
    Aug 10 18:35:36 SmartHomeNG systemd[1]: knxd.service: Main process exited, code=exited, status=1/FAILURE
    Aug 10 18:35:36 SmartHomeNG systemd[1]: Failed to start KNX Daemon.
    Aug 10 18:35:36 SmartHomeNG systemd[1]: knxd.service: Unit entered failed state.
    Aug 10 18:35:36 SmartHomeNG systemd[1]: knxd.service: Failed with result 'exit-code'.
    Aug 10 18:35:46 SmartHomeNG systemd[1]: knxd.service: Service hold-off time over, scheduling restart.
    Hier mal meine conf Datei:
    Code:
    KNXD_OPTS=/etc/knxd.ini
    START_KNXD=YES
    und meine ini:
    Code:
    [main]
    addr = 1.1.251
    client-addrs = 1.1.252:4
    connections = A.ip
    systemd = systemd
    cache = group-cache
    
    
    [A.ip]
    driver = ip
    
    
    [B.pace]
    delay = 50
    filter = pace
    Ich hoffe, ihr könnt mir weiter helfen.

    Vielen Dank.

    #2
    Zitat von Maxthomas2001 Beitrag anzeigen
    Ich hoffe, ihr könnt mir weiter helfen.
    Ich beherrsche die direkte Notation über das ini File nicht wirklich. Deshalb habe ich mal versucht deine Parameter über knxd_args abzubilden mit
    Code:
    knxd_args -e 1.1.251 -E 1.1.252:4 --send-delay=50 -b ip:
    und komme damit praktisch auf das Gleiche
    Code:
    [A.ip]
    driver = ip
    filters = B.pace
    [B.pace]
    delay = 50
    filter = pace
    [main]
    addr = 1.1.251
    client-addrs = 1.1.252:4
    connections = A.ip
    systemd = systemd
    Am Inhalt kann es wohl also nicht liegen. Wenn du ein ini File verwendest, muss dessen Name das einzige Argument für knxd sein. Ich vermute deshalb, dass der Start von knxd noch mit anderen Argumenten ergänzt wird. Du kannst es wohl beheben, wenn du in KNXD_OPTS die entsprechenden Parameter direkt angibst.

    EIB/KNX, VISU mit knxd + linknx + knxweb, Steuerbefehle via SMS und Email mit postfix + procmail

    Kommentar


      #3
      Hallo,

      die bisherigen Vorschläge führten leider zu keiner Verbesserung.
      Programmierung mit der ETS über die Schnittstelle funktioniert ohne Probleme. Ich denke, das Problem ist also beim knxd zu suchen.

      Ich habe auch die conf-Datei durch folgenden Eintrag ersetzt:

      Code:
      #KNXD_OPTS=/etc/knxd.ini
      START_KNXD=YES
      KNXD_OPTS="-e 1.1.251 -E 1.1.252:4 --send-delay=50 -b ip:"
      Leider ohne Erfolg.

      Hat vielleicht noch jemand eine Idee, wo ich weiter nach dem Fehler suchen könnte?
      Vielleicht kann mir auch jemand seine Konfiguration mit einer Mulitcast-Schnittstelle bereitstellen.

      Ach ja. Die Multicast-Schnittstelle hat die PA 0.0.1. Das ist denke ich ok so, oder? Sie muss doch in die Hauptlinie, oder verstehe ich da was falsch?

      Grüße
      Thomas

      Kommentar


        #4
        Zitat von Maxthomas2001 Beitrag anzeigen
        Leider ohne Erfolg.
        Nun, im ersten Versuch war es ganz klar ein Konfigurationsproblem (Layer2 '/etc/knxd.ini' not supported). Und jetzt lieferst du überhaupt keinen Hinweis auf Fehler mehr. Da kann dir schlecht geholfen werden. Hast du die Anleitung von https://knx-user-forum.de/forum/proj...chreiben-lesen durchgearbeitet?

        Was ist der Output von "systemctl status knxd" und "systemctl status knxd.socket" ?
        EIB/KNX, VISU mit knxd + linknx + knxweb, Steuerbefehle via SMS und Email mit postfix + procmail

        Kommentar


          #5
          Hallo,
          diese Befehle kannte ich bislang noch gar nicht. Danke dafür.

          Die Ausgabe von knxd.socket:
          Code:
          knxd.socket - KNX Daemon (socket)
             Loaded: loaded (/lib/systemd/system/knxd.socket; enabled; vendor preset: enabled)
             Active: active (running) since Sun 2019-08-18 11:26:09 CEST; 4min 30s ago
             Listen: /var/run/knx (Stream)
                     [::]:6720 (Stream)
          Die Ausgabe von knxd:
          Code:
          knxd.service - KNX Daemon
             Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
             Active: activating (auto-restart) (Result: exit-code) since Sun 2019-08-18 11:32:15 CEST; 4s ago
            Process: 2416 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
           Main PID: 2416 (code=exited, status=1/FAILURE)
          
          Aug 18 11:32:15 SmartHomeNG systemd[1]: knxd.service: Unit entered failed state.
          Aug 18 11:32:15 SmartHomeNG systemd[1]: knxd.service: Failed with result 'exit-code'.
          Und die Ausgabe der mail-Log-Datei:
          Code:
          Aug 18 11:26:14 SmartHomeNG knxd[1176]: initialisation of backend 'ip:' failed
          Aug 18 11:26:14 SmartHomeNG systemd[1]: knxd.service: Main process exited, code=exited, status=1/FAILURE
          Aug 18 11:26:14 SmartHomeNG systemd[1]: Failed to start KNX Daemon.
          Aug 18 11:26:14 SmartHomeNG systemd[1]: knxd.service: Unit entered failed state.
          Aug 18 11:26:14 SmartHomeNG systemd[1]: knxd.service: Failed with result 'exit-code'.
          Also so wie ich diese Ausgabe interpretiere, wird keine Verbindung zu meinem IP-Router aufgebaut.

          Und ja, ich habe diese Installationsanleitung gelesen. Und so wie ich diese verstanden habe, habe ich auch den knxd konfiguriert.

          Kommentar


            #6
            Zitat von Maxthomas2001 Beitrag anzeigen
            [CODE]
            knxd.service - KNX Daemon
            Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
            Active: activating (auto-restart) (Result: exit-code) since Sun 2019-08-18 11:32:15 CEST; 4s ago
            Process: 2416 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
            Main PID: 2416 (code=exited, status=1/FAILURE)
            Das bedeutet wohl, dass knxd mit der Konfiguration nicht zufrieden ist und gleich beim Aufstarten aussteigt. Ich sehe aber nicht warum das nicht klappen sollte.
            Zum Debuggen kannst du versuchsweise den Socket und den Service disablen (systemctl disable knxd;systemctl disable knxd.socket) und beide stoppen und mit status überprüfen, dass alles gestoppt ist. Dann startest du knxd im Vordergrund so (das -i ist anstelle von knxd.socket):
            /usr/bin/knxd -e 1.1.251 -E 1.1.252:4 -i --send-delay=50 -b ip:
            Jetzt müsste der Fehler klarer angezeigt werden. Und wenn es keinen Fehler geben sollte, dann liegt es daran, dass die Konfigfiles anders verwendet werden als du denkst. Wobei der Hinweis auf ip: schon mal zeigt, dass knxd scheinbar den richtigen Schnittstellenparameter benutzt.
            EIB/KNX, VISU mit knxd + linknx + knxweb, Steuerbefehle via SMS und Email mit postfix + procmail

            Kommentar

            Lädt...
            X