Ankündigung

Einklappen
Keine Ankündigung bisher.

Schaffe es nicht, knxd in buster zu kompilieren

Einklappen
Dieses Thema ist geschlossen.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Schaffe es nicht, knxd in buster zu kompilieren

    Hallo,

    eigentlich gibt es ja eine tolle Anleitung, um knxd in buster zu kompilieren. Aber das funktioniert bei mir nicht:
    Code:
    sh install-debian.sh
    + export LC_ALL=C.UTF-8
    + dirname install-debian.sh
    + cd .
    + : 1 install tools, minimal variant
    + sudo apt-get install --no-install-recommends build-essential devscripts equivs
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    build-essential is already the newest version (12.6).
    devscripts is already the newest version (2.19.5+deb10u1).
    equivs is already the newest version (2.2.0).
    The following packages were automatically installed and are no longer required:
    dkms docutils-common libjsoncpp1 libmicrodns0 linux-image-5.9.0-0.bpo.2-amd64 ndpi php5-common pve-firmware pve-headers-5.4.78-2-pve
    python-babel-localedata sphinx-common
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
    + : 2 auto-install packages required for building knxd
    + sudo mk-build-deps --install --tool=apt-get --no-install-recommends --yes --allow-unauthenticated debian/control
    dh_testdir
    dh_testroot
    dh_prep
    dh_testdir
    dh_testroot
    dh_install
    dh_installdocs
    dh_installchangelogs
    dh_compress
    dh_fixperms
    dh_installdeb
    dh_gencontrol
    dh_md5sums
    dh_builddeb
    dpkg-deb: building package 'knxd-build-deps' in '../knxd-build-deps_0.14.42-1_all.deb'.
    
    The package has been created.
    Attention, the package has been created in the current directory,
    not in ".." as indicated by the message above!
    Selecting previously unselected package knxd-build-deps.
    (Reading database ... 206468 files and directories currently installed.)
    Preparing to unpack knxd-build-deps_0.14.42-1_all.deb ...
    Unpacking knxd-build-deps (0.14.42-1) ...
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
    dkms docutils-common libjsoncpp1 libmicrodns0 linux-image-5.9.0-0.bpo.2-amd64 ndpi php5-common pve-firmware pve-headers-5.4.78-2-pve
    python-babel-localedata sphinx-common
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
    knxd-build-deps
    0 upgraded, 0 newly installed, 1 to remove and 49 not upgraded.
    1 not fully installed or removed.
    After this operation, 9216 B disk space will be freed.
    Removing knxd-build-deps (0.14.42-1) ...
    mk-build-deps: Unable to install knxd-build-deps at /usr/bin/mk-build-deps line 416.
    mk-build-deps: Unable to install all build-dep packages
    Das Ganze scheitert hier:
    Code:
    dpkg -i knxd-build-deps_0.14.42-1_all.deb
    Vormals nicht ausgewähltes Paket knxd-build-deps wird gewählt.
    (Lese Datenbank ... 206468 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von knxd-build-deps_0.14.42-1_all.deb ...
    Entpacken von knxd-build-deps (0.14.42-1) ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von knxd-build-deps:
    knxd-build-deps hängt ab von libusb-1.0-0-dev (>= 1.0.9); aber:
    Paket libusb-1.0-0-dev ist nicht installiert.
    knxd-build-deps hängt ab von libsystemd-dev (>= 228) | libsystemd-daemon-dev (>= 200) | base-files (<< 8); aber:
    Paket libsystemd-dev ist nicht installiert.
    Paket libsystemd-daemon-dev ist nicht installiert.
    Version von base-files auf dem System ist 10.3+deb10u8.
    knxd-build-deps hängt ab von libev-dev; aber:
    Paket libev-dev ist nicht installiert.
    knxd-build-deps hängt ab von libfmt-dev | libfmt3-dev | cmake (>= 2.8.12); aber:
    Paket libfmt-dev ist nicht installiert.
    Paket libfmt3-dev ist nicht installiert.
    Paket cmake ist nicht installiert.

    Ich hänge nochmal den ganzen Log an.

    Ich könnte jetzt o.g. Pakete manuell installieren.
    Aber sollte das Skript das nicht machen?

    Gruß,
    Hendrik
    Angehängte Dateien

    #2
    Ja, das sollte das Skript machen. Aber wenn du die Dinger nicht manuell installierst, merkst du nicht bei welcher Abhängigkeit das Problem auftritt, weil apt zu blöd dazu ist dir das zu sagen.

    D.h. bitte manuell installieren und dann berichten wo's hakt.
    DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

    Kommentar


      #3
      Hallo,

      vielen Dank.
      Ich versuche die Pakete manuell so zu installieren:
      Code:
      apt-get install libusb-1.0-0-dev libsystemd-dev libev-dev libfmt-dev cmake
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      libusb-1.0-0-dev is already the newest version (2:1.0.22-2).
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
      libsystemd-dev : Depends: libsystemd0 (= 241-7~deb10u7) but 247.3-3~bpo10+1 is to be installed
      E: Unable to correct problems, you have held broken packages.
      Das wird auch der Grund sein, weshalb das Skript scheitert, oder?

      Gruß,
      Hendrik

      Kommentar


        #4
        Hallo,

        Smurf
        Hast du hier noch einen Tipp für mich?
        Ich würd das als Gegenleistung auch in der Readme dokumentieren ;-)

        Gruß,
        Hendrik

        Kommentar


          #5
          Welche Paketquellen hast du eingestellt und welche Preferences? Ist *alles* auf dem aktuellen Stand in deinem System?

          Sieht nämlich definitiv nicht danach aus.
          DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

          Kommentar


            #6
            Hallo,

            vielen Dank für deine Antwort.
            Ich habe gerade ein
            Code:
            apt-get update
            und
            Code:
            apt-get dist-upgrade
            gemacht. Danach ein
            Code:
            apt-get install libusb-1.0-0-dev libsystemd-dev libev-dev libfmt-dev cmake
            führte wieder zu vorherigem Problem:

            Code:
            apt-get install libusb-1.0-0-dev libsystemd-dev libev-dev libfmt-dev cmake
            Paketlisten werden gelesen... Fertig
            Abhängigkeitsbaum wird aufgebaut.
            Statusinformationen werden eingelesen.... Fertig
            libusb-1.0-0-dev ist schon die neueste Version (2:1.0.22-2).
            Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
            Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
            Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
            nicht erstellt wurden oder Incoming noch nicht verlassen haben.
            Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
            
            Die folgenden Pakete haben unerfüllte Abhängigkeiten:
            libsystemd-dev : Hängt ab von: libsystemd0 (= 241-7~deb10u7) aber 247.3-3~bpo10+1 soll installiert werden
            E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
            apt-get -f install
            Paketlisten werden gelesen... Fertig
            Abhängigkeitsbaum wird aufgebaut.
            Statusinformationen werden eingelesen.... Fertig
            0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
            Das Ergebnis von apt-cache policy und die preferences hänge ich an.

            Code:
            apt policy libsystemd-dev
            libsystemd-dev:
            Installiert: (keine)
            Installationskandidat: 241-7~deb10u7
            Versionstabelle:
            247.3-3~bpo10+1 100
            100 http://deb.debian.org/debian buster-backports/main amd64 Packages
            100 http://httpredir.debian.org/debian buster-backports/main amd64 Packages
            241-7~deb10u7 500
            500 http://ftp.halifax.rwth-aachen.de/debian buster/main amd64 Packages
            Viele Grüße,
            Hendrik

            Angehängte Dateien
            Zuletzt geändert von henfri; 09.04.2021, 14:38.

            Kommentar


              #7
              Sorry, aber bei einem derartigen Berg Pins bist du selber dafür verantwortlich, korrespondierende Versionen zu installieren. Mach aptitude auf und bring das Ding dazu, dir eine saubere Lösung zu präsentieren. Apt ist damit heillos überfordert.

              Das ist kein knxd-Problem, das wirst du mit so gut wie jedem anderen Code den du auf so einem System baust genauso haben.
              DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

              Kommentar

              Lädt...
              X