Ankündigung

Einklappen
Keine Ankündigung bisher.

Node red KNX und MQTT schalten (Kommunikation)

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Node red KNX und MQTT schalten (Kommunikation)

    Hallo Leute,

    ich bin neu hier und steige gerade in die Haus Automatisation ein.
    Mein jetziges Vorhaben ist:
    Ich möchte mit einem KNX GA 4.0.0 einen Sonoff Mini R2 über das MQTT Protokoll schalten.

    Der Raspberry Pi 3 ist mit Mosquitto und Node Red installiert.
    Danach habe das KNX Easy Paket in Nodered installiert und Das Tasmota Sonoff Paket .

    Mein jetziges Problem:

    Wenn ich den Ein Befehl für das Schalten des KNX GAs sende schaltet auch der Sonoff ein.
    Schalte ich den GA wieder auf aus dann passiert nichts am Sonoff.

    In Node Red am KNX IN steht der Status nach dem Schalten auf True.
    Er wechselt aber nicht mehr in false.

    Vermute mal das da das Problem liegt.

    Sorry für die Anfänger Fragen aber ich bin da neu auf dem Gebiet.
    Habe x Videos geschaut und werde nicht schlau daraus.


    Vielleicht hat jemand eine Idee an was es liegen könnte.
    Zuletzt geändert von CSComputer; 06.05.2021, 09:05.

    #2
    Hallo CSComputer,

    ich habe zwar nicht das Tasmota Sonoff Addon installiert, aber verwende KNX Easy. Bei mir sieht die Ansteuerung eines Sonoff Mini so aus:
    Screenshot 2021-05-06 220754.png

    Die Konfiguration des knxEasy-in Nodes ist so:
    Screenshot 2021-05-06 221623.png
    Wie sieht deine Konfiguration aus?

    Gruß
    Jens

    Kommentar


      #3
      Hallo Jens,

      bei mir sieht es auch so aus.
      Was hast du in dem MQTT stehen?

      Könntest du mir das auch mal zur Verfügung stellen?

      Screenshot 2021-05-07 103851.jpg

      Screenshot 2021-05-07 103810.jpg

      Screenshot 2021-05-07 104352.jpg

      Screenshot 2021-05-07 104423.jpg
      Zuletzt geändert von CSComputer; 07.05.2021, 09:57.

      Kommentar


        #4
        Meine MQTT-Node Konfiguration sieht so aus, wie gesagt der Standard MQTT out Node:
        Screenshot 2021-05-07 142137.png

        Kommentar


          #5
          Wenn ich einen Debug Node einfüge sieht es so aus:
          Screenshot 2021-05-07 142547.png

          Kommentar


            #6
            Was passiert im Debug-Fenster, wenn du auf 4//0/0 FALSE von der ETS sendest? Gar nichts oder kommt TRUE?

            Um zu testen, ob dein MQTT-Node richtig konfiguriert ist, könntest du das mit zwei Inject-Nodes prüfen:
            Screenshot 2021-05-07 144830.png
            Konfiguration der Inject Nodes am Beispiel von true:
            Screenshot 2021-05-07 144848.png

            Wenn der Sonoff dann korrekt ein- und ausschaltet, liegt es am KNX-in Node.
            Zuletzt geändert von jgerhart; 07.05.2021, 13:52.

            Kommentar


              #7
              True.jpg

              Es wird nur true auf KNX in ausgegeben.
              Ich glaube, dass ist das Problem.


              Habe schon einmal probiert mit einer switch Node über das Dashboard anzusteuern.
              Das hat funktioniert.
              Zuletzt geändert von CSComputer; 07.05.2021, 14:21.

              Kommentar


                #8
                Hast du eine andere GA, die du mit einem KNX-in Node testen könntest?
                Gibst du über die ETS 3-mal TRUE auf 4/0/0 oder TRUE, FALSE, TRUE? Wieso kommen die 3 TRUE Messages im Debugger alle in der gleichen Sekunde an?
                Du testest doch direkt über die ETS?

                Kommentar


                  #9
                  Das war eine gute Idee mit der Diagnose über die ETS.
                  Wenn ich dort die Gruppenadresse mit ein und aus teste, dann schaltet der Sonoff.
                  Ich verwende in als Visu Server den Eibport V3.
                  Der Sendet mir beim Schalten immer nur den true Status. (Trotz Auswahl DPT 1.001)
                  DPT1.001.jpg
                  Bin jetzt daran, herauszufinden, wo es dran liegt.

                  Ich möchte dir schonmal für deine Hilfe danken.

                  Bin da noch neu im Geschäft.

                  Hatte mal vor 25 Jahren was mit KNX/Eib zu tun.


                  Gruß Carsten.

                  Kommentar


                    #10
                    So, habe es heraus gefunden.

                    Im Eibport war die verkehrte Funktion hinterlegt.
                    Bei der Cubevision Oberflöche lassen sich zwei unterschiedliche Schaltfunktionen auswählen.
                    Es gibt eine Funktion die genau das DPT 1.001 sendet.
                    DPT1.001 EIbport.jpg
                    Damit ging es.

                    Kommentar


                      #11
                      Na, dann ist ja gut.
                      Viel Erfolg weiterhin!

                      Kommentar

                      Lädt...
                      X