Ankündigung

Einklappen
Keine Ankündigung bisher.

Can't connect suite to MDT IP interface

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Can't connect suite to MDT IP interface

    I'm trying to get started with Konnekting but getting stuck at using the suite.
    Get following error when connecting:
    2019-09-16 23:45:50.105 INFO [AWT-EventQueue-0] de.konnekting.suite.Main.<init>: KONNEKTING Suite - Version 1.0.0-BETA4 Build 2016-10-10_18-18-18 DEBUG MODE!
    2019-09-16 23:45:50.120 INFO [AWT-EventQueue-0] de.konnekting.suite.Main.<init>: Running on: Windows 10
    2019-09-16 23:45:50.167 FINE [BackgroundTask(1) 'Connect to KNX'] de.konnekting.suite.BackgroundTask$1.run: Begin task(1) 'Connect to KNX'
    2019-09-16 23:45:50.360 INFO [BackgroundTask(1) 'Connect to KNX'] de.konnekting.suite.Main.connectKnx: Starting in TUNNELING mode: 1.1.1@192.168.1.186
    2019-09-16 23:45:50.497 SEVERE [BackgroundTask(1) 'Connect to KNX'] de.konnekting.suite.Main.connectKnx: Error creating knx access.
    de.root1.slicknx.KnxException: Error connecting to KNX: on connect to /192.168.1.186:3671
    at de.root1.slicknx.Knx.<init>(Knx.java:308)
    at de.konnekting.suite.Main.connectKnx(Main.java:247)
    at de.konnekting.suite.Main.access$100(Main.java:77)
    at de.konnekting.suite.Main$2.run(Main.java:169)
    at java.lang.Thread.run(Thread.java:745)
    at de.konnekting.suite.BackgroundTask$1.run(Backgroun dTask.java:59)
    Caused by: tuwien.auto.calimero.exception.KNXException: on connect to /192.168.1.186:3671
    at tuwien.auto.calimero.knxnetip.ClientConnection.con nect(ClientConnection.java:173)
    at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.<init >(KNXnetIPTunnel.java:131)
    at tuwien.auto.calimero.link.KNXNetworkLinkIP.<init>( KNXNetworkLinkIP.java:142)
    at tuwien.auto.calimero.link.KNXNetworkLinkIP.<init>( KNXNetworkLinkIP.java:180)
    at de.root1.slicknx.Knx.<init>(Knx.java:301)
    ... 5 more
    Caused by: java.net.SocketException: Network is unreachable: Datagram send failed
    at java.net.TwoStacksPlainDatagramSocketImpl.send(Nat ive Method)
    at java.net.DatagramSocket.send(DatagramSocket.java:6 93)
    at tuwien.auto.calimero.knxnetip.ClientConnection.con nect(ClientConnection.java:158)
    ... 9 more

    2019-09-16 23:45:50.500 FINE [BackgroundTask(1) 'Connect to KNX'] de.konnekting.suite.BackgroundTask$1.run: Finished task(1) 'Connect to KNX' in 333 ms.
    2019-09-16 23:45:54.928 INFO [Timer-0] de.konnekting.suite.StatusPanel$1.run: Clear status message
    With ETS I can connect to the IP Interface and see group addresses of a regular KNX switch & actuator.
    I also have one MultiInterface connected with firmware.

    Looked on the forum for hints and see there's been some mention of issues with tunneling mode. Can't find a solution though.
    Also version of the suite is pretty old ... but how to build it? I've tried cmd line with Maven but not successfull.

    Kind regards,
    Kurt

    #2
    Hej Kurt,

    Sounds strange... I personally have a MDT Router and tested this with Tunneling-Mode. Works.
    The Suite is telling in the exception-stracktrace:

    Zitat von Kurt14 Beitrag anzeigen
    Caused by: java.net.SocketException: Network is unreachable: Datagram send failed
    Looks like the Suite is not reaching the tunneling interface. Hmm, some open questions:

    * Did you just configure the tunneling interface, or did you use the detect mechanism?
    * How many network devices does you computer have?
    * Do you use WIFI or LAN?

    Suite 1.0.0 Beta 4 is the latest stable version. beta5 is still in development (which will continue this autumn) and not (yet) meant to be build "out-of-the-box" by the public (this will follow with beta5).

    best regards,
    Alex

    Kommentar


      #3
      Hi Alex,
      I used the detect mechanism which detects the MDT interface as tunneling. When in ETS I do 'device info' I see that the MDT runs a 'router app' and 2nd app doesn't show anything. Not sure If I need to load explicitly a 'tunneling app' on the MDT (sorry, still learning about ETS and KNX). Now from within ETS I tried to 'unload' the app to see if that changed anything. Device info now shows 'unloaded' but from within ETS things still seem to work.

      I tried on both Win10 PC and Linux laptop. Both have wifi and LAN, when I ping the MDT Interface I get a response. So the route is there.

      Anything else I can try?
      Kurt

      Kommentar


        #4
        Theres a chance that I did not test reaching the tunneling interface with mutliple network interfaces. For now, you can try to disable the unused network interfaces, so that java has no other chance as to use the right interface. If this helps, I know where to bugfix.
        If this does not help, i need to further investigate.

        br,
        Alex

        Kommentar


          #5
          Tried various things tonight. Not making progress unfortunately.
          I was unsure if I configured the SCN-IP000-02 correctly so played around with that in ETS. Very confusing device with the combination of IP interface & email. Anyways, from within ETS I can connect with it and see the bus activity.
          KonnectSuite always gives connection error no matter what I try disabling other networking interfaces & trying some different individual addresses.
          When adding port number (3671) to the IP address I did get an error stating 'invalid IPv6 address'. Could it have something to do with java setting up connection using IPv6 vs. the interface being IPv4?
          Kurt

          Kommentar


            #6
            As far as I know, the MDT device is using IPv4 (only). If you add a ":" to the IP, it may be detected as an IPv6, as IPv6 is typically containing ":".

            The tunneling mode is tested and works in generel (not only on my side, but also for others). So there is no general problem with it. Can you run the Suite with the DEBUG Batch file and try to detect and use the tunneling interface. When the error appears, close the suite and send me the log files it generated in the Suite's main folder.

            br,
            Alex

            Kommentar


              #7
              Some progress: From another MAC machine the suite connects to the IP interface and sees GAs. Now still need to figure out why the Linux & Win10 PC don't.

              Kommentar


                #8
                I had to disable all other network adapters. Like loopback adapter from Wireshark and virtual adapters from Virtualbox. Did you try that?

                Kommentar

                Lädt...
                X