Ankündigung

Einklappen
Keine Ankündigung bisher.

KNX2 - Bei Neustart wird der Status der Kontakte nicht vom Bus gelesen

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    KNX2 - Bei Neustart wird der Status der Kontakte nicht vom Bus gelesen

    Guten Morgen liebe Community,

    ich bin nun ebenfalls stolzer KNX2 Binding Nutzer Der Umstieg hat gut geklappt. Allerdings fällt folgendes aus:
    Wenn das System neu gestartet wird bekomme ich nicht zuverlässig den Status meiner GAs vom Bus übertragen. So bleiben zum Beispiel so gut wie immer die Fensterkontakte in OH ohne Daten.

    Unter dem KNX1 Binding wurde beim Start der komplette Bus ausgelesen und der Status übertragen. Das ist unter KNX2 leider nicht mehr so.

    Meine Bridge Konfiguration mit den Kontakten als Beispiel:

    Code:
    Bridge knx:ip:bridge [ 
        ipAddress="192.168.1.25", 
        portNumber=3671,  
        localIp="192.168.1.36",
        type="TUNNEL", 
        readingPause=50, 
        responseTimeout=10, 
        readRetriesLimit=3, 
        autoReconnectPeriod=1,
        localSourceAddr="0.0.0"
    ] {
    
    Thing device kontaktabfrage2 [
            address="1.1.181",
            fetch=false,
            pingInterval=300,
            readInterval=3600
        ] {
            Type contact        : kontakt_EG_Bad_Fenster                    "Bad [MAP(kontakt.map):%s]"                 [ga="<5/1/1"]
            Type contact        : kontakt_EG_Kueche_Spuele_Fenster          "Spüle [MAP(kontakt.map):%s]"               [ga="<5/1/2"]
            Type contact        : kontakt_EG_Kueche_Garten_Links_Fenster    "Küche Garten links [MAP(kontakt.map):%s]"  [ga="<5/1/3"]
            Type contact        : kontakt_EG_Kueche_Garten_Fenster          "Küche Garten [MAP(kontakt.map):%s]"        [ga="<5/1/10"]
            Type contact        : kontakt_EG_Essen_Balkon_Fenster           "Essen Balkon [MAP(kontakt.map):%s]"        [ga="<5/1/9"]
            Type contact        : kontakt_UG_Schrank_Fenster                "Wohnen Schrank [MAP(kontakt.map):%s]"      [ga="<5/0/2"]
            Type contact        : kontakt_UG_Wohnen_Fenster_Garten          "Wohnen Terrasse [MAP(kontakt.map):%s]"     [ga="<5/0/3"]
            Type contact        : kontakt_UG_Billard_Fenster_Terrasse       "Billard Terrasse [MAP(kontakt.map):%s]"    [ga="<5/0/4"]
            Type contact        : kontakt_UG_Flur_Heizraum_Fenster          "Flur Heizraum [MAP(kontakt.map):%s]"       [ga="<5/0/7"]
            Type contact        : kontakt_UG_Heizraum_Fenster               "Heizraum [MAP(kontakt.map):%s]"            [ga="<5/0/8"]      
        }
    
    }
    Ich freue mich auf eure Hilfe

    Viele Grüße
    Patrick

    #2
    Ich glaube ich habe das "Problem" selbst beseitig. Ich habe beim jeweiligen Thing

    readInterval=0

    gesetzt. Laut Doku ist das das einmalige Lesen beim Start.
    Sollte ich falsch liegen, freue ich mich über eine Berichtigung

    Viele Grüße
    Patirck

    Kommentar

    Lädt...
    X