Ankündigung

Einklappen
Keine Ankündigung bisher.

KNX Switch mit OH nicht in Sync

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    KNX Switch mit OH nicht in Sync

    Hallo,
    ich habe plötzlich (oder seit paar Tagen, weiss ich nicht genau) Probleme mit dem Schalten eines KNX Switch (Nachtautomatik ein/aus) über die OH Oberfläche. Eigene Konfigdateien (items, things etc. wurden diesbzgl. nicht geändert). Vor paar Tagen habe ich von OH2.3 auf OH2.4Mx gewechselt.
    Wenn ich auf KNX Seite den Taster betätige sehe ich die Änderung konsistent auf OH Seite (s. auch im log):
    Code:
    2018-11-04 12:07:58.380 [vent.ItemStateChangedEvent] - Nachtautomatik changed from ON to OFF
    2018-11-04 12:07:59.377 [vent.ItemStateChangedEvent] - Nachtautomatik changed from OFF to ON
    wenn ich nun auf OH-Seite den Switch betätige wird
    1) die Änderung auf KNX-Seite sichtbar (anhand LED am Taster)
    2) auf OH Seite ändert sich nichts (lt. Oberfläche), folgender LOG-Eintrag:
    Code:
    2018-11-04 12:14:07.861 [ome.event.ItemCommandEvent] - Item 'Nachtautomatik' received command OFF
    2018-11-04 12:14:07.878 [nt.ItemStatePredictedEvent] - Nachtautomatik predicted to become ON
    damit habe ich die Situation, dass KNX = AUS sagt, OH sagt aber EIN. Ein weiteres Schalten geht dann gar nicht mehr.

    jemand eine Idee, gab es Änderungen am KNX2-Binding, die hier ausschlaggebend sein könnten?

    hier noch zur Sicherheit die things und items dazu:
    Code:
    Switch Nachtautomatik "KNX-Nachtautomatik" <night> { channel="knx:device:KNXD:Wetterstation:CNachtautomatik"}
    Code:
    Bridge  knx:ip:KNXD "KNXD/IP Tunnel" @ "KNX" [
            type="TUNNEL",
            ipAddress="192.168.178.38",
            portNumber=3671,
            localIp="192.168.178.47",
            readingPause=50,
            responseTimeout=10,
            readRetriesLimit=3,
            autoReconnectPeriod=1,
            localSourceAddr="0.0.1" ]
            {
    Thing device Wetterstation "Wetterstation" @ "KNX" [ address="1.1.7", fetch=false, pingInterval=600, readInterval=0 ]
    {
    Type number-control : CHelligkeitOst "Hell Ost" [ ga="9.001:<1/1/1" ]
    Type number-control : CHelligkeitSued "Hell Sued" [ ga="9.001:<1/1/2" ]
    Type number-control : CHelligkeitWest "Hell West" [ ga="9.001:<1/1/3" ]
    Type number : CDaemmerung "Dämmerung" [ ga="9.001:<1/1/4" ]
    Type number : CTemperaturSued "Temp Sued" [ ga="9.001:<1/1/5" ]
    Type number : CWind "Wind" [ ga="9.001:<1/1/6" ]
    Type switch : CNiederschlag "Niederschlag" [ ga="1.001:1/1/23" ]
    Type switch : CSonnenautomatik "KNX-Sonnenautomatik" [ ga="1.001:1/2/37" ]
    Type switch : CNachtautomatik "KNX-Nachtautomatik" [ ga="1.001:0/0/6" ]
    }
    
    }

    #2
    Vermutlich ist eines der Things offline angezeigt. Da wurde etwas "verbessert" mit der Folge, dass es nicht mehr richtig funktioniert.
    Mein Tipp wäre, die physikalischen Addressen zu deaktivieren, dann sollten die Things dauerhaft online bleiben. Das ist natürlich nur ein Behandeln der Symptome.

    Kommentar


      #3
      Danke für den Tipp. Ich bin im englischen Forum auch in die Richtung fündig geworden. Ja, die Wetterstation wird offline angezeigt. Ich habe nun beim Item die Angabe
      Code:
      autoupdate="true"
      ergänzt. Verstehe ich zwar nicht ganz, aber es funktioniert.

      Kommentar


        #4
        Ah, wenn das reicht, ist es zumindest eine Möglichkeit, mit dem Problem umzugehen.

        Hintergrund: Bis vor kurzem hat openHAB als default autoupdate="true" gehabt und es gab auch nur die Option, autoupdate="false" zu setzen. Mit "true" führt openHAB nach einem sendCommand() automatisch im Anschluss ein postUpdate() mit dem passenden (z.B. bei Dimmer OFF=>0 ON=>100) Status abgesetzt. Eine Schaltaktion in der UI entspricht einem sendCommand().
        Der neue Mechanismus erkennt, ob das zugehörige Item sich selbst um den Status kümmern können sollte. Wenn das der Fall ist, kümmert sich openHAB nicht mehr selbst um den Status. Allerdings sehe ich hier noch ein Fehlverhalten seitens openHAB, denn es darf nicht davon ausgehen, dass ein OFFLINE gelistetes Thing dann sicher nicht erreichbar ist und deshalb erst gar nicht versuchen, das sendCommand() zu senden. Aber ich denke, darüber wird es noch eine Diskussion geben.

        Kommentar


          #5
          Ja das hat mir auch schon Probleme gemacht in der 2.4er OH Version. Musste ein paar Rules umbauen und so wirklich verstehe ich auch nicht wie er meine Things erkennt. Habe aber auch noch etwas kuddel in meiner Items datei. Habe noch einige KOs meinem generic Thing zugeordnet und da kann er natürlich auch kein Gerät offline oder online erkennen da es sich auf mehrere verteilt. Werde das mal bei zeiten gerade ziehen und dann sehen wie es sich verhält.

          Kommentar

          Lädt...
          X