Ankündigung

Einklappen
Keine Ankündigung bisher.

Probleme bei Einbindung Garagentor (Hörmann) in NodeRed/ realKNX/ ProServ/ Homekit

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Probleme bei Einbindung Garagentor (Hörmann) in NodeRed/ realKNX/ ProServ/ Homekit

    Hallo,

    ich habe kein vergleichbares Thema gefunden, sodass ich hoffe mit diesem Beitrag vielen mit ähnlichen Problemen eine Anlaufstelle zu schaffen.

    Problem:

    Ich habe ein Hörmann Supramatic P Motor über das KNX Gateway in die Haussteuerung eingebunden. Funktioniert einwandfrei.
    Nach längerer Zeit habe ich das Garagentor (Motor) zusätzlich mittels ProServ bzw. RealKNX in die Homekit App sowie in die iKNiX 2 App integriert. An sich funktioniert auch alles soweit. Siri reagiert, hoch, runter, Stopp (leider ist die Statusmeldung falsch, nicht das Thema).

    Was mir allerdings auffällt, dass Garagentor macht sich ab und an selbstständig. Plötzlich ist es offen ohne das über Taster, Funktaster, Siri oder der App etwas ausgelöst wurde. Ist natürlich nicht so schön wenn man von Arbeit kommt und das Tor steht den halben Tag offen. Kann leider auch noch nicht nachvollziehen was den Befehl auslöst oder ob das Phänomen bei der Verwendung von Siri oder iKNiX 2 App auftritt.

    Vermuten würde ich, dass vielleicht bei Node Red was ausgelöst wird was nicht passieren sollte oder vielleicht wenn sich Homekit "Aktualisiert"?

    Über Ratschläge wäre ich sehr dankbar.

    #2
    Hallo Jens,

    ich habe mein Garagentor (natürlich) auch kompl. eingebunden, allerdings ist es bei mir "nur" ein normaler Rolladenmoter mit dementsprechendem Aktor. Sonst ist auch alles am Start realknx, proserv, siri, node red (hat aber nix mit dem Tor zu tun).
    Bei mir ist noch nie was von selber aufgegangen, einzig ärgere ich mich manchmal über der Wortänderung bei Siri. Alle paar Monate geht plötzlich "Garage AUF" nicht mehr sondern man muss "Garage auffahren" sagen, vice versa, aber das ist ein anderes Thema und die Abhängikeit des IoT.

    An dein Problem kann man eigentlich nur ausschliesend rangehen. Dazu muss man natürlich erstmal wissen wer (welche Sensorik) das Tor bedienen kann oder ob der Aktor selber vielleicht falsch konfiguriert ist. Gibt es irgendwelche nachvollziehbare Auslösemöglichkeiten (Zeiten, Bewegungen, Wetter, Helligkeit), was macht NodeRed genau, hast du mal den Gruppenmonitor mitlaufen lassen? Die Steuerung des Hörmann kenne ich jetzt nicht aber kann natürlich auch ne Fehlerquelle sein.

    Gruss
    Guido
    Google oder Wiki-Hilfe-Hinweise nehme ich nur an wenn sie mich total blamieren..... dann ertrage ich sie auch in Demut und Dankbarkeit;-)

    Kommentar


      #3
      Hi Jens,
      Wie Guido sagt, würde ich auch versuchen das Problem einzugrenzen.
      Du kannst ja mal das AppleTV (oder den HomePod) ausschalten, in der Zeit, wo Du nicht daheim bist. Falls RemoteConnect aktiviert ist, kannst Du das ja auch deaktivieren.
      Damit schliesst Du aus, dass der Befehl in Deiner Abwesenheit von ausserhalb Deines Netzwerkes gekommen ist.
      Weiterhin würde ich die Garagentorbewegungen aufzeichnen. Einfach ein #L an den Funktionsnamen im proServ anhängen und den realKNX Server neu starten. Dann kannst Du zeitlich das ganze eingrenzen.

      LG
      Christian
      Chris (https://proknx.com)
      wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

      Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

      Kommentar


        #4
        Guten Morgen,
        hast du die Lichtschranke verbaut?
        Bei mir lag es an der!
        VG Ralf
        Gruß Ralf

        Kommentar


          #5
          Hallo zusammen,

          erst einmal Sorry für die verspätete Rückmeldung. Haben die fallenden Inzidenzen direkt für einen Kurztrip ausgenutzt.

          Vielen vielen Dank für euer Feedback.

          An das Ausschlussverfahren habe ich auch schon gedacht. Habe auch den Gruppenmonitor bereits mitlaufen lassen. Bisher ist der Fehler aber nicht mehr aufgetreten. Sodass ich weder über den Gruppenmonitor noch über ein "debug-Node" im Node-RED etwas nachvollziehen kann.

          Lichtschranke ist nicht verbaut.

          Ich habe allerdings mein Verhalten geändert. Ich versuche momentan das Garagentor immer nur mit einer Möglichkeit zu bedienen. Sprich, ich öffne über Siri dann schließe ich auch über Siri. Ich öffne über KNX-Taster dann schieße ich auch darüber. Ich öffne z.B. mit Siri , dann schließe ich aber NICHT über eine andere Möglichkeit. Bis dato ist das Problem nicht wieder aufgetaucht.

          Ich vermute einfach, dass die angelegte Logik im Node-Red nicht 100% korrekt ist.
          Hier mal ein Ausschnitt.


          Angehängte Dateien

          Kommentar

          Lädt...
          X