Ankündigung

Einklappen
Keine Ankündigung bisher.

Error beim Aufrufen des Backends

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Error beim Aufrufen des Backends

    Hallo zusammen,

    ich kann das Backend nicht aufrufen; Habe heute eine 1.4er - Installation auf 1.5 upgedated. Im Log kommt folgender Fehler:

    Code:
    2019-02-02  16:43:34 ERROR    CP Server Thread-8 [02/Feb/2019:16:43:34] HTTP
    Traceback (most recent call last):
      File "/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py", line 631, in respond
        self._do_respond(path_info)
      File "/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py", line 690, in _do_respond
        response.body = self.handler()
      File "/usr/local/lib/python3.5/dist-packages/cherrypy/lib/encoding.py", line 221, in __call__
        self.body = self.oldhandler(*args, **kwargs)
      File "/usr/local/lib/python3.5/dist-packages/cherrypy/_cpdispatch.py", line 60, in __call__
        return self.callable(*self.args, **self.kwargs)
      File "/usr/local/smarthome/plugins/backend/__init__.py", line 293, in index
        return self.render_template('index.html')
      File "/usr/local/smarthome/plugins/backend/__init__.py", line 275, in render_template
        self.find_visu_plugin()
      File "/usr/local/smarthome/plugins/backend/__init__.py", line 248, in find_visu_plugin
        for p in self._sh._plugins:
    AttributeError: 'SmartHome' object has no attribute '_plugins'
    2019-02-02  16:43:34 INFO     CP Server Thread-8 [02/Feb/2019:16:43:34] HTTP
    Request Headers:
      ACCEPT-ENCODING: gzip, deflate
      CACHE-CONTROL: max-age=0
      HOST: 192.168.1.107:8383
      CONNECTION: keep-alive
      ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
      ACCEPT-LANGUAGE: de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7
      USER-AGENT: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
      REFERER: http://192.168.1.107:8383/
      UPGRADE-INSECURE-REQUESTS: 1
      Remote-Addr: 192.168.1.160
    2019-02-02  16:43:34 INFO     CP Server Thread-8 192.168.1.160 - - [02/Feb/2019:16:43:34] "GET /backend/ HTTP/1.1" 500 3905 "http://192.168.1.107:8383/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36"
    2019-02-02  16:43:35 INFO     CP Server Thread-8 192.168.1.160 - - [02/Feb/2019:16:43:35] "GET /gstatic/img/favicon.ico HTTP/1.1" 200 26166 "http://192.168.1.107:8383/backend/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36"
    Kann jemand sagen was ich hier fixen muss?
    Dankeschön.

    VG
    Dieter
    Viele Grüße
    Dieter

    #2
    Bist Du sicher, dass Du auch die Plugins auf v1.5 upgedated hast?
    Viele Grüße
    Martin

    Kommentar


      #3
      Hi,
      dann werde ich das nochmal neu installieren.
      VG
      Dieter
      Viele Grüße
      Dieter

      Kommentar

      Lädt...
      X