Ankündigung

Einklappen
Keine Ankündigung bisher.

1-Wire Server Debian Buster

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    1-Wire Server Debian Buster

    Hallo zusammen,
    hat schon jemand Debian Buster mit 1-Wire erfolgreich zum laufen gebracht? Meine Versuche waren bislang leider nicht von Erfolg gekrönt.

    MFG
    Tom

    #2
    Hm, nutzt du das Raspi Image oder was anderes? Dort ist mir aufgefallen, dass das Service nicht startet, wohingegen das bei Stretch funktioniert hatte. Allerdings hab ich die Fehlermeldung so interpretiert, dass der nicht vorhandene 1-Wire Bus das Problem ist (ich hab kein 1-Wire)

    Kommentar


      #3
      Was ist denn das Problem? Ich habe den owserver auf Buster installiert (aber noch nicht getestet). Der Service startet aber ganz normal.
      Viele Grüße
      Martin

      Stay away from negative people. They have a problem for every solution.

      Kommentar


        #4
        Hallo zusammen,
        nein ich nutze nicht das Image sondern habe selber nach der Anleitung in der Anwenderdoku installiert. Die Installation verlief erfolgreich, der Service ist nach einen Reboot auch ganz normal gestartet
        shng@srv01:~ $ systemctl status owserver
        ● owserver.service - Backend server for 1-wire control
        Loaded: loaded (/lib/systemd/system/owserver.service; enabled; vendor preset: enabled)
        Active: active (running) since Wed 2019-08-21 14:03:43 CEST; 1 day 6h ago
        Docs: man owserver(1)
        Main PID: 308 (owserver)
        Tasks: 4 (limit: 4035)
        Memory: 2.4M
        CGroup: /system.slice/owserver.service
        └─308 /usr/bin/owserver -c /etc/owfs.conf
        Wenn ich allerdings den Service manuell beende und dann wieder starten möchte kommt folgende Meldung:

        shng@srv01:~ $ sudo systemctl start owserver
        Job for owserver.service failed because the service did not take the steps required by its unit configuration.
        See "systemctl status owserver.service" and "journalctl -xe" for details.
        shng@srv01:~ $ sudo systemctl status owserver
        ● owserver.service - Backend server for 1-wire control
        Loaded: loaded (/lib/systemd/system/owserver.service; enabled; vendor preset: enabled)
        Active: failed (Result: protocol) since Thu 2019-08-22 21:05:12 CEST; 10s ago
        Docs: man owserver(1)
        Process: 1489 ExecStart=/usr/bin/owserver -c /etc/owfs.conf (code=exited, status=0/SUCCESS)
        Main PID: 1489 (code=exited, status=0/SUCCESS)

        Aug 22 21:05:12 srv01 systemd[1]: owserver.service: Service RestartSec=100ms expired, scheduling restart.
        Aug 22 21:05:12 srv01 systemd[1]: owserver.service: Scheduled restart job, restart counter is at 5.
        Aug 22 21:05:12 srv01 systemd[1]: Stopped Backend server for 1-wire control.
        Aug 22 21:05:12 srv01 systemd[1]: owserver.service: Start request repeated too quickly.
        Aug 22 21:05:12 srv01 systemd[1]: owserver.service: Failed with result 'protocol'.
        Aug 22 21:05:12 srv01 systemd[1]: Failed to start Backend server for 1-wire control.
        Im Admin Interface von SHNG werden auch keine Werte angezeigt. Anbei ein Auszug des Fehlerlogs:
        2019-08-21 12:10:51 WARNING plugins.onewire 1-Wire: problem reading 28.FF6E2AB51603 /bus.0/28.FF6E2AB51603/temperature: no payload for /uncached/bus.0/28.FF6E2AB51603/temperature. Trying to continue with next sensor
        Installation ist das aktuelle Debian Buster mit der aktuellen Version von SHNG und SmartVISU 2.9. Auch wenn der Service nach einen Reboot laut Konsole fehlerfrei läuft werden keine Werte angezeigt. Wenn ich das gleiche unter Debian Stretch mache funktioniert 1-Wire ohne Probleme...
        Zuletzt geändert von Scaramangas; 22.08.2019, 20:12.

        Kommentar


          #5
          Hmm ich habe mir gestern einen pi1b mit buster neu aufgesetzt um mein ROT zum sprechen zu bringen, nachdem die SHNG SD nach vier jahren oder so nicht mehr zu retten war. Ich habe aber raspbian standard verwendet und nur das OWFS händisch nachinstalliert. SHNG läuft bei mir sowieso schon auf dem NAS.

          Die o.g. Fehler habe ich auch gesehen. Nach zweifachem Neustart war er aber weg - und nun sinds draußen wieder 29 Grad und nicht mehr 87,2 Grad ;-)
          Hast Du Das Kernelmodul aktiviert?

          Kommentar


            #6
            Servus, hat wer das Problem verstanden bzw. nachvollziehen können? Nutze auch das Image aber noch mit stretch. Ich bin mir sicher, dass es mal lief und die HW passt. Aktuell bekomme ich keine Daten, daher denke ich gerade über update nach.

            Code:
            [smarthome@SmartHomeNG ~]$ sudo /etc/init.d/owserver status
            ● owserver.service - LSB: 1-wire TCP server
               Loaded: loaded (/etc/init.d/owserver; generated; vendor preset: enabled)
               Active: active (running) since Sun 2019-09-08 16:49:39 CEST; 1h 4min ago
                 Docs: man:systemd-sysv-generator(8)
              Process: 1129 ExecStart=/etc/init.d/owserver start (code=exited, status=0/SUCCESS)
               CGroup: /system.slice/owserver.service
                       └─1135 /usr/bin/owserver -c /etc/owfs.conf --pid-file /var/run/owfs/owserver.pid
            
            Sep 08 16:49:38 SmartHomeNG systemd[1]: Starting LSB: 1-wire TCP server...
            Sep 08 16:49:38 SmartHomeNG OWFS[1135]: DEFAULT: ow_daemon.c:(144) Entered background mode, quitting.
            Sep 08 16:49:38 SmartHomeNG OWFS[1135]: DEFAULT: ow_usb_msg.c:(214) Opened USB DS9490 bus master at 1:4.
            Sep 08 16:49:38 SmartHomeNG OWFS[1135]: DEFAULT: ow_usb_cycle.c:(128) Set DS9490 1:4 unique id to 81 74 B6 34 00 00 00 7B
            Sep 08 16:49:39 SmartHomeNG owserver[1129]: Starting 1-Wire TCP Server: owserver.
            Sep 08 16:49:39 SmartHomeNG systemd[1]: Started LSB: 1-wire TCP server.
            Code:
            [smarthome@SmartHomeNG ~]$ sudo /etc/init.d/owhttpd status
            ● owhttpd.service - LSB: 1-wire HTTP server
               Loaded: loaded (/etc/init.d/owhttpd; generated; vendor preset: enabled)
               Active: active (exited) since Sun 2019-09-08 16:49:26 CEST; 1h 5min ago
                 Docs: man:systemd-sysv-generator(8)
              Process: 1094 ExecStart=/etc/init.d/owhttpd start (code=exited, status=0/SUCCESS)
               CGroup: /system.slice/owhttpd.service
            
            Sep 08 16:49:25 SmartHomeNG systemd[1]: Starting LSB: 1-wire HTTP server...
            Sep 08 16:49:25 SmartHomeNG OWFS[1100]: DEFAULT: ow_daemon.c:(144) Entered background mode, quitting.
            Sep 08 16:49:26 SmartHomeNG owhttpd[1094]: Starting 1-Wire HTTP Daemon: owhttpd.
            Sep 08 16:49:26 SmartHomeNG systemd[1]: Started LSB: 1-wire HTTP server.
            Sep 08 16:49:30 SmartHomeNG OWFS[1100]: DEFAULT: owlib.c:(52) No valid 1-wire buses found
            Habe auch folgende Fehlermeldungne im Log
            Code:
            2019-09-08  15:08:07 ERROR    plugins.onewire     1-Wire: could not connect to 127.0.0.1:4304: [Errno 111] Verbindungsaufbau abgelehnt
            Zapft ihr Narren der König hat Durst

            Kommentar


              #7
              Sieht mir schlicht so aus, als würde owserver keine Hardware erkennen. Verkabelung mal geprüft? Gerade diese komischen Steckverbinder von den USB 1-Wire Busmastern sind so anfällig wie Telefonkabel.

              Kommentar


                #8
                Zitat von bmx Beitrag anzeigen
                Sieht mir schlicht so aus, als würde owserver keine Hardware erkennen. Verkabelung mal geprüft? Gerade diese komischen Steckverbinder von den USB 1-Wire Busmastern sind so anfällig wie Telefonkabel.
                Webserver müsste doch unter port 2121 erreichbar sein und das USB Interface anzeigen. Und das unabhängig vom Kabel -> Tut auch nicht.
                Zapft ihr Narren der König hat Durst

                Kommentar


                  #9
                  So wie ich das oben interpretiere, ist aber owhttpd gar nicht gestartet. Sonst würde da bei "Active: active(running) since ...." stehen.

                  Kommentar


                    #10
                    Ich habe es auch mit Rasbian Buster und owfs 3.2p3 bzw. 3.2p2 probiert, es geht nichts. Mit der gleichen Hardware Raspi3 und 1wire Pi Plus aber Rasbian Strech und owfs 3.1p5-1 funktioniert es ohne Probleme. Leider habe ich noch keine, das Problem lösende, Antwort im Internet gefunden.

                    Kommentar


                      #11
                      Also ich hatte auch gekämpft mit dem onewire bis das zuverlässig lief. Ich bin dazu übergegangen und habe mir meine eigenen systemd dienste definiert:

                      Code:
                      $ cat /etc/systemd/system/owfs.service
                      [Unit]
                      Description=1-Wire FUSE driver
                      Requires=owserver.service
                      After=owserver.service
                      
                      [Service]
                      Restart=always
                      Type=simple
                      ExecStart=
                      ExecStart=/usr/bin/owfs --configuration /etc/owfs.conf --foreground
                      ExecStop=
                      RemainAfterExit=no
                      
                      [Install]
                      WantedBy=graphical.target multi-user.target
                      
                      $ cat /etc/systemd/system/owftpd.service.d/override.conf
                      [Unit]
                      Description=1-Wire FTP Server
                      Requires=owserver.service
                      After=owserver.service
                      
                      [Service]
                      Restart=always
                      Type=simple
                      ExecStart=
                      ExecStart=/usr/bin/owftpd --configuration /etc/owfs.conf --foreground
                      ExecStop=
                      RemainAfterExit=no
                      
                      $ cat /etc/systemd/system/owhttpd.service.d/override.conf
                      [Unit]
                      Description=1-Wire HTTP Server
                      Requires=owserver.service
                      After=owserver.service
                      
                      [Service]
                      Restart=always
                      Type=simple
                      ExecStart=
                      ExecStart=/usr/bin/owhttpd --configuration /etc/owfs.conf --foreground
                      ExecStop=
                      RemainAfterExit=no
                      
                      $ cat /etc/systemd/system/owserver.service.d/override.conf
                      [Unit]
                      Description=1-Wire TCP Server
                      
                      [Service]
                      Restart=always
                      Type=simple
                      ExecStart=
                      ExecStart=/usr/bin/owserver --configuration /etc/owfs.conf --foreground
                      ExecStop=
                      RemainAfterExit=no
                      vielleicht hilft euch das ja weiter

                      meine owfs.conf

                      Code:
                      $ egrep -v "(^#.*|^$)" /etc/owfs.conf
                      ! server: server = 127.0.0.1:4304
                      server: usb = all
                      server: timeout_usb=8
                      server: usb_flextime
                      owfs: mountpoint = /mnt/1wire
                      owfs: allow_other
                      http: port = 2121
                      ftp: port = 2120
                      server: port = 127.0.0.1:4304
                      server: error_level = 5
                      error_print = 1
                      error_level = 1
                      nozero
                      noautoserver
                      alias = /etc/owfs-alias.txt
                      unaliased
                      Celsius
                      Zuletzt geändert von TCr82; 25.10.2019, 19:13.

                      Kommentar


                        #12
                        Super! Wäre cool, wenn sonst noch jemand diese Änderungen testen könnte. Dann sollte ich wohl alle Services entsprechend ins nächste Image nehmen..!?

                        Kommentar


                          #13
                          Habe jetzt mal die Dateien so angelegt
                          Code:
                           [smarthome@SmartHomeNG ~]$ cat /etc/systemd/system/owfs.service
                          [Unit]
                          Description=1-Wire FUSE driver
                          Requires=owserver.service
                          After=owserver.service
                          
                          [Service]
                          Restart=always
                          Type=simple
                          ExecStart=
                          ExecStart=/usr/bin/owfs --configuration /etc/owfs.conf --foreground
                          ExecStop=
                          RemainAfterExit=no
                          
                          [Install]
                          WantedBy=graphical.target multi-user.target
                           [smarthome@SmartHomeNG ~]$ cat /etc/systemd/system/owftpd.service.d/override.conf
                          [Unit]
                          Description=1-Wire FTP Server
                          Requires=owserver.service
                          After=owserver.service
                          
                          [Service]
                          Restart=always
                          Type=simple
                          ExecStart=
                          ExecStart=/usr/bin/owftpd --configuration /etc/owfs.conf --foreground
                          ExecStop=
                          RemainAfterExit=no
                           [smarthome@SmartHomeNG ~]$ cat /etc/systemd/system/owhttpd.service.d/override.conf
                          [Unit]
                          Description=1-Wire HTTP Server
                          Requires=owserver.service
                          After=owserver.service
                          
                          [Service]
                          Restart=always
                          Type=simple
                          ExecStart=
                          ExecStart=/usr/bin/owhttpd --configuration /etc/owfs.conf --foreground
                          ExecStop=
                          RemainAfterExit=no
                           [smarthome@SmartHomeNG ~]$ cat /etc/systemd/system/owserver.service.d/override.conf
                          [Unit]
                          Description=1-Wire TCP Server
                          
                          [Service]
                          Restart=always
                          Type=simple
                          ExecStart=
                          ExecStart=/usr/bin/owserver --configuration /etc/owfs.conf --foreground
                          ExecStop=
                          RemainAfterExit=no
                          - owhttp startet nach einem neustart nicht von alleine.
                          - "sudo /etc/init.d/owhttpd status" zeigt, dass der sich alle 1-4 Sekunden selbst beendet und neu startet

                          Bin jetzt kein Experte. Habe das nur versucht so umzusetzten
                          Zuletzt geändert von Hochpass; 01.11.2019, 13:42.
                          Zapft ihr Narren der König hat Durst

                          Kommentar


                            #14
                            Das hört sich nach einem Startproblem an.... Logfile?

                            Für andere, man muss evtl. noch die Dienste wie folgt aktivieren (scheint ja aber bei dir schon geschehen zu sein):
                            zb: systemctl enable owhttpd.service

                            Und wie sieht deine owfs.conf denn aus?
                            Zuletzt geändert von TCr82; 04.11.2019, 22:16.

                            Kommentar

                            Lädt...
                            X