Ankündigung

Einklappen
Keine Ankündigung bisher.

test_requirements: package 'ruamel.yaml' v0.16.10 is too new. Maximum v0.15.74 is

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    test_requirements: package 'ruamel.yaml' v0.16.10 is too new. Maximum v0.15.74 is

    Hallo,
    habe heute eine system_update ausgeführt und jetzt erhalte ich beim Starten die Fehlermeldung:
    test_requirements: package 'ruamel.yaml' v0.16.10 is too new. Maximum v0.15.74 is needed
    Wie kann ich die alte Version wieder installieren?
    DANKE!
    Henry
    Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
    Raspberry Pi - MacMini - geoTHERM VWL S

    #2
    https://stackoverflow.com/questions/...sions-with-pip

    Kommentar


      #3
      pip install ruamel.yaml==v0.15.74
      ist die Lösung.
      DANKE!
      Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
      Raspberry Pi - MacMini - geoTHERM VWL S

      Kommentar


        #4
        system_update klingt nach meinem Image. Dort werden nach dem Update aller Python Packages eigentlich nochmals die Requirements durchgegangen. Dadurch sollten zu aktuelle Pakete automatisch auf die nötige Version gebracht werden. Vielleicht ist da was falsch gelaufen?

        Kommentar


          #5
          Vor ca. 3 Monaten habe ich dein Image Onkelandy installiert.
          Heute wurden sehr viele Updates installiert.
          Einige waren rot markiert. Ich kann leider damit nichts anfangen.
          Soll ich die LOGs zusenden? Wenn ja, dann welche?
          DANKE!
          Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
          Raspberry Pi - MacMini - geoTHERM VWL S

          Kommentar


            #6
            Ich hab es bei mir gerade probiert. Das Script wird wegen einem Problem mit numpy abgebrochen.
            Leider gibt es immer wieder mit einigen Packages Probleme mit dem Pi, warum auch immer. Nach einer manuellen Installation über piwheels mittels

            Code:
            runuser -l smarthome -c "pip3 install https://www.piwheels.org/simple/numpy/numpy-1.18.1-cp37-cp37m-linux_armv7l.whl#sha256=24817c750cbb59322d2fd5b1c5 ddb444417c7ad86dfd0451b41ba299321198b6"
            
            
            runuser -l smarthome -c "pip3 install --user https://www.piwheels.org/simple/scipy/scipy-1.4.1-cp37-cp37m-linux_armv7l.whl#sha256=048de8eb5643c98ca6528fc3ea c0b2f97f88d6017784f5749c430a52139089c5"
            läuft system_update durch.
            Zuletzt geändert von Onkelandy; 14.02.2020, 23:35.

            Kommentar


              #7
              Am Anhang das LOGfile von system_update
              Angehängte Dateien
              Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
              Raspberry Pi - MacMini - geoTHERM VWL S

              Kommentar


                #8
                Sonderbar - bei dir stoppt er bei rrdtool. Hast du die develop Version von smarthomeNG am Laufen?
                Mach doch mal das hier:
                Code:
                sudo apt-get install rrdtool librrd-dev
                Bei meinem Test wurde rrdtool für Python dann problemlos installiert. Notfalls python-rrdtool per apt installieren.

                Kommentar


                  #9
                  Ist das beim Image wirklich so das die Inhalte der requirements/all.txt installiert werden? Da sind einige Sachen drin, die sich gegenseitig beissen so wie z.B. nokia
                  Wenn für SHNG 1.7 ein neues Image released wird, würde ich diese Vorgehensweise ändern ...

                  Kommentar


                    #10
                    Bei SmartHOmeNG nutze ich Master und bei Smartvisu Develop.
                    Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
                    Raspberry Pi - MacMini - geoTHERM VWL S

                    Kommentar


                      #11
                      Nach dem

                      Code:
                      sudo apt-get install rrdtool librrd-dev
                      lief jetzt system_update durch.
                      Folgende Zeile sind noch ROT markiert:
                      ERROR: miflora 0.6 has requirement btlewrap==0.0.8, but you'll have btlewrap 0.0.9 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement arrow<0.13,>=0.12, but you'll have arrow 0.15.5 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement cherrypy<17.4,>=17.3, but you'll have cherrypy 18.5.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests-oauthlib<1.1,>=1.0, but you'll have requests-oauthlib 1.3.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement arrow<0.13,>=0.12, but you'll have arrow 0.15.5 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement cherrypy<17.4,>=17.3, but you'll have cherrypy 18.5.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests-oauthlib<1.1,>=1.0, but you'll have requests-oauthlib 1.3.0 which is incompatible.
                      ERROR: Command errored out with exit status 1:
                      command: /usr/bin/python3 /usr/local/lib/python3.7/dist-packages/pip/_vendor/pep517/_in_process.py build_wheel /tmp/tmp_v_1f1tu
                      cwd: /tmp/pip-install-nsc6osws/PyGObject
                      Complete output (45 lines):
                      running bdist_wheel
                      running build
                      running build_py
                      creating build
                      creating build/lib.linux-armv7l-3.7
                      creating build/lib.linux-armv7l-3.7/pygtkcompat
                      copying pygtkcompat/__init__.py -> build/lib.linux-armv7l-3.7/pygtkcompat
                      copying pygtkcompat/pygtkcompat.py -> build/lib.linux-armv7l-3.7/pygtkcompat
                      copying pygtkcompat/generictreemodel.py -> build/lib.linux-armv7l-3.7/pygtkcompat
                      creating build/lib.linux-armv7l-3.7/gi
                      copying gi/__init__.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_gtktemplate.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_compat.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_propertyhelper.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/docstring.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/importer.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_signalhelper.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/pygtkcompat.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/types.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_error.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_constants.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_ossighelper.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/_option.py -> build/lib.linux-armv7l-3.7/gi
                      copying gi/module.py -> build/lib.linux-armv7l-3.7/gi
                      creating build/lib.linux-armv7l-3.7/gi/repository
                      copying gi/repository/__init__.py -> build/lib.linux-armv7l-3.7/gi/repository
                      creating build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/__init__.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/Gio.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/keysyms.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/GdkPixbuf.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/GIMarshallingTests.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/GObject.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/GLib.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/Gtk.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/Gdk.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      copying gi/overrides/Pango.py -> build/lib.linux-armv7l-3.7/gi/overrides
                      running build_ext
                      Package glib-2.0 was not found in the pkg-config search path.
                      Perhaps you should add the directory containing `glib-2.0.pc'
                      to the PKG_CONFIG_PATH environment variable
                      No package 'glib-2.0' found
                      Command '('pkg-config', '--print-errors', '--exists', 'glib-2.0 >= 2.48.0')' returned non-zero exit status 1.

                      Try installing it with: 'sudo apt install libglib2.0-dev'
                      ----------------------------------------
                      ERROR: Failed building wheel for PyGObject
                      Failed to build PyGObject
                      ERROR: Could not build wheels for PyGObject which use PEP 517 and cannot be installed directly
                      ERROR: Command errored out with exit status 1:
                      command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"'; __file__='"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"' "', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-k84uktmu
                      cwd: /tmp/pip-install-4y31eza_/pykerberos/
                      Complete output (14 lines):
                      running bdist_wheel
                      running build
                      running build_ext
                      building 'kerberos' extension
                      creating build
                      creating build/temp.linux-armv7l-3.7
                      creating build/temp.linux-armv7l-3.7/src
                      arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c src/kerberos.c -o build/temp.linux-armv7l-3.7/src/kerberos.o
                      In file included from src/kerberos.c:19:
                      src/kerberosbasic.h:17:10: fatal error: gssapi/gssapi.h: Datei oder Verzeichnis nicht gefunden
                      #include <gssapi/gssapi.h>
                      ^~~~~~~~~~~~~~~~~
                      compilation terminated.
                      error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
                      ----------------------------------------
                      ERROR: Failed building wheel for pykerberos
                      Running setup.py clean for pykerberos
                      Failed to build pykerberos
                      Installing collected packages: pykerberos
                      Running setup.py install for pykerberos ... error
                      ERROR: Command errored out with exit status 1:
                      command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"'; __file__='"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"' "', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-0ulf1cna/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/smarthome/.local/include/python3.7m/pykerberos
                      cwd: /tmp/pip-install-4y31eza_/pykerberos/
                      Complete output (14 lines):
                      running install
                      running build
                      running build_ext
                      building 'kerberos' extension
                      creating build
                      creating build/temp.linux-armv7l-3.7
                      creating build/temp.linux-armv7l-3.7/src
                      arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c src/kerberos.c -o build/temp.linux-armv7l-3.7/src/kerberos.o
                      In file included from src/kerberos.c:19:
                      src/kerberosbasic.h:17:10: fatal error: gssapi/gssapi.h: Datei oder Verzeichnis nicht gefunden
                      #include <gssapi/gssapi.h>
                      ^~~~~~~~~~~~~~~~~
                      compilation terminated.
                      error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
                      ----------------------------------------
                      ERROR: Command errored out with exit status 1: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"'; __file__='"'"'/tmp/pip-install-4y31eza_/pykerberos/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"' "', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-0ulf1cna/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/smarthome/.local/include/python3.7m/pykerberos Check the logs for full command output.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests-oauthlib<1.1,>=1.0, but you'll have requests-oauthlib 1.3.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests-oauthlib<1.1,>=1.0, but you'll have requests-oauthlib 1.3.0 which is incompatible.
                      ERROR: pyatv 0.3.9 has requirement aiohttp<3,>=2.3.0, but you'll have aiohttp 3.6.2 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement arrow<0.13,>=0.12, but you'll have arrow 0.13.1 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement cherrypy<17.4,>=17.3, but you'll have cherrypy 18.5.0 which is incompatible.
                      ERROR: nokia 1.2.0 has requirement requests<2.20,>=2.19, but you'll have requests 2.22.0 which is incompatible.

                      Neustes Projekt: Ubutu als VM (Parallels) auf einem MacMini
                      Raspberry Pi - MacMini - geoTHERM VWL S

                      Kommentar


                        #12
                        Ich hab irgendwie noch nicht rausgefunden, warum PYGObject überhaupt installiert wurde. Für shng ist es jedenfalls egal. Und wenn du willst, kannst du ja die angegebenen Pakete installieren.

                        bmx Nachdem ja jeder andere Plugins nutzt, schien es mir sinnvoll, gleich alle Eventualitäten abzudecken. Dass diverse Plugins gegensetzliche Requirements haben, sollte irgendwann von den Autoren oder notfalls uns gelöst werden, nicht?

                        Ab 1.7 werden nicht installierte Pakete zwar automatisch nachinstalliert, das würde aber bei scipy und numpy am Raspi trotzdem zu Problemen führen und auch bei anderen Pakete sind diverse libraries nötig. Was ich allerdings ändern werde - nach dem Aktualisieren der Pakete sollen nur noch die Requirements aus conf_all angepasst werden und nicht mehr alle. Ist die beste Lösung oder nicht?

                        Kommentar


                          #13
                          Die gegensätzlichen Requirements wirst Du nie auflösen können weil die meisten aus externen Bibliotheken "eingeschleppt" werden. Das dauert teils extrem lange, bis sich da was tut oder aber man soll einen PR stellen warum man die Abhängigkeit X und nicht Y haben will. --> Ergo kannste vergessen.

                          scipy und numpy sind IMHO eine Ausnahme, eben so wie PyEphem derzeit. Die beste Lösung wäre IMHO wenn SHNG die benötigten Abhängigkeiten selbst installiert sobald ein Plugin konfiguriert wird. Das einzige, was wir nicht fangen können, wären notwendige Libs die über "sudo apt-get install xyz" installiert werden müssen. Beispielsweise das rrd-plugin wäre so ein Kandidat.
                          Ich habe keine rechte Idee, wie man da sinnvoll vorgeht. Denn Sachen mit sudo sollte der User selber entscheiden und die dürfen nicht einfach im Hintergrund "gemacht" werden ...

                          Kommentar


                            #14
                            Ich denke, dass er Raspi hier auch ein Sonderfall ist, gerade eben was scipy und Co anlangt. Wenn man's bunt treiben will, könnte man beim Start von shng checken, auf welcher CPU shng läuft. Wenn Raspi, dann auf piwheels.org suchen, ob es ein WHL File davon gibt und das aktuellste für die entsprechende CPU und python Version installieren. Wenn nicht, mittels pip3 <paketname>.
                            Ob's da nicht mehr Probleme gibt, sei dahin gestellt. Zumal wohl nicht alle problematischen Pakete dort angeboten werden und dann muss man eh wieder manuell ran. Daher würde ich vorschlagen, das für das Image wie oben beschrieben zu handhaben.

                            Kommentar


                              #15
                              Mit v1.7 installiert SmartHomeNG die Requirements von PyPi selbstständig nach, wenn ein Plugin mit Requirements konfiguriert wurde. Also braucht man dann vorab keinerlei Python Packages zu installieren.

                              Das einzige was nicht abgedeckt ist, wenn die Plugins oder die benötigten PyPi Packages Linux Pakete benötigen, die nicht installiert sind.
                              Viele Grüße
                              Martin

                              There is no cloud. It's only someone else's computer.

                              Kommentar

                              Lädt...
                              X