Ankündigung

Einklappen
Keine Ankündigung bisher.

SmarthomeNG 1.7.1 Image für Raspberry Pi

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    SmarthomeNG 1.7.1 Image für Raspberry Pi

    Wer SmarthomeNG auf einem Raspberry Pi nutzt, startet am einfachsten mit diesem Image. Es ist auf eine min. 8GB große SD-Karte zu brennen und quasi "Plug and Play" mit einer Vielzahl an Erweiterungen und Diagnosetools.

    AKTUELL: Version 10 mit SmarthomeNG 1.7.1
    Die Versionierung wurde abgeändert, um auch die Debian Version zu kommunizieren.

    Base:
    Raspbian Buster Lite

    German UTF-8 locale is activated by default. On English keyboards y is z.

    Python:
    Python 2.7.16
    Python 3.7.3

    Compatibility
    Raspberry Pi 1 B+, Raspberry Pi 2, Raspberry Pi 3, Raspberry 4
    When using a monitor you might need to uncomment the line hdmi_drive=2 in /boot/config.txt

    Login
    Standard user: smarthome
    Password: none

    SmartVISU
    ACHTUNG: Der Pfad zur Visu hat sich durch den finalen Release der Version 2.9 geändert! Die neueste Version der Visu ist nun über "smartvisu" (Kleinschreibung!) zu erreichen.

    Die Doku inkl. Changelog: https://github.com/smarthomeNG/raspberrypi-image/wiki
    Das Image: https://github.com/smarthomeNG/raspb...s/tag/10.1.7.1
    Zuletzt geändert von Onkelandy; 19.04.2020, 12:56.

    #2
    Aktuellste Version des Images mit neuestem shng und smartvisu ist online: https://github.com/smarthomeNG/raspb...ses/tag/10.1.7
    Aktuell als Pre-Release bezeichnet, final Release auf Ostern anvisiert. Daher bitte Probleme möglichst rasch kommunizieren.

    Nach wie vor freue ich mich über Hilfe! Man müsst die Doku von Sourceforge ins RST Format bringen. Einfach PR hier erstellen: https://github.com/smarthomeNG/raspberrypi-image/pulls

    Die Originaldoku: https://sourceforge.net/p/smarthomen...age/wiki/Home/

    Kommentar


      #3
      Kann man die Daten mit dem Markdown Beiträgen aus dem Wiki irgendwie en bloc herunterladen?

      Kommentar


        #4
        Wüsste auf die Schnelle nicht wie, aber ich hab jetzt mal alle Seiten 1:1 mit Wiki Markdown hier rein gelegt: https://github.com/smarthomeNG/raspb...ree/master/doc

        Es gäbe wohl mit pandoc und Co Möglichkeiten der automatischen Konvertierung, aber so ganz geklappt hat das bei mir nie.

        Kommentar


          #5
          Das könnte man auch erstmal in nicht-konvertiert als .md Dateien in die Anwender Doku einbinden. Würde dann aber erst mit dem nächsten Core Release in die Doku eingehen.

          Oder wir müssten für das Image eine eigene Doku aufmachen. Alternativ könnte man das auch erstmal in das gitgub Wiki aufnehmen.
          Viele Grüße
          Martin

          There is no cloud. It's only someone else's computer.

          Kommentar


            #6
            Richtig. Erst alles automatisch konvertieren lassen, Dann habe ich mir am linken Monitor das "schön formatierte" Markdown angeschaut und dann auf dem rechten dazu passend den rst Quellcode und die passende Preview. Das geht z.B. mit Visual Studio Code ganz gut. Doof sind Tabellen umzubauen...

            Ich fände es schön, wenn die Doku komplett ist :-)

            Kommentar


              #7
              Dank OnkelAndy haben wir fast alles bereits im image Repo. Ich habe die Dateien nur in .md umbenannt und sie sind da gut lesbar. Fehlt nur die Titelseite. Aus den Seiten würde ich erstmal eindach ein github Wiki machen. Ist unabhängig von core-Releases anpassbar und liegt direkt wo es themenmäßig hingehört.
              Viele Grüße
              Martin

              There is no cloud. It's only someone else's computer.

              Kommentar


                #8
                Hallo,

                habe gerade ein System mit dem neuen Image aufgesetzt.

                Kann es sein, dass mit der SmartVISU Installation etwas nicht in Ordnung ist? Ich erreiche die SmartVISU im Browser nicht.
                Sollte doch nun unter <IP-ADRESSE>/smartvisu zu erreichen sein oder?

                Netten Gruß
                Daniel

                Kommentar


                  #9
                  Guckst du: https://knx-user-forum.de/forum/supp...pi#post1490918

                  Kommentar


                    #10
                    Möchtest Du auf: „Zu Ostern soll der finale Release zur Verfügung stehen, bei dem etwaige Probleme behoben sind.“ verweisen oder den Hinweis, dass die Smartvisu nun unter „alles kleingeschrieben“ zu erreichen ist? Die Kleinschreibung hatte ich schon beachtet.

                    Kommentar


                      #11
                      Primär auf die neue Schreibweise. Hmm, also du hast ein ganz frisches Image und bei smartvisu kommt ein 404 Error?
                      Was passiert zB beim Aufruf deiner IP im Browser oder http://IP/phpinfo.php
                      Wenn du am Raspi mal systemctl status nginx ausführst, was kommt da für ne Info?

                      Kommentar


                        #12
                        Zitat von Onkelandy Beitrag anzeigen
                        Primär auf die neue Schreibweise. Hmm, also du hast ein ganz frisches Image und bei smartvisu kommt ein 404 Error?
                        Was passiert zB beim Aufruf deiner IP im Browser oder http://IP/phpinfo.php
                        Wenn du am Raspi mal systemctl status nginx ausführst, was kommt da für ne Info?
                        Ja, heute ein ganz frisches Image aufgesetzt. Meine alte SD-Karte ist abgeraucht, daher einmal alles Neu, mit neuer Karte usw.
                        Sowohl http://IP/smartvisu als auch http://IP/phpinfo.php liefern ein 502 Bad Gateway des nginx.

                        Er scheint aber zu laufen:
                        Code:
                        ● nginx.service - A high performance web server and a reverse proxy server
                        
                        Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
                        
                        Active: active (running) since Thu 2020-04-09 15:46:38 CEST; 3h 15min ago
                        
                        Docs: man:nginx(8)
                        
                        Process: 402 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
                        
                        Process: 554 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
                        
                        Main PID: 566 (nginx)
                        
                        Tasks: 6 (limit: 2200)
                        
                        Memory: 16.4M
                        
                        CGroup: /system.slice/nginx.service
                        
                        ├─566 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
                        
                        ├─567 nginx: worker process
                        
                        ├─568 nginx: worker process
                        
                        ├─573 nginx: worker process
                        
                        ├─574 nginx: worker process
                        
                        └─575 nginx: cache manager process
                        Das Admin Backend kann ich auch ohne Probleme aufrufen.

                        Kommentar


                          #13
                          Was steht im nginx log?
                          was passiert hier


                          sudo systemctl list-unit-files | grep -E 'php[^fpm]*fpm'

                          bzw läuft php7.3-fpm?

                          Kommentar


                            #14
                            Zitat von Onkelandy Beitrag anzeigen
                            Was steht im nginx log?
                            was passiert hier


                            sudo systemctl list-unit-files | grep -E 'php[^fpm]*fpm'

                            bzw läuft php7.3-fpm?

                            /var/log/nginx/error.log

                            Code:
                            2020/04/09 20:17:21 [crit] 567#567: *334 connect() to unix:/var/run/php/php7.3-fpm.sock failed (2: No such file or directory) while connecting to upstream, client: 192.168.100.250, server: domain_here, request: "GET /phpinfo.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.3-fpm.sock:", host: "192.168.100.3"


                            Code:
                            [smarthome@SmartHomeNG ~]$ sudo service php7.3-fpm status
                            
                            ● php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
                            
                            Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
                            
                            Active: failed (Result: exit-code) since Thu 2020-04-09 16:14:47 CEST; 4h 0min ago
                            
                            Docs: man php-fpm7.3(8)
                            
                            Process: 1740 ExecStart=/usr/sbin/php-fpm7.3 --nodaemonize --fpm-config /etc/php/7.3/fpm/php-fpm.conf (code=exited, status=78)
                            
                            Main PID: 1740 (code=exited, status=78)
                            
                            
                            
                            
                            Apr 09 16:14:47 SmartHomeNG systemd[1]: Starting The PHP 7.3 FastCGI Process Manager...
                            
                            Apr 09 16:14:47 SmartHomeNG php-fpm7.3[1740]: [09-Apr-2020 16:14:47] ERROR: unable to bind listening socket for address '/run/php/php7.3-fpm.sock': No such file or direct
                            
                            Apr 09 16:14:47 SmartHomeNG php-fpm7.3[1740]: [09-Apr-2020 16:14:47] ERROR: FPM initialization failed
                            
                            Apr 09 16:14:47 SmartHomeNG systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/CONFIG
                            
                            Apr 09 16:14:47 SmartHomeNG systemd[1]: php7.3-fpm.service: Failed with result 'exit-code'.
                            
                            Apr 09 16:14:47 SmartHomeNG systemd[1]: Failed to start The PHP 7.3 FastCGI Process Manager.


                            Code:
                            [smarthome@SmartHomeNG ~]$ sudo systemctl list-unit-files | grep -E 'php[^fpm]*fpm'
                            
                            php7.3-fpm.service enabled
                            Dann scheint wohl php7.3-fpm der Übeltäter zu sein.

                            Kommentar


                              #15
                              Hm, mal sehen, ob sonst auch wer das Problem hat. Habe gerade nochmals das Image auf eine SD Karte gesteckt und es läuft einwandfrei. Genug Speicherplatz hast du ja, oder? Leg doch notfalls das Verzeichnis /run/php selbst an und chown www-data:www-data

                              Kommentar

                              Lädt...
                              X