Ankündigung

Einklappen
Keine Ankündigung bisher.

Question about issue with HTTPS usage for smartVisu on SmartHomeNG

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Question about issue with HTTPS usage for smartVisu on SmartHomeNG

    Hello everyone, Hope its ok to post here in English.
    First of all, I would like to thank everyone here for creating/maintaining SmartHomeNG and SmartVisu. Finally found something I could get working rather quickly with my KNX installation.

    I have it working on the default HTTP pages, and can switch/dim any lights in my house and see each room temperature via the SmartVisu pages with knxd to the KNX bus.
    I then installed Certbot and 3rd party plugin to get a wildcard domain cert, verified by DNS entry, and certs are stored in /etc/letsencrypt/live/<domainname>/.
    I will use them also to copy over-to/use-in a few other devices in the house (NAS, router etc).

    My issue is that when I switch from http://<IPaddress>/smartvisu to httpS://<IPaddress>/smartvisu , I only see (header) texts and picture place holders. See below 2 pictures. (<IPaddress> would be like 192.168.x.x)
    I've tried a few things but dont know what else I am missing/ can try.
    Any help would be appreciated.

    In below, 'wildcard domain' is like '*.home.net', <domain name> is 'home.net', <hostname>.<domain name> is then 'smart.home.net'

    Added to: /etc/nginx/conf.d/https.conf
    server_name <hostname>.<domain name>;
    ssl_certificate /etc/letsencrypt/live/<domain name>/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/<domain name>/privkey.pem;
    ssl_trusted_certificate /etc/letsencrypt/live/<domain name>/fullchain.pem;

    I also tried:
    server_name <hostname>.<domain name> <domain name>;
    or
    server_name <domain name>;

    I also tried creating an extra file in /etc/nginx/conf.d with name <domain name>.conf and/or <hostname>.<domain name>.conf.
    Both being copies of https.conf with server_name adjusted accordingly.

    Build/setup:
    • Hardware: Raspberry Pi 3
    • Started with the Rasbian Image "Debian Buster, SmarthomeNG 1.7.1"
    • Apt-get update + apt-get upgrade
    • setup_all -> changed language to English, TZ: Europe/Dublin,
    • knxd enabled, SSH enabled,samba: disabled, nginx:enabled, reverse proxy: skip, fail2ban:disabled, NFS:enable, Lirc:disable, Monit:disable, Exim4:enabled, Logcheck:disabled, Mosquite:enabled, OpenVPN:enabled, InfluxDB:enabled, Grafana:enabled,
    • Changed SSH port from 22 to 10022

    system_update -> updated environment:
    SmartHomeNG version 1.7.2.master, Python version 3.7.3 final, SmartVise v2.9.b.Development, knxd v0.14.30

    working SmartVisu on http.pngnot working on https.png

    #2
    Zitat von Monster23 Beitrag anzeigen
    My issue is that when I switch from http://<IPaddress>/smartvisu to httpS://<IPaddress>/smartvisu , I only see (header) texts and picture place holders. See below 2 pictures.
    That is because modern Browsers don't allow mixtures of entcrypted Traffic and unencrypted Traffic on the same page.

    You have to use wss:// instead of ws:// protocol on the page. For that you have to configure the visu_websocket plugin for wss:// (it does only support ws:// or wss://, not both). The plugin doesn't use the certificates at the locations you named. You have to have the certificate in the smarthome/ect directory.

    And you have to configure the smartVISU for using wss://. It has been discussed in the smartVISU forum.
    Viele Grüße
    Martin

    There is no cloud. It's only someone else's computer.

    Kommentar

    Lädt...
    X