Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit plugin-Version

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Problem mit plugin-Version

    Ich hänge an folgender Zeile:

    plugin 'aaeigwerte' v0.1.8.2: SmartHomeNG v1.9.2 is too new for this plugin. It requires a version up to v0.0.0.5. The plugin was not loaded.

    Wo liegt mein Fehler!

    Danke für jede Hilfe
    Wolfgang

    #2
    Schau mal ob Du in der plugin.yaml Deines Plugins mit dem mutmasslichen Namen 'aaeigwerte' einen Abschnitt

    Code:
    sh_maxversion
    gesetzt hast.
    Zuletzt geändert von bmx; 31.07.2022, 17:15.

    Kommentar


      #3
      Mein Problem, nach vielen Versuchen auf die empfohlene v1.0.0 gesetzt,
      trotzdem kein Erfolg.

      version: 1.0.0 # Plugin version
      sh_minversion: 1.0.0 # minimum shNG version to use this plugin
      sh_maxversion: # maximum shNG version to use this plugin (leave empty if latest)

      version: 1.0.0 # Plugin version
      sh_minversion: 1.0.0 # minimum shNG version to use this plugin
      sh_maxversion: # maximum shNG version to use this plugin (leave empty if latest)



      Wie muss die Version eingetragen werden, 1.8.2 war mein aktueller Stand?

      -------------------- Init SmartHomeNG v1.9.2-master (cc57a0ad) --------------------
      2022-08-01 11:02:07 NOTICE lib.smarthome Running in Python interpreter 'v3.9.2 final', from directory /usr/local/smarthome
      2022-08-01 11:02:07 NOTICE lib.smarthome - on Linux-5.15.32-v7l+-armv7l-with-glibc2.31 (pid=7965)

      2022-08-01 11:02:12 ERROR lib.metadata plugin 'aaeigwerte' v1.0.0: SmartHomeNG v1.9.2 is too new for this plugin. It requires a version up to v0.0.0.5. The plugin was not loaded.

      Meine Vorgabe
      version: 1.0.0 # Plugin version
      sh_minversion: 1.0.0 # minimum shNG version to use this plugin
      sh_maxversion: # maximum shNG version to use this plugin (leave empty if latest)





      Hier eine Lösung zum Backend (ich erkenne keine Logik shminversion > Version ??
      Wo steckt das Problem??

      version: 1.5.15 # Plugin version
      sh_minversion: 1.6 # minimum shNG version to use this plugin
      # sh_maxversion: # maximum shNG version to use this plugin (leave empty if latest)
      multi_instance: False # plugin supports multi instance
      restartable: False
      classname: BackendServer # class containing the plugin



      Aus fremdem Plugin die Versionen geklaut und übernommen, dann lief es!

      Eintrag kann gelöscht werden!
      Zuletzt geändert von schloessl; 02.08.2022, 11:53. Grund: Problem gelöst, mir aber weiterhin unklar, siehe Backend

      Kommentar

      Lädt...
      X