Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

AVM Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    vermutlich ist die 2te instanz des plugins nicht aktiv. welche smarthomeng version? was zeigt das backend plugin im reiter plugins an

    Kommentar


      wobei ich sehe gerade: plugins.avm_repeater_eg Starting update loop for instance repeater_eg

      Check bitte mal, dass Deine Items wirklich ok sind wegen Klammerung etc... er MUSS an der Stelle was rausloggen wenn Du das self.logger.debug richtig drin hast. Mir kommts so vor, als springt er da ggf. wegen der Items nicht rein

      und änder den block temporär - wie bereits geschrieben - so (erste Zeile):

      Code:
              if True: #"wlanconfig_%s_%s" % (item.conf['avm_wlan_index'], action) in self._response_cache:
                  try:
                      response = self._session.post(url, data=soap_data, timeout=self._timeout, headers=headers,
                                                    auth=HTTPDigestAuth(self._fritz_device.get_user(),
                                                                        self._fritz_device.get_password()),
                                                    verify=self._verify)
                      self.logger.debug(response.content)
                  except Exception as e:
                      self.logger.error("Exception when sending POST request: %s" % str(e))
                      return
                  self._response_cache["wlanconfig_%s_%s" % (item.conf['avm_wlan_index'], action)] = response.content
              else:
                  self.logger.debug("Accessing TAM reponse cache for action %s!" % action)
      Zuletzt geändert von psilo; 24.08.2016, 06:46.

      Kommentar


        Sollte die Call-Funktion nun eigentlich funktionieren oder nicht? Bei mir klappts nämlich nicht mit der 7490.
        Egal ob mit http oder https, Port 49000 oder 49443. Wählhilfe ist aktiviert und auch Zugriff per Heimnetz.
        Im Log steht immer nur "Resetting dropped connection: fritz.box"

        Kommentar


          Resetting dropped connection hat nichts mit einem Fehler zu tun. Bei manchen Nutzern bricht, warum auch immer, nur dauernd die Session weg, dann kommt das...

          Bei mir mit DECT Telefonen nutze ich die call Funktion. Bei anderen Varianten konnte ich aber bisher nicht testen.

          Denk dran vorher den Call Origin zu setzen. Das war im alten Fritzbox v2 Plugin integriert. Interner Call - im Fall eines Alarms, bspw von der Hebeanlage - bei mir bspw so:

          Code:
          sh.fritzbox_7490.set_call_origin("**610")
          sh.fritzbox_7490.start_call('**9')
          Zuletzt geändert von psilo; 28.08.2016, 14:44.

          Kommentar


            Mittlerweile kann ich zumindest eine externe Nummer anrufen, nur intern klappt nicht.
            Wie hast du denn deine Telefoniegeräte eingerichtet? Ist deine Hebeanlage in der FritzBox sozusagen ein virtuelles Gerät?

            Kommentar


              kunig an was lag es?

              Zur Hebeanlage: die setzt eine GAD über den Bus im Alarmfall. Auf die mache ich watch_item und schicke dann mit den o.g. Funktionen den Alarm auf die Telefone.. Kein direkter Anschluß an die FB. Irgendwo auch logisch

              Die 610 ist die Interne Durchwahl des Mobilteil 1. Die Wählhilfe ist zudem angeschaltet und auf ein "virtuelles" Telefon am nicht belegten FON1 Anschluß namens "ALARM" gemapped. Das Ganze musste ich aber nur machen, damit im Display ALARM angezeigt wird ;-).

              **9 ist regulärer Gruppenruf.
              Zuletzt geändert von psilo; 29.08.2016, 05:26.

              Kommentar


                Ah danke, der Tipp mit dem FON1 in der Wählhilfe war es. Hatte zuvor immer das Mobilteil drin, da das ja angerufen wird. Jetzt gehts.
                Eine Frage hätte ich aber noch: Wie kann ich diesem Anruf einen eigenen Klingelton zuweisen? Mein Mobilteil ist ein FritzFon MT-F. Mit Eintrag ins Telefonbuch klappt es leider nicht.
                Zuletzt geändert von kunig; 29.08.2016, 11:42.

                Kommentar


                  kunig so versiert ist nichtmal meine Anbindung. Ist halt der Standardton Wenn Du rauskriegst wie es geht, lass mich/uns das aber gerne wissen

                  Kommentar


                    Guten Morgen,

                    ich habe eine Fritzbox 6360 von KabelBW bzw. Unitymedia.
                    Grundsätzlich scheint das AVM-Plugin zu funktionieren.

                    2016-09-02 08_50_50-ETS4 - TeamViewer.png

                    Ich bekomme aber ständig einen Verbindungsabbruch:

                    Code:
                    2016-09-02  08:43:58 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:43:58 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:43:59 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:43:59 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:00 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:00 ERROR    plugins.avm_fritzbox_6360 Attribute wan_upstream not available on the FritzDevice
                    2016-09-02  08:44:00 ERROR    plugins.avm_fritzbox_6360 Attribute wan_downstream not available on the FritzDevice
                    2016-09-02  08:44:00 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:01 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:01 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:02 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:02 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:03 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:04 INFO     plugins.avm_fritzbox_6360 Resetting dropped connection: 192.168.178.1
                    2016-09-02  08:44:04 ERROR    plugins.avm_fritzbox_6360 Attribute wlanconfig not available on the FritzDevice
                    2016-09-02  08:44:04 ERROR    plugins.avm_fritzbox_6360 Attribute wlanconfig_ssid not available on the FritzDevice
                    2016-09-02  08:44:04 ERROR    plugins.avm_fritzbox_6360 Attribute wlan_guest_time_remaining not available on the FritzDevice
                    So sieht meine plugins.conf aus:

                    Code:
                    [fritzbox]
                        class_name = AVM
                        class_path = plugins.avm
                    #    username = ... # optional
                        password = XXXXX
                        host = '192.168.178.1'
                        port = 49443
                        cycle = 300
                        ssl = True     # use https or not
                        verify = False # verify ssl certificate
                        call_monitor = True
                    #    call_monitor_incoming_filter = ... #optional, don't set if you don't want to watch only one specific number with your call monitor
                        instance = fritzbox_6360
                    Hab ich was falsch gemacht?
                    Gibt es ein Problem mit der Fritzbox 6360?
                    Firmware-Version ist FritzOS! 06.33.

                    Gruß
                    Markus

                    Kommentar


                      Das "Problem" haben mehrere, ich leider nicht, daher kann ich es nicht tieferlegen. Es ist aber ansich kein Problem, es bricht lediglich die Session weg und wird neu erstellt. Just ignore.. Und in der YAML Logging Datei ggf. das Loglevel umkonfigurieren (ab SHNG 1.2)

                      Zudem scheinen einige Attribute/Items bei Dir nicht zu gehen, da würde ich ggf. mal nachsehen was los ist.

                      6.33 ist halt leider auch eine sehr alte FW.. Ich glaube ich hatte anfangs mit 6.50 getestet, mit 6.3x gab es bei den WLAN Devices einen Bug in der FB

                      Kommentar


                        Zitat von psilo Beitrag anzeigen
                        Und in der YAML Logging Datei ggf. das Loglevel umkonfigurieren (ab SHNG 1.2)
                        Kannst Du mir nen Tip geben, wie ich in logging.yaml nur den Loglevel für das AVM-Plugin auf WARN ändere? Alles andere würde ich gerne auf INFO lassen.
                        Ich habe es so versucht, das zieht aber leider nicht:

                        Code:
                        loggers:
                           plugins.avm_fritzbox_6360:
                             level: WARN
                           plugins.avm:
                             level: WARN
                        root:
                            level: INFO
                            handlers: [file, console]
                        Ich hab plugins.avm_fritzbox_6360 versucht, weil das so im Logfile steht, und plugins.avm, weil so das Plugin heißt.
                        Wenn ich bei root den Level ändere, funktioniert es zwar, aber dann halt leider für alles.

                        Zitat von psilo Beitrag anzeigen
                        6.33 ist halt leider auch eine sehr alte FW.. Ich glaube ich hatte anfangs mit 6.50 getestet, mit 6.3x gab es bei den WLAN Devices einen Bug in der FB
                        Ja, das ist die traurige Geschichte bei Unitymedia. Von denen bekomm ich leider die Fireware-Updates sehr spät und sehr selten. Aber dank Routerfreiheit kann ich ja jetzt auf ne eigene Fritzbox umsteigen. Da muss ich mich nur noch drum kümmern und mir eine kaufen...

                        Danke!

                        Gruß
                        Markus

                        Kommentar


                          ide71 https://github.com/smarthomeNG/smarthome/wiki/Logging


                          So müsste es eigentlich funktionieren (instance im Namen):

                          Code:
                          loggers:
                            plugins.avm_fritzbox_7490:
                              level: ERROR
                          Warte mal mit dem Kauf noch, es kommen ja neue Modelle..
                          Zuletzt geändert von psilo; 02.09.2016, 09:12.

                          Kommentar


                            Zitat von psilo Beitrag anzeigen
                            [USER="18593"]
                            So müsste es eigentlich funktionieren (instance im Namen):

                            Tut es leider nicht.

                            Ich hab jetzt mal %(name) in den formatter aufgenommen, um zu sehen, wie der logger wirklich heißt. Er heißt "urllib3.connectionpool"! So funktioniert es jetzt:

                            Code:
                            loggers:
                               urllib3.connectionpool:
                                 level: ERROR
                            Die Frage ist, ob das so gewünscht ist, oder ob man den Namen des loggers im plugin anders setzen kann!?
                            Auf jeden Fall wäre es glaub sinnvoll, das in die Doku des Plugins aufzunehmen.

                            Gruß
                            Markus

                            Kommentar


                              Markus müsste man mal den Schöpfer des Loggings fragen... Ich konnte es wie gesagt nicht testen, da ich das Problem nicht feststellen kann ;-). Check vielleicht mal die CPU Auslastung Deiner Box.. ist die ggf am Limit? Schmeiss mal die Items raus die er nicht findet. Ggf. schiebst Du einfach zu viele Requests rüber.

                              Kommentar


                                Du kannst auch mal schauen welche Requests Version Du hast. Hier aktuell laut Backend Plugin
                                requests 2.11.1

                                Kommentar

                                Lädt...
                                X