Ankündigung

Einklappen
Keine Ankündigung bisher.

basic.stateswitch Problem beim Schalten von Sonoff Basic Aktoren

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    basic.stateswitch Problem beim Schalten von Sonoff Basic Aktoren

    Hallo SmartVISU Freunde,

    für ein kleineres VISU Projekt, dass ich derzeit mit der smartVISU realisieren möchte, habe ich aktuell das Problem, dass ich keine Sonoff Geräte per basic.stateswitch ausschalten kann. Einschalten ist kein Problem, nur ausschalten funktioniert nicht.

    Die Sonoff Geräte sind alle mit Tasmota geflasht und im lokalen Netzwerk eingebunden. Zugriff über MQTT und Weboberfläche im Browser funktioniert tatellos.
    Als Brücke zwischen der smartVISU und den Sonoff Aktoren setze ich ioBroker ein. Dafür verwende ich den von Smai entwickelten iobroker Treiber auf Basis des socket.io. Die Verbindung funktioniert reibungslos. Auch Aufzeichnungen für Heizungs Plots von Homematic Stellantrieben oder ähnliches werden reibungslos empfangen und dargestellt.

    Einzig das Schalten der Beleuchtung mittels dem basic.stateswitch funktioniert nicht korrekt. True und False werden als Value übermittelt.

    Hat da vielleicht jemand einen Ansatz für mich?
    Angehängte Dateien

    #2
    Versuch bei den Werten einmal 1 und 0 anstatt 'true' und 'false'.
    Du gibst diese ja als String an und nicht als boolean. Ich könnte mir vorstellen, dass ioBroker sowohl den String 'true' wie auch den String 'false' zu einem boolean true castet.

    Kommentar


      #3
      Zitat von smai Beitrag anzeigen
      Versuch bei den Werten einmal 1 und 0 anstatt 'true' und 'false'.
      Du gibst diese ja als String an und nicht als boolean. Ich könnte mir vorstellen, dass ioBroker sowohl den String 'true' wie auch den String 'false' zu einem boolean true castet.
      Hallo smai,

      hatte ich auch schon versucht. Du hast recht, dass ioBroker daraus automatisch den boolean true erzeugt. Aber auch mit 1 und 0 kann ich leider nicht mehr ausschalten.
      Einschalten nach wie vor kein Problem.

      Man sieht jedoch in dem Werte State beim ioBrocker kurz, dass false geschrieben wird, das Sonoff Gerät jedoch direkt wieder auf true springt und dann auch in der smartVISU das Symbol auf eingeschaltet bleibt.

      Verwende ich die ioBroker eigene VIS und erstelle gerade mal ein Bulb Switch und trage die GAD ein, schaltet es einwandfrei. Irgendwo ein Problem mit dem socket.io?

      Ist mir wie gesagt ein Rätsel. Setze die Sonoff allerdings auch das Erste mal ein. Hatte sowas ähnliches auch mal bei WEMOS Aktoren. Die hab ich zum testen aber leider nicht mehr.

      Schöne Grüße
      Jochen

      Kommentar

      Lädt...
      X