Ankündigung

Einklappen
Keine Ankündigung bisher.

develop und (fremdes?) FritzBox-Widget

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    develop und (fremdes?) FritzBox-Widget

    Hi,

    ich habe für einen Test mal von master auf develop (jeweils aktuell) gewechselt. Dabei hat er mir im develop ein "lokales" Widget um die Ohren gehauen (Server Error 500).

    Die Servermeldung war:

    Code:
    2020/12/31 14:04:08 [error] 3680#3680: *6872 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined method __TwigTemplate_c53ac07b29cd14e6b7e8da07c606374bd32e4d31e2a88f4af3a178610ab6e36e::getformula() in /srv/www/sv/smartvisu/vendor/Twig/src/Environment.php(497) : eval()'d code:227
    Stack trace:
    #0 /srv/www/sv/smartvisu/vendor/Twig/src/Environment.php(497) : eval()'d code(132): __TwigTemplate_abf3ba6f65c5f7bf5fb6a037586d7e7f44169e3310b59423c17dfd8b48363034->getsystem_info('fb_info', 'd.avm.uptime', 'd.avm.firmware', 'd.avm.hardware_...', '')
    #1 /srv/www/sv/smartvisu/vendor/Twig/src/Template.php(216): __TwigTemplate_42c47ee4ec34ea895a158216542a77fa7292f6ed21456eb09b329e3c00c17b90->block_content(Array, Array)
    #2 /srv/www/sv/smartvisu/vendor/Twig/src/Environment.php(497) : eval()'d code(79): Twig\Template->displayBlock('content', Array, Array)
    #3 /srv/www/sv/smartvisu/vendor/Twig/src/Template.php(216): __TwigTemplate_95f4239203a9d9f3c4e634fb98cd8cee6cc1d461b617284c2e64770ca8a7bd76->block_body(Array, Array)
    #4 /srv/www/sv/smartvisu/vend" while reading response header from upstream, client: 192.168.2.2, server: visu, request: "GET /index.php?page=room_data HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.sock:", host: "192.168.2.221"
    Daraus werde ich nicht schlau, vor allem kann ich nicht erkennen, wo denn jetzt der Fehler ist.

    Das Widget müsste hier aus dem Forum sein und heißt bei mir avm.html, bietet Callmonitor, WLAN-Control und anderes Zeugs für Fritzboxen an (s. Anhang).

    Im Master läuft es problemlos...
    Angehängte Dateien

    #2
    Das widget enthält mehrere veraltete Widgets (z.B. basic.value), die ab der develop-Version nicht mehr unterstützt werden und schon gelöscht sind. Die müssen umgestellt werden. Der Template Checker kennt die entsprechenden Replacement Strings und hilft bei der Umstellung.


    Gruß
    Wolfram

    Kommentar


      #3
      Morg Sprichst Du von dem Widget welches das avm Plugin mitbringt und installiert, wenn Du das visu_smartvisu Plugin nutzt?

      Daran habe ich einige alte widgets beseitigt. Schau Dir das im develop Bransch im avm Plugin mal an. Vielleicht löst das direkt Dein Problem.
      Viele Grüße
      Martin

      There is no cloud. It's only someone else's computer.

      Kommentar


        #4
        Danke euch beiden.

        Martin: ich weiß nicht mehr, woher das ist, aber ich kann mal ins AVM-Plugin reinschauen. "Mein" Widget ist oben angehängt.

        edit: ja, das war das Widget aus dem Plugin und ja, es hat geholfen. Vielen Dank
        Zuletzt geändert von Morg; 31.12.2020, 18:35.

        Kommentar

        Lädt...
        X