Ankündigung

Einklappen
Keine Ankündigung bisher.

E-Mail Versand: Verbindung vom Host abgelehnt. TLS gescheitert.

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    E-Mail Versand: Verbindung vom Host abgelehnt. TLS gescheitert.

    Hallo zusammen,

    ich habe bislang diverse Störmeldungen per E-Mail verschickt. Heute habe ich mich gewundert, dass diese nicht mehr versandt werden.
    Im Edomi Log steht folgender Fehler: Verbindung vom Host abgelehnt. TLS gescheitert.

    Mein Mail Provider hat wohl vor kurzem TLS in Version 1.0 abgeschaltet. Es wird nur noch ab V1.2 akzeptiert. Kann es etwas damit zu tun haben? Wie kann ich das Problem lösen?

    Danke für eure Tipps.

    #2
    Hallo, schade dass niemand geantwortet hat.

    Ich habe jetzt anscheinend das gleiche Problem.
    Gibt es eine Lösung um das Problem in Zukunft zu beseitigen?

    Habe einen Thread gelesen, in dem man eine cacert.pem immer mal wieder aktualisieren muss. Für mich leider keine so praktische Lösung, da ich bei Edomi sonst keine "Wartungsarbeiten" durchführen muss.

    Kommentar


      #3
      Moin,

      du kannst doch auch zeitlich z.b. monatlich einen Shellbefehl über Edomi absetzen der dann nichts anderes macht als die cacert.pem zu updaten....

      Grüße

      Kommentar


        #4
        Hey,
        ok, daran habe ich nicht gedacht. Das wäre möglich. Jedoch muss man auch noch die PHP.ini anpassen...würde eigentlich so wenig wie möglich am System ändern um bei einer Neueinrichtung nicht an sowas denken zu müssen.

        Jetzt bin ich mir aber auch immer noch nicht sicher, ob mich diese cacert.pem wirklich weiterbringt.
        Wenn die Abschaltung von TLS 1.0 wirklich der Grund ist. Ich habe in diesem Bereich leider null Hintergrundwissen.
        Vielleicht kann jemand Licht ins Dunkle bringen.

        Viele Grüße
        eMpTy

        Kommentar


          #5
          TLS 1.0 1999 Verwendung seit März 2021 unzulässig.[24]

          Kommentar


            #6
            Hallo zusammen,

            ich muss hier nochmal aufmachen, weil nun auch gmx mindestens TLS 1.2 erwartet. Insofern klappt der Mailversand auch hier nicht mehr. Ich habe den Ansatz von Jonofe in Emailversand über Office365 - KNX-User-Forum , #9 versucht. Bekomme aber folgende Fehler:

            Datei: /usr/local/edomi/main/include/php/incl_mail.php | Fehlercode: 8 | Zeile: 20 | Use of undefined constant STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT - assumed 'STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT' und dann in der Folgezeile

            stream_socket_enable_crypto() expects parameter 3 to be long, string given danach dann die Meldung aus dem Betreff.

            Was mache ich falsch (habe die Datei einfach entsprechend geändert) bzw. müssen noch weitere Dateien nachgeladen werden? Es wäre ja klasse, wenn Edomi ohne wiederkehrenden Aufwand "TLS 1.2-fähig" werden würde.

            Schon jetzt vielen Dank!

            Kommentar


              #7
              Hat GMX auch schon auf 2-Faktor-Authorisierung umgestellt? Dann könnten sich nämlich evtl. zwei Dinge überlagern. Schau mal hier.

              Kommentar


                #8
                Habe es gerade mal geprüft: GMX hat es als "kann-Variante". Muss dann aber extra freigeschaltet werden. Für das betreffende Konto ist 2-FA aber nicht hinterlegt.
                Die Probleme fingen auch tatsächlich erst mit dem offiziellen Aus von TLS 1.0 bei GMX an (01.06.22). Aber Danke für den Tipp.

                Kommentar


                  #9
                  Hallo,
                  ich betreibe seit Jahren einen HS 3 mit der Expertenversion 4.1.
                  Seit 1.6. werden keine Mails mehr über …@gmx.de versendet.

                  Meine Einstellungen:
                  STARTTLS
                  SMTP: mail.gmx.net
                  IP-Port: 587

                  Funktioniert GMX nicht mehr und welcher Anbieter funktioniert?
                  Dank

                  Gruß
                  Andi

                  Kommentar


                    #10
                    Zitat von BoHo Beitrag anzeigen
                    Die Probleme fingen auch tatsächlich erst mit dem offiziellen Aus von TLS 1.0 bei GMX an (01.06.22).
                    Ich denke, der HS3 kann kein TLS 1.2. Ich kann denke, es wird kaum noch Anbieter geben, die noch TLS1.0 unterstützen.

                    Kommentar


                      #11
                      völlig falsches Forum hier! Hier gibt es keinen HS!
                      Mfg Micha
                      Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                      Kommentar


                        #12
                        Hat niemand eine Lösung für TLS 1.2 direkt über Edomi (s. #6)?

                        Würde der E-Mail-LBS von Jonofe (19000587) als Workaround funktionieren?

                        Wäre für jede Hilfe dankbar!

                        Kommentar


                          #13
                          Stehe gerade vor dem selben Problem..
                          GMX unterstützt nur noch TLS 1.2 /1.3 und das kann anscheinend Edomi nicht.

                          Also dachte ich wechsel auf SSL weil ja GMX schreibt:

                          Alternativ können Sie für den Postausgangsserver auch Port 465 mit der Verschlüsselung "SSL" nutzen.
                          aber Pustekuchen
                          EMAIL-Fehler: Email konnte nicht gesendet werden (Reply-Code: 500 / Message-ID=59a6e142dce75b5df02143034417b4b1).
                          auch mit SSL kein Glück..

                          Kommentar


                            #14
                            Ich denke, der einzige gangbare Weg ist der der Update von Centos6.5 auf Centos7. Damit wird TLS1.2 unterstützt :
                            Code:
                            openssl s_client -connect mail.gmx.net:465 -tls1_2
                            CONNECTED(00000003)
                            SSL handshake has read 4510 bytes and written 415 bytes
                            ---
                            New, TLSv1/SSLv3, Cipher is ECDHE-RSA-AES256-GCM-SHA384
                            Server public key is 2048 bit
                            Secure Renegotiation IS supported
                            Compression: NONE
                            Expansion: NONE
                            No ALPN negotiated
                            SSL-Session:
                            Protocol : TLSv1.2
                            Cipher : ECDHE-RSA-AES256-GCM-SHA384
                            Session-ID: 2FE5E717EC2E09791B291821C9A93A62D10772CCFDA9AA3628 74836848C3C5CD
                            Session-ID-ctx:
                            Master-Key: AFE9751E1754AA0C8443CF080741E07F612335B4562A05A3F4 235382C77B47E8B411B69ACDDC02DDFABDDE1E2160A5D2
                            Key-Arg : None
                            Krb5 Principal: None
                            PSK identity: None
                            PSK identity hint: None
                            Start Time: 1655372008
                            Timeout : 7200 (sec)
                            Verify return code: 0 (ok)
                            ---
                            220 gmx.net (mrgmx105) Nemesis ESMTP Service ready

                            Kommentar


                              #15
                              Um mit dem Mailer-LBS (19000587) über GMAIL E-Mails zu verschicken muss man Google-App-Passwords nutzen.
                              Dazu einfach wie HIER beschrieben, ein App Passwort generieren und das an E6 des Mailer-LBS verwenden.
                              Damit funktioniert bei mir das Senden von E-Mail über GMAIL unter CentOS 7.6.1810 und PHP 7.2.34 problemlos.
                              Wichtig: Beim Ändern des Google Passworts, muss man ein neues App-Passwort generieren.

                              Kommentar

                              Lädt...
                              X