Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS19000(195|196|305) - HUE Bridge | Light | Plug

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    LBS19000(195|196|305) - HUE Bridge | Light | Plug

    Zwei neue Ostereier liegen im Nest
    1. HUE Bridge (LBS19000195) ===> DOWNLOAD <===
    2. HUE Light (LBS19000196) ===> DOWNLOAD <===
    Mit diesen Bausteinen ist es möglich Lampen aus dem Philips HUE System zu steuern und deren Status in EDOMI verfügbar zu machen.
    Der Bridge Baustein stellt dabei die Verbindung zur physikalischen HUE Bridge her, liest regelmäßig den Status aus und führt entsprechende Kommandos über die Bridge aus, welche von den HUE Light LBS kommen.

    Damit ist es möglich immer den aktuellen Zustand der HUE Leuchten in EDOMI zu haben, auch wenn diese extern geschaltet wurden, z.B. durch die offizielle Philips App oder über andere 3rd-Party Apps.

    Während der HUE Bridge LBS nur einmal benötigt wird, ist für jede HUE Leuchte ein HUE Light LBS einzufügen. Die Kommunikation zwischen den HUE Light LBS und dem HUE Bridge LBS erfolgt aus Performancegründen via Message Queue und nicht über KO's. Lediglich der Ausgang 1 'Bridge ID' des HUE Bridge LBS muss mit dem Eingang E1 von jedem HUE Light LBS via internem KO verbunden werden. Über dieses KO erfolgt der Austausch der Message Queue ID, damit alle Lichter mit der Bridge kommunizieren können und umgekehrt. Umsetzung: Internes KO erstellen (z.B. HUE-Bridge-ID), dieses über eine Ausgangsbox dem Ausgang A1 des HUE-Bridge-LBS zuordnen. Gleiches KO dann direkt oder via Eingangsbaustein dem E1 Eingang eines jeden HUE-LBS-Light Bausteins zuordnen.

    Auf der HUE Bridge muss noch ein neuer User für Edomi angelegt werden. Dazu bitte der Anleitung auf
    folgen. Dieser User wird dann auf E2 des HUE Bridge LBS eingetragen.

    Damit der HUE Bridge LBS funktioniert, sind noch ein paar Erweiterungen auf dem EDOMI Server notwendig, die auch im Hilfstext des LBS beschrieben sind.
    Dies sind:
    • git
    • php-process
    • wget
    • composer
    • Phue library
    Dazu einfach per ssh als root im EDOMI Server einloggen und folgende Befehle ausführen:

    Code:
    cd ~
    yum install -y git wget php-process php-xml
    wget --no-check-certificate https://getcomposer.org/installer
    php installer
    mv composer.phar /usr/local/bin/composer
    cd /usr/local/edomi/main/include/php
    git clone --branch=release/1.x https://github.com/sqmk/Phue
    cd Phue
    composer install
    Das sollte aber in 3 Minuten erledigt sein.

    Da ich nur begrenzte Zeit zum Testen hatte, es aber mit meinem 10 HUE Leuchten soweit ganz gut funktioniert, freue ich mich auf Euer Feedback.

    Viele Grüße und frohe Ostern

    André

    Changelog HUE - Bridge
    ===================

    v0.1: Initial version
    v0.1.1: Update of documentation. Correction of installation instructions.
    v0.1.2: Update of documentation on input E4

    v0.1.3: 'reachable' output now (0|1) instead of (no|yes)
    v0.1.4: stability improvement, additional debug info
    v0.2: Added support for OSRAM Lightify Plugs (LBS19000305)
    v0.3: bugfix release and introduction of custom log file


    Changelog HUE - Light
    ==================

    v0.1: Initial version
    v0.1.1: Correction of output on A7 (on). Sends now '0' instead of empty string, when status is off.
    Corrections of an error, which could lead to the situation, that the LBS forgot his $id.

    v0.1.2: Improved message queue handling
    v0.1.3: stability improvement, additional debug info
    v0.2: minor adjustments for OSRMA Lightify Plugs support (LBS19000305)
    v0.3: bug fix release and introduction of custom log file


    Changelog HUE - Plug
    ==================

    v0.1: Initial version of LBS 19000305 - Integration of OSRAM Lightify plugs into Philips HUE system
    Zuletzt geändert von jonofe; 28.07.2016, 08:50.

    #2
    Hallo,

    danke für das Osterei! und da ich mich ohnehin gestern ein wenig mit den Untiefen der vernetzten Birnen beschäftigt habe (Koppeln einer Osram Lightify A60 an die Hue Bridge), hab ich es gleich mal ausprobiert.
    Vorneweg- noch spiele ich auf einem Testsystem. Mich würde das Urteil der Profis hier angesichts der doch recht umfangreichen Modifikationen am Grundsystem interessieren. Kann man das machen, ohne die Stabilität des Gesamtsystems zu gefährden?

    Das Setup der Erweiterungen ist durchgelaufen, soweit ok.
    Die LBS ließen sich einlesen und stehen im Logikeditor zur Verfügung.

    ABER:
    Nach dem Aktivieren eines Projektes steht ein Fehler im Log.

    Code:
    2016-03-27 23:28:41    070736    ?    23960    Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000195.php | Fehlercode: 2 | Zeile: 17 | require(/usr/local/edomi/main/include/php/Phue/vendor/autoload.php): failed to open stream: No such file or directory    ERROR
    Das debug-Log sagt
    Code:
    2016-03-28 00:42:24 305480 EXEC 1484 HUE-Bridge-LBS : ### INFO ### - HUE Bridge LBS started [v0.1] Ok
    2016-03-28 00:42:24 308156 EXEC 1484 HUE-Light-LBS : ### INFO ### - HUE Light LBS stopped [v0.1] Ok


    Hab dann noch die LBS auf eine aktive Logikseite gezogen, mein System konfiguriert und einen Test-Button in die Visu gebaut- konnte jedoch meine Lampe nicht schalten.
    Da schlaf ich jetzt erstmal drüber. Zwei Sachen noch:

    1. Als unerfahrener Logik-Bastler irritiert mich folgender Satz:
    "Lediglich der Ausgang 1 'Bridge ID' des HUE Bridge LBS muss mit dem Eingang E1 von jedem HUE Light LBS via internem KO verbunden werden."
    Ich könnte den Ausgang 1 des Bridge-LBS schön direkt im Logikeditor mit dem Eingang 1 des Light-LBS verbinden (Linie).
    Wie mach ich das "via internem KO?" Ausgangsbox an Ausgang 1 des Bridge-LBS, KO "Bridge ID" auf Eingangswert E1 setzen, KO "Bridge ID" an E1 des Light-LBS?

    2. Wer das Hue-System bisher nur mit dem Smartphone bedient hat, ist vermutlich mit dem Usernamen überfragt? Eventuell ist ein Verweis auf
    http://www.developers.meethue.com/documentation/getting-started
    hilfreich (Step3, Mitte).

    Ich schau morgen nochmal drauf, vielleicht gibts hier auch in diesem Thread dann noch ein paar hilfreiche Tipps.

    Grüße,
    Gunnar







    Zuletzt geändert von junibart; 28.03.2016, 00:19.

    Kommentar


      #3
      Zitat von junibart Beitrag anzeigen
      Hallo,

      Mich würde das Urteil der Profis hier angesichts der doch recht umfangreichen Modifikationen am Grundsystem interessieren. Kann man das machen, ohne die Stabilität des Gesamtsystems zu gefährden?
      Die Tools wget, git und composer sind ja nur für die Installation notwendig und wirklich Standardtools, die den Betrieb sicher nicht beeinträchtigen.
      php-process und die Phue library sind die einzigen neuen Komponenten, die zur Laufzeit von EDOMI eine Rolle spielen.
      php-process ist dabei quasi Bestandteil der Linux Distribution und somit stabil. Phue ist die derzeit am besten gepflegte PHP library für HUE.

      Objektiv ist sicher die größte Stabilitätsgefahr im LBS an sich zu sehen und nicht in den Zusatzkomponenten.

      Zitat von junibart Beitrag anzeigen
      Das Setup der Erweiterungen ist durchgelaufen, soweit ok.
      Die LBS ließen sich einlesen und stehen im Logikeditor zur Verfügung.

      ABER:
      Nach dem Aktivieren eines Projektes steht ein Fehler im Log.

      Code:
      2016-03-27 23:28:41 070736 ? 23960 Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000195.php | Fehlercode: 2 | Zeile: 17 | require(/usr/local/edomi/main/include/php/Phue/vendor/autoload.php): failed to open stream: No such file or directory ERROR
      Das debug-Log sagt
      Code:
      2016-03-28 00:42:24 305480 EXEC 1484 HUE-Bridge-LBS : ### INFO ### - HUE Bridge LBS started [v0.1] Ok
      2016-03-28 00:42:24 308156 EXEC 1484 HUE-Light-LBS : ### INFO ### - HUE Light LBS stopped [v0.1] Ok
      Debug Log ist okay. Hast du denn die Installation von Phue tatsächlich im Verzeichnis /usr/local/edomi/main/include/php gemacht? Entweder du hast es woanders gemacht oder ggf. das "composer install" im Verzeichnis /usr/local/edomi/main/include/php/Phue vergessen. Das sollte eigentlich einige Abhängigkeiten downloaden und auch das autoload.php erstellen. Habe es gerade noch mal bei mir getestet.

      Was zeigt denn das folgende "ls" bei dir?

      2016-03-28 02_01_10-edomi-vm.feld.home (root).png

      Zitat von junibart Beitrag anzeigen
      Zwei Sachen noch:

      1. Als unerfahrener Logik-Bastler irritiert mich folgender Satz:
      "Lediglich der Ausgang 1 'Bridge ID' des HUE Bridge LBS muss mit dem Eingang E1 von jedem HUE Light LBS via internem KO verbunden werden."
      Ich könnte den Ausgang 1 des Bridge-LBS schön direkt im Logikeditor mit dem Eingang 1 des Light-LBS verbinden (Linie).
      Wie mach ich das "via internem KO?" Ausgangsbox an Ausgang 1 des Bridge-LBS, KO "Bridge ID" auf Eingangswert E1 setzen, KO "Bridge ID" an E1 des Light-LBS?
      Okay, da hast du Recht. Aber du hast die Lösung schon exakt beschrieben. KO auf Ausgangsbox und dann KO jedem E1 aller Lights direkt oder per Eingangsbaustein zuweisen. Damit empfängt dann jeder Light-LBS die ID.

      Zitat von junibart Beitrag anzeigen
      2. Wer das Hue-System bisher nur mit dem Smartphone bedient hat, ist vermutlich mit dem Usernamen überfragt? Eventuell ist ein Verweis auf
      http://www.developers.meethue.com/documentation/getting-started
      hilfreich (Step3, Mitte).
      Guter Punkt. Das hatte ich auch geplant, hab es dann bei der Dokumentation meines Bausteins wieder vergessen. Werde ich ergänzen. Es gibt im bin Verzeichnis von Phue übrigens auch noch ein shell Skript, mit dem man einen User anlegen kann. Aber die Variante über den von dir geposteten Link ist am besten.

      Hoffe das hat geholfen. Insbesondere die Ursache für das nicht gefundene autoload.php würde mich interessieren. Evtl. habe ich ja doch noch einen Schritt vergessen.

      VG
      André
      Zuletzt geändert von jonofe; 28.03.2016, 01:03.

      Kommentar


        #4

        Zitat von jonofe Beitrag anzeigen
        Was zeigt denn das folgende "ls" bei dir?
        Das ls zeigt nichts, denn nicht einmal das Verzeichnis vendor, in dem Du es ausführst, existiert bei mir. Ich muss auch meine Aussage zurücknehmen, dass die Installation der Erweiterungen "durchläuft"- ich hatte eine Fehlermeldung übersehen, die sicher die Ursache für die Probleme auf meinem Rechner sind:
        "Your requirements could not be resolved to an installable set of packages."
        Mehr ist auf dem Screenshot zu sehen. Ich hoffe, es hilft bei der Fehlersuche- ich selbst blicke bei der PHP-Programmierung nicht durch und kann nur "Kochrezepte" nachvollziehen...

        Danke und Grüße,

        Gunnar

        php_fehler.jpg
        Zuletzt geändert von junibart; 28.03.2016, 09:38.

        Kommentar


          #5
          Danke für das Feedback. Habe es gerade noch mal auf einer neuen EDOMI VM nachgestellt. Konnte exakt die Fehlermeldung reproduzieren.
          Es fehlt noch ein php Modul in der Anleitung. Bitte folgenden Befehl ausführen

          Code:
          yum install php-xml
          und danach das

          Code:
          composer install
          Danach lief es bei mir durch.

          Ich habe jetzt den HUE-Bridge-LBS (v0.1.1) und das erste Posting dieses Threads entsprechend angepasst. Danke für das Feedback.

          VG
          André
          Zuletzt geändert von jonofe; 28.03.2016, 09:56.

          Kommentar


            #6
            Hi,

            noch eine Frage. Auf A1 beim Hue Light kommt die ID von E1 Hue Bridge?

            Habe da noch einen Fehler wo drinnen.
            2016-03-28 10:43:22 903844 EXEC 95215 HUE-Bridge-LBS : ### INFO ### - HUE Bridge LBS started [v0.1] Ok
            2016-03-28 10:43:22 925410 EXEC 95215 HUE-Light-LBS : ### INFO ### - HUE Light LBS stopped [v0.1] Ok
            2016-03-28 10:43:22 926423 EXEC 95215 HUE-Light-LBS : ### INFO ### - HUE Light LBS started (Light: 1) [v0.1] Ok
            2016-03-28 10:43:22 943583 EXEC 95215 HUE-Light-LBS : ### INFO ### - HUE Light LBS stopped (Light: 1) [v0.1] Ok
            2016-03-28 10:43:23 089191 EXEC 95254 HUE-Light-EXEC : ### INFO ### - HUE Light EXEC started (Light: 1) [v0.1] Ok
            2016-03-28 10:43:23 092361 EXEC 95251 HUE-Light-EXEC : ### INFO ### - HUE Bridge EXEC started [v0.1] Ok
            2016-03-28 10:43:23 096272 EXEC 95251 HUE-Light-EXEC : ID->1530034497088873 [v0.1]

            2016-03-28 10:31:17 803901 ? 92861 Exception: Connection failure

            Kommentar


              #7
              Hi André,

              mit dem zusätzlichen Modul hat es jetzt funktioniert!

              Die Grundfunktion der Leuchte (Ein/Aus) funktioniert. Heute abend teste ich mal Farbwahl etc.

              Danke nochmal für das Osterei!

              Grüße,

              Gunnar

              Kommentar


                #8
                Zitat von timberland Beitrag anzeigen
                Hi,
                noch eine Frage. Auf A1 beim Hue Light kommt die ID von E1 Hue Bridge?
                Das scheint nicht richtig zu sein. So sieht meine funktionierende Minimalkonfiguration aus:

                minimal.jpg
                Angehängte Dateien

                Kommentar


                  #9
                  Ja, passt jetzt wenn ich die ID per Ko auf den Eingang gebe. Habe die vorher fix eingetragen.

                  Kommentar


                    #10
                    Die ID wird beim Start von EDOMI zufällig aber unique generiert. Daher funktioniert es nur, wenn man die Verbindung per KO macht.

                    Kommentar


                      #11
                      Zitat von junibart Beitrag anzeigen
                      Die Grundfunktion der Leuchte (Ein/Aus) funktioniert. Heute abend teste ich mal Farbwahl etc.
                      Man kann es übrigens auch ganz einfach ohne VISU testen, indem man z.B. ein KO für RGB erstellt. Diese mit dem Eingang E15 des HUE-Light-LBS verbindet. Danach EDOMI Admin Konsole einfach einen Wert, z.B. ff00ff (pink) auf dieses KO senden.

                      2016-03-28 11_54_44-EDOMI · Administration.png

                      Dann sollte sich die Farbe der Leuchte schon ändern und man kann auf der Logikseite über "Livewerte aktualisieren" auch den aktuellen Status am HUE Light LBS sehen. Letzteres natürlich nur, wenn auch Ausgangsboxen dranhängen (die können dafür natürlich auch ohne KO-Zuweisung sein).
                      Die anderen Funktionen lassen sich natürlich gleichermaßen testen, sofern am Eingang des Light LBS entsprechende KO's zugewiesen sind.

                      VG
                      André

                      Kommentar


                        #12
                        Hi,

                        ich würde gerne den Ausgang A7 am Light LBS als Status verwenden. Nur bei 0 am Eingang E4 bleibt der Ausgang A7 leer, und somit kann ich den als Status für das Visuelement Schalten mit Status nicht verwenden?

                        Oder wie macht ihr das mit den Status?

                        Kommentar


                          #13
                          Zitat von timberland Beitrag anzeigen
                          Hi,

                          ich würde gerne den Ausgang A7 am Light LBS als Status verwenden. Nur bei 0 am Eingang E4 bleibt der Ausgang A7 leer, und somit kann ich den als Status für das Visuelement Schalten mit Status nicht verwenden?

                          Oder wie macht ihr das mit den Status?

                          Eigentlich musst du nur die BridgeID (E1) und die Light No. (E2) belegen. Danach sollten die Ausgänge funktionieren.
                          Wie hast du denn UpdateMode und UpdateIntervall am Bridge LBS konfiguriert?
                          Screenshot deiner Logik (inkl. Livewerte aktualisieren) wäre evtl. hilfreich. Und ggf. das Traceloglog, ab dem Neustart von Edomi. Dort sollte eigentlich der initiatle Status aller Leuchten auftauchen.

                          Habe gerade gesehen, dass ich den UpdateMode in der Hilfe nicht ausreichend erklärt habe. es gibt folgende Optionen:

                          all - Update der Ausgänge A3 - A23
                          hsv - Update der Ausgänge A7-A12, A20-A23
                          rgb - Update der Ausgänge A7-A8, A16-A19, A20-A23
                          hsv - Update der Ausgänge A7-A8, A13-A15, A20-A23

                          Bei einem anderen Wert werden nur die Ausgänge A7-A8 und A20-A23 gesetzt.

                          Werde die Hilfe entsprechend anpassen und im nächsten Update veröffentlichen.
                          Zuletzt geändert von jonofe; 30.03.2016, 11:01.

                          Kommentar


                            #14
                            Der Baustein selber funktioniert perfekt. Schaltet auch ein und aus.
                            Nur auf A7 habe ich bei ein eine 1 und bei aus ist der Ausgang leer. Für den Status würde ich aber eine 0 benötigen, damit das Visuelemt den Status richtig anzeigt.

                            Kommentar


                              #15
                              ah okay, verstanden. Ich schau mir das mal an. Evtl. wird da noch ein false zurückgegeben statt einer null.

                              Kommentar

                              Lädt...
                              X