Ankündigung

Einklappen
Keine Ankündigung bisher.

Weinzierl KNX BAOS Module 838 kBerry

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Noch ne kleine Info:

    Hier bekomm ich nur den Fehler:

    Code:
    knxd /etc/knxd.conf
    E00000084: [ 1:main] There is no KNX addr= in section 'main'.
    F00000109: [ 1:main] Error setting up the KNX router.
    Hier rennt der knxd sofort los und funktioniert auch ...

    Code:
    knxd /etc/knxd.ini
    Layer 4 [ 1:main        0.000] initialized
    I00000131: [ 1:main] 0.14.28:672ca39: knxd /etc/knxd.ini
    Layer 4 [ 1:main        0.000] setting up
    Layer 0 [ 4:log/main    0.000] State setup
    Layer 3 [ 5:server/Server     0.000] registerLink: 5:server
    ich verstehs nur nicht, warum das über die .conf nicht geht

    Kommentar


      Zitat von mentor2k Beitrag anzeigen
      ich verstehs nur nicht, warum das über die .conf nicht geht
      wenn knxd nur ein Argument bekommt, muss es ein INI-File sein. Sonst müssen es all die Parameter sein, welche intern über knxd_args automatisch in ein INI-File umgewandelt werden.

      EIB/KNX, VISU mit knxd + linknx + knxweb, Steuerbefehle via SMS und Email mit postfix + procmail

      Kommentar


        Hallo Weinzerl User,

        auch ich muss mich wegen Problemen bei der Inbetriebnahme des BAOS 838 Moduls melden. Ich will für einen Bekannten den Raspi vorbereiten, da ich mich waghalsig aus dem Fenster gelehnt habe und meinte, dass ich das schnell ausgesetzt bekomme. Nun hänge ich schon 2 Tage daran und weiß leider nicht weiter.

        Ich kann zwar in der Kommandozeile knxd starten, aber leider scheitern bei mir die systemd Aufrufe. Ich habe folgendes gemacht:
        - Raspi3B+ mit Wienzerl BAOS 838 Modul
        - openhabian image installiert und eingerichtet
        - bt und weitere Notwendigkeiten eingerichtet bzw. deaktiviert
        - über openhabian-config die knxd Erweiterung installiert (dauerte lange, da er alles kompiliert hat. Es ist jetzt die Version: knxd 0.14.28:81e6e7b-emipatch )
        - Konfigurationsdatei nun in /etc/default/knxd
        - "knxd -t 0xffff -f 9 -e 1.1.240 -E 1.1.241:4 -i 6720 -D -T -R -S -b ft12cemi:/dev/serial0" in Kommandozeile funktioniert, nur dass ich dann in ETS5 alle Nachrichten 4x sehe
        --> gibt es da ggf. einen Konflikt mit meinem 2. Raspi mit knxd aber mit USB KNX Stick? In der Router Spalte werden für die 4 identischen Nachrichten die Zahlen 0, 2, 4 und 6 gelistet... soll aber hier jetzt nicht gelöst werden
        - die knxd.service Datei erwartet eine konfigurationsdatei bei /etc/default/knxd. Als Parameter habe ich schon alles mögliche probiert:
        Code:
           - KNXD_OPTIONS="-f9 -t1023 -e 1.1.240 -E 1.1.241:4 -DTRS -b ft12cemi:/dev/ttyAMA0"
           - KNXD_OPTIONS="-e 1.1.240 -E 1.1.241:4 -u/tmp/eib -B single -t 1023 -b ft12cemi:/dev/ttyAMA0 -D -TS -c"
           - KNXD_OPTIONS="-f 9 -t 1023 -e 1.1.240 -E 1.1.241:4 -u/tmp/eib -B log -A delay=30 -B pace -b ft12cemi:/dev/ttyAMA0 -D -B log -TRS -i 6720"
           - und noch einiges weiteres
        Das Ergebnis ist überall gleich. Der Aufruf "sudo systemctl restart knxd.service" führt dazu, dass nicht umgehend zurückgesprungen wird, sondern eine ganze Weile vergeht, in der auch fleißig KNX Traffic in /var/log/syslog geloggt wid, aber nach einer Weile ein Abbruch stattfindet mit der folgenden Fehlermeldung:
        Code:
        Jan  9 19:16:33 RaspiHBS knxd[4086]: Layer 0 [12:B.ft12cemi/ft12wrap   88.860] Sequence jump
        Jan  9 19:16:35 RaspiHBS systemd[1]: knxd.service: Start operation timed out. Terminating.
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 4 [ 9:B.ft12cemi/Conn       90.116] Stopping
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 5 [ 9:B.ft12cemi/Conn       90.116] up => >down
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 5 [ 9:B.ft12cemi/Conn       90.116] Stopping
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 0 [17:B.ft12cemi/log        90.116] Stop
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 2 [16:B.ft12cemi/ft12cemi   90.116] CloseL2
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 0 [17:B.ft12cemi/log        90.116] Stopped
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 5 [ 9:B.ft12cemi/Conn       90.116] >down => down
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 4 [ 9:B.ft12cemi/Conn       90.116] down
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 4 [ 9:B.ft12cemi/Conn       90.116] down
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 4 [ 9:B.ft12cemi/Conn       90.117] is down
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 0 [17:B.ft12cemi/log        90.117] Closing
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 0 [13:B.ft12cemi/log        90.117] Closing
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 0 [15:B.ft12cemi/log        90.117] Closing
        Jan  9 19:16:35 RaspiHBS knxd[4086]: Layer 2 [14:B.ft12cemi/FT12_ser   90.117] Close
        Jan  9 19:16:35 RaspiHBS systemd[1]: Failed to start KNX Daemon.
        Jan  9 19:16:35 RaspiHBS systemd[1]: knxd.service: Unit entered failed state.
        Jan  9 19:16:35 RaspiHBS systemd[1]: knxd.service: Failed with result 'timeout'.
        Über hilfreiche Tips würde ich mich unglaublich freuen.
        Zuletzt geändert von Shotte; 09.01.2019, 19:23.

        Kommentar


          ...jetz habe ich es mit viel probieren und weiteren Installationen, Updates und Konfigurations-Parameter hin bekommen:

          - die openhabian-config installation rückgängig gemacht und alles rausgeschmissen
          - den master von git ausgechekct und nach Anweisung compiliert und installiert
          - in der /etc/default/knxd Datei alles auskommentiert
          - in der /etc/knxd.conf Datei die folgenden Parameter benutzt (Router Option habe ich vorübergehend rausgenommen, da ich schon einen Router im System habe):
          Code:
          KNXD_OPTS="-e 1.1.240 -E 1.1.241:4 -u/tmp/eib -B log -A address=15.15.255 -B single -b ft12cemi:/dev/ttyAMA0 -D -B log -TS -c"
          Auf einmal ging es, obwohl ich auch zuvor diese Parameter schon mal ausprobiert hatte. Komisch, aber wenn es jetzt geht, dann will ich mal nicht meckern.

          Vielen Dank für Eure gute Arbeit,
          Shotte

          Kommentar

          Lädt...
          X