Ankündigung

Einklappen
Keine Ankündigung bisher.

Harmony-Hub-Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Nachbilden ist nicht das Problem, die Aktion ist dann auf der Fernbedienung nur nicht aktiv.

    Die Fernbedienung ist aber auf die richtige Aktion angewiesen, da die sonst nicht die passende Belegung der Tasten liefert.

    Also wenn ich z.B. mit dem Plugin eine Aktion nachgebildet hab, und die Ausführe, angenommen BluRay schaun,

    ABER die letzte Aktion an der Fernbedienung ist z.B. FireTV, stellt die Fernbedienung keine Tasten für die PS3 zur Verfügung, sondern natürlich fürs FireTV.


    Gruß Wolfi

    Kommentar


      #17
      Zitat von OsLee540i Beitrag anzeigen
      Nachbilden ist nicht das Problem, die Aktion ist dann auf der Fernbedienung nur nicht aktiv.

      Die Fernbedienung ist aber auf die richtige Aktion angewiesen, da die sonst nicht die passende Belegung der Tasten liefert.

      Also wenn ich z.B. mit dem Plugin eine Aktion nachgebildet hab, und die Ausführe, angenommen BluRay schaun,

      ABER die letzte Aktion an der Fernbedienung ist z.B. FireTV, stellt die Fernbedienung keine Tasten für die PS3 zur Verfügung, sondern natürlich fürs FireTV.


      Gruß Wolfi
      Ok, verstanden. Bin schon am Einbauen.

      Gruss,

      Stefan
      Sonos

      Kommentar


        #18
        Abend zusammen,

        das Plugin ist im develo-Zweig von SmarthomeNG geupdatet. Die "Activities" sind jetzt drin. Ich habe einiges geändert, deshalb verweise ich dringend auf das Readme.

        --> README <--

        Hinweisen möchte ich aber expliziet auf die veränderte Zeitverzögerung zwischen den Aktionen. Der Wert "delay" beschreibt nun die Verzögerung des Kommandos/Activity, in dem der Delay definiert wurde, nicht mehr das folgende Kommando.

        Code:
        activity:123456:10 | 888888:PowerOn:1 ....
        In dem Beispiel wird die Activity 123456 10sec verzögert gestartet, das Kommando "PowerOn" mit 1 Sekunde Verzögerung. "Activities" und "Kommandos" können gemischt werden.

        Die Anleitung sollte ausführlich genug sein, bei Fragen gerne hier posten.


        Gruss,

        Stefan
        Sonos

        Kommentar


          #19
          Hallo,

          Stefan vielen Dank!!

          Morgen hab ich wieder Zeit zum testen.

          Gruß Wolfi

          Kommentar


            #20
            Servus,

            also ich hab jetzt mal ein wenig rumgespielt und muss sagen, bisher funktioniert alles tadellos.

            Die Aktionen frag ich über die ID in einer Logik ab.
            Somit kann man auch schön noch schön ein Paar Lichter an und ausmachen.

            Die einzelnen Kommandos funktionieren bis jetzt auch perfekt.

            Hab ein bisserl was gebastelt das beim ausführen einer Aktion ein Soundfile auf dem Yamaha abgespielt wird, bis die Rollos runtergefahren sind und das Licht auf die passende Farbe gefadet wird.

            Den Fernseher kann man jetz auch endlich per KNX Taster an und aus schalten.

            Also für mich bisher eine echte Bereicherung.

            Vielen Dank für das tolle Plugin!

            Gruß Wolfi

            Kommentar


              #21
              Danke Stefan für das Plugin. Ich werde mir nun definitiv auch einen Harmony Hub beschaffen.
              Habe schon lange damit geliebäugelt und dachte schon, ich müsse selbst ein Plugin schreiben.

              Dazu noch eine Hardwarefrage: Bauche ich den "Harmony Hub" oder reicht der "Harmony Ultimate Hub", welcher etwa halb so viel kostet?
              Auf der Logitechseite finde ich nur einen davon.

              Gruss
              Stefan

              Kommentar


                #22
                Hi,

                ich habe auch nur den normalen. Und der geht

                Gruss,

                Stefan
                Sonos

                Kommentar


                  #23
                  Normal heisst dann der mit Ultimate im Namen und der Artikelnummer 915-000218? (sehr verwirrend diese Namensgebung)
                  Wenn ich es richtig gesehen habe, hat dieser im Gegensatz zum anderen mit der Nr. 915-000262 u.A. kein Bluetooth.

                  Es geht mir ja nicht Mal primär um die paar Taler Unterschied. Ich will v.A. vermeiden, dass der dann mit deinem schönen Plugin nicht funktioniert.
                  Zuletzt geändert von smai; 10.02.2017, 22:14.

                  Kommentar


                    #24
                    915-000218 sollte meiner sein, ich habe mit Bluetooth. Es werden aber zu 99,8% beide funktionieren, solange der xmpp-Port offen ist.
                    Sonos

                    Kommentar


                      #25
                      So Halli Hallo,

                      nun nach ein paar Tagen im Einsatz, ist mir aufgefallen, das ich am Morgen meinen Fernseher nicht über die Visu einschalten kann.

                      Ich wollte mit dem Iphone im Log schauen, die App ist aber immer wieder abgestürzt, jetzt weis ich auch wieso:

                      die Log Dateien sind über 200MB groß geworden.

                      Ich bekomme ab 1 Uhr nachts, wenn sich mein WLAN ausschaltet, alle 3s folgendes:

                      2017-02-16 02:36:48 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR harmony_init Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      2017-02-16 02:36:51 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                      2017-02-16 02:36:51 INFO read_thread Try to re-connect after 60
                      2017-02-16 02:36:51 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                      Ab 5:30 Uhr wenn das WLAN wieder an ist kommt pro Sekunde:

                      2017-02-16 05:30:20 ERROR harmony_init Error reading from XML stream.
                      2017-02-16 05:30:20 ERROR harmony_init Error reading from XML stream.
                      2017-02-16 05:30:20 ERROR harmony_init Error reading from XML stream.
                      2017-02-16 05:30:20 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:20 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 104] Connection reset by peer
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 104] Connection reset by peer
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:20 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 104] Connection reset by peer
                      2017-02-16 05:30:20 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:20 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:21 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:21 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:21 ERROR read_thread Session stopped: {}
                      2017-02-16 05:30:21 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:21 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:21 INFO read_thread Try to re-connect after 60
                      2017-02-16 05:30:21 ERROR read_thread Could not connect to Harmony Hub: [Errno 107] Transport endpoint is not connected
                      2017-02-16 05:30:21 INFO read_thread Try to re-connect after 60
                      Das Plugin verbindet sich auch nicht mehr, nur Neustart hilft.

                      Gruß Wolfi

                      Kommentar


                        #26
                        Ok, schaue ich mir an.

                        Gruss,

                        Stefan
                        Sonos

                        Kommentar


                          #27
                          Zitat von OsLee540i Beitrag anzeigen

                          Das Plugin verbindet sich auch nicht mehr, nur Neustart hilft.
                          Neue Version ist im Dev-Zweig, Problem sollte behoben sein.

                          Gruss,

                          Stefan

                          Sonos

                          Kommentar


                            #28
                            Servus,

                            hab mir gestern die neue Version gezogen und teste.
                            Muss heute nur meine WLAN Zeitschaltung wieder aktivieren.
                            Vielen Dank schon mal.

                            Gruß Wolfi

                            Kommentar


                              #29
                              Servus Stefan,

                              bisher sieht alles gut aus.

                              Wenns WLAN in der Früh wieder eingeschaltet wird, verbindet sich das Plugin wieder, und läuft.

                              Das Einzige, was ich nicht verstehe ist, dass die Errors, alle 3 - 5 Sekunden kommen, obwohl die reconnect-Zeit ja im Plugin auf 60 steht.

                              Sind halt dann doch immer ca 12000 Zeilen im Log von 1:00 - 5:30 Uhr.

                              2017-03-01 01:25:08 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                              2017-03-01 01:25:08 INFO read_thread Try to re-connect after 60
                              2017-03-01 01:25:08 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                              2017-03-01 01:25:11 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                              2017-03-01 01:25:11 INFO read_thread Try to re-connect after 60
                              2017-03-01 01:25:11 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                              2017-03-01 01:25:16 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                              2017-03-01 01:25:16 INFO read_thread Try to re-connect after 60
                              2017-03-01 01:25:16 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                              2017-03-01 01:25:19 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                              2017-03-01 01:25:19 INFO read_thread Try to re-connect after 60
                              2017-03-01 01:25:19 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                              2017-03-01 01:25:22 ERROR read_thread Could not connect to Harmony Hub: [Errno 113] No route to host
                              2017-03-01 01:25:22 INFO read_thread Try to re-connect after 60
                              2017-03-01 01:25:22 ERROR read_thread Could not connect to 192.168.0.100:5222. Socket Error #113: No route to host
                              Aber das ist Jammern auf hohem Niveau, das Plugin an sich läuft spitze.

                              Dank nochmal dafür!

                              Gruß Wolfi

                              Kommentar


                                #30
                                Hi Wolfi,
                                evtl. hilft es Dir das Plugin zu stoppen wenn das WLAN off ist.
                                Bin leider noch nicht dazugekommen das Plugin zu testen, aber beim AVM-Plugin bspw. klappt das wunderbar wenn ich die WLAN-Repeater nachts abschalte.

                                Beim AVM-Plugin mache ich das via "sh.xxxx.stop()" bzw. "sh.xxxx.run()" bspw.

                                VG,
                                Oliver


                                Kommentar

                                Lädt...
                                X