Ankündigung

Einklappen
Keine Ankündigung bisher.

Supportthread für UZSU Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Zitat von Onkelandy Beitrag anzeigen
    Du musst unbedingt das widget der aktuellen smartvisu 2.9 nutzen. Device.uzsu

    hab nun korrekte fehlermeldung eingebaut.
    Habe ich eventuell die falsche SmartVisu oder das Falsche Widget?

    Wenn ich in die changelog.md schaue, siehe ich nur Version 2.8 - woher nehmt Ihr die 2.9?
    Unter smartVISU/widgets sehe ich kein Device.uzsu, daher habe ich es von hier kopiert: https://github.com/mworion/uzsu_widget
    Das ist vielleicht genau das Problem.

    Sorry, wenn ich Euch mit Anfängerfragen nerve, KNX, Linux, ETS, Homeserver - alles kein Problem - aber mit SHGN steige ich gerade erst tiefer ein.

    Liebe Grüße
    greppie

    Kommentar


      #17
      smartVISU hat eine Doku, da musst du nicht in die Ordner gucken: index.php?page=device/widget_device.uzsuicon&pages=docu
      Du musst dir den develop Zeig ziehen - es gibt noch keine finale 2.9 - aber develop funktioniert prima: https://github.com/Martin-Gleiss/smartvisu/tree/develop

      Kommentar


        #18
        Hi Onkel Andy,


        Zitat von Onkelandy Beitrag anzeigen
        smartVISU hat eine Doku, da musst du nicht in die Ordner gucken: index.php?page=device/widget_device.uzsuicon&pages=docu
        Du musst dir den develop Zeig ziehen - es gibt noch keine finale 2.9 - aber develop funktioniert prima: https://github.com/Martin-Gleiss/smartvisu/tree/develop
        Ich hatte mir in der Zwischenzeit auch mal Dein Plugin aus Deinem Repository gezogen, aber hat trotzdem nicht funktioniert.

        Der entscheidende Hinweis war, dass Du auch die Developer Version von Martin Gleiss nimmst. Also habe ich bei mir nochmal geschaut. Ich dachte, ich wäre auf dem Developer Branch, war aber noch in Master. Nachdem ich geswitched habe und das Plugin mit
        Code:
        {{ device.uzsuicon('uzsu_example1', 'EG.Wohnzimmer.Deckenspots.Schalten.Schaltuhr', 'Schaltuhr', '', '', 'num') }}
        eingebunden habe, funktioniert es.

        1.000 Dank. Eigentlich sollte man die Doku vom UZUSU Plugin auch um diese Dinge erweitern, oder es in der SmartVISU Doc beschreiben.

        Egal - bei mir funktioniert es jetzt. 1.000 Dank!

        Liebe Grüße
        Greppie

        Kommentar


          #19
          Super! Ja, das mit dem sv dev branch ist nicht optimal

          Kommentar


            #20
            Warum sind eigentlich alle mit Releases so zurückhaltend? Dauert teilweise Jahre zwischen zwei Versionen? Gibt es nicht genug, die mitentwickeln?
            Auch Deine Änderungen am Plugin sind ja nicht im "offiziellen" Branch, oder?

            Kommentar


              #21
              Doch, die uzsu Änderungen sind im Master drin. Bei der SmartVISU arbeiten tatsächlich praktisch keine Leute mit, davon wird dir smai vermutlich ein Lied singen. Allerdings wart ich dort auch schon über ein Jahr auf den Merge meiner PR..

              Kommentar


                #22
                Hallo,
                bei dem uzsuicon in der SmartVISU werden die gewählten Wochentage normalerweise farblich hervorgehoben. Das klappt bei mir mit allen verfügbaren Designs (ice, night,...) bis auf das Design Darkblue, welches ich gerne verwenden würde.
                Ist das ein bekannter Bug?

                Kommentar


                  #23
                  Hm, es gab da wohl ein Problem mit den Checkboxes, Wochentage wüsste ich jetzt nicht. Hier gabs mal ein Update: https://github.com/Martin-Gleiss/smartvisu/pull/230
                  Falls es noch ein Problem geben soll, am besten hier ein Issue erstellen: https://github.com/Martin-Gleiss/smartvisu/issues
                  Oder noch besser einen Fix als PR erstellen

                  Kommentar


                    #24
                    Zitat von Onkelandy Beitrag anzeigen
                    Hm, es gab da wohl ein Problem mit den Checkboxes, Wochentage wüsste ich jetzt nicht.
                    Ja, der Bug war auch bei den Wochentagen. Diese sind eigentlich nur gruppierte Checkboxen bzw. toggle buttons.
                    Der Darstellungsfehler war grundsätzlich bei allen diesen Buttons, nicht nur in der UZSU. Dort war er nur besonders auffällig.

                    Kommentar


                      #25
                      Hallo, habe das fertige Image von Onkelandy (SmarthomeNG1.6.1 mit SmartVisu2.9) auf Raspberry Pi3 B+ installiert und ist grundsätzlich voll funktionsfähig.
                      UZSU habe ich wie in diesem Thread beschrieben installiert - bekomme aber folgende Fehlermeldung nach dem test:
                      Code:
                      [smarthome@SmartHomeNG /]$ sudo apt-get install libatlas-base-dev
                      Paketlisten werden gelesen... Fertig
                      Abhängigkeitsbaum wird aufgebaut.
                      Statusinformationen werden eingelesen.... Fertig
                      libatlas-base-dev ist schon die neueste Version (3.10.3-8+rpi1).
                      Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
                        libdrm-etnaviv1 libllvm6.0
                      Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
                      0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
                       [smarthome@SmartHomeNG /]$ sudo pip3 install scipy-1.3.1-cp37-cp37m-linux_armv7l.whl
                      WARNING: Requirement 'scipy-1.3.1-cp37-cp37m-linux_armv7l.whl' looks like a filename, but the file does not exist
                      Requirement already satisfied: scipy==1.3.1 from file:///scipy-1.3.1-cp37-cp37m-linux_armv7l.whl in /usr/local/lib/python3.7/dist-packages (1.3.1)
                      Requirement already satisfied: numpy>=1.13.3 in /usr/local/lib/python3.7/dist-packages (from scipy==1.3.1) (1.17.2)
                      WARNING: You are using pip version 19.3; however, version 19.3.1 is available.
                      You should consider upgrading via the 'pip install --upgrade pip' command.
                       [smarthome@SmartHomeNG /]$ python3
                      Python 3.7.3 (default, Apr  3 2019, 05:39:12)
                      [GCC 8.2.0] on linux
                      Type "help", "copyright", "credits" or "license" for more information.
                      >>> from scipy install interpolate
                        File "<stdin>", line 1
                          from scipy install interpolate
                                           ^
                      SyntaxError: invalid syntax
                      >>>
                      Backend GUI ist nach uzsu Aktivierung im Plugin.yaml nicht erreichbar.
                      Was mache ich falsch? Tips gerne Willkommen.

                      Kommentar


                        #26
                        Beim Image musst du gar nichts machen, da ist schon alles drauf!
                        Wenn du den 1. Beitrag hier nochmals genau durchliest, erkennst du zwei Dinge, die du nicht korrekt durchgeführt hast:
                        - Das WHL müsste zuesrt heruntergeladen werden.
                        - In Python heißt es import nicht install

                        Kommentar


                          #27
                          Hallo Onkelandy,
                          Vielen Dank für deine Antwort. Erst mal großes Lob für deine Arbeit und dein Image!!! Läuft bei mir seit einem Jahr (zuerst 1.5., nun 1.6.) stabil und problemlos und war eine riesen Hilfe für mich! Danke auf diesem Wege!!!!!

                          Bzgl. dem Problem mit dem Scipy habe ich natürlich einen falschen Befehl in meinem vorigen Post genannt - es heißt natürlich "from scipy import interpolate"...
                          Zur Erklärung:
                          ich kämpfte schon länger mit diesem Problem und hatte den vorgang der Installation nochmals durchgespielt um es hier danach zu posten...

                          Wie auch immer, anbei nun der aktuelle Stand:

                          Code:
                           [smarthome@SmartHomeNG ~]$ python3
                          Python 3.7.3 (default, Apr  3 2019, 05:39:12)
                          [GCC 8.2.0] on linux
                          Type "help", "copyright", "credits" or "license" for more information.
                          >>> from scipy import interpolate
                          >>>
                           [smarthome@SmartHomeNG ~]$ sh.log
                          2019-12-26  18:39:18 WARNING  __main__            --------------------   Init SmartHomeNG 1.6.master (1dcb4fb5)   --------------------
                          2019-12-26  18:39:18 WARNING  __main__            Running in Python interpreter 'v3.7.3 final' (pid=881) on linux platform
                          2019-12-26  18:39:19 ERROR    lib.shpypi          test_requirements: package 'scipy' v1.3.1 is too new. Maximum v1.2.1 is needed
                          2019-12-26  18:39:19 CRITICAL __main__            Python package requirements for configured plugins are not met.
                          2019-12-26  18:39:19 CRITICAL __main__            Aborting
                          d.h. die WHL hatte ich zuvor richtig runter gespielt und installiert, beißt sicher aber anscheinend mit der aktuellen Python Version?!
                          Soweit ich es aber in Erfahrung bringen konnte, sollte aber Python 3.7 mit scipy 1.3.1 kompatibel sein?!?!
                          Verwende ich die dennoch falsche WHL?
                          Nochmals zur Info meine Systemconfig:
                          (SmarthomeNG1.6.1 mit SmartVisu2.9) auf Raspberry Pi3 B+; WHL Datei:
                          scipy-1.3.1-cp37-cp37m-linux_armv7l.whl

                          Für jeden Tip dankbar!!! LG Joe

                          Kommentar


                            #28
                            Zitat von jhw75 Beitrag anzeigen
                            sollte aber Python 3.7 mit scipy 1.3.1 kompatibel sein
                            Die Meldung bezieht sich auch nicht auf Python, sondern das Plugin ist laut Plugin Autor nur mit scipy bis v1.2.1 kompatibel und Du hast scipy v1.3.1 installiert.
                            Viele Grüße
                            Martin

                            There is no cloud. It's only someone else's computer.

                            Kommentar


                              #29
                              Passt alles. Bitte lösch einfach das <1.2 im plugin.yaml vom uzsu plugin

                              Kommentar


                                #30
                                Onkelandy Du meintest sicher in der requirements.txt des Plugins die Zeile
                                Code:
                                scipy>=1.1.0,<=1.2.1
                                durch
                                Code:
                                scipy>=1.1.0
                                ersetzen.
                                Viele Grüße
                                Martin

                                There is no cloud. It's only someone else's computer.

                                Kommentar

                                Lädt...
                                X