Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

Support Thread für das Husky2 Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • bmx
    antwortet
    Der PR ist gemergt, somit sollte in develop der aktuelle Stand zu finden sein.

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Hallo,
    habe soeben einen PR erstellt. Somit sollte das Plugin demnächst wieder normal oder zumindest im Develop branch von SmarthomeNG verfügbar sein.

    LG

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    Hey hijacker7

    ich kann nun bestätigen, dass husky2 nun wunderbar bei mir funktioniert!

    Vielen herzlichen Dank für den sehr schnellen fix.

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    hijacker7 Das ging ja fix - tolle Nachricht. Teste es gerne in den nächsten Tagen.

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Hallo,

    ich habe noch keine Antwort vom Entwickler auf mein Issue erhalten.
    Dennoch habe ich zum Testen inzwischen bei mir einen Branch erstellt, der den Source-Code vom aioautomower package enthält und darin habe ich die nötige Änderung gemacht, damit der Code auch auf python 3.8 läuft. Ihr könnt gerne inzwischen diesen Branch bzw. noch besser nur das Plugin husky2 benutzen. Wenn die Änderung dann im offiziellen package nachgezogen wird erstelle ich einen Pull Request auf SmarthomeNG (natürlich ohne dem Source-Code). Für die Benutzung ändert sich dann von der Konfiguration her nichts.

    Der Branch bzw. das Plugin ist unter https://github.com/gruberth/plugins/tree/husky2/husky2 zu finden.

    Ich gebe bescheid wenn es updates gibt.


    brunosa3 Falls es Erfolge oder Probleme damit gibt, kannst du dich gerne melden.

    LG
    Zuletzt geändert von hijacker7; 01.09.2022, 16:37.

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    Oh super das sind grossartige Neuigkeiten. Vielen Dank für Deine Bemühungen

    lg

    sandro

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Ja das update ist nötig denn nur in den neuen Versionen ist die Anmeldung via application secret drinnen. Das gabs bei den alten noch gar nicht.

    Ich hab gestern schon was gemacht und auch dem Entwickler von aioautomower geschrieben.

    Ich denke, dass ich im laufe der Woche eine funktionsfähige Version bereit habe.

    Melde mich wenns was neues gibt.

    Lg
    Thomas

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    ui das ist ärgerlich. Gut das wir das geklärt haben. Danke für Dein Nachhaken und Deine raschen Reaktionen. Meinst Du ein upgrade von aioautomower ist notwendig für die neue Anmeldung?

    Wie sieht es bei Dir motivations/zeittechnisch aus in das neue einloggen hineinzuschauen?

    Ich will kein Druck aufbauen nur abschätzen ob es sich für mich lohnt da auch Näher hineinzuschauen.

    LG

    Sandro

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Hab gerade eine neue aplication erstellt und es mit der Versucht und siehe da es geht bei mir auch nicht mehr. Wahrscheinlich lag es nur daran, dass mein zuletzt bezogenes Token von der alten aplication noch ein paar Tage gültig ist.

    Sieht so aus als wäre der von mir befürchtete Login-Wechsel schon passiert... Ich versuchs demnächst zu fixen. Mein Hauptproblem ist nur, dass die neuen Versionen von aioautomower alle python 3.9 vorraussetzen und ich das möglichst vermeiden wollte, weil viele (so wie ich und du auch) ihr System auf 3.8 laufen haben. Mal schauen was geht.

    Jedenfalls vorerst danke für deinen Hinweis.

    LG

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    oh ich verstehe das ist ärgerlich.

    Im Log hat sich die Fehlermeldung nicht geändert.

    image.png

    image.pngDas sind die verbundenen APIs

    image.png
    Meinst Du es ist denkbar, dass für neu erstellte Applikationen man bereits das secret applikation verwenden muss?

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Du hattest auch vorhin diese Version von aioautomower, das sollte somit schon gepasst haben.

    Ich kann diese URL bei mir nicht löschen, denn es wird midestens eine Benötigt laut dem Portal.

    Nein, aktuell ist es noch möglich sich per username und password anzumelden. Somit wird dieser im Plugin nicht benötigt und ist in der Konfiguration nicht enthalten. Wahrscheinlich wird sich der Login aber in naher Zukunft ändern (schon wieder 😒😫) und dann wird der secret application code ins Spiel kommen.

    Kommt im Log immenoch die selbe Fehlermeldung wenn du den localhost eingetragen hast?
    Welche APIs hast du im Dev Portal mit der application "connected"?

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    habe die neuste aioautomower version sicherhaltshalber nochmals deinstalliert und die oben benannte Version installiert.

    image.png

    leider erhalte ich immer noch keine Verbindung auch mit der redirected URL http://localhost:8080 im developer portal.
    wird Deine Verbindung eigentlich getrennt wenn du diese URL im Developer Portal löscht?

    Wird für einen erfolgreichen API request eigentlich nicht auch die secret application benötigt? wenn ja wo wird diese eigentlich vom plugin abgegriffen?

    LG

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Hallo,

    Husqvarna hat in letzter Zeit ziemlich was geändert, dies ist mir auch gerade erst aufgefallen. Musste man vorher nicht angeben. Bei meiner application ist
    Code:
    http://localhost:8080
    eingetragen. Versuch das mal.

    LG

    Einen Kommentar schreiben:


  • brunosa3
    antwortet
    ich verwende folgende version

    image.png

    Die redirected URLs habe ich im developer portal von Husquana beim einrichten von einer neuen application eingegeben. Was habt ihr hier eingegeben?

    image.pnghttps://developer.husqvarnagroup.cloud/docs/get-started

    LG

    Sandro

    Einen Kommentar schreiben:


  • hijacker7
    antwortet
    Hallo,

    welche version von aioautomower hast du aktuell installiert? Falls es nicht die Version 2022.3.1 ist, schau dir bitte https://knx-user-forum.de/forum/supp...79#post1775379 an.

    Das Plugin benötigt keine Angabe einer URL durch den Anwender, wo hast du diese angegeben? Im Terminal zum Testen meinst du?

    LG
    Zuletzt geändert von hijacker7; 27.08.2022, 09:58.

    Einen Kommentar schreiben:

Lädt...
X