Ankündigung

Einklappen
Keine Ankündigung bisher.

Fehlersuche nach Homeserverupdate auf 4.8

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Fehlersuche nach Homeserverupdate auf 4.8

    Hallo Liebe Experten,

    seit dem Update des Gira Homeservers auf 4.8 funktioniert meine Abfrage unsers Kaco-Solartransformators nicht mehr.


    Ich komme aber in der Fehlersuche allein nicht weiter.


    Es gibt einen Stammfehler

    "CLogikBSItem.addEingang Len : [5002L, 9502L, 1L, 0L, 0L]"

    auf den ich mir keinen Reim machen kann und mehrere Exceptions

    von denen diese hier wohl:

    4.01.2019 16:10:58 (20610)
    File "./../hssrc/hs_event.py", line 938, in doSend
    File "./../hssrc/lib_tcpclient.py", line 73, in recv
    timeout: timed out

    Teil des Problems sein dürfte.

    Die Webabfrage selbst scheint zu funktionieren, wenn ich die Event-BiDir richtig interpretiere

    14.01.2019 16:10:28 (IP: XXX.XXX.XXX.XXX) (Port: 80)
    (Send: 72) 0x47 0x45 0x54 0x20 0x2f 0x72 0x65 0x61 0x6c 0x74 0x69 0x6d 0x65 0x2e 0x63 0x73 0x76 0x20 0x20 0x48 0x54 0x54 0x50 0x2f 0x31 0x2e 0x30 0xd 0xa 0x48 0x6f 0x73 0x74 0x3a 0x20 0x31 0x39 0x32 0x2e 0x31 0x36 0x38 0x2e 0x31 0x38 0x31 0x2e 0x32 0x35 0xd 0xa 0x43 0x6f 0x6e 0x6e 0x65 0x63 0x74 0x69 0x6f 0x6e 0x3a 0x20 0x43 0x6c 0x6f 0x73 0x65 0xd 0xa 0xd 0xa
    GET /realtime.csv HTTP/1.0
    Host: XXX.XXX.XXX.XXX
    Connection: Close


    Kann mir jemand ein Anstoß in die richtige Richtung geben oder weiß, wo ich weiter suchen kann?


    Vielen Dank

    Janko













    #2
    Stammfehler heißt eigentlich immer Projekt passt nicht zur Firmware.
    Projekt mit aktuellem Experten hochladen
    Nils
    xxAPI² - HTML5 Client für den Gira Homeserver (Status: Beta / Visuclient = 80% / xxAPI¹ Funktionen = 100% / zusätzlich: Slider/Drehknöpfe/Balken/mausnahe Popups/.... ) - Installation: Logikbaustein nach Start Triggern / Startlink auf der Debugseite

    Kommentar


      #3
      Hallo Nils, danke für die schnelle Antwort

      Zitat von NilsS Beitrag anzeigen
      Stammfehler heißt eigentlich immer Projekt passt nicht zur Firmware.
      Projekt mit aktuellem Experten hochladen
      Projekt ist mit dem Experten 4.8.181109 hochgeladen und der Homerserver meldet 4.8.0.181017.
      Ist das schon eine zu große Abweichung?


      Kommentar


        #4
        Der Timeout ist ein einfacher tcp Timeout.
        Der Port 80 ist aus irgendwelchen Gründen nicht erreichbar. Teste das sonst mal mit nem Browser.
        Zuletzt geändert von NilsS; 14.01.2019, 16:31. Grund: Sorry Handy und große Finger
        Nils
        xxAPI² - HTML5 Client für den Gira Homeserver (Status: Beta / Visuclient = 80% / xxAPI¹ Funktionen = 100% / zusätzlich: Slider/Drehknöpfe/Balken/mausnahe Popups/.... ) - Installation: Logikbaustein nach Start Triggern / Startlink auf der Debugseite

        Kommentar


          #5
          Im Browser läuft alles:

          Request:
          Code:
          GET /realtime.csv HTTP/1.1
          Host: 192.168.181.25
          Connection: close
          Response:
          Code:
          HTTP/1.1 200 OK
          Content-Length:     51
          Content-type: text/html
          
          1549129266;0;0;0;5185;5000;5146;0;0;0;0;0;0;0;912;2

          Wie kann ich den Fehler finden? Im Event-BiDir siehts weiterhin aus wie im Eröffnungsbeitrag beschrieben.


          Kommentar


            #6
            Zitat von jankod Beitrag anzeigen
            Projekt ist mit dem Experten 4.8.181109 hochgeladen und der Homerserver meldet 4.8.0.181017
            bring den HS doch auch auf 4.8.181109 hoch. Das ist doch problemlos und du hast dies als Fehler ausgeschlossen.

            Kommentar


              #7
              Gibt es denn überhaupt eine neuere Firmware als 4.8.0.181017?
              Ein Firmwareupdate bringt jedenfalls keine andere Versionsnummer und auch keine Besserung beim Problem:

              Hat noch jemand eine Idee?

              Der Ethernetdebug-Abschnitt zeigt keine Timeouts und keine Fehler:
              Code:
               Ethernet  
              IP-Adresse 192.168.181.70
              IP-Ports 443, 80 (HTTP)
              Default-Gateway 192.168.181.1
              Interne Gateways ?
              DNS-Server 192.168.181.1
              Anz. TO 0
              Last TO ?
              Anz. ERR 0
              Last ERR ?
              Anz. BLOCK_REQ 0
              Last BLOCK_REQ ?


              und dennoch sieht die Event so aus:
              Code:
              03.02.2019 11:46:31 (IP: 192.168.181.25) (Port: 80)
              (Send: 69) 0x47 0x45 0x54 0x20 0x2f 0x72 0x65 0x61 0x6c 0x74 0x69 0x6d 0x65 0x2e 0x63 0x73 0x76 0x20 0x48 0x54 0x54 0x50 0x2f 0x31 0x2e 0x31 0xd 0xa 0x48 0x6f 0x73 0x74 0x3a 0x20 0x31 0x39 0x32 0x2e 0x31 0x36 0x38 0x2e 0x31 0x38 0x31 0x2e 0x32 0x35 0xd 0xa 0x43 0x6f 0x6e 0x6e 0x65 0x63 0x74 0x69 0x6f 0x6e 0x3a 0x20 0x63 0x6c 0x6f 0x73 0x65 0xd 0xa
              GET /realtime.csv HTTP/1.1
              Host: 192.168.181.25
              Connection: close
              Die gleiche Abfrage von meinem Rechner bringt die gewünschte Antwort. Was kann ich noch überprüfen oder ausprobieren? Wie gesagt alles seit Update auf 4.8...

              Hat noch jemand eine Idee bitte?



              Kommentar


                #8
                Also der Klassiker: Downgrade zu 4.5. für Firmware und Experten und anschließend funktioniert die Abfrage wieder...

                Kommentar

                Lädt...
                X