Ankündigung

Einklappen
Keine Ankündigung bisher.

Newbie Dimming@openHAB

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Newbie Dimming@openHAB

    Hi zusammen,

    bin ganz neu auf dem Gebiet und habe es endtlich geschafft openHAB2 auf meinem Synology NAS zu installieren.
    Hab mich auch gleich an die Konfiguration gemacht, und jetzt setzt es aus :-(

    Einen normalen Schaltaktor kann ich ansprechen:

    Switch eg_buero_decke "Büro Deckenlampe" <light> (gEGOffice) { knx="1/1/13" }

    Kein Problem, aber einen Dimmer ....tjaaa ... geht nicht ...

    Dimmer dim_eg_wa_ceiling "Flur Decke [%.0f %%]" <light> (gEGFlur) { knx="1/1/8, 2/1/5, 1/3/22" }

    Leider bin ich auch kein wirklicher KNX Profi:

    Also, der Aktor Phys. 1.1.12 im Keller hat die 1/1/8 als Schaltgruppe im Ausgang 1 (Schalten) eingestellt.
    Ausgang 2 (Dimmen) geht auf 2/1/5 (das ist ja der Increase/Decrease Part (wie hier beschrieben https://github.com/openhab/openhab/wiki/KNX-Binding)

    Aber was trage ich als Percentage ein ?

    Bin leider im Moment ratlos ....

    Gibts zu solchen speziellen Fragestellungen eine gute deutsche Beschreibung. Mein Englisch ist zwar ganz passabel, aber da mir auch das KNX KnowHow fehlt, beisst es bei den Fachbegriffen oft aus.

    Merci@All und Grüße,

    Wurzelseppi




  • #2
    Aaalso...
    Der Dimmaktor hat mehrere Kommunikationsobjekte. Das sind zum steuern
    • Ein/Aus (1bit),
    • Heller/Dunkler (4bit) und
    • absoluter Helligkeitswert (8bit)

    darüber hinaus gibt es normalerweise mindestens noch zwei weitere Kommunikationsobjekte für die Rückmeldung,
    • Ein/Aus (1bit) und
    • absoluter Helligkeitswert (8bit)

    Wenn der Dimmaktor folgendermaßen parametriert ist
    Code:
    1/1/ 1 Ein/Aus
    1/1/ 2 Heller/Dunkler
    1/1/ 3 Helligkeit
    1/1/11 Status Ein/Aus
    1/1/13 Status Helligkeit
    sähe das passende Item in openHAB so aus:
    Code:
    Dimmer myDimmer "Dimmer [%d %%]" { knx="1/1/1+<1/1/11, 1/1/2, 1/1/3+<1/1/13" }
    Wenn die Ansteuerung über INCREASE/DECREASE nicht richtig funktioniert (es kommt auf den Dimmertyp an, ob das von openHAB aus geht, siehe Erklärung unten), ist es besser, eine Rule zu definieren, die das Kommando INCREASE/DECREASE in einen absoluten Dimmwert umsetzt. Dafür darf dann die entsprechende GA (im Beispiel 1/1/2) NICHT im Binding stehen. Entweder setzt Du dann eine GA ein, die gar nicht existiert, also ins Leere geht, oder (besser) Du lässt die GA weg, dann musst Du aber den DPT für die hinteren GA mit angeben, damit openHAB die GA korrekt zuordnet
    Code:
    Dimmer myDimmer "Dimmer [%d %%]" { knx="1/1/1+<1/1/11, 5.001:1/1/3+<5.001:1/1/13" }
    Da Du OH2 einsetzt, und in der BasicUI echte Slider zur Verfügung stehen, sollte diese Konfiguration sogar komplett ohne Rule funktionieren. Falls Du die ClassicUI einsetzen willst, musst Du eine Rule definieren, da dort nur die Heller/Dunkler Schaltflächen zur Verfügung stehen:
    Code:
    rule "send absolute dim value"
    when
        Item myDimmer received commmand
    then
        if (receivedCommand == INCREASE)
            myDimmer.sendCommand((myDimmer.state as DecimalType) + 5)
        else if (receivedCommand == DECREASE)
            myDimmer.sendCommand((myDimmer.state as DecimalType) - 5)
    end
    Zu der Sache mit den Dimmern:

    Es gibt in knx verschiedene Möglichkeiten, INCREASE/DECREASE umzusetzen. Dazu muss man wissen, dass dieses Kommando verschiedene Schrittweiten kennt (deshalb 4bit, das MSB gibt die Dimmrichtung an, die drei LSB setzen die Schrittweite)

    Die eine Variante ist, zu Beginn des Dimmvorgangs ein INCREASE/DECREASE mit einer Schrittweite > 0 zu schicken und zum Ende des Dimmvorgangs ein weiteres INCREASE/DECREASE mit Schrittweite = 0 zu schicken, also quasi ein STOP-Kommando.

    Die zweite Variante ist, wiederholt das entsprechende Kommando zu senden und am Ende des Dimmvorgangs einfach keinen weiteren Befehl zu senden. openHAB verwendet ausschließlich dieses Verfahren, leider unterstützen nicht alle knx Dimmer diese Variante (ich gehe aber davon aus, dass auch die erste Variante nicht von allen Dimmern unterstützt wird).

    Ich habe ~ 2013 dazu einen Issue aufgemacht, aber die Umsetzung in konkreten Code ist wohl nicht so einfach, zumal diese Art der Steuerung eine Spezialität von knx ist, die meisten anderen Systeme verwenden nur INCREASE/DECREASE. Der Vorteil der ersten Variante ist leicht erkennbar, es werden pro Dimmvorgang lediglich zwei Telegramme benötigt, die Buslast ist also erheblich geringer.

    Kommentar


    • #3
      Hi,

      ohne das Ganze jetzt ausprobiert zu haben, möchte ich schon mal ein WOW!! los schicken ..... so ausführlich hat mir noch keiner geantwortet :-)
      Herzlichen Dank und, auch wenns das hier nicht gibt, bekommst Du ein "Like" :-)))

      Ich werds nach dem Glücksprinzip vergelten, und einfach jedem der was frägt das ich weiß (auch wenn das im Moment in diesem Bereich eher wenig ist :-) ) eine ähnlich ausführliche Antwort geben ...

      Ich berichte von meinem Erfolg bzw. Misserfolg wenn ich durch bin ...

      Großes Merci aber schon jetzt und bis bald,

      Wurzelseppi

      Kommentar


      • #4
        Hey, aaallllsssoooo

        zu aller Erst ....... der Wahnsinn .... funktioniert !!

        Mein Setting:

        Dimmer dim_eg_wa_ceiling "Flur Decke [%.0f %%]" <light> (gEGFlur) { knx="1/1/8+<5/1/0, 2/1/5, 2/1/6+<5/1/1" }

        Ich werde die BasicUI, ja....

        Eine kleine Frage ist aber trotzdem noch offen..

        Ich hab für die Rückmeldungen im Haus eine eigene Gruppenhierarchie gemacht.

        Also,

        Rückmeldungen -> Keller / EG / Obergeschoss

        Dann für jeden Aktor eine Gruppe: Also z.B
        SZ(Schaltzustand)_FlurDeckeLicht (5/1/0)
        W(Wert)_FlurDeckeLicht (5/1/1)

        und hab diese dann mit den Ausgängen des entsprechenden Aktors verbunden. Der Aktor meldet also seine Zustände in diese Gruppen.

        Angewandt habe ich es in der OH2 Konfig dann so wie oben im Beispiel zu sehen ist.

        Im Log von openHAB2 kommt allerdings nun immer diese Fehlermeldung (bis er es irgendwann aufhört zu versuchen):

        2017-01-02 14:18:41.027 [WARN ] [al.bus.KNXBindingDatapointReaderTask] - Autorefresh: Cannot read value for item 'dim_eg_wa_ceiling' from KNX bus: timeout waiting for group read response: timeout
        2017-01-02 14:18:41.028 [WARN ] [al.bus.KNXBindingDatapointReaderTask] - Autorefresh: Give up, could not read address '5/1/1' after '3' retries.

        Er kann also die Werte nicht aus der Gruppe lesen. Ich vermute mal der Aktor meldet die dann wahrscheinlich auch nicht dorthin :-(

        Seh ich das richtig ? Was meinst Du ?

        Danke Dir im Voraus und Grüße,

        Wurzelseppi

        Kommentar


        • #5
          So ganz verstehe ich nicht, was Du da machst. Jeder Aktorkanal ist normalerweise mit einem Item verbunden. Dazu gehören die Kommunikationsobjekte, um den Aktor zu steuern und die Kommunikationsobjekte, die den Zustand des Aktors zurück melden. Jedes Kommunikationsobjekt hat dabei eine exklusive GruppenAdresse im knx System. Diese GA werden überall da eingetragen, wo der Aktor gesteuert werden soll, also in den Tastern, die eventuell einen Aktor direkt steuern sollen ebenso wie in dem Item, welches den Aktorkanal in openHAB repräsentiert. Ein einzelner Kanal eines Schaltaktors hat also mindestens zwei GA, eine zum Steuern, eine für den Status, ein Kanal eines Dimmaktors hat mindestens vier GA, siehe voriges Posting.
          Je nach Wunsch können auch zusätzliche GA definiert werden, z.B. um innerhalb knx Szenen zu definieren, oder um Zentral Aus zu realisieren. Dabei sind auf knx Seite nur die GA aktiv lesbar, die einen Status zurückmelden. Es darf jeweils nur exakt ein Gerät auf einen solchen ReadRequest reagieren (L-Flag ist gesetzt).

          Ein Autorefresh sollte im Normalfall unnötig sein. Interessant ist der Autorefresh z.B. für GA in denen Sensorwerte landen, die aber nicht zyklisch senden (wobei man allein daran schon erkennen kann, dass sich das irgendwie selbst widerspricht, man kann genauso gut im Sensor zyklisches Senden aktivieren und auf Autorefresh verzichten).
          Wenn Du mehrere Aktorkanäle gemeinsam darstellen willst (also z.B. gibt es im Wohnzimmer mehrere Lichtkreise und Du möchtest eine Anzeige, ob Licht im Wohnzimmer an ist), fasst Du die Items der Einzelkanäle in openHAB als Gruppe zusammen. Der Gruppe kannst Du dabei verschiedenes Verhalten beibringen, im vorliegenden Fall wäre ein OR(ON,OFF) angebracht, das heißt dann, dass die Gruppe ON signalisiert, sobald mindestens eines der Items ON ist.

          Kommentar


          • #6
            Hi,

            hab mal ein paar Infos zu meiner Konfiguration zusammengetragen. Wahrscheinlich hab ich einen dicken Denkfehler im Hirn.

            Das Problem ist, das der ursprüngliche Elektriker, der das aufgebaut hat, scheinbar nur das Nötigste gemacht hat, und ich jetzt mit meinem Halbwissen auch noch das ETS Projekt erweitern muss :-(

            Die Rückmeldegruppen hab ich z.B selbst aufgebaut, weil ursprünglich gar keine Rückmeldungen vorgesehen waren.

            Ich denke es muss erstmal "Schnackeln" bei mir, dann komm ich voran, aber das ist leider noch nicht passiert :-(

            Alles weitere im Attachement (keine Sorge, bin Viren-frei) :-)
            Angehängte Dateien
            Zuletzt geändert von Wurzelseppi; 04.01.2017, 13:35.

            Kommentar


            • #7
              behauptet nicht jeder von sich, virenfrei zu sein? Aber ich riskierte es mal, immerhin sollten etliche Virenscanner Alarm geben, bevor die Datei geöffnet wird...

              Die Konfiguration sieht soweit erst mal gut aus. INCREASE/DECREASE solltest Du aus dem Binding entfernen und stattdessen für die hinteren GA den DPT mit angeben
              Code:
              Dimmer dim_gf_kitchen_bar "Bar Lampen [%.0f %%]" <light> (gGFKitchen) { knx="1/1/2+<5/1/9, 5.001:2/1/7+<5.001:5/1/8" }
              Man kann im Busmonitor sehen, dass Dein Dimmer mit Dimstart/Dimmstop arbeitet, openHAB beherrscht diese Art Dimmen nicht, siehe Posting #2 in diesem Thread.
              Was leider nicht sichtbar ist, sind die Flags in ETS, in der Rückmeldung muss das L-Flag gesetzt sein.

              Wie ist openHAB an knx angebunden?

              Glatt vergessen... Hast Du mal die UI neu aufgemacht? manchmal funktioniert nur die Aktualisierung der Darstellung nicht korrekt...
              Zuletzt geändert von udo1toni; 04.01.2017, 17:16.

              Kommentar


              • #8
                @udo1toni: Du bist der Wahnsinn.
                Es funktioniert !! Und es war alles andere als Einfach, aber es geht !!!

                Ich habe in der ETS im Aktor die richtigen Datenpunkte (1.001 (schalten) und 5.001 (dimmwert)) definiert und sie auf "Lesen" gesetzt, und in der Gruppe auch die jeweiligen DPT´s gesetzt, und es funzt ......

                Mein Gott .....oder besser udo1toni ..... geh schnell in die Küche und hol Dir einen Kaffee auf mich ..... den hast Du dir verdient ....

                Im Ernst .... weis nicht, wie ich Dir danken soll ...

                Ist zwar noch ein Haufen Arbeit das bei den anderen 30 Dimmaktoren im Haus zu machen, aber das ist jetzt Fleisarbeit ... der Groschen ist gefallen...

                Meine Konfiguration im OH ist erstmal die Alte geblieben, ohne die direkten DPT´s anzugeben:

                Dimmer dim_gf_kitchen_ceilinglights "Kueche Deckenlampen [%.0f %%]" <light> (gGFKitchen) { knx="1/1/1+5/1/7, 2/1/4, 2/1/8+<5/1/6" }

                Warum meintest du ich sollte INC/DEC aus dem Binding nehmen ?

                Kommentar


                • #9
                  Zitat von Wurzelseppi Beitrag anzeigen
                  Warum meintest du ich sollte INC/DEC aus dem Binding nehmen?
                  Wenn Du aus irgendeinem Grund mal ein INCREASE/DECREASE Kommando über openHAB schickst, dimmt der Dimmer bis maximale oder minimale Helligkeit.
                  Falls Du mal die Classic UI anschaust, wirst Du feststellen, dass dort kein Slider für die Helligkeit vorhanden ist, sondern... genau! UP/DOWN Buttons, was dann schnell zu Verstimmung führt, weil man dort nicht dimmen kann.
                  Nun gibt es den Workaround aus Posting #2 mittels Rule aber wenn openHAB das INCREASE/DECREASE Kommando tatsächlich an den Bus schickt, geht das entsetzlich schief. Solange also openHAB nicht in der Lage ist, ein DIMMSTOP zu senden, sollte der entsprechende Befehl gar nicht erst auf den Bus gelangen können.
                  Auch ankommend (d.h. dimmen über einen Wandtaster, openHAB hört dann den Befehl INCREASE/DECREASE mit) führt das im Zweifel zu Chaos, wenn auch nicht so schlimm.
                  Natürlich kann man auch dagegen argumentieren, dass dann INCREASE/DECREASE nicht mehr in events.log auftaucht. Irgendwas ist ja immer...

                  Kommentar


                  • #10
                    Ich möchte das Thema nochmal aufgreifen, weil ich nun seit Stunden rum probiere und trotz dieser tollen Anleitung keinen Erfolg mit den Dimmern hin bekomme.

                    Ich verwende einen Berker-Dimmaktor mit 4 Kanälen, die folgendermassen betitelt sind:
                    - Schalten: 2/0/30
                    - Rückmeldung Schalten: 2/0/32
                    - Helligkeitswert: 2/0/33
                    - Dimmen: 2/0/31

                    Nach obiger Logik aus Post #2 fehlt mir demnach die "Helligkeit" da ich den Helligkeitswert als "Status Helligkeit" verstehe. Daher ist mein Code {knx="2/0/30+<2/0/32, 5.001:2/0/31+<2/0/33"} bzw. habe ich auch {knx="2/0/30+<2/0/32, 2/0/31, 2/0/33"} probiert. Kann mir jemand bitte helfen?

                    Kommentar


                    • #11
                      Nein, Helligkeitswert kann sowohl Status als auch Steuerbefehl sein, das musst Du notfalls ausprobieren. Vermutlich ist es der Steuereingang, sonst hieße der Punkt Rückmeldung Helligkeitswert. Dimmen ist aber immer ein INCREASE/DECREASE mit DTP3.007, das ist ein 4-Bit-Wert. Ob der Berker Dimmaktor ein DIMMSTOP benötigt, musst Du ausprobieren oder über die ETS in Erfahrung bringen. Die korrekte Definition ist also
                      Code:
                      Dimmer MyDimmer "Dimmwert [%d %%]" {knx="2/0/30+<2/0/32, 2/0/31, <5.001:2/0/33"}
                      Du kannst versuchen, ein INCREASE/DECREASE über eine Rule zu senden:
                      Code:
                      rule "relatives dimmen"
                      when
                          Item MyRelDimm received command
                      then
                          MyDimmer.sendCommand(INCREASE)
                      end
                      Alternativ kannst Du untenstehende Sitemap mit der Classic UI verwenden, dort sollte es dann UP/DOWN Buttons geben. kurzer Druck = EIN/AUS, langer Druck = INCREASE/DECREASE.
                      Sobald das Item MyRelDimm einen Befehl erhält, triggert die Rule.
                      Wenn der Dimmer nur wenig heller wird, funktioniert das relative Dimmen mit dem Berker Dimmer ohne Stopp Befehl. Wenn das Licht aber bis zur vollen Helligkeit hoch geht, nutzt Dir das relative Dimmen nichts, dann entfernst Du exakt 2/0/31, aus der Item Definition und dimmst nur absolut. Ob der Helligkeitswert auch über dieselbe GA zurückgeliefert wird, kannst Du feststellen, indem Du an einem Wandtaster dimmst. Wenn sich anschließend der Dimmwert in openHAB geändert hat, funktioniert die Rückmeldung. Ob das absolute Dimmen funktioniert, kannst Du über die Basic UI feststellen, da gibt es einen "Schieberegler", wenn Du eine eigene Sitemap erstellst:
                      Code:
                      sitemap test label="Test Sitemap" {
                          Frame {
                              Switch item=MyDimmer
                          }
                      }
                      So gut wie alle knx Dimmer können ihre aktuelle Helligkeit rückmelden, es kommt natürlich auf den exakten Dimmertyp an, ob es eventuell irgendwo konfiguriert werden muss, vielleicht ist aber auch nur das Rückmeldeobjekt nicht mit einer GA verknüpft, das könntest Du dann in ETS nachholen..

                      Kommentar


                      • #12
                        Vielen Dank udo1toni, es funktioniert somit schon mal viel mehr als gestern. Zugegebenermassen habe ich openHAB erst gestern installiert (auf einer Synology RS) und somit noch nicht allzuviel Erfahrung.

                        Der entscheidende Punkt war, dass der Dimmaktor so eingestellt war, dass er keine Rückmeldung liefert. Im Moment habe ich das Verhalten, dass ich über den Schieberegler ein und ausschalten kann, das rauf und runter Dimmen funktioniert, aber 2 Dinge noch nicht:
                        1. Wenn ich ihn leicht einschalte, springt der Regler immer auf 100%, obwohl die Helligkeit noch ziemlich runter gedreht ist. Erst wenn ich ihn von da wieder runter regle wird's realistisch. Das ist übrigens mit und ohne das "2/0/31, " so.
                        2. Das bei dir in Klammer angegebene "[%d %%]" hat bei mir keine Auswirkung. Wofür steht es denn genau und weswegen kann es sein, dass nichts angezeigt wird?

                        Du hattest übrigens recht, "Helligkeitswert" ist ein Steuerbefehl. Ich habe nämlich noch einen weiteren Berker Dimmer mit 5 Kanälen und da gibt's zusätzlich einen Kanal "Rückmeldung Wert".

                        Da ich Probleme gerne selber löse, könntest du an deiner Syntax bitte folgende Dinge erklären:
                        1. Ich kenne inzwischen das Verbinden von Gruppenadressen mit "+". Was aber macht dein "<"-Zeichen da drin? Was ist die Bedeutung?
                        2. Wie kann die Syntax allgemein beschrieben werden? knx="Schalten+<Status,..." aber welche Parameter kann man einem Dimmer weiter übergeben, da du ja im Zweifel ja eine Variante ohne das "2/0/31, " vorgeschlagen hast.
                        3. Was genau bedeutet das "<5.001"?

                        Rules... keine Ahnung, muss ich mir noch ansehen. Aber bevor ich das mache möchte ich niemanden darum bemühen.

                        Kommentar


                        • #13
                          Der Reihe nach:
                          Code:
                          Dimmer MyDimmer "Dimmwert [%d %%]" <light> (Group) {knx="2/0/30+<2/0/32, 2/0/31, <5.001:2/0/33"}
                          Dimmer steht für den Itemtyp
                          MyDimmer ist der Name des Items
                          In den Anführungszeichen steht das Label. Dabei sorgen die eckigen Klammern dafür, dass dieser Teil des Textes rechtsbündig fett ausgegeben wird. %d steht für den Zahlenwert des Items (0 bis 100) und %% bewirkt die Ausgabe des Zeichens % im rechtsbündigen Teil.
                          In den spitzen Klammern (bzw. kleiner und größer Zeichen) steht der Name des Icons, welches links vom Label dargestellt wird. Falls der Iconname Status enthält, wird das passende Icon dynamisch angezeigt.
                          In den runden Klammern stehen die Gruppen, denen das Item zugeordnet ist (diese Gruppen müssen vorher angelegt worden sein)
                          Danach folgen in den geschweiften Klammern die Bindings, die mit dem Item verbunden sind.

                          Ein Dimmer kennt verschiedene Steuerbefehle, und zwar ON/OFF (1.GA) und INCREASE/DECREASE (2.GA). Weiterhin kann der Status ON/OFF oder ein Helligkeitswert (3.GA, Ganzzahl von 0 bis 100) sein. Das Blöde ist, dass es nur einen Status gibt, also wird normalerweise nur ein Zahlenwert zurückgeliefert.
                          Allerdings gibt es einen Automatismus in openHAB, und zwar wird eine Änderung des Helligkeitswerts auf >0 immer auch einen Change OFF->ON zur Folge haben. Ein Change nach ON wird von openHAB als 100 interpretiert. Deshalb springt der Schieberegler auf 100. Weil knx offensichtlich keinen Levelstatus zurück liefert, bleibt der Wert so stehen.
                          Das < bewirkt, dass openHAB beim Start versucht, von exakt dieser GA den Status zu lesen. Die Zahl 5.001 ist der DPT in knx (in diesem Fall 8 bit unsigned %), der muss angegeben werden, damit openHAB weiß, dass es sich um den Helligkeitswert handelt. Die Schreibweise der GA und des DPT lehnt sich an ETS an.

                          Du musst in ETS dafür sorgen dass pro Rückmelde-GA exakt 1 Gerät (Aktorkanal) auf Read Requests antwortet, dann sollte es funktionieren.

                          Kommentar


                          • #14
                            Vielen Dank für die ausführliche Erklärung!

                            Ich habe nun 6 Dimmgeräte eingerichtet und alle funktionieren. Bei mir lag offensichtlich einiges noch im Argen, was in ETS zu korrigieren war. Mit den richtigen Einstellungen, hat nun nämlich doch jeder Dimmer 5 Kanäle. Diese erscheinen jedoch nur, wenn die Rückmeldung auch auf ein steht. Da ich das nicht selbst gemacht hatte, musste ich ein wenig nachjustieren. Nach der Nachjustieriung funktioniert es nun nach dem von dir weiter oben angegebenen Schema
                            Code:
                            {knx="0/1/30+<0/1/32, 0/1/31, 0/1/33+<0/1/34"}
                            Was nach wie vor nicht "perfekt" ist, sind folgende 2 Dinge:
                            1. Beim einschalten springt der Schieberegler auf 100% und erst nach 1-2 Sekunden auf den eingestellten Wert. Das ist aber eher ein kosmetisches Problem und deiner Erkärung nach wohl auch nicht zu beheben.
                            2. Aus welchen Gründen auch immer, bei mir werden keine Prozentwerte angezeigt. Das
                            Code:
                            [%d %%]
                            bewirkt nichts. Hast du eine Idee woran das liegen könnte?

                            Rules habe ich nachgelesen. Tolle Sache, zum Glück habe ich Programmiererfahrung

                            Kommentar


                            • #15
                              Du kannst versuchen, ob [%f.0 %%] funktioniert, das wäre dann eine Fließkommazahl ohne Nachkommastellen.

                              Was das Springen des Schiebestellers auf 100% betrifft, ja, das ist ein Schönheitsfehler. Du kannst versuchen, ob es besser wird, wenn Du autoupdate abschaltest, dazu ergänzt Du bei der binding-Definition vor der schließenden geschweiften Klammer ein , autoupdate="false", damit wird verhindert, dass openHAB selbst den Status des Items ändert, Der Zustand des Items ändert sich dann ausschließlich durch über knx ankommende Nachrichten und über gezieltes Setzen mit Rules - Item.postUpdate(Value) wäre dazu der Befehl, aber das nur am Rande.

                              Kommentar

                              Lädt...
                              X