Ankündigung

Einklappen
Keine Ankündigung bisher.

knxd im falschen Verzeichnis installiert ???

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    knxd im falschen Verzeichnis installiert ???

    Hallo zusammen...

    habe mir einmal die Mühe gemacht SmarthomeNG komplett unter Debian Buster auf einem Windows HyperV Gastsystem zu installieren.
    Soweit lief alles gut und hatte smartVISU installiert und konnte die SmartVISU Seite und auch Port 8383 (Backend) einwandfrei aufrufen.

    Als nächster Schritt war vorgesehen, den knxd zu installieren.
    Da ich mich aber noch durch die Installation von SartVISU im Verzeichnis /var/www/html/smartVISU/ befand, hatte ich die Installation des knxd Paketes von hier aufgerufen und die Installation verlief erfolgreich.

    Jetzt bemerkte ich aber den Fehler., dass ein Verzeichnis knxd unterhalb von smartVISU angelegt wurde...

    da ich aber kein Linux Freak bin, habe ich nun meine Zweifel bekommen.

    Frage: In welchem Verzeichnis wird das KNXD Paket installiert, habe nichts brauchbares in der Doku gefunden, siehe:

    Quellcode laden, compilieren und ein Paket schnüren
    Zunächst den Quellcode für den knxd vom github laden und sicherstellen, das der 0.14 branch gewählt wird:
    git clone https://github.com/knxd/knxd.git
    cd knxd
    git checkout v0.14


    Kann man das Verzeichnis unterhalb smartVISU (html Bereich) einfach löschen und knxd erneut unterhalb des richtigen Verzeichnisses neu installieren und wo?


    Vielleicht kann mir mal einer auf die Sprünge helfen.

    Gruß aus Solingen

    #2
    Also prinzipiell bringt buster den knxd bereits als Paket mit. Du musst das nur noch installieren. Daher gilt die Komplettanleitung aktuell auch nur für stretch und nicht für buster.

    Also einfach knxd unterhalb SmartVISU löschen.

    Ein "sudo apt-get install knxd" sollte dann den knxd installieren...

    Kommentar


      #3
      Hallo Bmx,

      habe ich gemacht, aber wo legt der das neuen knxd Verzeichnis an...?

      Kommentar


        #4
        Gar nicht. Der apt-get lädt das Paket und installiert dann knxd auf Deinem Rechner. Du brauchst das nicht mehr selbst zu "bauen".

        Die Config ist dann wie immer in /etc/knxd.conf zu finden. Die musst Du anpassen und dann den knxd neu starten.

        Kommentar


          #5
          habe ich gemacht, aber die Kommunikation stimmt noch nicht, kann keinen Groupwrite auf ip:localhost absetzen... keine Reaktion
          Vielleicht liegt das an meiner IP-Schnittstelle von ABB.

          Aber mal eine andere Frage:
          in der knxd.conf setzt man ja die IP zum KNX-Gateway, hier bei mir ist das der APP IPS 2.1 mit der IP 192.168.10.235

          Was stellt ihr denn in der Config ein um mit dem knxd zu kommunizieren ?
          Habe hier in der SmartVISU Config Eibd stehen mit der IP des SmarthomeNG Rechners, also die 192.168.10.230 könnte man ja auch die 127.0.0.1 eintragen, da alles auf der gleichen Maschine läuft.

          Aber wenn man in der SmartVISU einen Button oder Schalter setzt, kommt die Meldung:

          Driver: eibd
          Error writing item!

          Idee?

          Oder wird hier Smarthome.py ausgewählt?


          Angehängte Dateien

          Kommentar


            #6
            Wenn Du aus smartVISU direkt auf den KNXD schreibst, wieso stellst Du die Frage dann in SmartHomeNG Forum?
            Viele Grüße
            Martin

            Stay away from negative people. They have a problem for every solution.

            Kommentar


              #7
              Erwartet smartVisu evtl., dass das Programm auf den Namen "eibd" hört? Leg mal einen Symlink an:

              Code:
              sudo ln -s knxd /usr/bin/eibd

              Kommentar


                #8
                Zitat von Cybso Beitrag anzeigen
                Erwartet smartVisu evtl., dass das Programm auf den Namen "eibd" hört? Leg mal einen Symlink an:
                Nein
                Viele Grüße
                Martin

                Stay away from negative people. They have a problem for every solution.

                Kommentar


                  #9
                  Meine Frage oben war eher sarkastisch gemeint. Sie zeigt, dass AFeldt die Einleitungs-Seite der SmartHomeNG Seite nicht gelesen hat. Die Graphik dort zeigt deutlich, dass smartVISU und KNXD nicht direkt miteinander kommunizieren wenn man SmartHomeNG nutzen möchte.

                  Der Befehl mit dem er versucht hat einen Befehl auf den Bus zu schreiben ist auch falsch. Auch dieses hätte ihm die Doku verraten.
                  Viele Grüße
                  Martin

                  Stay away from negative people. They have a problem for every solution.

                  Kommentar


                    #10
                    Vielleicht hilft Dir die Einleitung mit dem Übersichtsbild ein wenig weiter. Darauf solltest Du schliessen können, das in der SmartVISU der Treiber für SmartHome.py ausgewählt wird.
                    Um erstmal zu prüfen, ob knxd funktioniert, solltest Du eine shell auf dem Rechner aufmachen wo Du gerade knxd installiert hast und es dort mit den knxd Befehler versuchen.

                    Kommentar


                      #11
                      Zitat von bmx Beitrag anzeigen
                      das in der SmartVISU der Treiber für SmartHome.py ausgewählt wird
                      oder SmartHomeNG, je nach eingesetzter Version der smartVISU.
                      Viele Grüße
                      Martin

                      Stay away from negative people. They have a problem for every solution.

                      Kommentar


                        #12
                        Der Thread hier entwickelt sich in die gleiche Richtung, wie der erste, den Du vor ein paar Tagen erstellt hast.

                        Lass mal SmartHomeNG und SmartVISU beiseite und kümmere Dich erst einmal um den knxd und dessen Verbindung zum KNX-Gateway. Dazu stehen in Deinem ersten Thread die wichtigsten Tipps mit Links.
                        Schau erstmal, ob die Netzwerkverbindung zu Deinem Gateway steht (Subnetz / IPV4 oder IPV6/ im Router schauen, ob IP 192.168.10.235 angemeldet ist / feste IP des Gateways / ping ...).
                        Wenn das passt, trägst Du die IP des Gateways und die bereits im ersten Thread diskutierten Optionen in der knxd.conf ein und startest den knxd neu:
                        Code:
                         systemctl restart knxd
                        Wenn das ohne Fehler abläuft und die knx-tools installiert sind, dann kannst Du mit folgendem Befehl auf dem KNX mithören (starten und dann ein paar Schalter im Haus betätigen):
                        Code:
                        groupsocketlisten ip:127.0.0.1
                        Wenn das alles klappt, kannst Du Dich an die Konfiguration von SHNG/SV machen.

                        Gruß Wolfram

                        Kommentar


                          #13
                          Hallo zusammen ,

                          Ich habe wohl ein ähnliches Problem .

                          Ich habe mein Raspberry Pi 3+ mit Onkelandy s image bestückt und folge strickt der Anwenderdokumentation (https://www.smarthomeng.de/user/inst...tung_knxd.html). Leider hänge ich bei dem Schritt knxd richtig zu konfigurieren.

                          knxd.conf Datei sieht wie folgt aus (Ich besitze einen IP-Router von MDT SCN-IP100.03):
                          Code:
                          #KNXD_OPTS=/etc/knxd.ini
                          START_KNXD=YES
                          #KNXD_OPTS="-e 1.1.245 -E 1.1.246:8 --no-tunnel-client-queuing -B single -b ipt:10.0.0.101 -c -DTRS"
                          
                          # You might want to remove the -DTRS in the end.
                          KNXD_OPTS="-e 0.0.1 -E 0.0.1:8 -c -b ip:192.168.178.35"
                          nachdem ich die änderungen wirksam werden lasse über:

                          Code:
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl stop knxd.socket
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl stop knxd.service
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl enable knxd.service
                          Synchronizing state of knxd.service with SysV service script with /lib/systemd/systemd-sysv-install.
                          Executing: /lib/systemd/systemd-sysv-install enable knxd
                          
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl enable knxd.socket
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl start knxd.socket
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl start knxd.service
                          erhalte ich einen Fehler mit dem Status 1
                          Kann mir jemand sagen was mir diese Fehlermeldung sagen will ?

                          Code:
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl status knxd.socket
                          ● knxd.socket - KNX Daemon (socket)
                          Loaded: loaded (/lib/systemd/system/knxd.socket; enabled; vendor preset: enabled)
                          Active: active (listening) since Wed 2020-01-15 01:13:24 CET; 12s ago
                          Listen: /var/run/knx (Stream)
                          [::]:6720 (Stream)
                          CGroup: /system.slice/knxd.socket
                          
                          Jan 15 01:13:24 SmartHomeNG systemd[1]: Listening on KNX Daemon (socket).
                          [smarthome@SmartHomeNG /etc]$ sudo systemctl status knxd.service
                          ● knxd.service - KNX Daemon
                          Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
                          Active: activating (auto-restart) (Result: exit-code) since Wed 2020-01-15 01:13:35 CET; 3s ago
                          Process: 29515 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
                          Main PID: 29515 (code=exited, status=1/FAILURE)
                          Randnotiz:

                          Ich habe Zugang zu meinem IP-Router

                          Code:
                           [smarthome@SmartHomeNG /etc]$ ping 192.168.178.35
                          PING 192.168.178.35 (192.168.178.35) 56(84) bytes of data.
                          64 bytes from 192.168.178.35: icmp_seq=1 ttl=255 time=0.804 ms
                          64 bytes from 192.168.178.35: icmp_seq=2 ttl=255 time=0.850 ms
                          64 bytes from 192.168.178.35: icmp_seq=3 ttl=255 time=0.688 ms
                          64 bytes from 192.168.178.35: icmp_seq=4 ttl=255 time=0.663 ms
                          64 bytes from 192.168.178.35: icmp_seq=5 ttl=255 time=0.531 ms
                          64 bytes from 192.168.178.35: icmp_seq=6 ttl=255 time=0.533 ms
                          ^C
                          --- 192.168.178.35 ping statistics ---
                          6 packets transmitted, 6 received, 0% packet loss, time 144ms
                          rtt min/avg/max/mdev = 0.531/0.678/0.850/0.122 ms



                          Kommentar


                            #14
                            Mach doch lieber einen eigenen Thread auf...

                            Kommentar


                              #15
                              Wenn Du schon nach der Anleitung vorgehst, verstehe ich nicht warum Du da die ganzen Kommandozeilenparameter dranhänst. Mach doch erstmal den ersten Schritt bevor Du da jede Menge Parameter dranhängst. Im Übrigen wären Sachen um den knxd im entsprechenden Unterforum besser aufgehoben...

                              Kommentar

                              Lädt...
                              X