Ankündigung

Einklappen
Keine Ankündigung bisher.

Fertig: DFF4.1 - Roto RotoTronic Dachfenster Aktor

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Hallo Roland,

    da Alex aktuell in Urlaub ist versuche ich deine Fragen zu beantworten.

    Es ist so, jeder möchte einen vernünftigen Preis. Das kann man nur ab einer bestimmten Menge an bestellten Teilen erreichen.
    Wenn ich richtig im Kopf haben sind es z.B. 100 Relais... (bitte nicht festnageln).
    Bei den Gehäusen ist es ähnlich. Da verlangt der Hersteller einen Zuschlag wenn man unter Summe xyz (ich glaube 100 Euro netto) liegt.
    D.h. wenn man unter 100 Euro bleibt verschenkt man das Geld. Wenn man für 100 Euro einkauft, dann kommt man schon auf ca. 10 Gehäuse-Bausätze... Unschön ist nur wenn man gerade nur 1-2 braucht. Die anderen liegen dann rum und das Geld ist vorerst weg. (So ist bei meinen MicroBCUs und MIs der Fall. Ich bin in Vorleistung gegangen und mehrere hundert Euro investiert. Wenn ich nicht alle MicroBCUs und MIs verkaufe, dann bleibe ich auf den Kosten sitzen.)

    Jetzt kommen wir zum Gehäuse drucken.
    1. Wir haben aktuelles Gehäuse ausgewählt weil es flexibel genug ist, und viele Abdeckungen bietet. Und es ist ein einziges Gehäuse, das auch KNX-Klemmenabdeckung hat. Man könnte meinen: "braucht man nicht unbedingt"... Ich würde sagen: "doch!". Grund ist einfach: entweder man fängt an zu basteln und Gehäuse/andere Abdeckung zurecht schneiden -> unschön, viel Arbeit und sieht wirklich nach Bastlerei aus, oder komplett ohne Abdeckung -> da ist die Platine wo die Pins für die KNX-Klemme verlötet sind komplett nagt. D.h. Berührungsschutz ist nicht ohne weiteres gegeben. Und beim REG ist 230V überall...
    2. Man könnte praktisch ein beliebiges REG-Gehäuse nehmen und nur die KNX-Klemmen drucken lassen. Sieht zwar auch nicht mehr so professionell aus, aber so ist man flexibler und sicher genug. Nur, jemand muss sich hinsetzen und diese Abdeckung designen. Da kommt noch Logistik ins Spiel. Ich habe z.B. einen 3D-Drucker (3D designen kann ich noch nicht). Alex hat keinen. D.h. ich müsste die Teile drucken, an Alex schicken. Das bedeutet wieder extra Aufwand, extra Kosten... ob es wirklich billiger ist als bei einem bekanntem Hersteller zweifele ich...
    3. Komplettes Gehäuse drucken. a) Jemand muss designen... auch alle Abdeckungen dazu... b) man muss Feuerbeständigkeit beachten, d.h. richtiges Filament nutzen. c) sieht nicht unbedingt schön aus: https://www.thingiverse.com/thing:1129148

    Jetzt zurück zum Thema: Falls jemand bereit ist ein paar hundert Euro in die Hand zu nehmen und "Lager befüllen" und die Sammelbestellung organisieren, dann wird wahrscheinlich Alex da mitspielen.

    Gruß
    Eugen

    Kommentar


      #17
      Hallo Eugen,

      erstmal vielen Dank für die ausführliche Antwort und vor allem für euer gemeinschaftliches Engagement in der KNX kompatiblen Hardwareentwicklung mit allem was dazu gehört!

      Das mit dem Gehäuse war ja nur so eine Idee und dass sowas nicht von alleine existiert und das jemand machen muss, ist mir auch klar. An die Punkte Brandschutz und die damit verbundene Materialfrage, habe ich in der Tat zunächst nicht gedacht. Das so ein Teil dann evtl. nicht "ganz sooo professionell" aussieht, wäre mir eigentlich egal. Im besten Fall "verschwindet" das Teil doch im REG-Schrank und wird ja nicht täglich in Augenschein genommen (dennoch verstehe ich den damit verbundenen Anspruch :-) ) Aber was nützt mir denn der schönste Bausatz, wenn es dafür leider keine Teile gibt? Und das jetzt bitte nicht als Kritik verstehen, mir ist das Problem der Mindermengenzuschläge und die damit verbundene Lösung der Sammelbestellung bekannt.

      Das ich geschrieben hatte, dass es wohl an der Verfügbarkeit der Gehäuse scheitert, hatte damit zu tun, dass Alex mir schon mal signalisiert hatte, dass es evtl. noch einige elektr. Bauteile, so auch unter anderem noch MicroBCUs von Dir, geben könnte, die für einen Bausatz möglicherweise reichen würden. Das das im allgemeinen Fall für viele der verwendeten Bauteile gilt, ist mir ebenfalls klar.

      Ich persönlich habe Interesse an zwei solcher DFF Bausätze. Damit sich das auch irgendwann mal vlt. realisieren lässt, hatte ich versucht hier im Forum eine solche Sammelbestellung zu initiieren, oder wenigstens weitere Interessenten zu finden. Die konkrete Bestellung sollte dann aber doch lieber jemand übernehmen, der auch Ahnung davon hat. Und bei der letzten Aktion hat Alex doch auch immer je nach Geldeingang neue Bestellungen ausgelöst, ich denke, um mögliche Risikoauslagen seinerseits zu minimieren und das ist auch in Ordnung so.

      Also bin ich weiterhin in geduldiger Hoffnung hier weitere Interessenten und engagierte Mitstreiter zu finden...

      viele Grüße
      Roland

      Kommentar


        #18
        Gehäuse bräuchten wir ca. 10 Stück damit sich die bestellBes lohnt.

        3D drucken... Ich glaube das lohnt noch weniger. Vor allem weil die Platinen auf die OKW Gehäuse abgestimmt sind. Da müsste man erst noch ein oassepass gehauGe konstruieren.

        Kommentar


          #19
          wenns um ne kleinere Menge Gehäuse geht kann ich evl. aushelfen, falls du dann damit irgendwas anderes aufbrauchen kannst oder so.

          Kommentar


            #20
            Ich muss gestehen dass ich die vergangenen Wochen auch wenig Zeit hatte mich darum intensiv zu kümmern.

            Es gibt in der Tat drei Knackpunkte:

            1) Das Gehäuse. Eine Bestellung macht erst ab 10-12 Gehäusen Sinn, denn unter 100EUR Netto-bestellwert kommt ein Krasser Mindermengenaufschlag dazu. Ich werden den Hersteller OKW mal dazu befragen ob er noch eine andere Lösung für uns hat. Ggf. gibt's ja doch Händler die an Privatpersonen liefern und kleine Mengen ausliefern.

            2) BCU ... Man kann für rund 26EUR eine SiemensBCU nehmen (und muss dafür wieder mehr Bauteile bestücken, weil man neben den 5V auch 3.3V braucht), oder man nimmt Eugen's MicoBCU für 19EUR. Eugen hat die für gewöhnlich nicht unbedingt im Regal liegen. Aktuell zeichnet es sich aber ab, als gäbe es hier einen ausreichend großen Puffer aus dem man sich bedienen kann.

            3) Bauteile ... Da ich nicht alles bei Reichelt oder Conrad bekomme, muss ich bei mehreren Lieferanten bestellen. In der Tat sind das mindestens Digikey USA, Reichelt und Conrad. Auch bei Digikey gibt es eine Art Mindermengenzuschlag in Form von "hohen Versandkosten". Reichelt und Conrad haben das nicht, aber die Versandkosten lassen den Gerätepreis auch ein wenig anwachsen.

            Wenn mich nicht alles täuscht, dann habe ich für 2-4 Sets noch Teile da. Aber es hapert an den Gehäusen.
            Wenn ich mit Beta5 schon fertig wäre, dann hätte ich noch einige andere Geräte in der Pipeline, wo ich auch Gehäuse brauche. Aber da ich so schnell nicht dazu komme weitere Geräte zu entwickeln (weil beta5 fertig werden muss), will ich mir da auch nicht 100EUR an Gehäusen ins Regal stellen und einstauben lassen.


            2-3 Gehäuse würde ich mir noch zulegen. Plus zwei von dir higgx wären schon 5. Fehlen noch weitere 5 für eine Sammelbestellung.

            Oder andi11 hat noch zwei Gehäuse für dich, dann schau ich dass ich das Material für Platinen und Co. zusammenkratze ...

            Alles in allem: Mir gefällt die Situation der notwendigen Sammelbestellung auch nicht. Mir wäre es lieber ich könnte die Teile für einzelne Sets bei Reichelt und Co. bestellen. Aber je mehr Qualität man in ein Gerät steckt, desto aufwendiger sind die Teile.
            Wenn wir einen Lieferanten für das Gehäuse finden würden, bei dem man ab 1-3 Gehäusen schon bestellen kann, wäre uns sehr geholfen.

            Es gibt auch günstigere, einfacher zu beschaffende Gehäuse. Aber zum einen ist die Qualität eine andere, und zum anderen sind diese nicht für KNX Klemmen vorgesehen. Klar, KNX mann man auch mit Schraubterminals verbinden. Aber wie lautet eine Signatur hier im Forum: Das kann man schon so machen, aber dann ist es halt kacke.

            Gruß
            Alex

            Kommentar


              #21
              So, OKW angeschrieben und auch Antwort erhalten. Ich hab nun einen Händler der die Teile auch einzeln anbietet und kein Mindermengenzuschlag will.

              Bestelle ich 10 Gehäuse inkl. aller Abdeckungen, liegt der Preis pro gehäuse bis es bei mir auf dem Tisch liegt bei 12,22EUR.

              Die Abdeckungen kann man nur im 10er-Pack bestellen, was den Preis für ein einzelnes Gehäuse etwas nach oben treibt. Bestellt man also nur ein Gehäuse, liegt der Preis bei 29,25EUR inkl. VSK. Dafür hat man dann 6 perforierte Abdeckungen für Schraubklemmen, 9 KNX Abdeckungen und 7 Abdeckungen mit Lüftungsgitter und 8 Schrauben "übrig".

              Zwei Gehäuse liegen dann bei rund 18EUR pro Stück.
              Drei liegen bei 16EUR

              Ich finde, 18EUR ist so die persönliche Schmerzgrenze für ein Gehäuse...

              Wenn man ca. 5 Stück zusammen bekommt ist der Preis echt akzeptabel.

              higgx Ich schau die Woche mal dabeim was noch an Material da ist und melde mich wieder bei dir.
              Zuletzt geändert von tuxedo; 04.09.2018, 14:06.

              Kommentar


                #22
                also ich hab mal gestöbert. Max 3 Gehäuse hätte ich.

                Kommentar


                  #23
                  die MicroBCUs werden Ende dieser Woche wieder ausreichend "im Regal" liegen.

                  Kommentar


                    #24
                    Hey Leute, ihr seid echt großartig! Würde mich wirklich freuen, wenn das was wird.

                    Die Gehäuse scheinen ja echt begehrt und vielseitig zu sein. Da ich sonst im Moment nicht viel zu den Konnekting Projekten beitragen kann, könnte ich mir als meinen Beitrag vorstellen z.B. 10 von den Gehäusen vorzufinanzieren und Alex oder wer auch immer kann mir das Geld dann je nach Warenausgang wieder rücküberweisen. Das hätte doch den Vorteil, dass nicht jeder 10 von den Gehäuseabdeckungen kaufen müsste, oder?

                    Solange nehme ich aber auch gerne die Gehäuse vom Andi11

                    Vielen Dank schon mal für eure Unterstützung und viele Grüße
                    Roland

                    PS: wie geht das eigentlich hier im Forum mit den Links auf die Member? Oder andere Verlinkungen? Oben die Kette zeigt mir dann ein großes Fenster an, in dem ich den Link dann auch eintragen kann, aber in der Vorschau erscheint es dann irgendwie nicht...

                    Kommentar


                      #25
                      Hallo higgx (bzgl. Namensnennung im Beitrag: Ein '@' Zeichen eingeben, gefolgt vom Usernamen...),

                      das mit der Vorfinanzierung ist ein tolles Angebot, macht den gesamten Prozess aber ein wenig komplexer. Dadurch dass wir nun einen alternativen Händler haben, wo es sich schon bei 5 Gehäusen rechnet, ist die Situation schon deutlich entschärft. 5 Stück kann ich auch auf Lager legen.

                      Den zwei Aktoren für dich steht nun eigtl nichts mehr im Weg. Ich schicke dir ne PM mit den Details.

                      Gruß
                      Alex
                      Zuletzt geändert von tuxedo; 11.09.2018, 12:33. Grund: falsche wortwahl

                      Kommentar


                        #26
                        Hallo @tuxedo,

                        ich habe mal einen Log mitgeschnitten. Dabei habe ich folgendes gemacht.

                        Aktor gestartet (Fenster öffnen) und 2s laufen lassen (handgestoppt)
                        dann 8s Pause (bis Sekunde 10)
                        2s laufen lassen
                        8s Pause (bis Sekunde 20)
                        2s laufen lassen
                        10s Pause (bis Sekunde 32)

                        alles von Hand gestoppt, deshalb natürlich keine ganz exakten Zeiten.
                        Erwartung ist: Eigentlich sind es ca. 6s reine Fahrzeit und entspricht somit 1/5 der Gesamtfahrzeit -> Aktor sollte also von 20% Fensteröffnung ausgehen.
                        Tatsächlich sind die Zeiten und Positionen alle so, als hätte ich nicht den Stop-Button gedrückt. Nur das Logging wurde unterbrochen.
                        Nach der letzten Pause bei Sekunde 32 jedenfalls sagt der Aktor das Fenster sei 100% geöffnet und setzt auch die LED entsprechend.

                        Da ich nicht weiß, wie ich einen Log hier sinnvoll ablegen kann, hier ein Link auf Google Docs (hoffe, dass das funktioniert)
                        https://docs.google.com/document/d/1...it?usp=sharing

                        viele Grüße
                        Roland
                        Zuletzt geändert von higgx; 27.11.2018, 12:42.

                        Kommentar


                          #27
                          Du kannst deinem Post auch ein Attachment hinzufügen. Oben rechts neben dem Antworten-Feld gibt's das Icon mit dem Blatt Papier und der Büroklammer.

                          Kommentar


                            #28
                            Hab das Log mal runtergeladen und ausseinander genommen:

                            Zeile 2006: Position steht auf 5%,. Letzter gesendeter Status ist 0x09(hex) im Bereich 0..255 Das entspricht also 3,5%.Gesendet wir nur alle paar sekunden, sonst würden wir den Bus fluten.
                            Zeile 2010: Hier kommt der erste Stop per Button am Aktor rein.
                            Zeile 2022: Merkwürdigerweise steht hier was von 0% Position.
                            Zeile 2023: Und diese 0% werden wohl auch noch gesendet?!

                            Zumindest laut Log wäre hier schon der erste Fehler.

                            Zeile 2041: Hier sind wir wieder bei einer korrekten Position. 6,8%. Das passt wieder ins Bild.
                            Zeile 2043: Duration: 10114 .... Da summieren sich in der tat die 8sec und 2sec auf 10sec auf, was nicht sein sollte.
                            Zeile 2045: Jetzt wird's wieder schräg: Auf einmal 33% ...wohl basierend auf den falschen 10sek Dauer.
                            Von da an summiert sich das auf fast 22sek auf:
                            Zeile 5782: duration: 21678 ....
                            Zeile 5784: Schon 70% erreicht.
                            Zeile 5793: Erneuter Stop per Button
                            Zeile 5815: Manuelles öffnen ...
                            Zeile 5819: ... beginnend bei 72%
                            Zeile 5821: duration: 32315
                            Zeile 5822: aber: allowed time open: 30600
                            --> Limit erreicht, muss also schon ganz offen sein:
                            Zeile 5832: STATUS SEND curr pos: 1.000000 -> 0xff





                            Ich bin mir nicht 100% sicher ob ich alle Statis wie sie auf dem Bus auftauchen auch im Log wiederfinde bzw implementiert habe. Eigentlich müsste man, um es richtig zu testen, die einzelnen Status-KOs mit GAs belegen und dann im Gruppenmonitor schauen. Das war zumindest das, was ich zuletzt überprüft hatte und ist auch das worauf es ankommt. Und das ist auch das, was ich bis zum umfallen getestet und verifiziert hatte. Würde der Aktor worklich so krass "falsch" laufen, hätten sich (hoffentlich) die anderen die den Aktor nun ebenfalls (hoffentlich) in Betrieb haben, schon gemeldet. Das ist das was mich aktuell massiv verwirrt.

                            Wie dem auch sei: Ich bin diese Woche geschäftlich unterwegs und kann das nicht direkt ausprobieren. Bis ich wieder zurück bin lautet also die Empfehlung: Hänge an die Status-KOs Test-GAs und schaue dir das ganze im Gruppenmonitor in der ETS nochmal an wenn der Aktor arbeitet.
                            Sollte es auch hier nicht passen müssen wir schauen dass wir die Ursache finden, bzw. ich das bei mir reproduziert bekomme. Vielleicht hast du ja doch noch einen falschen Software-Stand erwischt...

                            Gruß
                            Alex



                            Kommentar


                              #29
                              Ok hab den gleichen Test wie zuvor beschrieben noch mal in der ETS geloggt... ( ETS Log.txt )

                              Ist das gleiche Verhalten zu beobachten.. Sprünge (vor und zurück) in der Positionsberechnung, ganz analog zum anderen Log-file. Außerdem dass der Aktor durch einen Doppelklick nach 32s quittiert, dass das Fenster vollständig geöffnet sei, spricht ja auch dafür, dass da intern die Zeit- und Positionsberechnung etwas durcheinander kommt... kann also nicht nur eine fehlerhafte Logmeldung sein.

                              Softwarestand ist der, den man vom GitHub bekommt... (letzter Commit scheint vom 06.06.18 8:39h zu sein)

                              Dann lass ich dich mal in Ruhe, bis du Gelegenheit hast wieder danach zu schauen. Bin eigentlich fast sicher, dass es sich nur um eine fehlerhafte oder fehlende Initialisierung der _startMoveMillis handeln kann oder dass die Zwischenpositionsstände nicht richtig zwischengespeichert werden. Aber da bin ich noch nicht so weit in den Code vorgedrungen, dass ich da schon die richtige Stelle gefunden hätte noch dass ich sicher bin, ob das auch genau der Fehler ist.
                              Angehängte Dateien
                              Zuletzt geändert von higgx; 27.11.2018, 16:51.

                              Kommentar


                                #30
                                Werde mir das heute anschauen. Hab den Fehler mit meinem Aktor schon reproduzieren können.
                                Bildschirmfoto vom 2018-12-06 09-44-27.png
                                Hab den Aktor auf 47s Öffnungszeit eingestellt, hab rund 23sek (also rund 50%) öffnen lassen. Bin auch bei den geplanten rund 50% angekommen, aber beim Stoppen springt er tatsächlich auf 0%.

                                Kein Plan wie mir das nicht auffallen konnte. Vermutlich weil ich immer nur mit absoluten Positionen fahre?
                                Angehängte Dateien
                                Zuletzt geändert von tuxedo; 06.12.2018, 11:30.

                                Kommentar

                                Lädt...
                                X