Ankündigung

Einklappen
Keine Ankündigung bisher.

Supportthread für UZSU Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #76
    Die Pakete hast du alle installiert?

    https://www.smarthomeng.de/user/plug...highlight=uzsu

    und auch die Requirements?

    Code:
    pip3 install -r plugins/<pluginname>/requirements.txt --user

    Kommentar


      #77
      Bei SmartHomeNG v1.7 installieren sich die requirements selbstständig.
      Viele Grüße
      Martin

      There is no cloud. It's only someone else's computer.

      Kommentar


        #78
        Oh. Da hab ich wohl den Go-live verschlafen Vielen Dank für die Info. Und vor allem vielen Dank für die ganze Arbeit und den Einsatz. Da muss ich schnell auf 1.7 nachziehen. Ich sag nur struct in struct. Klasse.

        Kommentar


          #79
          Wobei scipy und numpy am Raspi ordentlich Ärger macht. Am besten darüber installieren:
          https://www.piwheels.org/project/scipy/
          https://www.piwheels.org/project/numpy/

          Andererseits würde shng gar nicht starten, wenn die Requirements nicht erfüllt wären bzw. wie msinn sagt automatisch installiert werden.
          Zuletzt geändert von Onkelandy; 07.04.2020, 09:45.

          Kommentar


            #80
            es lag an der Visu Version, umgestellt auf 2.9 Master und es funktioniert.

            Vorher musste ich allerdings scipy und numpy neu installieren.

            Vielen Dank für eure Hilfe!

            VG Gatzi

            Kommentar


              #81
              Mobile Ansicht:
              Im Portrait-Modus fehlt der Experte-Button wo ich Sonnenaufgang etc. Einstellen kann.
              im Landscape-Modus ist er da.
              In der Desktop-Ansicht ist alles ok.

              Getestet im Chrome, Firefox und Opera auf einem Smartphone.
              ​​​
              Angehängte Dateien
              Zuletzt geändert von wolder; 19.04.2020, 06:53.

              Kommentar


                #82
                Ja. Das ist Absicht - aus Platzgründen.

                Gruß
                Wolfram

                Kommentar


                  #83
                  also scipy ist in ordnung habe schon 1.4.1 probiert uhnd auch 1.2.1 sowie die 1.3.5 aber immer das gleiche ergebniß.

                  2020-05-18 18:44:34 WARNING Main Unable to import Python package 'scipy' which is necessary for interpolation.
                  2020-05-18 18:44:34 WARNING Main Unable to import Python package 'scipy' which is necessary for interpolation.
                  2020-05-18 18:44:34 ERROR Main Plugins: Plugin 'uzsu' initialization failed, plugin not loaded
                  2020-05-18 18:44:34 ERROR Main Plugins: Plugin 'uzsu' initialization failed, plugin not loaded

                  debian Buster smhg 1.7.1 visu 2.9 alles neu. Auch für den --user

                  Kommentar


                    #84
                    Hast du verschiedene Python Environments? Ist wirklich für den smarthome User alles richtig installiert? Was sagt der PyPi Tab im Admin Tool (nach Deaktivieren vom uzsu Plugin)

                    Kommentar


                      #85
                      habe das alles schon mehrmals durch und auch user ist richtig anbei admin tool pypi mit scipy1.2
                      hatte auch schon die 1.3 aber das gleiche ..
                      Angehängte Dateien

                      Kommentar


                        #86
                        Nächstes Mal bitte als jpg nicht gezipptes bmp

                        beim Fehler bin ich überfragt

                        Kommentar


                          #87
                          norm_normal_file_format.png

                          Kommentar


                            #88
                            Schau mal hier:

                            https://knx-user-forum.de/forum/supp...zsu-nicht-mehr

                            Kommentar


                              #89
                              Na ja guter Tip, fehler war , das die libadlas noch nicht da war also install gemach und uzsu geht.
                              Danke

                              Kommentar


                                #90
                                Hallo zusammen,

                                ich bekomme seit ein paar Tagen einen Fehler von der uzsu im log geliefert:
                                Code:
                                2020-06-02 23:50:00 ERROR plugins.uzsu Problems assigning dmin: day is out of range for month. Wrong syntax: 18:00<sunset+210m<23:50. Should be [H:M<](sunrise|sunset)[+|-][offset][<H:M]
                                2020-06-02 23:50:00 ERROR plugins.uzsu Error '18:00<sunset+210m<23:50' parsing time: 'NoneType' object has no attribute 'strftime'
                                Das passiert wohl, seit sunset+210m nach Mitternacht liegt.
                                Die obere Grenze (23:50) habe ich angegeben, weil ich befürchtet habe, dass es zu Problemen kommen kann, wenn eben der Schaltzeitpunkt nach Mitternacht liegt. Ist diese Vermutung richtig, oder ist die obere Grenze nicht nötig? Die untere Grenze (18:00) habe ich dann testweise angegeben, falls bei oberer Grenze auch eine untere angegeben werden muss (das stimmt vermutlich aber nicht)
                                Das uszu Item wurde über das popup Widget aus der smartVisu (2.9) beschrieben und sieht eigentlich richtig aus (insbesondere die angemerkte 'wrong syntax' müsste doch eigentlich korrekt sein, oder?):
                                Code:
                                {'interpolation': {'type': 'none', 'initialized': False, 'itemtype': 'bool', 'interval': '', 'initage': ''}, 'list': [{'active': True, 'rrule': 'FREQ=WEEKLY;BYDAY=MO,TU,WE,TH,FR,SA,SU', 'value': '1', 'calculated': '21:40', 'time': 'sunset+30m'}, {'active': True, 'rrule': 'FREQ=WEEKLY;BYDAY=MO,TU,WE,TH,FR,SA,SU', 'value': '0', 'calculated': '23:50', 'time': '18:00<sunset+210m<23:50'}], 'active': True, 'lastvalue': '0', 'sunrise': '05:10', 'sunset': '21:10'}
                                Sh Version ist 1.7.1, uzsu 1.5.3, müsste also alles aktuell sein und wurde nach Anleitung auf einem docker container installiert.

                                Viele Grüße
                                Franz

                                Kommentar

                                Lädt...
                                X