Ankündigung

Einklappen
Keine Ankündigung bisher.

WOLi2

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zitat von trax Beitrag anzeigen
    das Zauberwort heißt "intent" - und WOli kann eines an Tasker senden. Auf der Website ist das Beispielhaft erklärt - also einfach die GA vom PM auf SendIntent und Tasker den Übergabewert auswerten lassen...
    auf sendintent bin ich mittlerweile gestoßen. Leider fehlt mir da auf tasker seite die erfahrung den bildschirm ein/aus zu schalten. Oder welchen task würdest du dort wählen. Hast du evtl auch einen screenshot wie tasker die dazen empfängt versrbeitet? Da muss doch irgendwo auch ein Unterschied zwischen 1 und 0 von der GA abgefragt werden, oder?

    Wanni (dem Tasker noch ein Buch mit sieben Siegeln ist)


    Kommentar


      sorry wanni ... aber Tasker Support kann ich hier keinen leisten - ev. im Tasker Forum
      Grüße
      Christian
      __________________
      Developer of WOLi

      Kommentar


        Hallo Wanni

        Ich verwende http://llamalab.com/automate/ mit dem habe ich geschafft von Woli zu empfangen und zu senden.

        Derzeit sende ich Akku Stand und Laden über Woli ins KNX.

        Empfange von Knx über woli Display ein und starte App ( App wir nur dann gestartet wenn Display aus ist, und Visu wir die starte Seite aufgerufen )

        Wenn du Interesse hast melde ich

        Kommentar


          @michael: Oh ja das klingt interessant

          @trax: kein Problem, wollte auch nur fragen ob es da son Standard Ding gibt was du per copy paste rausgehauen hättest

          Kommentar


            wanni
            Hier die Dateien für den Empfang und Senden über Automate http://llamalab.com/automate/

            Die Datei mit der Endung txt muss noch in .flo umgeschrieben werden.

            Weiteres habe auch jetzt neu den befehl "Startseite" das macht wenn das Display ausgeht schickt es einen Befehl über das Knx an den Edomi um auf die Startseite zu Wechseln

            Anbei noch wie es auf der Visu ausschaut

            Angehängte Dateien

            Kommentar


              Hallo zusammen,

              ich muss mich einfach mal hier melden, bin so langsam am verzweifeln... ich habe Woli auf keinem meiner Geräte ans Laufen gebracht (Fire7, Galaxy Tab A, Medion Lifetab, Galaxy S8). Ich habe dann mal die Beta installiert als auch die V0.18 mit fast immer dem gleichen Ergebnis.... und heute bin ich per Zufall mit meinem Tab auf meiner FritzBox im "Gast" Netz gelandet und siehe da, ich bekomme Woli zum laufen, d.h. ich kann es starten, sehe nun auch oben meine IP.

              Melde ich das Gerät im "normalen" WLAN an, dann sehe ich die IP nicht mehr (IP Address: not available) und kann den Dienst nicht starten, egal was ich mache, ich dachte zuerst es liegt an den Sonderzeichen in der SSID, ist es aber nicht, habe dann einen neuen AccessPoint installiert, komme auf das Netz, erhalte eine IP, aber kann Woli nicht starten, ich sehe oben die IP nicht. Ich nutze intern auf meiner FritzBox einen internet konformen IP Adressbereich (194.xxx.xxx.xxx) und keinen privaten IP Adressbereich, kann das daran liegen? glaube ich ja nicht... ich finde auch keine Einstellung auf dem Router was ich noch anpassen könnte.

              Wenn ich die V0.18 installiere, dann sieht das auf allen Geräten etwas anders aus, ich sehe zwar auch oben die IP-Adresse nicht und der "start" Button ist nicht da, aber ich sehe meine KNX-Schnittstellen, die Siemens als auch den MDT-Router, verbinden kann ich mich aber trotzdem nicht...

              Hat ev. einer von euch sowas auch schon gehabt und eine Lösung/Einstellung für mich?

              Kurz zu meiner Person... bin recht neu hier und auf der Suche nach einer Visualisierung auf das Forum gestoßen, echt viele gute Infos, was mir sehr geholfen hat. Unsere EIB/KNX Installation habe ich im Zuge unseres Neubaus seit 2000 am laufen und bis 2005 immer wieder erweitert.

              Viele Grüße
              Gerald
              Angehängte Dateien

              Kommentar


                ... das ist ja interessant !
                vor Allem, dass vom System scheinbar nicht mitgeteilt wird, dass eine Verbindung besteht wenn du im 194er Netz bist (soweit ich das richtig verstehe)
                "not connected" wird ausschließlich dann ins Log geschrieben, wenn NetworkInfo fürs aktive Netzwerk null (also nicht vorhanden) ist. Würde also (eigentlich) bedeuten: es existiert keine aktive Netzwerkverbindung.

                Vermutlich ist UDP Multicast in deinem Gastnetzwerk nicht möglich oder das Subnetz in dem sich die Gateways befinden nicht erreichbar/sichtbar.

                [Edit]
                ... tja... im vorliegenden Fall ist doch das 194er Netz das Problem, denn die IP wird auf "verwendbare Plausibilität" getestet, indem LoopBack Adressen ausgeschlossen und nur private Adressen zugelassen werden.
                In meinen Augen ist das absolut sinnvoll - und die Verwendung nicht privater Adressen im LAN (eher) suboptimal...
                Zuletzt geändert von trax; 12.03.2018, 21:53.
                Grüße
                Christian
                __________________
                Developer of WOLi

                Kommentar


                  Hallo Christian,

                  ... Danke für's Feedback.
                  Richtig, in meinem 194er Netz sind alle meine Komponenten, z.B. IP .20 bis .100 für DHCP und darüber für feste IP's wie Server, Drucker und meine KNX Gateways. Mit allen Geräten kann ich wunderbar auf alle Ressourcen zugreifen, bis jetzt ohne Probleme. Auch der EDOMI Server hat keinerlei Abbrüche oder Laufzeitprobleme mit dem MDT Router für den KNX-Bus als auch das Siemens IP-Gateway nicht. Das Netz ist auch nicht segmentiert, also ein kompl. Class C Netz.

                  Wenn ich die V0.18 installiere, dann findet er meine KNX Router/Gateway und ich kann auswählen, aber zeigt auch nicht die IP oben an (not available) ... im Netz sind die Geräte alle, kann sie auch "anpingen" und auf meinen Edomi-Server kann ich ohne Probleme zugreifen, nur eben bekommt Woli nichts mit....

                  Sobald ich in meinem Gastnetz bin (intern 192.168.179.xxx) läuft Woli, lässt sich starten... ich habe nur keine Verbindung mit meinem eigentlichen Netzwerk und kann die Einstellungen nicht beeinflussen, ist eben eine FritzBox 7490.

                  Ich werde morgen noch einmal versuchen eine IP-Schnittstelle in das Gastnetz zu hängen und dann mal versuchen ob Woli kompl. funktioniert... ich denke dass es irgend eine Einstellung für das Netzwerk ist.

                  Viele Grüße
                  Gerald

                  Kommentar


                    Gerald...
                    ... ich denke du hast mich missverstanden:
                    - WOLi funktioniert nur in privaten Netzwerken - das ist so beabsichtigt.
                    Grüße
                    Christian
                    __________________
                    Developer of WOLi

                    Kommentar


                      Hallo Christian,
                      sorry, Dein [Edit] hatte ich nicht gelesen, da meine Antwort etwas länger gedauert hatte, ich war dazwischen immer wieder am "testen" und habe nach dem senden nicht nach oben geschaut. ... super... das erspart mir einiges... oder auch nicht ;o) ich werde dann meinen Adressbereich ändern....

                      Nur zur Info: ich hatte für meine Firma in den 90er Jahren 16 internet konforme class "C" Netze reserviert/geerbt, das ging da sehr einfach, weil es eine Abspaltung von einem großen Chemiekonzern war. Damit hatte ich dann alle unsere Niederlassungen in Deutschland mit je einem class "C" Netz versorgt. Der 194er Bereich war meine "Niederlassung" im Rheinland, welche ich später übernommen und die Geschäfte auf eigene Rechnung fortgeführt habe... ich hatte einfach keine "Lust" gehabt, die ganzen fest vergebenen Adressen der Server zu ändern, da einige in Datenbanken fest "verdrahtet" sind. Ich werde das Thema dann wohl doch angehen.

                      Danke für Deine Hilfe.
                      Viele Grüße
                      Gerald

                      Kommentar


                        Hallo Christian,
                        heute mußte ich mein Tablet zurücksetzen und Woli neu konfigurieren.
                        Das Produkt gefällt mir immer noch sehr gut.

                        Bei dieser Gelegenheit habe ich als Url einen Webradiolink ausprobiert (zur Ansteuerung eines Bluetooth Lautspecher).
                        Beispiel:
                        http://mp3channels.webradio.antenne.de/antenne
                        Leider muss auf dem Samsung Tablet im Chrome- und WoliBrowser der Stream mit dem Playknopf zusätzlich gestartet werden :-(
                        Auf meinem PC muss der Playknopf nicht gedrückt werden!
                        Gibt es eine Einstellung im Betriebssystem oder im Woli, damit der Stream automatisch startet?
                        Weiter läuft der Stream beim Aufruf einer weiteren Webseite im Hintergrund oder unsichtbarem Tab weiter und bricht dann nach x Minuten ab.

                        Gruß
                        Andreas

                        Kommentar


                          Zitat von Andi99 Beitrag anzeigen
                          Hallo Christian,
                          Leider muss auf dem Samsung Tablet im Chrome- und WoliBrowser der Stream mit dem Playknopf zusätzlich gestartet werden :-(
                          .. welche Android Version ?, welches Tablet ?
                          -ich kann das nämlich nicht nachvollziehen, auf allen von mir Getesteten (u.a Android 4.1, 4.4, 5.1, 6.0) lief das sofort an - auch über WOLi.
                          Grundsätzlich weist das Video-Tag der HTML den autoplay Parameter auf - und sollte entsprechend automatisch starten.

                          Mal Betriebssystem und Chrome (sowie Android WebView) aktualisieren
                          Sonst leider keine Ideen ...
                          Grüße
                          Christian
                          __________________
                          Developer of WOLi

                          Kommentar


                            Hallo,
                            ich habe ein Samsung Tab7 mit Android-Version 4.4.2
                            Der oben genannte Link funktioniert heute über Woli mit dem Chrome Browser Version 65.0.3325.109 --> startet automstisch.
                            Im Woli Browser 0.38.5 muss ich den PlayKnopf drücken (siehe Anhang).



                            Gruß
                            Andreas

                            Kommentar


                              Gibt es eigentlich eine Option, dich ich nicht finde, dass Woli automatisch "gestartet" wird? Also nicht die App selbst, das klappt, aber dann muss ich immer noch auf "Start" tippen. Würde gerne bei einem Tablet-Neustart Woli starten und laufen lassen, ohne manuellem Eingriff.
                              Evtl. gibt es auch nen Workaround über Tasker oder Automate.

                              Danke für die Hilfe.
                              ---
                              Martin

                              Kommentar


                                Zitat von martinb07 Beitrag anzeigen
                                Gibt es eigentlich eine Option, dich ich nicht finde, dass Woli automatisch "gestartet" wird? Also nicht die App selbst, das klappt
                                Klar gib es das, du musst aber vorher einmal eine gültige Netzwerkeinstellung hinterlegen.
                                Ist hier sonst auch einfach erklärt https://knx-user-forum.de/forum/öffentlicher-bereich/knx-eib-forum/diy-do-it-yourself/33661-woli2?p=562281#post562281

                                Kommentar

                                Lädt...
                                X