Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

LBS Prognose PV-Ertrag -> Datenarchiv

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Bei mir läuft der LBS seit einigen Tagen alle 3h und habe diese Fehler noch nicht gehabt.

    Wenn du die Fehler reproduzierbar hast, dann liegt’s daher vermutlich an den Eingangsparametern; es lohnt sicher ein prüfender Blick. Mein Klassiker sind , statt . bei der Angabe vom Längen/Breitengrad oder kWp...

    Kommentar


      #17
      Nachtrag: Heute morgen um 6:00 hatte ich die selben Fehler erstmals. Aber um 9, 12 und 15 Uhr keine mehr. Daher wird es dann wohl doch weniger an den Parametern liegen, als am abgefragten Server. Vielleicht haben die am WE ein Wartungsfenster, wo es zeitweise mal nicht geht...

      Kommentar


        #18
        Hi,

        ich hatte den Fehler heute morgen auch zum ersten Mal im Log stehen. Ebenfalls genau um 6:00 anschließend funktionierte es wieder. Ich selbst trigger den LBS stündlich. Leider weiß ich nicht was da genau für eine xml angekommen ist. Denke da einfach etwas bei der Abfrage fehlerhaft. Ggfs müsste das xml noch nach der Abfrage überprüft werden. Werde ich mir mal anschauen.

        Kommen die Fehler bei euch häufiger vor?

        Kommentar


          #19
          gestern nacht mal wieder 1x. Also sehr sporadisch, nix was drängt.

          Ich schätze auch, dass es ein Fehler auf Sender-Seite ist. Da man ja oft genug abholt würde ich bei einem fehlerhaften XML den Lauf einfach ignorieren mit einem Satz im Log - das kann man dann nach Bedarf an/aus schalten. Man hat ja noch die letzten Werte und der nächste Lauf folgt ja bald.

          Kommentar


            #20
            Ok, ich schaue es mir an..... bin eh an einer Variante mit bis zu 3 Dächern dran. Denke werde ich am WE fertigstellen. Bin schon in der Testphase.


            VG

            Kommentar


              #21
              Hi,


              ich habe jetzt mal Hilfe usw. geschrieben. Es werden sich die Ein- und Ausgänge minimal ändern. Aktuell läuft der LBS und liefert auch richtige Ergebnisse.

              Allerdings habe ich noch ein Problem mit dem addieren der Gesamterträge pro Tag. Diese werden sauber auf die Ausgänge der einzelnen Dächer ausgegeben und auch auf den Gesamtausgang für Dach 1-3. Leider kommt es dabei aber zu einem Fehler im Log und ich bin gerade etwas ratlos warum. Der Fehler im Log ist:

              Code:
              A non-numeric value encountered
              Allerdings ist es numeric und wird auch so auf dem Ausgang ausgegeben. Hab auch schon einfach versucht ein +0 hinzuzufügen und auch (int), der Fehler bleibt allerdings bestehen. Wenn ich dies gelöst habe lade ich den LBS hoch.

              Kommentar


                #22
                Hi,


                also der neue LBS ist online. Viel spaß beim testen.

                Achtung: Ausgänge wurden leicht verändert.

                Kommentar


                  #23
                  Hi Benji,

                  vielen Dank. Habe meine 2. Instanz schon abgebaut und jetzt alles aus einer. Sieht bis jetzt gut aus.

                  Frage: Wenn man das Abfragelimit erreicht hat - merkt das der LBS bevor er die Ausgänge mit nichts beschreibt und die Archive gelöscht hat oder danach? Es scheint mir. Dein LBS macht es richtig weil ich gerade beim Testen rasch (und erstmals) ans Limit kam, aber meine Archive nicht leer sind. Allerdings die Gesamterträge an A3/A4 genullt. Daher vermute ich, die Antwort laute: DA löschen erst danach, Ausgänge aber davor/trotzdem.

                  Wenn ich das richtig vermute: Entweder man löst es hinter dem LBS (ist alles machbar) oder im LBS. Oder liege ich falsch und habe nur falsch getestet?

                  VG,
                  Carsten

                  Kommentar


                    #24
                    Hallo Carsten,


                    ja da hast du recht. Ich frage den Status des Fehlers(Ratelimit oder so) vor den Datenarchiven ab. Die Ausgänge werden allerdings trotzdem beschrieben. Dies ist etwas unglücklich, da muss ich dir recht geben. Ich werde ein kleines Update machen und dann die Ausgänge im Fehlerfall auf den alten Werten bestehen lassen.

                    VG

                    Kommentar


                      #25
                      Hi Benji,

                      heute Nacht hatte ich auch 2x
                      Code:
                      Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19002271.php | Fehlercode: 8 | Zeile: 173 | Undefined variable: akt
                      Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19002271.php | Fehlercode: 8 | Zeile: 173 | Undefined variable: akt2
                      Hatte noch keine Zeit, selber zu schauen, was das sein könnte. Werte habe ich aber wie es scheint.

                      Nachtrag 8:00: Ich habe auf jeden Fall Werte. Keine Eile daher...

                      VG,
                      Carsten
                      Zuletzt geändert von saegefisch; 11.05.2021, 07:06.

                      Kommentar


                        #26
                        Hi,

                        schaue ich mir auch an. Wird sich aber wohl auch mit dem prüfen der Abfrage erledigen. Die variablen sind eigentlich die Werte der aktuellen Stunde von Dach 1 und 2

                        Kommentar


                          #27
                          benji : Danke für Deinen Baustein. Ich habe den Fehler auch und habe mal mitgeschrieben, welches Ergebnis von der URL kommt, wenn der Fehler auftritt:

                          Code:
                          <html><head><title>Error</title><style>body{margin:0;padding:30px;font:12px/1.5 Helvetica,Arial,Verdana,sans-serif;}h1{margin:0;font-size:48px;font-weight:normal;line-height:48px;}strong{display:inline-block;width:65px;}</style></head><body><h1>Error</h1><p>A website error has occurred. The website administrator has been notified of the issue. Sorry for the temporary inconvenience.</p></body></html><?xml version="1.0" encoding="UTF-8"?>
                          <response>
                          <result></result>
                          <message>
                          <code></code>
                          <type>error</type>
                          <text></text>
                          <info></info>
                          <ratelimit>
                          <period>3600</period>
                          <limit>60</limit>
                          <remaining>57</remaining>
                          </ratelimit>
                          </message>
                          </response>
                          Eventuell kannst Du das ja mit einem Errorhandler abfangen? Ich hätte eine Bitte, könntest Du eventuell in den Baustein einen neuen Eingang APIKey einbauen? Ich habe für 12 Euro/Jahr einen Key bestellt. Die URL würde dann so ausschauen:
                          Code:
                          $url = 'https://api.forecast.solar/' . $apikey . '/estimate/watts/'. $lat . '/' . $lon . '/' . $dec . '/' . $az . '/' . $kwp . '.xml';
                          VG
                          Matthias

                          Kommentar


                            #28
                            Hi,

                            werde mir das mit den Änderungen bzgl. Fehler anschauen. In diesem Zuge dann auch das mit dem API, sollte normal kein Problem sein.

                            Ich schaue mal ob ich über Pfingsten dazu komme.

                            Kommentar


                              #29
                              maque

                              Hallo Matthias,

                              hast du deinen API-Key schon? Ich wollte eben einen machen zum Testen, ging allerdings nicht. Wurde ein Fehler gemeldet bei Paypal.



                              Ich hatte mal ein LBS zusammengebaut mit API Key. Wenn du eine EDOMI Spielwiese am laufen hast kann ich dir den gerne mal via E-Mail zukommen lassen zum testen.
                              Wie viele Dächer hast du in der Abfrage aktiv?


                              VG Benjamin

                              Kommentar


                                #30
                                Hallo Benjamin,

                                hört Sicht gut an. ja, ich habe den Key schon und natürlich eine „Spielwiese zum Testen. Ich kann dir den auch gerne mal als PM schicken. Ich habe nur eine Dachfläche.
                                VG
                                Matthias

                                Kommentar

                                Lädt...
                                X