Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS 19000141 - Beschattungssteuerung

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #46
    Ich habe das gleiche Problem (siehe hier), aber trotz den folgenden Hinweisen (z. B. hier) noch nicht hin bekommen, die Rollläden sind auf 0 wie sie sollen, aber A2 ist immer noch 1.

    Kommentar


      #47
      Hallo und guten Abend miteinander,

      bin das eben mit einer Test-VM am nachstellen. Nicht dass sich ein Fehler eingeschlichen hat, was ja beim Refactoring des Bausteines durchaus der Fall sein könnte. Allerdings funktioniert die Beschattung bei mir wie gewünscht, wobei ich jedoch A1 oder A2 nicht verwende...
      Kind regards,
      Yves

      Kommentar


        #48
        In dem BS ist auch ein copy/paste Fehler drinn. die 180° Jalousien existieren nicht. Du hast 2x
        Code:
        if ($shutterType == 0)
        drinn
        Mfg Micha
        Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

        Kommentar


          #49
          Hallo Marco

          Zitat von fly998 Beitrag anzeigen
          ich experimentiere seit ein paar Tagen mit den Beschattungsbaustein. Leider habe ich das Problem das der Wert für das kippen der Lamellen immer auf 0 steht.
          Ich vermute das ich irgendwo noch einen groben Schnitzer in den Einstellungen habe, ich komme aber nicht drauf wo.
          Seltsam ist auch das mir ein Lamellenwinkel in Grad ausgegeben wird.
          Hat von euch jemand eine Idee wo mein Fehler liegt?
          Also für mich sieht das alles korrekt aus. Bei einer Elevation von 60° müssten die Lamellen bei Deinen Lamellenabmessungen um -35° nach innen geschwenkt werden, um gerade soweit geschlossen zu sein, dass die Sonne nicht direkt herein scheint. Du hast aber E12=0, also Lamellen die nur 90° Schwenkbereich haben und diese gehen maximal auf waagerecht. Von daher ist die %- und Byte-Angabe korrekt mit jeweils 0. Der angegebene Winkel ist ja auch -35°, was wie oben schon beschrieben bedeutet, dass diese Lamellen von der Waagerechten aus um -35° nach innen geschwenkt werden müssten, was ja technisch bei diesem Lamellentyp nicht geht.

          Ich habe auch Storen vom Typ 0 und hier bei mir wird der %-Wert des Lamellenwinkel erst bei einer Elevation von weniger als ~25° grösser als 0.
          Kind regards,
          Yves

          Kommentar


            #50
            Hi Micha

            Zitat von vento66 Beitrag anzeigen
            In dem BS ist auch ein copy/paste Fehler drinn. die 180° Jalousien existieren nicht. Du hast 2x
            Code:
            if ($shutterType == 0)
            drinn
            Nein dem ist nicht so. Der Code ist m.M.n. korrekt an dieser Stelle:

            Code:
                if ($shutterType == 0) {
                    // 90° shutters
                    // "-" = 0° = 0%, "\" = 90° = 100%
                    ...
                } else {
                    // 180° shutters
                    // "/" = -90° = 0%, "-" = 0° = 50%, "\" = 90° = 100%
                    ...
                }
            Kind regards,
            Yves

            Kommentar


              #51
              Hallo Peter

              Zitat von Peter Beitrag anzeigen
              Leider geht der Ausgang A2 immer mit dem Ausgang A1 auf 1, egal wie die Helligkeit ist.
              Den Sonnenstand Baustein trigger ich alle 15 Minuten mit dem System KO23.
              Die Berechnung ob die Fassade in der Sonne ist (A1) funktioniert.
              Nach deinem Screenshot ist das alles korrekt. Der rechte Baustein hat einen Schwellwert von 50000 konfiguriert (nur 5000 sichtbar, aber wird wohl das Default von 50000 sein) und die aktuelle Helligkeit ist vermutlich ein Wert um 75060 herum (nur 7506 sichtbar aber um die Mittagszeit nach dem Fassadenwinkel vermutlich auch ein Wert um die 75k). Damit wird die Fassade beschienen, der Schwellwert ist überschritten, also gehen A1 und A2 jeweils auf 1.

              Was mich eher verwundert ist, warum A3-A7 auf 0 stehen. Lief der Timer noch zum Zeitpunkt des Screenshot? Aber dann müsste da ja eigentlich ein roter Rahmen drumherum sein...
              Zuletzt geändert von starwarsfan; 16.07.2016, 22:29.
              Kind regards,
              Yves

              Kommentar


                #52
                Zitat von starwarsfan Beitrag anzeigen
                Allerdings funktioniert die Beschattung bei mir wie gewünscht, wobei ich jedoch A1 oder A2 nicht verwende...
                Auch wenn du A1 und A2 nicht verwendest, wechseln die Ausgänge korrekt den Status bei Dir?

                Kommentar


                  #53
                  Hallo zusammen,

                  ich habe mir das ganze gestern nochmal angeschaut. Die Ausgänge A1 und A2 wechseln bei mir korrekt den Status. Das passt alles.
                  Auch die Winkel der Jalousie wird richtig angesteuert. Ich hatte das Minus nicht gesehen / verstanden. Aber nach deiner Erklärung ist dies nur klar.

                  Ich habe nun auch mal einen Test mit 2 Stores gemacht, funktionierte, soweit ich das bei dem sch... Wetter gestern beurteilen kann, einwandfrei.

                  Vielen Dank nochmal fürs Erstellen des Bausteins und für die Erklärung.

                  Viele Grüße
                  Marco

                  Kommentar


                    #54
                    Hi

                    Zitat von panzaeron Beitrag anzeigen
                    Auch wenn du A1 und A2 nicht verwendest, wechseln die Ausgänge korrekt den Status bei Dir?
                    Wie es scheint, gibt's da noch einen Bug und zwar genau dann, wenn die Beschattungshelligkeit die untere Schwelle unterschreitet und der Shutter geöffnet werden soll. Ich bin dran...
                    Kind regards,
                    Yves

                    Kommentar


                      #55
                      Hallo miteinander,

                      als Test bitte mal Zeile 267 wie folgt ändern:

                      Ist:
                      Code:
                      LB_LBSID_prepareOutput($id, 1, [B][COLOR=#FF0000]1[/COLOR][/B], $shutterHeightPercent, $shutterAnglePercent, $shutterHeightByte, $shutterAngleByte, $shutterAngle, $delayUp, true);
                      Soll:
                      Code:
                      LB_LBSID_prepareOutput($id, 1, [B][COLOR=#FF0000]0[/COLOR][/B], $shutterHeightPercent, $shutterAnglePercent, $shutterHeightByte, $shutterAngleByte, $shutterAngle, $delayUp, true);
                      Und im Anschluss daran natürlich berichten, ob A2 nun korrekt gesetzt wird.
                      Kind regards,
                      Yves

                      Kommentar


                        #56
                        Hi Yves,

                        vielen Dank für die vielen Updates! :-)
                        Habe den Baustein mal auf die letzte Version aktualisiert und teste nun mal mit je einem Testfenster Ost/Süd/West.

                        Folgendes ist mir bereits aufgefallen: wir haben bei uns gerne die Jalousien ganztägig komplett runtergefahren und die Lamellen auf 50% (wir haben den 180 Grad "Sonderfall"). 50% bedeutet also komplett waagrecht, so dass man gerade durchsehen kann. Nun hat der Baustein heute in der Mittagszeit die Lamellen bei meinem Südtestfenster leicht angewinkelt, obwohl eigtl. Die "Normalstellung" mit 50% auch kein Sonnenlicht ins Zimmer gelassen hätte.
                        Ich habe bei E18/E19 100%/50% eingestellt und hätte jetzt vermutet, dass der Baustein erkennt, dass zwar grundsätzlich beschattet werden muss, aber aufgrund des aktuellen Winkels keine Korrektur der Lamellen erfolgen müsste. Habe ich da einen Denkfehler? Kann ich die von uns bevorzugte Lamellenführung mit dem Baustein irgendwie erreichen?
                        Gewollt ist also:
                        - Normalstellung Höhe/Winkel: 100/50
                        - Beschattung falls nötig, anschließend wieder 100/50
                        - Nach Dämmerungeschwelle 100/100

                        Danke für dein Feedback dazu und vielen Dank für den tollen Baustein! :-)

                        p.s.: Glückwunsch zum 1000. Beitrag! :-)
                        Gruß,
                        Matthias

                        Kommentar


                          #57
                          Irgendwo hatte ich das in dem BS mal geändert, das bei 180 Grad Jalousien die Automatik nicht über 50% fährt. Wenn Du magst kann ich dir den geänderten Baustein schicken.
                          Mfg Micha
                          Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                          Kommentar


                            #58
                            Zitat von vento66 Beitrag anzeigen
                            Irgendwo hatte ich das in dem BS mal geändert, das bei 180 Grad Jalousien die Automatik nicht über 50% fährt. Wenn Du magst kann ich dir den geänderten Baustein schicken.
                            Hi Micha,
                            vielen Dank für dein Angebot! Würde ich gerne mal ausprobieren! Nur, dass wir nicht aneinander vorbei reden: die Lamellen dürfen schon auf über 50% fahren - aber eben nur, falls das zur Beschattung nötig ist.

                            Gruß,
                            Matthias

                            Kommentar


                              #59
                              Wie soll das zur Beschattung notwendig sein, die Lamellen auf <50 % zu stellen?
                              Mfg Micha
                              Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                              Kommentar


                                #60
                                N'abend@all,

                                bevor nun Bausteine hin und her geschickt werden würde mich zunächst interessieren, ob die oben genannte Anpassung zum gewünschten Resultat führt!
                                Kind regards,
                                Yves

                                Kommentar

                                Lädt...
                                X