Ankündigung

Einklappen
Keine Ankündigung bisher.

Wie werden Szenen verwendet?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #91
    Ja, genau! Das braucht's tatsächlich mit einer Sequenz; ich habe 2s Wartezeit für das Lernen gewählt. Danke für den Hinweis; habe einen Screenshot in meinem Beispiel ergänzt...

    Wenn das Aufrufen der alten Szene nicht geht: Kannst Du eco manuell aufrufen und die stimmt (lernen hat funktioniert, Aufruf geht nicht) oder ist TEMP schlicht falsch (lernen hat nicht funktioniert)?

    Die TEMP-Szene sieht genau aus wie alle anderen. Ich habe stets für jeden Raum zunächst eine Szene gemacht mit für den Raum relevanten Kanälen (alle auf Wert 128) und dann stets einfach kopiert. Nur MAX und AUS habe ich danach angepasst (0, 255), der Rest alles gelassen - auch TEMP. Das passiert ja alles später per lernen. Und daher wär's klasse, wenn man die Werte aus der Live-Version ins Arbeitsprojekt übernehmen könnte - denn dann wären die zu diesem Zeitpunkt aktuellen Szene auch Teil des Backups.
    Zuletzt geändert von saegefisch; 14.02.2020, 17:31.

    Kommentar


      #92
      Jetzt wird es etwas länger und ausfühlicher, sorry schon mal dafür

      Marha danke für den Tipp mit der Sequenz

      Zitat von saegefisch Beitrag anzeigen
      Wenn das Aufrufen der alten Szene nicht geht: Kannst Du eco manuell aufrufen und die stimmt (lernen hat funktioniert, Aufruf geht nicht) oder ist TEMP schlicht falsch (lernen hat nicht funktioniert)?
      Ich vermute, dass das mit dem Lernen nicht so richtig klappt. bzw. nun klappt es teilweise das der gelernt Wert wieder eingespielt wird. Aber wie es jetzt läuft, ist es nicht komfortabel

      Hier mal ein paar Screenshots von einigen Szenen

      AUS - Szene 0
      Bildschirmfoto 2020-02-14 um 21.29.08.png

      Standard - Szene 1 - soll gestartet werden wenn Auto-AN 0 aktiv + Bewegung
      Bildschirmfoto 2020-02-14 um 21.30.16.png

      Standard Light - Szene 2 - wir nur manuell angewählt
      Bildschirmfoto 2020-02-14 um 22.16.25.png

      Temp - Szene Temp
      Bildschirmfoto 2020-02-14 um 21.54.29.png


      Hier die Sequenz in der Ausgangsbox (Boxnummer 594) welche die aktuellen Werte speichern und Auto-Eco aufrufen soll
      Bildschirmfoto 2020-02-14 um 21.55.24.png
      und die Sequenz selber
      Bildschirmfoto 2020-02-14 um 21.56.52.png

      Und hier die 2 Befehle die aktiviert werden soll, wenn bei aktiven Auto-eco wieder eine Bewegung erkannt wird (Box 598)
      Bildschirmfoto 2020-02-14 um 21.58.47.png

      Und hier noch einmal die Logik für Auto-eco (hier habe ich gerade die Standard-Light Szene manuell ausgewählt)
      Bildschirmfoto 2020-02-14 um 21.59.40.png
      Bildschirmfoto 2020-02-14 um 22.02.40.png
      1. Wenn ich jetzt eine Abwesenheit simuliere, springt der Dimmwert nach 2s auf Eco (es wird nicht der Timer abgewartet)
      Wenn dann wieder Anwesenheit kommt, dann ändert er den Dimmwert nicht wieder auf 50 (wie er hätte es eigentlich lernen müssen) sondern belässt ihn aus 15 (von Eco).
      2. Aber jetzt kommt es!!! Wenn ich jetzt wieder manuell Standard Light auswähle änder sich der Dimmwert auf 50 (manuelle Auswahl klappt prima), wenn dann Abwesenheit wieder simuliert wird, wartet er auch tatsächlich den Timer ab bis Auto-Eco aktiviert wird (super!) und wenn ich nun die Anwesenheit wieder simuliere klappt es auch mit der gelernten Szene (sprich der Dimmwert springt auf 50 und alles ist gut).
      3. und jetzt wird es ganz verrückt. Wenn ich wieder die Abwesenheit simuliere, passiert das selbe wie bei Punkt 1.
      und das Spiel kann ich ewig so fortführen...nur bei jedem 2 Ablauf klappt es wie gewünscht.
      Ich danke nochmal für eure Geduld mit mir!!!! Langsam müsste ich euch einmal einen ausgeben

      Kommentar


        #93
        shortyle

        Vielleicht kannst Du aus Deiner Sicht nochmal den Vorteil von AUS_eco gegenüber AUS darstellen/erklären. Ich habe es noch nicht ganz durchdrungen.

        Kommentar


          #94
          Zitat von Marha Beitrag anzeigen
          shortyle

          Vielleicht kannst Du aus Deiner Sicht nochmal den Vorteil von Eco gegenüber AUS darstellen/erklären. Ich habe es noch nicht ganz durchdrungen.
          Also "Aus_Eco" als Szene habe ich nicht. Ich orientierte mich da erstmal an den Szenen die auch saegefisch hinterlegt hat.
          "Aus" = Lampen aus
          "Standard" = Lampen 75%
          "Standard Light" = Lampen 50%
          "Max" = Lampen 100%
          "Eco" = Lampen 15%
          "Temp" = Speicher für die zu lernenden Werte

          "Auto_Eco" ist keine eigene Szene Szene sonder die Sequenz welche 1. die Werte in die Szene "Temp" lernt und 2. die Szene "Eco" aufruft.

          Kommentar


            #95
            Zitat von shortyle Beitrag anzeigen
            1. Wenn ich jetzt eine Abwesenheit simuliere, springt der Dimmwert nach 2s auf Eco (es wird nicht der Timer abgewartet)
            Wenn dann wieder Anwesenheit kommt, dann ändert er den Dimmwert nicht wieder auf 50 (wie er hätte es eigentlich lernen müssen) sondern belässt ihn aus 15 (von Eco).
            2. Aber jetzt kommt es!!! Wenn ich jetzt wieder manuell Standard Light auswähle änder sich der Dimmwert auf 50 (manuelle Auswahl klappt prima), wenn dann Abwesenheit wieder simuliert wird, wartet er auch tatsächlich den Timer ab bis Auto-Eco aktiviert wird (super!) und wenn ich nun die Anwesenheit wieder simuliere klappt es auch mit der gelernten Szene (sprich der Dimmwert springt auf 50 und alles ist gut).
            3. und jetzt wird es ganz verrückt. Wenn ich wieder die Abwesenheit simuliere, passiert das selbe wie bei Punkt 1.
            und das Spiel kann ich ewig so fortführen...nur bei jedem 2 Ablauf klappt es wie gewünscht.
            Ich danke nochmal für eure Geduld mit mir!!!! Langsam müsste ich euch einmal einen ausgeben
            Kann es sein, dass Du den LBS 594 zwei mal hintereinander aufrufst? Einmal um die alte Szene zu lernen und eco aufzurufen. Beim zweiten Mal lernst Du dann eco als TEMP-Szene ein und rufst anschließend wieder eco auf. An der Beleuchtung siehst Du erstmal keinen Unterschied. Erst wieder dann, wenn Du die TEMP-Szene wieder aufrufst, und falsche Beleuchtungswerte gesetzt sind. Bei solchen Phänomenen versuche ich mir immer mit dem LBS 18000110 zu helfen. Rückmeldung wäre schön, ob Du weiter gekommen bist, bzw. wie Du Deinem Fehler auf die Spur gekommen bist, bzw. ihn lösen konntest.

            Kommentar


              #96
              Hmmm also die Ausgangsbox 594 beinhaltet nur einen Befehl und das ist das Ausführen der Sequenz (die du auch empfohlen hast) welche zuerst die Tempszene beschreibt und nach 2s die Eco Szene abruft. Ein zweites Mal wird dieser Befehl nicht ausgeführt (denke ich zumindest )

              Das mit dem Logging versuche ich mal. Mal schauen wo der Fehler liegt.

              Ich melde mich dann wieder

              Kommentar


                #97
                So ich habe das jetzt mal mal dem Jogging gemacht und in der Tat ist es so, dass Auto-Eco zweimal ausgeführt wird (mit einem zeitlichen Versatz von 15s -> eigentlich die Eco Wartezeit) und damit beim zweiten Ausführen die Eco-Werte zwischengespeichert werden und anschließend wiederhergestellt werden. Marha dank dir für den Tipp und Gedanken Anstoß. Ich kann es mir jetzt nur so erklären, dass ich ja nur einen "virtuellen PM" habe, der sofort auf 0 Schaltet bei Abwesenheit und nicht die Nachlaufzeit (sofern eingestellt) abwartet.
                saegefisch undMarha sind bei euch die PM mit Nachlaufzeit parametriert welche größer ist als die Wartezeit für Auto-Eco? und sind die PM dahingehend "dumm" parametriert und ihr löst das anders?

                Kommentar


                  #98
                  Dazu hatte ich weiter oben schon mals geschrieben: Am liebstn wäre mir vom PM/BWM nur 1s - aber einige haben bei mir als minimum 10s. Egal wie die drei melden, ich fasse sie zusammen und mache daraus ein 10s-KO für die diverse Anwendungen - inkl. Szenen. Ggf. könntest Du das über eine Flankenerkennung lösen.

                  Kommentar


                    #99
                    Zitat von saegefisch Beitrag anzeigen
                    Dazu hatte ich weiter oben schon mals geschrieben: Am liebstn wäre mir vom PM/BWM nur 1s - aber einige haben bei mir als minimum 10s. Egal wie die drei melden, ich fasse sie zusammen und mache daraus ein 10s-KO für die diverse Anwendungen - inkl. Szenen. Ggf. könntest Du das über eine Flankenerkennung lösen.
                    Aber müsste es dann bei dir, wenn deine „Nachlaufzeit“ nur 10s beträgt und dein Eco-Timer > 10s ist, nicht auch zu einer doppelten Ausführung des 4fach UND-Gatter kommen und damit 2x die Auto-Eco Sequenz abgerufen werden mit allen Konsequenzen?

                    Wenn ich mal ganz blöd fragen darf, den Begriff Flankenerkennung habe ich hier ein Edomi Unterforum schon öfter gelesen, aber nie verstanden was es damit auf sich hat. Was kann ich darunter verstehen?

                    Kommentar


                      Meine Auto-Ecozeit ist zwar im LBS 10s, aber über KO 1426 schon immer auf 600s.

                      Ich kann Deinem Gedankengang leider nicht folgen. Warum sollte es 2x auslösen? Edomi arbeitet event-basiert und ein UND-Gatter wird nur 1x die Sequenz auslösen, wenn alle 4 Eingänge 1 sind. Einer davon kommt vom Timer.

                      Flankenerkennung: Standard-LBS 13000039, um zum Beispiel zu erkennen, wenn ein KO 0>1 (steigende Flanke) oder 1>0 (fallende Flanke) umschaltet. Wenn man x BWM über eine steigende Flanke auswertet, dahinter z.B. eeinen Timer. Mit der steigenden Flankenerkennung , ist es egal, wie lange jeder BWM tatsächlich auf 1 bleibt.

                      Kommentar


                        Zitat von saegefisch Beitrag anzeigen
                        Ich kann Deinem Gedankengang leider nicht folgen. Warum sollte es 2x auslösen? Edomi arbeitet event-basiert und ein UND-Gatter wird nur 1x die Sequenz auslösen, wenn alle 4 Eingänge 1 sind. Einer davon kommt vom Timer
                        Also bei mir verhält es sich aktuell so.

                        Aktuelle Gegebenheit. Auto-An und Auto-Eco sind an. Auto-An hat automatisch auf Szene 1 (Standard) geschalten.

                        UND Gatter

                        E1 = Auto Eco An/Aus -> steht auf 1, da An
                        E2 = 1 wenn Szene (außer AUS) aktiv -> steht auf 1, da aktive Szene 1 (Standard)
                        E3 = erhält 1 (durch Inverter) wenn Restzeittimer abgelaufen ist. Restzeittimer wird immer ausgelöst bei manueller Szenenwahl und/oder Erkannter Bewegung -> steht auf 1 da durch Auto-An ja Szene 1 ausgelöst wurde
                        E4 = bekommt eine 1 (durch Inverter) wenn PM 0 meldet -> steht auf 0 da ich im Raum bin

                        Ich vermute bei E3 liegt noch mein Gedankenfehler, denn dieser steht ja eigentlich immer auf 1 außer während der Restzeittimer läuft. Wenn nun durch Abwesenheit E4 unmittelbar auf 1 gesetzt wird, (wenn keine Nachlaufzeit eingestellt ist) ist das UND Gatter ja erfüllt (4x 1) und die Eco Szene wird automatisch über die Sequenz ausgelöst. Durch dieses Auslösen der Szene Eco wird ja wiederum der Restzeittimer getriggert (E3 wechselt auf 0) und nach Ablauf der Zeit wird E3 erneut mit einer 1 beschrieben und es sind erneut alle Vorraussetzungen erfüllt.

                        Mit der Nachlaufzeit > Restzeittimer wird E3 ja vor E4 beschrieben und es kommt nicht zu dieser Dopplung.
                        Deswegen verwundert es mich, dass es bei dir dennoch klappt, denn dein 10s KO (Nachlaufzeit) ist ja kleiner als der Restzeittimer.

                        ich hoffe ich konnte es verständlich rüber bringen.

                        Kommentar


                          bin unterwegs im Hotel - ich werde dazu erst am WE schauen können....

                          Kommentar


                            Meine PMs sind alle mit einer Nachlaufzeit von >= 5 min parametriert. Stammt noch aus Zeiten bevor ich mich mit Edomi beschäftigt/eingesetzt hatte. Meine PMs sind sowieso von Hause aus relativ dumm. Das Thema einstellbare Nachlaufzeiten muss ich wohl mal überdenken. Welche Vorteile/Anwendungen seht ihr dabei?
                            Mal abgesehen davon, verwende ich eine andere Logik als die von saegefisch. Habe den Vorteil noch immer nicht durchdrungen.

                            Kommentar


                              Ich möchte die BWM/PM so dumm
                              wie möglich und so kurz wie möglich auf 1 im edomi haben. Dort bin ich dann maximal flexibel und kann dann anwendungsbezogen passend agieren und nach Belieben verlängern/beruhigen.

                              Für die Szenen als Impuls zum (re)triggern der Timer. Im Wohnbereich ist der Timer auch recht lang, aber in Fluren auch viel kürzer. Denn die Logik läuft bei mir in vielen Räumen, wenn auch meist etwas vereinfacht ( kein Esstisch, keine Couch im Treppenhaus... ). Auf jeden Fall würden 5min zu lang für Flure sein und würde mir dann nur die steigende Flanke auswerten.

                              Kommentar


                                Bei der Verwendung der Szenen ist mir nun ein für mich neues Einsatzgebiet in den Sinn gekommen. Beim Thema Szenen hatte ich bisher nur an irgendwelche Beleuchtung-/Beschattung-/TV-Szenen gedacht. Es gibt Situationen in manchen Logiken, wo man sich einen Zustand merken möchte/muß, den man später wiederherstellen will/muß. Für dieses Merken würden sich Szenen ebenfalls eignen (einlernen und später abrufen). Kann für diese Verwendung jemand etwas sagen, vielleicht aus Erfahrung? Im Moment sehe ich noch keine wesentlichen Nachteile. Im Moment scheint es mir, dass die Logiken übersichtlicher werden. Ich bin auf Eure Meinung gespannt.

                                Kommentar

                                Lädt...
                                X