Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS Resol VBus / Viessmann Vitosol 200

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Hallo panzaeron,
    ich hab heute die vBus/LAN-Schnittstelle bekommen und gleich angeschlossen. Mit der Resol ServiceCenter Software bekomme ich auch schön die Daten angezeigt. Allerdings bekomme ich in der Log-Datei von dem Baustein folgende Fehlermeldung:

    Code:
     
    2018-01-05 17:52:43 303491 15077 3 (ID1428) : socket_recv() failed; reason: 104 Connection reset by peer
    Ich habe im Baustein auch schon den Port geändert auf den Wert der mir im Webinterface angezeigt wird, leider ohne Erfolg. Woran kann das noch liegen das die Verbindung nicht zustande kommt?

    Gruß Christian

    Kommentar


      #17
      Gute Frage, warum die Verbindung abgebrochen wird. Der Port im Webinterface (bei mir 6432) darf jedenfalls nicht mit dem im LBS (bei mir 7053) übereinstimmen. Sollte mich aber wundern, wenn dein VBUs-LAN einen anderen Port verwendet als der von mir und der Fehler deutet für mich auf einen fehlerhaften Port hin. Oder vielleicht passt auch das Passwort (vbus) oder die Übertragungsrate (9600) nicht?

      Passen den die Daten die dir das Service Center anzeigt mit denen in deinem LBS überein? Am Besten bei Rohinformationen unter Rohprotokoll schauen, dort steht die Protokollversion, die Quelle mit der ID (0x....) usw. Oder noch besser, du machst zwei Screenshots von deinem Resol Service Center (Rohinformationen und Protokollinformationen), dann könnte ich abgleichen, ob das zu meinem passt.

      Kommentar


        #18
        achso die Ports dürfen nicht übereinstimmen

        ok dann funktioniert das fast perfekt. Musste nur die ID ändern, von 0x4213 auf 0x4214.
        Ein paar Werte scheinen vertauscht zu sein. Hier mal ein paar Screenshoots.
        Logik_Rohdaten.PNGLogik_Protokoll.PNG

        Kommentar


          #19
          In meinem LBS gibt noch einen Fehler bei der Auswertung von negativen Temperaturwerten, dieser ist in der 0.3 Version im Downloadportal behoben.

          Kommentar


            #20
            Hallo ChrisChros !

            Habe seit dem Wochenende auch den Adapter in Betrieb und bekomme die selbe Fehlermeldung wie du. Im Resol-Servicecenter läuft die Kommunikation einwandfrei. Am Port sollte es nicht liegen und wo hast du die ID geändert?
            LG

            Kommentar


              #21
              Hallo Klaus007,

              welche Anlage hast du denn verbaut bzw. welchen Regler?

              Kommentar


                #22
                Hallo ChrisChros!

                Es ist eine SKSC3 von Sonnenkraft.

                Kommentar


                  #23
                  Ok, dann schau mal bitte im Resol ServiceCenter bei den Rohinformationen was bei Quelle rechts oben angezeigt wird. Dort steht in runden Klammern z.B. 0x7161. Das ist die ID des Reglers die du im Baustein angeben musst.

                  Du muss aber auch sehr wahrscheinlich die Ausgänge neu definieren. Der SKSC3 hat um einiges mehr an Parametern die ausgegeben werden als mein SKSC2.
                  Zuletzt geändert von ChrisChros; 15.01.2018, 17:46.

                  Kommentar


                    #24
                    Dass ich die Ausgänge anpassen muss, ist mir bewusst, aber wo im LBS finde ich die ID?

                    Kommentar


                      #25
                      Bei dir dürfte das ein bischen anders aussehen als bei mir:
                      Code:
                      case 0x0010: { // DFA
                                  debug($id, "destination DFA detected", 7);
                                  switch($source_addr) {                
                                      case 0x4214: {  // Sonnenkraft SKSC2 HE Regler
                      In diesem Fall ist 0x4214 die ID von dem Regler. Hier musst du deine Eintragen die du in dem Resol ServiceCenter sehen kannst.

                      Kommentar


                        #26
                        Danke für die Info! Jetzt habe ich zwar keine Einträge mehr in Log, bekomme aber auch keine Werte angezeigt .

                        Kommentar


                          #27
                          Dann musst du an den Ausgängen noch rumschrauben, da kann ich dir aber leider nicht wirklich helfen in Sachen php bin ich nicht wirklich erfahren.
                          panzaeron hat mir da sehr weitergeholfen.

                          Kommentar


                            #28
                            Danke, mit php habe ich auch nicht viel zu tun. Werde mich aber in nächster Zeit daran setzten und versuchen den Baustein für das SKSC3 zu adaptieren.

                            Kommentar


                              #29
                              viel Erfolg. schau dir mal noch den anderen Baustein von schobi in post #6 an. Bei Viessmann wird auch ein recht großer Datensatz übertragen. Vielleicht kannst du davon was adaptieren, hatte ich damals auch gemacht.

                              Kommentar


                                #30
                                Erstmal vielen Dank an schobi und panzaeron für die sehr gute Arbeit.
                                Ich habe hier einen LBS für eine Oventrop Frischwasserstation Regtronic RQ-B hochgeladen.

                                Besonderheiten meines LBS:
                                - Der LBS wird getriggert (Details bitte der Hilfe entnehmen), da eine sekündliche Abfrage mMn zu viel des Guten ist.
                                - Der LBS läuft NICHT als Dämon, sondern wird jedes Mal nach der Abfrage beendet. Vorteil: Bei Kommunikationsverlust arbeitet der LBS weiter, Edomi muss nicht neu gestartet werden.

                                Leider ist mein Regler nicht so gut dokumentiert wie die Euren. Ein paar Fehler (z.B. Relais 5 das es nicht gibt) konnte ich ausmerzen. Entgültig kann ich erst die Ausgänge 53-56 testen, wenn die Friwa am Puffer hängt.

                                Was noch fehlt und mein Ziel ist, den WW Sollwert per Edomi verändern zu können, aber dazu muss ich morgen mal bei Resol anrufen, ob die die ID für die Sollwertverstellung rausrücken. Eine RPT oder XML Datei wäre natürlich noch besser.
                                >>Smelly One<<
                                >> BURLI <<
                                Grüße Armin

                                Kommentar

                                Lädt...
                                X