Ankündigung

Einklappen
Keine Ankündigung bisher.

Homeconnect Suite LBS 19002520-19002530

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Homeconnect Suite LBS 19002520-19002530

    Ich hab mal meine Version der LBS für homeconnect hochgeladen. Ein Reverse Proxy ist nicht notwendig. Im Detail sind es

    Neu: LBS19002520 home connect Server
    Dient zur Verbindung mit den homeconnect Server und kümmert sich um die Aktualisierung des tokens. Der LBS bekommt alle Statusänderungen mit, und gibt sie zur Auswertung an die Geräte LBS weiter.

    Neu: LBS19002521 homeconnect hob / oven
    Steuerung und Status von Kochfeld / Backrohr / Dampfgarer

    Neu: LBS19002522 homeconnect hod
    Steuerung und Status von Dunstabzugshaube

    Neu: LBS19002523 homeconnect dishwasher
    Steuerung und Status von Geschirrspüler

    Neu: LBS19002524 homeconnect washer / dryer
    Steuerung und Status von Waschmaschine, Trockner, Waschtrockner

    Neu: LBS19002525 homeconnect coffemaker
    Steuerung und Status Kaffeemaschine

    Neu: LBS19002526 homeconnect fridge / freezer
    Steuerung und Status Kühlschrank, Gefrierfach, Kühl- Gefrier Kombi
    Zugriff auf die Kamera ist nicht möglich.

    Neu: LBS19002527 homeconnect wine cooler
    Steuerung und Status Weinkühler

    Neu: LBS19002528 homeconnect cook processor
    Steuerung und Status Küchenmaschine (nur Basics, mehr im Laufe des Jahres)

    Neu: LBS19002529 homeconnect cleaning robot
    Steuerung und Status Saugroboter. Zugriff auf die Kamera ist nicht möglich.

    Neu: LBS19002530 homeconnect warming drawer
    Steuerung und Status Wärmeschublade

    Für die Nutzung ist ein developer Account notwendig.
    Registrierung:
    - Developer account unter https://developer.home-connect.com/ anlegen
    - unter "Applications - Register Applications" eine Application anlegen
    - Athorization "Authorization Code Grant Flow"
    - redirect URI ist "http://--ip vom EDOMi Rechner--/visu/redir.php"

    - LBS 19002520 mit einer 9 an E1 Starten
    - die URL die an A2 ausgegeben wird im Browser aufrufen (dazu sollte A2 mindestens mit einer Klemme verbunden sein)
    - auf der Seite mit dem developer account anmelden, und Zugriff gewähren

    Dann sollte eine Bestätigungsseite erscheinen:

    ok.png

    Wenn das geglückt ist, den LBS 19002520 mit einer 1 an E1 fix belegen, und die Geräte LBS verbinden.


    Fals die Seite jedoch so ausschaut:


    fail.png


    Die Seite schliessen, die Anmeldedaten kontrollieren, und den LBS mit einer 9 an E1 erneut starten.

    So schaut das dann am Ende aus:


    hc1.png

    Einige Geräte LBS sind nicht getestet, andere nur über die Simulation von Homeconnect. Die scheint aber teilweise andere Sachen zu schicken, wie ein reelles Gerät.
    Falls ihr Daten vermisst, die an E1 ankommen, aber nicht am passenden Ausgang auftauchen, dann das Logging im Geräte-LBS auf 6 stellen, und den Log mir zukommen lassen.

    Bei Fragen einfach hier posten.
    Zuletzt geändert von vento66; 07.01.2022, 23:15.
    Mfg Micha
    Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

    #2
    Genial! Danke! Ich werde es nächste Woche mit unserem Trockner testen. Vielen Dank für Deine Arbeit!!!

    Kommentar


      #3
      Hallo Micha, die Download Links zeigen alle auf den selben LBS... Ansonsten ist das genau was ich schon lange mal bei mir einbauen wollte... lieben Dank!

      Kommentar


        #4
        Hoi Micha,

        coole Sache, vielen Dank.

        Kann zwar erst morgen genauer testen, nur was mir gleich auffällt: Beim Baustein für die Kaffeemaschine funktioniert es nicht mehr, den Tassenwärmer zu aktivieren.
        Kind regards,
        Yves

        Kommentar


          #5
          Dann mal den Log aufdrehen (8) und schauen was da kommt....
          Mfg Micha
          Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

          Kommentar


            #6
            starwarsfan Da war wohl was schief gegangen, E8 wurde ersatzlos gestrichen Habs wieder repariert. Jetzt in V0.21 wieder verfügbar.
            Mfg Micha
            Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

            Kommentar


              #7
              Zitat von vento66 Beitrag anzeigen
              Ein Reverse Proxy ist nicht notwendig.
              Hi Micha,
              dieser Kommentar hat mich etwas stutzig gemacht, da ich davon ausgegangen war, dass auch der Homeconnect Server die Redirect URI verifiziert.
              Nach gut einer Stunde Debugging musste ich feststellen, dass es an meinem speziellen Mikrotik DNS Setup im Zusammenspiel mit meinem Adguard Home Server lag.
              Jetzt geht es nämlich auch mit meinem Homeconnect API LBS ohne Reverse Proxy. Dabei habe ich auch noch gemerkt, dass neue Applikationen jetzt das Client-Secret benötigen, um das Access Token zu updaten. Bei meiner 2 Jahre alten Applikationen habe ich immer noch einen Schalter, um das auszuschalten. Auch das ist jetzt korrigiert.

              Gleiches gilt vermutlich auch für den Spotify LBS. Das werde ich mir noch mal anschauen.
              Also Danke noch mal für den Hinweis. Ich wäre da vermutlich nicht mehr selbst drauf gekommen.

              Kommentar


                #8
                Na das freut mich doch, so haben alle was davon!
                Mfg Micha
                Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                Kommentar


                  #9
                  In dem Atemzug bräuchte ich mal die Hilfe von jemanden, der einen Backofen / Dampfgarer hat, Wenn man die Temperatur von einem Programm verstellt, schickt die Simulation von Homeconnect aller 3 Sekunden einen Tempwert der immer einen Step in die entsprechende Richtung geht. Ist das im echten Leben auch so? Verstellt man die Temperatur von 200°C auf 100°C dauert es ewig bis der richtige Sollwert angekommen ist. Bitte mal des Log im Geräte LBS auf 8 stellen, und schauen wie die Werte da ankommen. Optional mir das Log zukommen lassen. Achtung! Bei Loglevel 8 können persönliche Daten wie das Login token im log vorhanden sein. bevor ihr sowas hier postet, den Teil im Log löschen.
                  Zuletzt geändert von vento66; 08.01.2022, 09:55.
                  Mfg Micha
                  Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                  Kommentar


                    #10
                    Hi Vento,
                    super, vielen Dank für den LBS. Habe diesen jetzt für unseren Geschirrspüler getestet.

                    Ein paar Stolpersteine hatte ich. Aber jetzt scheint es zu laufen.
                    Bei mir kamen auf den Ausgängen erst Werte an nachdem ich aus dem JSON an Eingang E1 die HaID ausgelesen und im LBS Eingang E2 eingetragen hatte.
                    Das war aus Deiner Anleitung nicht zu erkennen.

                    Ich habe noch eine Frage.
                    Wäre es möglich die Verbrauchsdaten Wasser und Strom auszulesen?

                    Kommentar


                      #11
                      In der Hilfe von jedem Geräte LBS:
                      E2 = haId des Gerätes (findet man am passenden Ausgang A3-A15 von 19002520)
                      von den Verbrauchsdaten ist in der API keine Rede, also glaub ich nicht das es geht.
                      Mfg Micha
                      Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                      Kommentar


                        #12
                        Hhmm, wer lesen kann ist einfach klar im Vorteil.

                        Hatte mich an dem Post durchgehangelt und nicht in der LBS Hilfe gelesen. Aber da steht es ja. Sorry.

                        Ja schade das das mit den Verbrauchsdaten nicht geht.

                        Kommentar


                          #13
                          mno kannst Du mal den angehängten LBS testen? Scheinbar hat das Ding hellseherische Fähigkeiten Ich hab in den tiefen des Forums noch einen "Energy Forecast" und einen "Water Forecast" gefunden. Mit Loglevel 6 sollten die Werte in den Log geschrieben werden, sowie in die Varablen 5 und 6 (sieht man in der Liveansicht, wenn man auf Hilfe klickt).
                          Zuletzt geändert von vento66; 08.01.2022, 14:36.
                          Mfg Micha
                          Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                          Kommentar


                            #14
                            Zitat von vento66 Beitrag anzeigen
                            In dem Atemzug bräuchte ich mal die Hilfe von jemanden, der einen Backofen / Dampfgarer hat, Wenn man die Temperatur von einem Programm verstellt, schickt die Simulation von Homeconnect aller 3 Sekunden einen Tempwert der immer einen Step in die entsprechende Richtung geht. Ist das im echten Leben auch so? Verstellt man die Temperatur von 200°C auf 100°C dauert es ewig bis der richtige Sollwert angekommen ist. Bitte mal des Log im Geräte LBS auf 8 stellen, und schauen wie die Werte da ankommen. Optional mir das Log zukommen lassen. Achtung! Bei Loglevel 8 können persönliche Daten wie das Login token im log vorhanden sein. bevor ihr sowas hier postet, den Teil im Log löschen.

                            Habe es bei mir soeben getestet. Die Übernahme der richtigen Temperatur ist problemlos.
                            Mir ist nur aufgefallen, dass der "Fortschritt in %" permanent auf 100% ist und nach dem Ausschalten, die Werte gespeichert bleiben.
                            Zuletzt geändert von nemooo; 08.01.2022, 11:21.

                            Kommentar


                              #15
                              Das ist in der Simulation ähnlich, ich dachte das das im echten Leben anders ist, da muss ich halt den Wert bei "fertig" auf 0 setzen. Am besten wir sammeln das mal, damit wir hier nicht 100 Versionen der LBS innerhalb von einer Woche generieren. Das wird ja wahrscheinlich bei den Waschmaschinen / Trocknern ähnlich sein. Kommt bei der Temperatur glech der richtige Wert?
                              Mfg Micha
                              Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                              Kommentar

                              Lädt...
                              X