Ankündigung

Einklappen
Keine Ankündigung bisher.

Edomi im Docker-Container - revised

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #91
    also den:
    sudo docker run --name edomi --net=host --restart=on-failure -p 22222:22 -e KNXGATEWAY=192.168.178.23 -e KNXACTIVE=true -e HOSTIP=192.168.178.32 -d starwarsfan/edomi-docker:latest

    Kommentar


      #92
      Hi Willi,

      Ich habe in deinem Logfile folgendes gesehen:
      (98)Address already in use: make_sock: unable to listen for connections on address [::]:80
      (98)Address already in use: make_sock: unable to listen for connections on address 0.0.0.0:80

      Das heißt dein Container kann nicht starten, da der Port 80 bereits durch deinen physikalischen Rechner belegt ist.
      Läuft hier ein Apache oder ein anderes Prorgamm das den Port 80 benötigt?

      Kommentar


        #93
        Das ist sehr gut möglich. Wie kann ich das ausschalten? Benötige Apache eigentlich nicht, war nur eine Option bei primärer Installation

        Kommentar


          #94
          Falls der Apache sicher nicht mehr benötigt wird, dann kann dieser über "sudo apt-get purge apache2" entfernt werden, alternativ lässt sich der Port auch in der "/etc/apache2/ports.conf" umkonfigurieren (danach dann einen "sudo systemctl restart apache2" ausführen)

          Kommentar


            #95
            So, apache2 ist aus. Über IP-Adresse/admin komme ich auch auf eine Edomi Seite, allerdings nur bis zu einem Wartesymbol, mehr passiert nicht.

            und der log zeigt weiterhin folgende Dauerschleife:

            MAIN ENDE============================================== =========================
            Server wird in 5s neu gestartet... (Abbrechen mit ENTER)
            Server: Reboot...
            Exiting container with return value 1 to trigger Docker restart
            HOSTIP set to 192.168.178.32 ... configure /usr/local/edomi/edomi.ini and /etc/httpd/conf/httpd.conf
            KNXGATEWAY set to 192.168.178.23 ... configure /usr/local/edomi/edomi.ini
            KNXACTIVE set to true ... configure /usr/local/edomi/edomi.ini
            MySQL Daemon failed to start.
            Starting mysqld: [FAILED]
            Starting vsftpd for vsftpd: [ OK ]
            Starting httpd: [ OK ]
            Starting ntpd: [ OK ]
            Starting sshd: [ OK ]
            --------------------------------------------------------------------------------
            EDOMI - (c) Dr. Christian Gärtner
            --------------------------------------------------------------------------------
            setterm: $TERM is not defined.
            setterm: $TERM is not defined.
            setterm: $TERM is not defined.
            chmod: cannot access `/dev/vcsa': No such file or directory
            Stopping mysqld: [ OK ]
            MySQL Daemon failed to start.
            Starting mysqld: [FAILED]
            Shutting down ntpd: [FAILED]
            ntpd: time slew -0.006677s
            Starting ntpd: [ OK ]
            >>> EDOMI startet in 3 Sekunden (Abbrechen mit ENTER) <<<
            EDOMI-Konfiguration

            MAIN START============================================= =========================
            php: no process killed
            EDOMI starten...
            14.02.2018 19:05:32 Prozess MAIN gestartet
            14.02.2018 19:05:33 EDOMI-Version: 1.54
            14.02.2018 19:05:33 EDOMI-ClientId: 6dc0e47ac7fda6bb8b9592c342ce292d85841b95fef9
            14.02.2018 19:05:33 Server wurde rebootet
            14.02.2018 19:05:33 Prüfung: 64-Bit-System
            14.02.2018 19:05:33 PHP-Zeitzone: Europe/Berlin (Winterzeit)
            14.02.2018 19:05:33 Datenbank: Verbindung herstellen
            14.02.2018 19:05:33 Prozess MAIN beenden... (Modus 13)
            14.02.2018 19:05:33 EDOMI: Beenden...
            14.02.2018 19:05:33 EDOMI: Warten auf LBS (3 Sekunden)...
            14.02.2018 19:05:36 Prozess SYSINFO (PID=) beenden
            14.02.2018 19:05:36 Prozess KNX (PID=) beenden
            14.02.2018 19:05:36 Prozess LOGIC (PID=) beenden
            14.02.2018 19:05:36 Prozess QUEUE (PID=) beenden
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMsysInfo löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMcmdQueue löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMko löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMlogicElement löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMlogicElementVar löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMlogicLink löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMlogicCmdList löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMknxRead löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMknxWrite löschen
            14.02.2018 19:05:36 Datenbank: edomiLive.RAMsysProc löschen
            14.02.2018 19:05:36 EDOMI: Warten auf EXEC-LBS (3 Sekunden)...
            14.02.2018 19:05:39 Datenbank: Verbindung schließen
            14.02.2018 19:05:39 Prozess MAIN beendet (13)
            php: no process killed
            MAIN ENDE============================================== =========================
            Server wird in 5s neu gestartet... (Abbrechen mit ENTER)
            Server: Reboot...
            Exiting container with return value 1 to trigger Docker restart

            Bitte um weitere Ideen

            Kommentar


              #96
              Problem ist, dass mysql nicht gestartet werden kann. Ist das ggf. auch ein Konflikt mit der Host Installation? Läuft da evtl. auch ein mysqld?

              Kommentar


                #97
                Ist das immer noch der gleiche Container oder ein neuer?

                Kind regards,
                Yves

                Kommentar


                  #98
                  Das ist immer noch der gleiche Container, habe nur Apache beendet. MySQL muss ich Mal ausprobieren. Wie finde ich raus, ob das läuft?

                  Kommentar


                    #99
                    Das war es tatsächlich. MySQL ausgeschaltet und es funktioniert. Vielen Dank!

                    Kommentar


                      Genau das ist der Fluch der --net=host Option. Aber solange ich nicht herausgefunden habe, was Edomi da anders macht, ist es leider nicht anders zu lösen.
                      Kind regards,
                      Yves

                      Kommentar

                      Lädt...
                      X