Ankündigung

Einklappen
Keine Ankündigung bisher.

Diskussionsthread EDOMI-Releases/Updates

Einklappen
Das ist ein wichtiges Thema.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #31
    Sorry - ich hab's im falschen Thread geposted - hier also nochmal:

    Bald können Freunde des InitScans bei Problemen aufatmen - es wird geloggt...
    2018-02-19 06:40:17 725356 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 1... Ok
    2018-02-19 06:40:24 385305 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
    2018-02-19 06:40:44 393326 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 2... Ok
    2018-02-19 06:40:44 495477 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
    2018-02-19 06:41:04 501135 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 3... Ok
    2018-02-19 06:41:04 602638 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
    2018-02-19 06:41:24 608999 MAIN 4993 KNX: InitScan beendet: 112 GAs abgefragt / Abfragen von 1 GAs fehlgeschlagen (3 Abfragen / 60 Checks) TIMEOUT
    2018-02-19 06:41:24 610446 MAIN 4993 KNX: InitScan: Keine Antwort von GA 2/1/5 Taster Gästebad (379) TIMEOUT
    EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

    Kommentar


      #32
      gaert Super, das fehlte wirklich noch

      Kommentar


        #33
        gaert

        Dann hoffe ich auch noch Gehör bei dir zu finden.

        Seit 4 Wochen hane ich das Problem dass, die Logic Queue sporatisch voll läuft und innerhalb eines Tages bis zu 32000 hoch läuft. Nach einem stop/start des Edomi ist dann für einige Tage alles Ok, und dann passiert es wieder.....

        Gibt es hier eine Möglichkeit anzuzeigen oder zu loggen, was aktuell in der Queue hängt.

        Wenn das Problem permanent auftreten würde, könnte ich über das Deaktivieren von Logiken dennFehler ja eingrenzen. Aber nachdem nun alles über den Edomi läuft, muss ich jeden Morgen nach den queues schauen und ggf.stop/start ausführen, was aus Dauer spassfrei ist.

        Hartwig
        Gruß Hartwig

        Kommentar


          #34
          Hallo Hartwig,
          ich hatte das selbe Problem und Edomi hat sich dann immer aufgehängt bzw. Teilweise nur sehr langsam(verzögert) reagiert.

          Bei mir kam es von keiner Logik direkt, sondern von einem zu hohen Bus Traffic welcher in ein Datenarciv geschrieben wurde. Ich hatte die Wirkleistung von allen drei Phasen versehentlich bei 2% Änderung gesendet.
          Also eventuell auch mal die Datenarchive durchschauen.

          Gruß
          Patrick

          Kommentar


            #35
            Hallo Patrick,

            danke für den Tipp. Ich habe Heute mal die Datenarchive durchsucht. Bis auf ein Archiv war alles Ok. In einem Archiv hatte ich 3Millionen Datensätze seit Edomi 1 angesammelt. Das löschen hat das Diagramm massiv beschleunigt, allerdings ansonsten keine Änderung.

            insofern, wäre nach wie vor mein Wunsch analysieren zu können, was in der Queue steckt, oder welcher Lbs oder Logik die cpu Last verursacht
            Gruß Hartwig

            Kommentar


              #36
              Es gibt doch eine Datenbank RAMQueue oder so ähnlich. Dort müssten doch die Einträge drinn stehen. Wenn Du dir das mal mit Excel exportierst, sollte das klappen. Ich hab leider nix im Queue sonst könnte ich da mal reinschauen, ob da was drin steht.
              Mfg Micha
              Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

              Kommentar


                #37
                Korrekt. Die Queue ist normaler Weise leer - denn diese wird ja im Normalfall schnellstens abgearbeitet. Wenn sich hier etwas massiv staut, muss irgendwo ein ziemlicher Wurm drin stecken

                Ich würde auf eine Schleife o.d.G. tippen - wird gerne auch mal indirekt (versehentlich) erstellt: Ausgangsbox beschreibt ein KO und dieses KO bewirkt ganz woanders irgendwas, das wiederum eine andere Logik triggert, die wiederum......
                EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

                Kommentar


                  #38
                  Problem dabei ist, dass es manchmal 4Tage ohne Probleme geht. Das macht die Fehlersuche so schwierig.
                  Aktuell seit 2 Tages ist wieder alle ok.
                  Gruß Hartwig

                  Kommentar


                    #39
                    Zitat von gaert Beitrag anzeigen
                    Sorry - ich hab's im falschen Thread geposted - hier also nochmal:

                    Bald können Freunde des InitScans bei Problemen aufatmen - es wird geloggt...
                    2018-02-19 06:40:17 725356 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 1... Ok
                    2018-02-19 06:40:24 385305 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
                    2018-02-19 06:40:44 393326 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 2... Ok
                    2018-02-19 06:40:44 495477 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
                    2018-02-19 06:41:04 501135 MAIN 4993 KNX: InitScan (112 GAs), Abfrage 3... Ok
                    2018-02-19 06:41:04 602638 MAIN 4993 KNX: InitScan (112 GAs), Überprüfung (max. 20 Zyklen)... Ok
                    2018-02-19 06:41:24 608999 MAIN 4993 KNX: InitScan beendet: 112 GAs abgefragt / Abfragen von 1 GAs fehlgeschlagen (3 Abfragen / 60 Checks) TIMEOUT
                    2018-02-19 06:41:24 610446 MAIN 4993 KNX: InitScan: Keine Antwort von GA 2/1/5 Taster Gästebad (379) TIMEOUT
                    Hallo gaert

                    seit Update habe ich nun nicht mehr eine GA die sich meldet...jetzt sind es viele

                    HTML-Code:
                       2018-02-22 10:09:05 113234 MAIN 4466 KNX: InitScan beendet: 215 GAs abgefragt / Abfragen von 92 GAs fehlgeschlagen (1 Abfragen / 3 Checks) TIMEOUT
                    Gruß Andre

                    Oder ich habe einfach viele, die warum auch immer nicht im Init-Scan gelesen werden wollen...damn it.
                    Zuletzt geändert von eXec; 22.02.2018, 10:34.
                    ...and I thought my jokes were bad!

                    Kommentar


                      #40
                      Am Initscan-Mechanismus habe ich nix verändert - nur ist das Logging jetzt eindeutiger Vor dem Update sind Dir die fehlenden GA-Antworten schlichtweg nicht aufgefallen.
                      EDOMI - Intelligente Steuerung und Visualisierung KNX-basierter Elektro-Installationen (http://www.edomi.de)

                      Kommentar


                        #41
                        Rückmeldung zum Update.

                        Version 1.56 erfolgreich installiert. Update lief ohne Probleme. Alles läuft wie gehabt.
                        Danke gaert für die neue Version und auch das einbringen unserer Vorschläge!

                        Kommentar


                          #42
                          Hallo gaert ,

                          ich habe eben das Update installiert, leider startet das System seitdem nicht mehr.
                          Folgendes ist in der Konsole zu sehen.
                          IMG_20180222_190943.jpg

                          Irgendwas hat mir da das System zerschossen.
                          Nach einem weiteren Neustart kam ich dann etwas weiter:

                          IMG_20180222_192443.jpg

                          IMG_20180222_194109.jpg

                          Wie komme ich jetzt an das letzte backup ran, bzw. wie bekomme ich das System wieder zum laufen?
                          Hatte zuvor 1.55 am laufen.

                          Gruß Chris
                          Zuletzt geändert von ChrisChros; 22.02.2018, 19:43.

                          Kommentar


                            #43
                            Das sieht schwer nach einem Festplattenproblem aus. Kann es sein, dass Dir die Platte vollgelaufen ist? Zuviele Daten? Zu grosse Backups? Wenn das Dateisystem nur lesbar gemountet ist, dann ist es i.d.R. voll oder ein Festplattenfehler liegt vor. Ich würde mal von einem Rescue-Stick booten und schauen, wie es auf der Festplatte aussieht.
                            Kind regards,
                            Yves

                            Kommentar


                              #44
                              wenn ich den reboot abbreche komme ich per ssh drauf.
                              darüber müsste ich doch auf sehe wie voll die platte ist oder?

                              Kommentar


                                #45
                                Als erstes mal EDOMI beim Start abbrechen (innerhalb der 3 Sekunden "Enter" drücken. Wenn Du einen WIN Rechner dein eigen nennst, mit WINSCP auf den Edomi Rechner verbinden. Unter /var/edomi-backups/ liegt das letzte Backup.
                                Mfg Micha
                                Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                                Kommentar

                                Lädt...
                                X