Ankündigung

Einklappen
Keine Ankündigung bisher.

eibd(war bcusdk) Fork -> knxd

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Bitte etwas Thread-Disziplin!
    Für fhem, openhab oder Rpi Diskussion und separate Implementierungen: eigener Thread..

    Hier eibd/knxd

    Makki
    Über Mobile Device
    EIB/KNX & WireGate & HS3, Russound,mpd,vdr,DM8000, DALI, DMX
    -> Bitte KEINE PNs!

    Kommentar


      Hello again!

      The description how to build knxd and its dependencies is great. I just have a problem with git clone and then doing ./bootstrap.sh and dpkg-buildpackage I get this:

      Code:
      dpkg-source: error: can't build with source format '3.0 (quilt)': no upstream tarball found at ../knxd_0.9.0.orig.tar.{bz2,gz,lzma,xz}
      dpkg-buildpackage: error: dpkg-source -b knxd gave error exit status 255
      It says something about a "knxd_0.9.0.orig.tar.* missing and I tried looking for it but I couldn't find it anywhere.

      - Teemu

      Kommentar


        Für die Analyse auf IP-Ebene habe ich den Wireshark-Decoder auf den aktuellen Stand gebracht (Wireshark 1.12).

        Der Code findet sich hier: https://github.com/smurfix/knx-wireshark

        Nach wie vor nicht implementiert ist das Auseinanderpflücken der KNX-Payload …
        DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

        Kommentar


          Zitat von MaximilianX Beitrag anzeigen
          It says something about a "knxd_0.9.0.orig.tar.* missing and I tried looking for it but I couldn't find it anywhere.
          You probably want to build the binary package only (dpkg-buildpackage -b). -uc and -us might also be needed, depending on your signing setup/requirements.

          Kommentar


            Zitat von Smurf Beitrag anzeigen
            Nach wie vor nicht implementiert ist das Auseinanderpflücken der KNX-Payload …
            Update: die aktuelle Entwicklerversion von wireshark kann das, wie mir berichtet wurde. Ich habe mir folglich den Code von dort geschnappt und auf 1.12 zurückportiert. Der Code ist im o.g. github-Archiv.

            Da wird das Debuggen doch gleich viel einfacher.
            DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

            Kommentar


              Auf Wunsch von https://github.com/knxd/knxd/issues/43 habe ich eine Google-Group eingerichtet:
              "soll" = Englisch (Deutsch gibts ja hier)


              Wünschenswert ist trotzdem das mitlesen bei der "alten" https://sourceforge.net/p/bcusdk/mailman/bcusdk-list/

              Maintainer bitte bei mir melden, damit ich euch eintragen kann.

              Makki
              EIB/KNX & WireGate & HS3, Russound,mpd,vdr,DM8000, DALI, DMX
              -> Bitte KEINE PNs!

              Kommentar


                Ich habe mal eben ein paar Changes gepusht. ETS5 findet jetzt den knxd via Multicast (und bekommt seine physikalische Adresse mitgesendet).
                Knackpunkt war, dass die Seriennummer nicht 0 sein durfte. *Hrmpf*.

                Morgen geht's weiter.
                DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

                Kommentar


                  Das Hauptproblem der ETS5 < 5.0.3 (bzw. des eibd/knxd) ist jedoch, das der Routing-Counter schlicht falsch ist (?)
                  Weiter pushen

                  Makki
                  EIB/KNX & WireGate & HS3, Russound,mpd,vdr,DM8000, DALI, DMX
                  -> Bitte KEINE PNs!

                  Kommentar


                    Hi, leider kann ich Euch bei der Entwicklung nicht weiterhelfen, mein C is quasi nicht vorhanden. Ich habe gerade versucht auf 2 verschiedenen Ubuntu Systemen (12.04 und 14.04, beide LTS) den knxd zu installieren, jedoch leider ohne Erfolg.

                    Ubuntu 14.04:
                    Beim bootstrap command bekomme ich folgende Warnungen für mehrere C Dateien, hier ein Beispiel.
                    src/client/c/Makefile.am:5: warning: source file 'gen/getbusmonitorpacketts.c' is in a subdirectory,
                    src/client/c/Makefile.am:5: but option 'subdir-objects' is disabled

                    Beim dpkg-buildpackage command bekomme ich diese Fehlermeldung:
                    Nicht erfüllte Bauabhängigkeiten: libusb-1.0-0-dev (>= 1.0.10)

                    libusb wurde jedoch installiert.

                    Ubuntu 12.04:
                    configure.ac:47: error: possibly undefined macro: AC_COMPILER_OPTION
                    If this token and others are legitimate, please use m4_pattern_allow.
                    See the Autoconf documentation.

                    Vielen Dank für die Hilfe.

                    *EDIT*
                    Ich habe es jetzt noch mal mit einem frisch installierten Debian versucht, bekomme auch den Fehler:
                    configure.ac:47: error: possibly undefined macro: AC_COMPILER_OPTION
                    If this token and others are legitimate, please use m4_pattern_allow.
                    Zuletzt geändert von bigblue1735; 21.03.2015, 18:54.

                    Kommentar


                      Versuche mal das bootstrap script zu editieren:

                      aclocal --force -I m4

                      das hat dann bei ir funktioniert (raspbian)

                      Kommentar


                        Danke, das bootstrap Problem habe ich hinbekommen. Leider habe ich jetzt noch ein Problem bei Build.
                        Code:
                         [COLOR=#333333][FONT=Helvetica Neue][SIZE=14px]dpkg-source: error: can't build with source format '3.0 (quilt)': no upstream tarball found at ../knxd_0.9.0.orig.tar.{bz2,gz,lzma,xz}
                        dpkg-buildpackage: error: dpkg-source -b knxd gave error exit status 255[/SIZE][/FONT][/COLOR]
                          [COLOR=#333333][FONT=Helvetica Neue][SIZE=14px]After updating the "debian/source/format" from "quilt" to "native". After this update the build begin, but failed with the following command:
                        configure: exit 2
                        dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libexecdir=${prefix}/lib/knxd --disable-maintainer-mode --disable-dependency-tracking --enable-usb --enable-eibnetip --enable-eibnetiptunnel --enable-eibnetipserver --enable-groupcache --enable-tpuart --enable-ft12 returned exit code 2
                        make[1]: *** [override_dh_auto_configure] Error 25
                        make[1]: Leaving directory `/usr/local/src/knxd'
                        make: *** [build] Error 2
                        dpkg-buildpackage: error: debian/rules build gave error exit status 2[/SIZE][/FONT][/COLOR]
                        Nur noch mal zur Info. Wie hasst du das pthsem package unter raspbian installiert?

                        Kommentar


                          Hallo Bigblue,
                          hatte gerade auch Probleme mit pthsem auf dem raspberry/raspbian. Bei den Abhängigkeitenim README.md auf github fehlen die Pakete "debhelper" und "libusb-1.0.0-dev", zumindest habe ich das den Fehlermeldungen vorhin entnommen und diese Pakete nachinstalliert, danach ließen sich im pthsem-Verzeichnis das dpkg-buildpackage ohne Fehlermeldung ausführen.

                          #snowdd

                          EDIT: Das upstream tarball Problem wurde oben schon einmal beschrieben, siehe post #214, da bin ich dann auch als nächstes (nach pthsem) reingelaufen...
                          Zuletzt geändert von snowdd; 30.03.2015, 22:36. Grund: Mißverständnis
                          Deutschsprachiges homebridge-knx-Forum unter https://github.com/snowdd1/homebridge-knx-de

                          Kommentar


                            *EDIT 2*
                            Auf einem frisch instalierten Debian klappt es ohne Probleme. Ich werde jetzt noch mal ein Ubuntu versuchen und mich dann noch mal melden.

                            Vielen vielen dank. Jetzt hat es auf dem Raspberry Pi geklappt. Hat jemand eine Idee, wieso es auf meinem IntelI3 nicht klappt? Ich habe erste die pthsem und eibd aus dem debian Repo von mkoegler installiert. Anschließend habe ich pthsem selbst compiliert und installiert und dann versucht knxd zum laufen zu bringen, leider Ohne Erfolg. Da es jetzt auf dem Raspberry klappt, denke ich dass ich nichts falsch gemacht habe.

                            *EDIT*
                            Betriebssystem ist Ubuntu 12.04

                            Ich bekomme immer folgende Fehlermeldung bei dem "dpkg-buildpackage". Egal ob mit "-b" oder ohne.
                            Code:
                            #define HAVE_TPUARTs 1
                            #define HAVE_EIBNETIP 1
                            #define HAVE_EIBNETIPTUNNEL 1
                            
                            configure: exit 1
                            dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libexecdir=${prefix}/lib/knxd --disable-maintainer-mode --disable-dependency-tracking --enable-usb --enable-eibnetip --enable-eibnetiptunnel --enable-eibnetipserver --enable-groupcache --enable-tpuart --enable-ft12 returned exit code 1
                            make[1]: *** [override_dh_auto_configure] Fehler 25
                            make[1]: Verlasse Verzeichnis '/usr/local/src/knxd/knxd'
                            make: *** [build] Fehler 2
                            dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules build war 2
                            *EDIT 3*
                            So das ist jtzt auch der letzte Edit. Es scheint an dem Ubuntu 12.04 zu liegen. Mit dem neuesten Debian geht es ohne Probleme, bei Ubuntu bekomme ich die oben geschriebenen Fehler.

                            Ich werde jetzt mal ein wenig rumspielen.

                            *EDIT 4*
                            Mit Ubuntu 14.04 klappt es. Es ist also nur ein Problem bei Ubuntu 12.04. Somit wird es wohl an einer Version eines Packages liegen.
                            Zuletzt geändert von bigblue1735; 31.03.2015, 21:44.

                            Kommentar


                              Hi, wollte mich mal mit was erfreulichem zu Worte melden. Nachdem ich in letzter Zeit immer nur mit Problemen um die Ecke kann, wollte ich euch mitteilen dass der knxd auf der Raspberry ohne Probleme funktioniert und genau das macht was er soll. Ob die Verbindung mit der ETS geht habe ich noch nicht getestet ist aber mir auch nicht so wichtig.

                              VIELEN DANK an alle die mir dabei geholfen haben. Das Problem mit dem Ubuntu 12.04 hat sich hoffentlich sowieso bald erledigt.

                              Kommentar


                                Hallo Leute,

                                arbeitet jemand aktuell daran, dass man mit dem knxd und der ETS5 Busgeräte programmieren kann?
                                Oder muss man hier alles selber machen? ;-)
                                DistKV, Home Assistant, 1wire, KNX, Python, Asterisk, SMD-Lötkolben

                                Kommentar

                                Lädt...
                                X