Ankündigung

Einklappen
Keine Ankündigung bisher.

Homeconnect Suite LBS 19002520-19002530

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    2022-01-30 15:13:38 560700 7756 debug EXE19002520 [v0.3.1]: no connection, reconnect
    2022-01-30 15:13:38 694359 7756 debug EXE19002520 [v0.3.1]: File: /usr/local/edomi/www/data/liveproject/lbs/EXE19002520.php | Error: 2 | Line: 91 | fopen(https://api.home-connect.com/api/hom...ances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
    2022-01-30 15:13:38 708364 7756 debug EXE19002520 [v0.3.1]: an error has occurred fopen(https://api.home-connect.com/api/hom...ances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
    2022-01-30 15:13:38 711538 7756 debug EXE19002520 [v0.3.1]: token to old (1373983) try refresh
    2022-01-30 15:13:38 713711 7756 debug EXE19002520 [v0.3.1]: refresh token
    Das war das Problem. Habe ihn jetzt neu registriert und alles läuft wieder. Danke.

    Kommentar


      Ich habe gerade das Problem, dass er Werte für unseren Geschirrspüler anzeigt, die nicht zusammenpassen.
      Er läuft gerade, der LBS zeigt zwar den Programmfortschritt und Restzeit an, aber angeblich ist er inaktiv und off. Zudem wird das falsche Programm angezeigt.

      Ich habe vorhin den LBS zweimal neu registriert.

      Bildschirmfoto 2022-02-01 um 23.07.42.png

      Ein aktuelles Logfile hängt an.
      Angehängte Dateien
      ---
      Martin

      Kommentar


        Hallo zusammen,

        ich scheitere leider schon recht weit am Anfang. Ich habe mich bei home-connect regisitriert und die ID und das Secret in dem Server-Baustein eingetragen. Leider kommt dann eine Fehlermeldung. Ich vermute wieder ein Anfängerfehler - vielleicht kann mir einer von euch auf die Sprünge helfen.

        Viele Grüße

        Fehlermeldung:
        fehler.jpg


        home-connect-Einstellungen:

        homeconnect.jpg
        Angehängte Dateien

        Kommentar


          Hi,

          hast du das auch ausgeführt?

          Zitat von vento66 vento66 Beitrag anzeigen
          - LBS 19002520 mit einer 9 an E1 Starten
          - die URL die an A2 ausgegeben wird im Browser aufrufen (dazu sollte A2 mindestens mit einer Klemme verbunden sein)
          - auf der Seite mit dem developer account anmelden, und Zugriff gewähren
          vento66, ich kann über ein ähnliches Problem wie martinb07 in Post #122 berichten. Seit dem Umstieg auf den aktuellen LBS werden die Werte teilweise nicht richtig abgerufen.

          Mir ist es aufgefallen da die Sockelbeleuchtung über die Dunstabzugshaube geschalten wird. Momentan bleibt sie aber aus.
          Mache ich einen refresh über E32 ist wieder alles ok bzw die Beleuchtung geht an.

          Hattest du etwas an der Abfrage der LBS geändert?
          Zuletzt geändert von toddler; 06.02.2022, 15:12.

          Kommentar


            Yep hab ich gemacht. Die Fehlermeldung erhalte ich bei Aufruf des Links.

            Kommentar


              Hi, leider plagt mich nach einer Projektaktivierung wieder das Problem aus Post #121. Hab den Server LBS in der Version 0.3.1 im Einsatz. Hat jemand ne Idee, wieso mein Token da immer zu alt wird?

              Kommentar


                Habe gerade ins Log geschaut. Den Fehler mit dem Token hatte ich wohl auch ...
                Hat heute Nacht angefangen:

                Code:
                2022-02-06 01:51:22 356563 11451 debug EXE19002520 [v0.3.1]: token to old (80001) try refresh
                2022-02-06 01:51:22 357724 11451 debug EXE19002520 [v0.3.1]: refresh token eyxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxn0=
                2022-02-06 01:51:22 358609 11451 debug EXE19002520 [v0.3.1]: refresh curl
                2022-02-06 01:51:22 523685 11451 debug EXE19002520 [v0.3.1]: got no token
                Sieht so aus als wurde ein neuer Token angefordert aber keiner erhalten.
                Bis heute mittag:

                Code:
                2022-02-06 13:43:09 442667 11451 debug EXE19002520 [v0.3.1]: File: /usr/local/edomi/www/data/liveproject/lbs/EXE19002520.php | Error: 2 | Line: 91 | fopen(https://api.home-connect.com/api/homeappliances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
                2022-02-06 13:43:09 444853 11451 debug EXE19002520 [v0.3.1]: an error has occurred fopen(https://api.home-connect.com/api/homeappliances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
                2022-02-06 13:43:09 446283 11451 debug EXE19002520 [v0.3.1]: token to old (122708) try refresh
                2022-02-06 13:43:09 447309 11451 debug EXE19002520 [v0.3.1]: refresh token eyxxxxxxxxxxxxxxxxxxxxxxxxn0=
                2022-02-06 13:43:09 448098 11451 debug EXE19002520 [v0.3.1]: refresh curl
                2022-02-06 13:43:15 972362 11451 debug EXE19002520 [v0.3.1]: got no token
                2022-02-06 13:43:26 478338 11451 debug EXE19002520 [v0.3.1]: no connection, reconnect
                2022-02-06 13:43:26 562261 11451 debug EXE19002520 [v0.3.1]: File: /usr/local/edomi/www/data/liveproject/lbs/EXE19002520.php | Error: 2 | Line: 91 | fopen(https://api.home-connect.com/api/homeappliances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
                2022-02-06 13:43:26 564235 11451 debug EXE19002520 [v0.3.1]: an error has occurred fopen(https://api.home-connect.com/api/homeappliances/events): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized[CR][LF]
                2022-02-06 13:43:26 565685 11451 debug EXE19002520 [v0.3.1]: token to old (122725) try refresh
                2022-02-06 13:43:26 566703 11451 debug EXE19002520 [v0.3.1]: refresh token eyxxxxxxxxxxxxxxxxxxxxxxxxxxxn0=
                2022-02-06 13:43:26 567497 11451 debug EXE19002520 [v0.3.1]: refresh curl
                2022-02-06 13:43:29 419109 11451 debug EXE19002520 [v0.3.1]: got new token write to file
                2022-02-06 13:43:29 423068 11451 debug EXE19002520 [v0.3.1]: no new token before: 16:43:29 02/06/22
                2022-02-06 13:43:31 926568 11451 debug EXE19002520 [v0.3.1]: found new token, close connection
                2022-02-06 13:43:36 928023 11451 debug EXE19002520 [v0.3.1]: no connection, reconnect
                2022-02-06 13:43:39 656374 11451 debug EXE19002520 [v0.3.1]: reconnect successfull
                2022-02-06 13:44:34 926724 11451 debug EXE19002520 [v0.3.1]: filetime: 65 line event:KEEP-ALIVE
                2022-02-06 13:44:38 950993 11451 debug EXE19002520 [v0.3.1]: filetime: 69 line event:KEEP-ALIVE
                2022-02-06 13:45:29 718534 11451 debug EXE19002520 [v0.3.1]: filetime: 120 line event:KEEP-ALIVE
                2022-02-06 13:46:25 017261 11451 debug EXE19002520 [v0.3.1]: filetime: 176 line event:KEEP-ALIVE
                2022-02-06 13:47:10 768538 11451 debug EXE19002520 [v0.3.1]: filetime: 221 line event:KEEP-ALIVE

                Kommentar


                  Hab gerade geschaut, war hier auch so, scheint ein generelles Problem bei denen gewesen zu sein.
                  Code:
                  2022-02-06 13:51:55 392549 31054 notice EXE19002520 [v0.3.1]: token to old (106374) try refresh 
                  2022-02-06 13:52:18 763945 31054 notice EXE19002520 [v0.3.1]: reconnect successfull
                  Mfg Micha
                  Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                  Kommentar


                    Hallo vento66,

                    kleines Detail: Die Bausteine 19002520-22 heissen "home connect...", die restlichen Bausteine aber "homeconnect...". Also ohne Space dazwischen. Das könntest Du bei Gelegenheit vielleicht noch einheitlich machen, ich hab' mich eben gewundert, warum ich den Server bei der Suche nach "homeconnect" nicht gefunden habe...

                    Aber ansonsten, alles bestens.
                    Kind regards,
                    Yves

                    Kommentar


                      Zitat von pewe1835 Beitrag anzeigen
                      ich scheitere leider schon recht weit am Anfang. Ich habe mich bei home-connect regisitriert und die ID und das Secret in dem Server-Baustein eingetragen. Leider kommt dann eine Fehlermeldung.
                      Gelöst: Nach Rücksprache mit Bosch gab es wohl ein Serverproblem. Jetzt läuft es.

                      Noch ein kleine Rückmeldung zu der Inbetriebnahmeanleitung von LBS 19002520:

                      Zusätzlich zu dem in der Anleitung beschriebenen Developer-Account muss auch ein separater Endkunden-Account angelegt sein. Ohne diesen lässt sich Dialog der beim Öffnen der URL an A2 ausgegeben wird nicht abschließen. Und noch eine Kleinigkeit: in der Hilfe steht, dass "A2-A15 ID der gefundenen Geräte (mehrere mit '|' getrennt)". Das müsste aber eher A3-A15 sein, A2 gibt bei mir nur die URL aus.
                      Zuletzt geändert von pewe1835; 07.02.2022, 12:49.

                      Kommentar


                        Zitat von vento66 vento66 Beitrag anzeigen
                        Neu: LBS19002528 homeconnect cook processor
                        Steuerung und Status Küchenmaschine (nur Basics, mehr im Laufe des Jahres)
                        Danke für den Baustein! Ich weiß nicht ob ihn schon jemand getestet hat bzw. ob es schon Rückmeldungen gab. Du vento66 hast ja geschrieben, dass er noch in der Entwicklung ist deshalb hier die Punkte die mir aufgefallen sind:

                        E6: Pause funktioniert
                        E7: Resume funktioniert noch nicht
                        E8: start prog funktioniert noch nicht

                        A7-A10: hier habe ich bisher noch keine Ausgabe gesehen

                        Falls du noch jemand zum Testen suchst, kann ich da gerne weiterhelfen :-)

                        Kommentar


                          irgendwo im Dishwasher-LBS (19002523) scheint noch ein Fehler zu sein:

                          2022_02_10_14_07_14_Window.png

                          Vento, könntest Du Dir diesen LBS noch einmal zur Brust nehmen ? DANKEEE !!!

                          Kommentar


                            ak68 erledigt!
                            pewe1835 Nicht jedes Gerät unterstützt alle EIN- und Ausgänge. Interessant wäre ein Log mit Level 8 vom Geräte LBS, wenn Du E7 / E8 triggerst. Der LBS ist nur aus der Theorie und der API Beschreibung entstanden. Auf der Website steht auch das für das Gerät nur die Basis Steuerung funktioniert, es soll aber 2022 erweitert werden.
                            Zuletzt geändert von vento66; 10.02.2022, 20:46.
                            Mfg Micha
                            Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                            Kommentar



                              Danke für die prompte Erledigung !

                              zu früh gefreut-leider tauchen die Fehlermeldungen weiterhin auf


                              2022_02_11_07_20_46_Window.png

                              Zuletzt geändert von ak68; 11.02.2022, 07:23.

                              Kommentar


                                Hallo vento66
                                Kann es sein, dass dein LBS ein Memoryleak hat?
                                Hatte heute Nacht diesen Fehler im Log:
                                Code:
                                Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19002520.php | Fehlercode: 1 | Zeile: 605 | Allowed memory size of 134217728 bytes exhausted (tried to allocate 69206272 bytes)


                                Könnte eventuell daran liegen, dass in der Refresh Methode das curl_close fehlt um die Resource wieder freizugeben.
                                Zuletzt geändert von philipp900; 26.02.2022, 07:43.

                                Kommentar

                                Lädt...
                                X