Ankündigung

Einklappen
Keine Ankündigung bisher.

Amazon Alexa Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    zu base64: in nginx gibt man das base64 encodede ergebnis aus user : passwort an, also im fall smartvisu:xxx ein c21hcnR2aXN1Onh4eA==

    das würde es einfacher machen.. dort hatte ich für die weiterleitung die creds von der kamera hinterlegt und musste das jetzt erst wieder decoden, weil ich sie vergessen hatte.. ist aber nur nice to have

    Kommentar


      Kurzer Nachtrag :

      Die "alexa_auth_cred" brauchst Du nur wenn der Zugang zu Kamera mit User usw. angelegt ist. Das hat nichts mit der Nginx-Config zu tun.
      Die Infos werden aus der Amazon-Cloud an das Show oder Spot gesendet und der Stream direkt von dort aufgebaut. Es geht dann keine Kommunikation mehr über den Nginx bzw. über extern.

      Kommentar


        AndreK offenbar habe ich das zu kompliziert ausgedrückt

        1) die cam ist basic auth geschutzt
        2) die basic auth credentials der kamera habe ich im nginx konfiguriert, da ich von "aussen" auf die kamera zugreife und der nginx für die weiterleitung diese wissen muss
        3) nginx hat diese info base64 encoded - da ich den vor ca 1 jahr eingerichtet habe, wusste ich sie nichtmehr im original. daher musste ich sie mir jetzt via https://www.base64decode.org/ wieder dekodieren, um sie in klartext in deinem plugin einzutragen

        => den letzten schritt hätte ich mir gespart, wenn neben der klartextangabe auch die base64 version in deinem plugin gehen würde (und dann intern dekodiert wird). das ist aber wirklich nice to have...

        Kommentar


          ps: alexa sagt derzeit wenn ich "zeige die kamera in der küche" sage, "Küche reagiert gerade nicht.. ich vermute meine url passt nicht für rtsp.. leider ist die trendnet cam sehr mager dokumentiert.. ich teste mal weiter..

          Kommentar



            das wäre der teilanonymisierte payload.. offenbar steht irgendwo hardcoded noch doorcam drin? oder woher kommt das beim cookie? {"payload": {"cameraStreams": [{"authorizationType": "BASIC", "videoCodec": "H264", "audioCodec": "G711", "resolution": {"width": 1920, "height": 1080}, "protocol": "RTSP"}]}, "header": {"name": "InitializeCameraStreams", "namespace": "Alexa.CameraStreamController", "messageId": "...", "payloadVersion": "3", "correlationToken": "..."}, "endpoint": {"scope": {"type": "BearerToken", "token": "Atza|..."}, "endpointId": "kitchencam", "cookie": {"extraDetail1": "doorcam"}}}

            Kommentar


              hmm habe jetzt die rtsp url im vlc erfolgreich getestet und die basic auth der kamera deaktiviert. kamera küche reagiert aber immer noch nicht.mmhm

              aktuelle konfig:
              Code:
              doorcam:
                  name: 'Kamera Küche'
                  alexa_description: 'Kamera Küche'
                  alexa_name: 'Kamera Küche'
                  alexa_device: kitchencam
                  alexa_icon: CAMERA
                  alexa_actions: InitializeCameraStreams
                  alexa_camera_imageUri: 'http://192.168.178.40/image/jpeg.cgi'
                  alexa_csc_uri: '{"Stream1":"192.168.178.40/play1.sdp"}'
                  alexa_auth_cred: ''
                  alexa_stream_1: '{
                  "protocols":["RTSP"],
                  "resolutions":[{"width":1920,"height":1080}],
                  "authorizationTypes":["BASIC"],
                  "videoCodecs":["H264"],
                  "audioCodecs":["G711"]
                  }'
              ich teste gerade mit MP4A als Audio Codec, müsste ja korrekt sein, oder:

              dd.JPG
              Angehängte Dateien
              Zuletzt geändert von psilo; 01.01.2019, 19:17.

              Kommentar


                Ich habe jetzt überall NONE eingetragen, leider auch ohne effekt - die auflösung habe ich auch korrigiert:
                Code:
                kitchencam:
                    name: 'Kamera Küche'
                    alexa_description: 'Kamera Küche'
                    alexa_name: 'Kamera Küche'
                    alexa_device: kitchencam
                    alexa_icon: CAMERA
                    alexa_actions: InitializeCameraStreams
                    alexa_camera_imageUri: 'http://192.168.178.40/image/jpeg.cgi'
                    alexa_csc_uri: '{"Stream1":"192.168.178.40/play1.sdp"}'
                    alexa_auth_cred: ''
                    alexa_stream_1: '{
                    "protocols":["RTSP"],
                    "resolutions":[{"width":1280,"height":720}],
                    "authorizationTypes":["NONE"],
                    "videoCodecs":["H264"],
                    "audioCodecs":["NONE"]
                    }'
                das "doorcam" kam übrigens wohl vom itemnamen. das ist jetzt weg.

                die myStream Daten aus der p3_tools.py:

                Code:
                plugins.alexa4p3.p3_tools {'expirationTime': '2019-01-01T19:45:30.20Z', 'videoCodec': ['H264'],
                 'audioCodec': ['NONE'], 'resolution': {'height': 720, 'width': 1280}, 'protocol': 'RTSP', 'authorizationType': ['NONE'], 'ur
                i': 'rtsp://192.168.178.40/play1.sdp', 'idleTimeoutSeconds': 30}
                Zuletzt geändert von psilo; 01.01.2019, 19:42.

                Kommentar


                  achja und in der p3_tools.py ist noch ein typo: "experitationDate" => "expirationDate"

                  Kommentar


                    Ich habe den CamerstreamController für den Edomi Smarthome Skill auch implementiert aber auch nicht zum Laufen bekommen.
                    Problem sind vermutlich die Security Anforderungen seitens Amazon, d.h. es muss ein RTSP Stream auf Port 443 mit TLS1.2 sein.:

                    https://developer.amazon.com/de/docs...s-requirements

                    Der Monocle Smarthome Skill scheint das irgendwie anders zu machen, denn der funktioniert mit all meinen Hikvision Cams.

                    Kommentar


                      Hallo psilo,

                      bitte poste doch mal den Eintrag aus der streamdump.txt (natürlich teilanonymisiert) bei der Anfrage an das Alexa-Device nach dem Stream.
                      Vielleicht gibts daraus erweiterte Erkenntnisse (das sind die Daten die aus dem Skill/Lambda an das Device gesendet werden).
                      Es geht aus der Amazon Doku nicht ganz klar hervor, was an das Gerät tatsächlich gesendet wird.
                      Auch die Beispiele auf der Amazon Skill-Website und auf den Beispielseiten von Amazon auf Github sind widersprüchlich.

                      Auf welchem Device hast du getestet Show oder Spot. Eventuell liegt es auch einfach daran, dass beim Test auf dem Spot die Auflösung von 1280x720 nicht dargestellt werden kann (lt Amazon Spezi kann das Spot 480x480)

                      jonofe : Wenn das bei mit Monocle funktioniert kannst Du eventuell via Wireshark mal mit protokollieren was da an Traffic gesendet wird.
                      Nach meinen Erkenntnissen (Monocle Doku) sollte nach Übermittlung der Daten an das Alexa-Device das Protokoll usw. keine Rolle mehr spielen da der Stream dann direkt vom Alexa-Device von der Cam angefordert wird (siehe Config-Doku von Monocle hier wird auch via rtsp auf Port 554 übertragen ).

                      Mal sehen ob wir das gemeinsam nicht doch ans Laufen bekommen.


                      monocle.png
                      Zuletzt geändert von AndreK; 02.01.2019, 03:14.

                      Kommentar



                        {"payload": {"cameraStreams": [{"protocol": "RTSP", "authorizationType": "NONE", "resolution": {"height": 720, "width": 1280}, "videoCodec": "H264", "audioCodec": "NONE"}]}, "endpoint": {"endpointId": "kitchencam", "scope": {"type": "BearerToken", "token": "Atza|..."}, "cookie": {"extraDetail1": "kitchencam"}}, "header": {"messageId": "957049a7-0102-458b-bbfc-00002a14f912", "correlationToken": "...", "payloadVersion": "3", "name": "InitializeCameraStreams", "namespace": "Alexa.CameraStreamController"}}

                        auf dem echo show 2 in der kueche gleiches verhalten. ich würde auch erwarten, dass amazon das video skaliert. die tagesschau wird nur fuer den spot z.b. auch kein aufloesungstechnisch kleineres video bereitstellen

                        hier noch die cam settings, ich nehme den ersten stream:
                        ddd.JPG
                        Zuletzt geändert von psilo; 02.01.2019, 08:40.

                        Kommentar


                          nur kurz zu monocle: soweit ich das sehe, bindet monocle die kamera doch "von außen" ein. kann es sein, dass reiner LAN zugriff doch nicht geht?

                          Kommentar


                            Zitat von psilo Beitrag anzeigen
                            nur kurz zu monocle: soweit ich das sehe, bindet monocle die kamera doch "von außen" ein.
                            Da bin ich noch nicht ganz sicher. Oder Monocle klemmt sich nur für die Initialisierung dazwischen und wenn Alexa das akzeptiert hat, wird der Stream dann irgendwie umgebogen. Habe mich aber noch nicht tiefer damit beschäftigt. Bei Monocle habe ich auch eine Verzögerung von 10-20 Sekunden, was ja wieder für eine Umleitung des Stream nach extern sprechen könnte.

                            Kommentar


                              ich kann evtl heute abend (oder freitag) mal die dyndns url für rtsp einrichten und das von extern konfigurieren..

                              Kommentar


                                Zitat von AndreK Beitrag anzeigen
                                Hallo ASSR85,

                                hört sich gut an, nehmen wir dann im "Neuen Jahr" in Angriff, hast du eine Webcam bei Dir im Netz ? Zur Not könnte ich auch meine Door-Cam für einen Test
                                freigeben. Ich werde das vernünftig vorbereiten und melde mich dann.

                                Wenn das dann so funktioniert wie ich mir das vorstelle (wenn auch der Smartlock funktioniert) will ich mir auch ein EchoSpot oder EchoShow zulegen.
                                Also doch nicht ganz so selbstlos :-)

                                So nun aber genug.

                                Viel Spass noch


                                geht das Gabze auch mit einem Amazon Tablet? z.B. Fire HD 8. Den kann ich in den Show-Mode versetzen...

                                Kommentar

                                Lädt...
                                X