Ankündigung

Einklappen
Keine Ankündigung bisher.

Amazon Alexa Plugin

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Hallo,

    das ist mein Alexa- Teil:
    Code:
    location /alexa {
            auth_basic "Restricted Area: Alexa";
            auth_basic_user_file /etc/nginx/htpasswd.alexa;
    
        # Zugreifendes Land erlaubt?
            if ($allowed_country = no) {
                    return 403;
            }
    
            proxy_pass http://192.168.1.13:9000/;
            proxy_set_header Host $host;
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
        }
    Ich hab keine Änderungen wegen der v3 gemacht.

    Kommentar


      Hallo Jürgen ,

      beim mir sieht die Config wie folgt aus :

      Router lauscht auf Port 1443 , leitet diesen auf 443 auf den Nginx weiter. Der Nginx leitet die location /alexa auf den Smarthome-PI Port 9000 weiter.
      In der Lambda habe ich Port 1443 eingtragen. Pfad in Der Lambda muss der "location" im Nginx entsprechen. Im Alexa-Plugin is Port 9000 konfiguriert.

      Nginx-Config sieht wie folgt aus, wobei die 192.168.178.37 der SmartHome-PI ist :

      Code:
          # Alexa Plugin Weiterleitung
          location /alexa {
              auth_basic "Restricted Area: Alexa";
              auth_basic_user_file /etc/nginx/.smartvisu;
      
              # Zugreifendes Land erlaubt?
              if ($allowed_country = no) {
                      return 403;
              }
      
              proxy_pass http://192.168.178.37:9000/;
              proxy_set_header Host $host;
              proxy_set_header X-Real-IP $remote_addr;
              proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
              proxy_set_header X-Forwarded-Proto $scheme;
          }
      Das Ziel muss für P3 nicht geändert werden, es bleibt alles wie gehabt. Für P3 muss lediglich im "Skill" von V2 auf V3 umgstellt werden.
      !! Im Skill umstellen, d.h. nichts mit eventuellen Testfunktionen in der Lambda zu tun, diese müssen manuelle umgestellt werden !!

      Gruss Andre

      Kommentar


        Hallo,

        was wäre eigentlich nötig, um dem User die Installation einfacher zu machen?
        Wäre es nicht möglich, den Skill zu offizialisieren und auf smarthome-ng.de das Gegenstück zu hosten?

        Gruß,
        Hendrik

        Kommentar


          Hallo Hendrik,

          im Prinzip ist das ja alles OK, das Problem in meinen Augen: Die verfügbaren Anleitungen sind von "Profis" geschrieben.
          Wenn man mit der Materie bisher wenig bis nichts zu tun hatte, scheitert man oft an für den Schreiber selbstverständlichen Dingen.
          Daher dokumentiere ich für mich jeden Schritt zu einem einzigen Dokument. Wenn es dann mal läuft, wird das dann bei einem Kollegen (DAU) auf Tauglichkeit geprüft.
          :-)

          OK, meine Ports scheinen zu stimmen, im Lambda habe ich "/alexa/" mit einem zweiten Slash stehen ?!
          Ich bin direkt mit V3 gestartet.
          Ich baue gerade eine neue Nginx.conf auf, bin da wohl mit den {} irgendwo durcheinander geraten..



          Gruß Jürgen

          Kommentar


            Hä? Gerade deshalb schlage ich es ja vor.

            Kommentar


              Bezog sich auf:
              >Wäre es nicht möglich, den Skill zu offizialisieren und auf smarthome-ng.de das Gegenstück zu hosten?
              Mit einer vernüftigen ANleitung kommt man auch mit dem eigenen Skill durch.

              Gruß
              Jürgen

              Kommentar


                So, neuer Zwischenstand:
                Nach dem Jonglieren der {} in der nginx.conf startet der Proxy nun und leitet auch Anfragen für "mydomain/Port/alexa" weiter (Passwortabfrage im Browser).
                Die Alexa App kann den Service aber noch nicht aktivieren, ein Zugriff taucht im acess.log nicht auf.
                Da geht es vielleicht morgen weiter...

                Mühsam nährt sich das Eichhörnchen.
                Spannend, aber nichts für den "Normalen Anwender", aber wer ist hier schon normal ;-)

                Gruß
                Jürgen

                Kommentar


                  Zitat von Jürgen Beitrag anzeigen
                  Kann mal jemand den Alexa Block aus der Nginx.conf posten?
                  Anbei der Code:

                  Code:
                      # Alexa Plugin Weiterleitung
                      location /alexa {
                          auth_basic "Restricted Area: Alexa";
                          auth_basic_user_file /etc/nginx/.alexa;
                          proxy_pass http://IP-Adresse:9000/;
                          proxy_set_header Host $host;
                          proxy_set_header X-Real-IP $remote_addr;
                          proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                          proxy_set_header X-Forwarded-Proto $scheme;
                      }
                  Das Ziel bei der AWS bleibt gleich.

                  Kommentar


                    Hallo Leuts, da bin ich wieder :-)

                    wieder mal in den Copy&Paste Fehler gelaufen, wie schon in #323 von jemandem berichtet:

                    Ich kann meinen Skill nicht über die Alexa APP / Browser aktivieren. Zunächst kam die Fehlermeldung "Kann derzeit nicht aktiviert werden".
                    Ich bin dann alle 30 Seiten hier durchgegangen und habe wohl das Problem mit einem falschen "Scope".
                    In der Anleitung
                    https://www.smarthomeng.de/aws-fuer-...gin-einrichten
                    steht
                    Scope profile
                    Wenn ich nun in das Feld den Namen meines AWS Security Profiles eintrage, bekomme ich die Meldung:
                    Verknüpfung fehlgeschlagen.
                    Der Autorisierungsserver meldete einen error- Parameter. Weitere Informationen finden Sie unter https://tools.ietf.org/html/rfc6749#section-4.1.2.1.


                    Was genau muss denn nun in der Lambda Konfiguration hinter scope eingetragen werden? Ich bin ratlos...
                    Wäre auch schön, wenn Marc René Fries seine Beschreibung an dieser Stelle aktualisieren würde :-)

                    In der Amazon Doku steht:

                    https://developer.amazon.com/de/blogs/post/Tx3CX1ETRZZ2NPC/Alexa-Account-Linking-5-Steps-to-Seamlessly-Link-Your-Alexa-Skill-with-Login-wit
                    Scope Login with Amazon supports several scopes, for this example, let’s use “profile”. This will allow your code to retrieve a unique Amazon userid, email address, and full name for the user.
                    Bringt mich momentan aber auch nicht wirklich weiter, zu viele Bäume vor dem Wald..
                    Zumal der Link zur Erklärung der Scopes auch nicht funktioniert...

                    Gruß und Dank
                    Jürgen
                    Zuletzt geändert von Jürgen; 13.01.2019, 16:29.

                    Kommentar


                      Hallo Jürgen ,

                      zur Lambda findest Du eine ziemlich aktuelle Doku hier.

                      Meine Skill-Settings hier : die Redirect-URL´s sind wichtig, ohne die geht nichts.
                      Skill_Acount-Linking.png
                      Gruss Andre

                      Kommentar


                        Hallo Andre,

                        vielen Dank!
                        Ja, die Urls sind drin, sonst kommen andere Fehlermeldungen..
                        Wenn ich profile:user_id eintrage bekomme ich wieder "Verknüpfung mit ALEXA_SMARTHOMENG konnte diesmal nicht hergestellt werden. ", kein unterschied zu scope profile
                        Ich sehe den Skill in meiner APP, bei Amazon ist soweit scheinbar alles ok, aber die Aktivierung scheitert.

                        OK, die Rolle aus der Beschreibung habe ich nicht angelegt, das schaue ich mir noch einmal an...

                        Gruß Jürgen
                        Zuletzt geändert von Jürgen; 13.01.2019, 17:16.

                        Kommentar


                          Hallo Jürgen ,

                          hab mal noch eine Doku für die Erstellung des Skills und den Settings für "Login with Amazon" (LWA) erstellt und hochgeladen. Siehe hier.
                          (War ja schon lang fällig)

                          Bitte probiers mal damit.
                          Eventuelle Änderungen oder Unklarheiten bitte melden, ich werds dann entsprechend in der Doku ändern.

                          Gruss Andre
                          Zuletzt geändert von AndreK; 13.01.2019, 20:54. Grund: added LWA

                          Kommentar


                            Hallo Andre,

                            hatte ich soweit doch alles schon.
                            Im Letzten Fenster unter Sicherheitseinstellungen hast Du bei "Zulässige Originale" nichts stehen.
                            Wenn ich da meine dyndns Domäne eintrage, kommt bei der Aktivierung:Klicken Sie auf Zulassen um sich bei <Mein Sicherheitsprofilname> anzumelden.
                            Unten im Fenster ist der Link zu meiner "Datenschutzerklärung"..
                            Leider kann ich meinen Skill immer noch nicht aktivieren, es ist auch kein Zugriff im Proxy zu sehen.
                            Nun habe ich keine Idee mehr..

                            Die Verknüpfung des Skills mit meinem Konto läuft doch intern bei Amazon ab..
                            Ich starte in der Alexa APP die Skillsuche, dort steht dann: "Aktivieren / Kontoverknüpfung erforderlich"
                            Ich klicke "Aktivieren" und melde mich mit meinem Amazon Account an

                            https://skills-store.amazon.de/external/link-result?success=false&languageCode=de_DE&skillId=am zn1.ask.skill.<MEINE SKILLID>&skillStage=development

                            Bringt dann : Verknüpfung kann nicht hergestellt werden
                            Weitere Informationen und Unterstützung bei der Konfiguration Ihres Skills für die Kontoverknüpfung mit OAuth finden Sie in diesem Handbuch.
                            Das Handbuch ist leider offline...

                            Welche Accounts gebe ich bei der Verknüpfung an? Meinen AWS Account? Ich gebe da momentan 2x meinen normalen Amazon Account / Passwort für Alexa an...
                            Das irritiert mich...

                            Ratlose Grüße
                            Jürgen

                            Kommentar


                              Hallo Jürgen,

                              unter zulässige Originale darf nichts stehen. Hast Du geprüft ob die Redirect-URL´s bei LWA / Webeinstellungen hinterlegt sind ? (zulässige Rückleitungs-URL´s).
                              Diese findest Du beim Skill unter Account-Linking ganz unten.
                              Es müssen alle drei eingetragen werden.

                              Bitte Check das nochmal

                              Beim Aktivieren des Skills wird dein normaler Amazon-Acount verwendet, nicht der der AWS bzw. des Developer-Accounts.
                              Gruss Andre
                              Zuletzt geändert von AndreK; 14.01.2019, 17:50. Grund: Tip zur Anmeldung ergänzt

                              Kommentar


                                Hallo Andre,

                                ja, die URLs sind alle drei drin (siehe #596)..
                                Passiert bei der Aktivierung schon etwas in Richtung meines Routers, oder ist das intern bei Amazon?
                                Ich verstehe wohl noch nicht, was da womit verknüpft wird...

                                Gruß und Dank
                                Jürgen

                                Kommentar

                                Lädt...
                                X