Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS19000809 - Alexa Control

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Der Bindestrich scheint das neue Leerzeichen zu sein, zumindest funktioniert das erstmal als work-around bei mir.

    EDIT: Beim SSML Eingang funktionieren die Leerzeichen übrigens noch so wie sie sollen.
    Zuletzt geändert von jonofe; 08.03.2020, 19:17.

    Kommentar


      Problem ist gefixt. Es war zwar wohl eine Änderung in der Alexa API, das Problem wurde aber durch den LBS ausgelöst, da dieser jedes Leerzeichen durch einen Unterstrich ersetzt hat, da das vermutlich damals notwendig war. Jetzt erzeugt dies genau das beschriebene Problem und die neue Version 1.15 behebt dieses.

      Kommentar


        Hallo

        Ich möchte nochmals eine Frage zu Beitrag Nr. https://knx-user-forum.de/forum/proj...79#post1302279 stellen.

        Funktioniert bei euch die Bluetooth Verbindung mit der "roten" Nummer zuverlässig?
        Ich bekomme diese Nummer leider nicht raus, da bei mir immer die Meldung bezüglich Captcha kommt obwohl alles andere funktioniert. Wo könnte ich da ansetzen?
        Gibt es eine andere Möglichkeit, diese Nummer ausfindig zu machen?
        Bei welchen Echos (Dots) funktioniert die Verbindung über die XX:XX:XX:XX ID?

        Vielen Dank!

        Gruss
        Patrick

        Kommentar


          Hallo zusammen,

          ich hab jetzt den LBS bei mir auch am Laufen. Allerdings musste ich E8- E10 füllen, damit es geht? E38 steht auf auto (E3-E6 ist gefüllt). Ist E8-E10 immer notwendig?

          Gruß und danke
          Johannes

          Kommentar


            E8/E9 ist nur im Manual Mode notwendig.

            E10 ist natürlich notwendig, wie sonst sollte der LBS wissen, welches Echo Device er steuern soll.

            Kommentar


              Guten Morgen,

              seit ein paar Tagen funktioniert das Login im Auto Modus nicht.
              User-Agent erneuern, hat auch nicht geholfen.
              Hab mich dann auf der Alexaseite angemeldet und musste ein Captcha eingeben.
              Danach hat das Login immer noch nicht funktioniert und ich hab die Alexa Dateien im tmp Ordner gelöscht.

              Jetzt wird zwar eine neue Cookie Datei angelegt, aber die ist quasi leer:
              Code:
              # Netscape HTTP Cookie File
              # http://curl.haxx.se/rfc/cookie_spec.html
              # This file was generated by libcurl! Edit at your own risk.
              Daher wahrscheinlich auch die Fehlermeldung im Log:
              Code:
               
              2020-04-23 03:57:26 135677 5945 debug EXE19000809 [v1.15]: Running in auto mode
              2020-04-23 03:57:26 136571 5945 debug EXE19000809 [v1.15]: Is manual mode?
              2020-04-23 03:57:26 137583 5945 debug EXE19000809 [v1.15]: Is autol mode ? 1
              2020-04-23 03:57:26 828573 5945 debug EXE19000809 [v1.15]: 1:CONTENT:
              2020-04-23 03:57:26 828768 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:26 829668 5945 debug EXE19000809 [v1.15]: "HTTP\/1.1 302 Found\r\nContent-Length: 8\r\nConnection: keep-alive\r\nServer: Server\r\nDate: Thu, 23 Apr 2020 01:57:26 GMT\r\nx-amzn-RequestId: cec152742c8-714295-435da-a3362-9223463905e94b\r\nContent-Encoding: deflate\r\nLocation: https:\/\/www.amazon.de\/ap\/signin?showRmrMe=1&openid.return_to=https%3A
              2020-04-23 03:57:26 830811 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:26 832083 5945 debug EXE19000809 [v1.15]: 1:INFO:
              2020-04-23 03:57:26 832185 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:26 832338 5945 debug EXE19000809 [v1.15]: {"url":"https:\/\/www.amazon.de\/ap\/signin?showRmrMe=1&openid.return_to=https%3A%2F%2F alexa.amazon.de%2F&openid.identity=http%3A%2F%2Fsp ecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&op enid.assoc_handle=amzn_dp_project_dee_de&openid.mo de=checkid_setup&openid.claimed_id=http%3A%2F%2Fsp ecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&op enid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0 &","content_type":"text\/html;charset=UTF-8","http_code":200,"header_size":1964,"request_siz e":936,"filetime":-1,"ssl_verify_result":0,"redirect_count":1,"total_ time":0.271892,"namelookup_time":4.1e-5,"connect_time":0.017255,"pretransfer_time":0.066 232,"size_upload":0,"size_download":9277,"speed_do wnload":34120,"speed_upload":0,"download_content_l ength":8,"upload_content_length":0,"starttransfer_ time":0.132161,"redirect_time":0.118372,"certinfo" :[]}
              2020-04-23 03:57:26 832453 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 027205 5945 debug EXE19000809 [v1.15]: 2:CONTENT:
              2020-04-23 03:57:27 027376 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 027616 5945 debug EXE19000809 [v1.15]: "HTTP\/1.1 100 Continue\r\n\r\nHTTP\/1.1 200 OK\r\nContent-Type: text\/html;charset=UTF-8\r\nTransfer-Encoding: chunked\r\nConnection: keep-alive\r\nServer: Server\r\nDate: Thu, 23 Apr 2020 01:57:27 GMT\r\nStrict-Transport-Security: max-age=47474747; includeSubDomains; preload\r\nX-XSS-Protection: 1\r\nX-Content-Type-Options: nosniff\r\nX-Frame-Options: SAMEORIGIN\r\nx-ua-compatible: IE=edge\r\nPragma: No-cache\r\nCache-Control: max-age=0, no-cache, no-store, must-revalidate\r\nExpires: Thu, 01 Jan 1970 00:00:00 GMT\r\nSet-Cookie: ap-fid=\"\"; Domain=.amazon.de; Expires=Thu, 01-Jan-1970 00:00:10 GMT; Path=\/ap\/; Secure\r\nVary: Accept-Encoding,X-Amzn-CDN-Cache,X-Amzn-AX-Treatment,User-Agent\r\nContent-Encoding: gzip\r\nx-amz-rid: T89FPSW
              2020-04-23 03:57:27 027834 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 028774 5945 debug EXE19000809 [v1.15]: 2:INFO:
              2020-04-23 03:57:27 028882 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 029001 5945 debug EXE19000809 [v1.15]: {"url":"https:\/\/www.amazon.de\/ap\/signin","content_type":"text\/html;charset=UTF-8","http_code":200,"header_size":1100,"request_siz e":818,"filetime":-1,"ssl_verify_result":0,"redirect_count":0,"total_ time":0.191434,"namelookup_time":3.6e-5,"connect_time":0.017432,"pretransfer_time":0.070 836,"size_upload":1225,"size_download":962,"speed_ download":5025,"speed_upload":6399,"download_conte nt_length":-1,"upload_content_length":1225,"starttransfer_time ":0.089233,"redirect_time":0,"certinfo":[]}
              2020-04-23 03:57:27 029103 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 031125 5945 debug EXE19000809 [v1.15]: Importing session id from cookie file...
              2020-04-23 03:57:27 033113 5945 debug EXE19000809 [v1.15]: File: /usr/local/edomi/www/data/liveproject/lbs/EXE19000809.php | Error: 8 | Line: 1472 | Undefined variable: session_id
              2020-04-23 03:57:27 181546 5945 debug EXE19000809 [v1.15]: 3:CONTENT:
              2020-04-23 03:57:27 181694 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 181879 5945 debug EXE19000809 [v1.15]: "HTTP\/1.1 404 Not Found\r\nContent-Type: text\/html;charset=UTF-8\r\nTransfer-Encoding: chunked\r\nConnection: keep-alive\r\nServer: Server\r\nDate: Thu, 23 Apr 2020 01:57:27 GMT\r\nStrict-Transport-Security: max-age=47474747; includeSubDomains; preload\r\nX-XSS-Protection: 1\r\nX-Content-Type-Options: nosniff\r\nX-Frame-Options: SAMEORIGIN\r\nx-ua-compatible: IE=edge\r\nPragma: No-cache\r\nCache-Control: max-age=0, no-cache, no-store, must-revalidate\r\nExpires: Thu, 01 J
              2020-04-23 03:57:27 182080 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 183157 5945 debug EXE19000809 [v1.15]: 3:INFO:
              2020-04-23 03:57:27 183275 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 183396 5945 debug EXE19000809 [v1.15]: {"url":"https:\/\/www.amazon.de\/ap\/signin","content_type":"text\/html;charset=UTF-8","http_code":404,"header_size":983,"request_size ":493,"filetime":-1,"ssl_verify_result":0,"redirect_count":0,"total_ time":0.146991,"namelookup_time":3.6e-5,"connect_time":0.017008,"pretransfer_time":0.067 649,"size_upload":77,"size_download":769,"speed_do wnload":5231,"speed_upload":523,"download_content_ length":-1,"upload_content_length":0,"starttransfer_time":0 .145482,"redirect_time":0,"certinfo":[]}
              2020-04-23 03:57:27 183499 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 455759 5945 debug EXE19000809 [v1.15]: 4:CONTENT:
              2020-04-23 03:57:27 455929 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 456768 5945 debug EXE19000809 [v1.15]: "HTTP\/1.1 302 Found\r\nContent-Length: 20\r\nConnection: keep-alive\r\nServer: Server\r\nDate
              2020-04-23 03:57:27 457866 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 458854 5945 debug EXE19000809 [v1.15]: 4:INFO:
              2020-04-23 03:57:27 458961 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 459089 5945 debug EXE19000809 [v1.15]: {"url":"https:\/\/www.amazon.de\/ap\/signin?showRmrMe=1&openid.return_to=https%3A%2F%2F alexa.amazon.de%2Fx&openid.identity=http%3A%2F%2Fs pecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&o penid.assoc_handle=amzn_dp_project_dee_de&openid.m ode=checkid_setup&openid.claimed_id=http%3A%2F%2Fs pecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&o penid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2. 0&","content_type":"text\/html;charset=UTF-8","http_code":200,"header_size":2197,"request_siz e":1042,"filetime":-1,"ssl_verify_result":0,"redirect_count":1,"total_ time":0.270767,"namelookup_time":3.9e-5,"connect_time":0.016969,"pretransfer_time":0.064 148,"size_upload":0,"size_download":9300,"speed_do wnload":34346,"speed_upload":0,"download_content_l ength":20,"upload_content_length":0,"starttransfer _time":0.130265,"redirect_time":0.119243,"certinfo ":[]}
              2020-04-23 03:57:27 459199 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 460786 5945 debug EXE19000809 [v1.15]: Importing CSRF from cookie file...
              2020-04-23 03:57:27 461733 5945 debug EXE19000809 [v1.15]: Login result:
              2020-04-23 03:57:27 461833 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT START ================
              2020-04-23 03:57:27 461919 5945 debug EXE19000809 [v1.15]: {"1":true,"2":true,"3":false,"4":false}
              2020-04-23 03:57:27 461998 5945 debug EXE19000809 [v1.15]: ================ ARRAY/OBJECT END ================
              2020-04-23 03:57:27 462887 5945 debug EXE19000809 [v1.15]: Amazon Alexa Connection failed
              Wenn ich in den manual Mode wechsle und E6,E8,E9 ausfülle, dann funktioniert das Login und der Baustein.

              Wie bekomm ich, den Auto Mode, wieder zum Laufen?

              Danke und Grüße

              Kommentar


                Hast du MFA mal aktiviert?

                Kommentar


                  Hatte ich trotz MFA auch, bis ich bei User Agent (E43)

                  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

                  eingetragen habe.
                  Gruß Wolfgang
                  __________________________________________________ ____
                  HS

                  Kommentar


                    Wie sind denn bei euch so die Reaktionszeiten?

                    Ich hab zB in meiner Testvisu gerade einen Play Button hinzugefügt, der dann ein einen Wert auf E12 (play) und E20 (Radiosation) schickt. Es dauert nach dem klicken des Buttons allerdings ca. 5-6 Sekunden, bis die Musik dann losgeht. Ist das bei euch auch so?

                    Gruß und danke
                    Hannes

                    Kommentar


                      Zitat von h4nnes Beitrag anzeigen
                      nach dem klicken des Buttons allerdings ca. 5-6 Sekunden, bis die Musik dann losgeht. Ist das bei euch auch so?
                      Ja, ist bei mir auch so.

                      Wenn ich über das Webinterface alexa.amazon.de einen Radiosender starte, sind es ca. 4 Sekunden. Die zusätzlichen 1-2 Sekunden werden vermutlich durch das Login verursacht. Beim Webinterface passiert das Login ja vorher, bevor du Musik startest.

                      Kommentar


                        Danke für die schnellen Antworten.

                        Zitat von jonofe Beitrag anzeigen
                        Hast du MFA mal aktiviert?
                        Nein, mit MFA habe ich mich noch nicht beschäftigt.


                        Komischerweise funktioniert jetzt auch wieder der Auto Mode und die Cookie Datei wird befüllt.
                        Durch den Hinweis von woda, habe ich gerade gesehen, dass ich beim Setzten des User Agenten etwas falsches übergebe: "User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0"

                        Vielleicht wurde duch diesen Fehler, das Captcha auf der Alexaseite erzeugt?
                        Und vielleicht haben dann die, Anmeldeversuche mit dem falschen User-Agent dazu geführt, dass der Automatische Login blockiert wurde?

                        Kommentar


                          Hallo,
                          wollte gerade posten wegen dem "Unterstrich_Problem"... aber da sehe ich das die Version 1.15 das schon adressiert.
                          Danke Jonofe!
                          Aber da schwirrt mir noch eine Frage in den Kopf: kann alexa nicht mittlerweile auch "öffnen und schließen" oder "hoch und runter" für Rollläden mit dem Smarthome-Skill?
                          Bisher sage ich immer "schalte Rollladen Küche ein/aus" (für runter/hoch) - und habe dafür Power Controller und Percentage controller aktiviert.
                          Gibt es hier mittlerweile schon Weiterentwicklungen/Empfehlungen wie man auf/zu hoch/runter o.ä. umsetzen kann?

                          Gruß
                          Thorsten Gehrig
                          Meine Inst.: 73 KNX-Geräte, 18 Rolläden, 36 Schaltkanäle, 22 Dimm-Kanäle, 12 Heizungskanäle, 16 PM, 18 Gruppentaster
                          Wiregate: >50 x Temperaturfühler, 2 x Luftfeuchte, Transponderleser || Gira Homeserver: Visu: 98%, Logiken 98% || Heizung: Dimplex WP mit KNX || Sonstiges: 3xSqueezebox, Mobotix T24, Asterisk

                          Kommentar


                            Zitat von ThorstenGehrig Beitrag anzeigen
                            Gibt es hier mittlerweile schon Weiterentwicklungen/Empfehlungen wie man auf/zu hoch/runter o.ä. umsetzen kann?
                            Ja die gibt es und die laufen bei mir schon seit Ende letzten Jahres. Habe dann wohl vergessen das Update zu publishen. Der Alexa Smarthome Skill ist inzwischen bei v0.8 und ich habe gerade gesehen im DL Portal ist es noch v0.5. Werde das in Kürze mal updaten.

                            Damit ist es dann möglich z.B. den Befehl "Alexa, Rolläden hoch" zu geben. In Zusammenspiel mit dem Last-Alexa-Device-LBS kann das dann Raum-übergreifend gemacht werden.

                            Kommentar


                              Hi
                              ich frage mal ganz vorsichtig nach... im Downloadportal ist jetzt die 0.7 - allerdings auch ohne große Updatebeschreibung :-)
                              Ich vermute mal die Update-Infos kommen hier im Thread - und du sagst bescheid wenn sich ein Update lohnt? Danke im Vorraus!

                              Gruß
                              Thorsten
                              Meine Inst.: 73 KNX-Geräte, 18 Rolläden, 36 Schaltkanäle, 22 Dimm-Kanäle, 12 Heizungskanäle, 16 PM, 18 Gruppentaster
                              Wiregate: >50 x Temperaturfühler, 2 x Luftfeuchte, Transponderleser || Gira Homeserver: Visu: 98%, Logiken 98% || Heizung: Dimplex WP mit KNX || Sonstiges: 3xSqueezebox, Mobotix T24, Asterisk

                              Kommentar


                                Die 0.5 bezog sich auf den 1201. Ist noch unverändert im DL Portal. Haber derzeit leider keine Zeit dafür. Übrigens ist es dann nicht hier im Thread, da es ja hier um Alexa Control geht und nicht um den Smarthome Skill.

                                Kommentar

                                Lädt...
                                X